source: projects/specs/trunk/t/tigervnc/tigervnc-vl.spec @ 12329

Revision 12329, 25.4 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

fltk-1.3.5-1

tigervnc-1.10.1-1

Line 
1Name:           tigervnc
2Version:        1.10.1
3Release:        1%{?_dist_release}
4Summary:        A TigerVNC remote display system
5Group:          User Interface/Desktops
6
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        GPLv2+
11URL:            http://www.tigervnc.com
12
13Source0:        https://github.com/TigerVNC/tigervnc/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14Source1:        vncserver.service.upstart
15Source2:        vncserver.sysconfig.upstart
16Source3:        10-libvnc.conf
17Source6:        vncviewer.desktop
18
19#[ad-hoc] xorg-x11-server-source: has no hw/xfree86/Xorg.sh.in
20Source1000:     Xorg.sh.in
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23
24Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
25Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
26
27BuildRequires:  libX11-devel, automake, autoconf, libtool, gettext
28BuildRequires:  libXext-devel, xorg-x11-server-source, libXi-devel
29BuildRequires:  xorg-x11-xtrans-devel, xorg-x11-util-macros, libXtst-devel
30BuildRequires:  libdrm-devel, libXt-devel, pixman-devel libXfont2-devel
31BuildRequires:  libxkbfile-devel, openssl-devel, libpciaccess-devel
32BuildRequires:  mesa-libGL-devel, mesa-libEGL-devel
33BuildRequires:  libXinerama-devel, ImageMagick
34BuildRequires:  freetype2-devel, libXdmcp-devel, libxshmfence-devel
35BuildRequires:  desktop-file-utils
36BuildRequires:  libjpeg-turbo-devel, gnutls-devel, pam-devel
37BuildRequires:  cmake
38# TigerVNC 1.4.x requires fltk 1.3.3 for keyboard handling support
39# See https://github.com/TigerVNC/tigervnc/issues/8, also bug #1208814
40BuildRequires:  fltk-devel >= 1.3.3
41
42Requires(post): coreutils
43Requires(postun):coreutils
44
45Requires:       hicolor-icon-theme
46
47Patch1:         tigervnc-manpages.patch
48Patch2:         tigervnc-getmaster.patch
49Patch3:         tigervnc-shebang.patch
50Patch4:         tigervnc-xstartup.patch
51Patch5:         tigervnc-utilize-system-crypto-policies.patch
52Patch7:         tigervnc-passwd-crash-with-malloc-checks.patch
53
54#Patch100:       tigervnc-xserver120.patch
55
56
57%description
58Virtual Network Computing (VNC) is a remote display system which
59allows you to view a computing 'desktop' environment not only on the
60machine where it is running, but from anywhere on the Internet and
61from a wide variety of machine architectures.
62This package contains a client which will allow you to connect to
63other desktops running a VNC server.
64
65%package server
66Summary:        A TigerVNC server
67Group:          User Interface/X
68Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
69Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
70Requires:       perl
71Requires:       xorg-x11-xauth, xorg-x11-xinit, xorg-x11-server-Xorg
72Requires:       mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
73Requires(post): chkconfig
74Requires(preun):chkconfig
75Requires(preun):initscripts
76Requires(postun):initscripts
77
78%description server
79The VNC system allows you to access the same desktop from a wide
80variety of platforms. 
81This package includes the following components:
82 - TigerVNC server: It allows others to access the desktop on your machine
83 - set of utilities: It makes usage of TigerVNC server more user friendly
84 - x0vncserver program: It can export your active X session
85
86
87%prep
88%setup -q
89
90cp -r /usr/share/xorg-x11-server-source/* unix/xserver || exit 1
91cp -a %{SOURCE1000} unix/xserver/hw/xfree86/ || exit 1
92pushd unix/xserver
93for all in `find . -type f -perm -001`; do
94        chmod -x "$all"
95done
96#patch100 -p1 -b .xserver116-rebased
97patch -p1 < ../xserver119.patch
98popd
99
100# Synchronise manpages and --help output (bug #980870).
101%patch1 -p1 -b .manpages
102
103# libvnc.so: don't use unexported GetMaster function (bug #744881 again).
104%patch2 -p1 -b .getmaster
105
106# Don't use shebang in vncserver script.
107%patch3 -p1 -b .shebang
108
109# Clearer xstartup file (bug #923655).
110%patch4 -p1 -b .xstartup
111
112# Utilize system-wide crypto policies
113%patch5 -p1 -b .utilize-system-crypto-policies
114
115%patch7 -p1 -b .tigervnc-passwd-crash-with-malloc-checks
116
117%build
118#export CFLAGS="$RPM_OPT_FLAGS -fpic"
119#export CXXFLAGS="$CFLAGS"
120export CFLAGS="$RPM_OPT_FLAGS -fpic"
121export CXXFLAGS="$CFLAGS -std=c++11"
122
123%{cmake} .
124make %{?_smp_mflags}
125
126pushd unix/xserver
127autoreconf -fiv
128%configure \
129        --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
130        --disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
131        --with-pic --disable-static \
132        --with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
133        --with-fontdir=%{_datadir}/X11/fonts \
134        --with-xkb-output=%{_localstatedir}/lib/xkb \
135        --enable-install-libxf86config \
136        --enable-glx --disable-dri --enable-dri2 --enable-dri3 \
137        --disable-unit-tests \
138        --disable-config-hal \
139        --disable-config-udev \
140        --with-dri-driver-path=%{_libdir}/dri \
141        --without-dtrace \
142        --disable-devel-docs \
143        --disable-selective-werror \
144        ;
145
146make %{?_smp_mflags}
147popd
148
149# Build icons
150pushd media
151make
152popd
153
154%install
155rm -rf $RPM_BUILD_ROOT
156make install DESTDIR=$RPM_BUILD_ROOT
157rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{README.txt,LICENCE.TXT}
158
159pushd unix/xserver/hw/vnc
160make install DESTDIR=$RPM_BUILD_ROOT
161popd
162
163# Install init stuff
164mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
165mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
166install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/vncserver
167install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/vncservers
168
169# Install desktop stuff
170mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
171
172pushd media/icons
173for s in 16 24 48; do
174install -m644 tigervnc_$s.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x$s/apps/tigervnc.png
175done
176popd
177
178mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
179desktop-file-install \
180        --dir $RPM_BUILD_ROOT%{_datadir}/applications \
181        %{SOURCE6}
182
183%find_lang %{name} %{name}.lang
184
185# remove unwanted files
186rm -f  $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/libvnc.la
187
188mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
189install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch -c %{_datadir}/icons/hicolor
196if [ -x %{_bindir}/gtk-update-icon-cache ]; then
197        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
198fi
199
200%postun
201touch -c %{_datadir}/icons/hicolor
202if [ -x %{_bindir}/gtk-update-icon-cache ]; then
203        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
204fi
205
206%post server
207/sbin/chkconfig --add vncserver
208
209%triggerun -- vnc-server < 4.1.3
210/sbin/service vncserver stop &>/dev/null || :
211/sbin/chkconfig --del vncserver >/dev/null 2>&1 || :
212
213%files -f %{name}.lang
214%defattr(-,root,root,-)
215%license LICENCE.TXT
216%doc README.txt
217%{_bindir}/vncviewer
218%{_datadir}/applications/*
219%{_mandir}/man1/vncviewer.1*
220%{_datadir}/icons/hicolor/*/apps/*
221
222%files server
223%defattr(-,root,root,-)
224%config(noreplace) %{_sysconfdir}/sysconfig/vncservers
225%config(noreplace) %{_sysconfdir}/init.d/vncserver
226%{_bindir}/x0vncserver
227%{_bindir}/vncserver
228%{_bindir}/vncconfig
229%{_bindir}/vncpasswd
230%{_bindir}/Xvnc
231%{_mandir}/man1/vncserver.1*
232%{_mandir}/man1/x0vncserver.1*
233%{_mandir}/man1/Xvnc.1*
234%{_mandir}/man1/vncpasswd.1*
235%{_mandir}/man1/vncconfig.1*
236%{_libdir}/xorg/modules/extensions/libvnc.so
237%config %{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
238
239
240%changelog
241* Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
242- new upstream release.
243- replaced all patches.
244- dropped java stuff.
245
246* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.1-1
247- new upstream release
248- added BR: libxshmfence-devel
249
250* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.0-1
251- new upstream release
252
253* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.3-1
254- new upstream release
255
256* Wed Mar  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-2
257- rebuilt
258
259* Sun Jan  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-1
260- initial build based on Fedora rawhide
261
262* Tue Sep  9 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-11
263- Added missing part of xserver114.patch (bug #1137023).
264
265* Wed Sep  3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
266- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
267
268* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
269- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
270
271* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
272- Input reset fixes from upstream (bug #1116956).
273- No longer need ppc64le patch as it's now in xorg-x11-server.
274- Rebased xserver114.patch again.
275
276* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
277- xserver 1.15.99.903 ABI rebuild
278
279* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
280- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
281
282* Thu May 22 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-5
283- Keep pointer in sync when using module (upstream bug #152).
284
285* Mon Apr 28 2014 Adam Jackson <ajax@redhat.com> 1.3.1-4
286- Add version interlocks for -server-module
287
288* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-3
289- xserver 1.15.99-20140428 git snapshot ABI rebuild
290
291* Mon Apr  7 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-2
292- Allow build with dri3 and present extensions (bug #1063392).
293
294* Thu Mar 27 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-1
295- 1.3.1 (bug #1078806).
296- Add ppc64le support (bug #1078495).
297
298* Wed Mar 19 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-15
299- Disable dri3 to enable building (bug #1063392).
300- Fixed heap-based buffer overflow (CVE-2014-0011, bug #1050928).
301
302* Fri Feb 21 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-14
303- Enabled hardened build (bug #955206).
304
305* Mon Feb 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-13
306- Clearer xstartup file (bug #923655).
307
308* Tue Jan 14 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-12
309- Fixed instructions in systemd unit file.
310
311* Fri Jan 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-11
312- Fixed viewer crash when cursor has not been set (bug #1038701).
313
314* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-10
315- Avoid invalid read when ZRLE connection closed (upstream bug #133).
316
317* Tue Dec  3 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-9
318- Fixed build failure with -Werror=format-security (bug #1037358).
319
320* Thu Nov 07 2013 Adam Jackson <ajax@redhat.com> 1.3.0-8
321- Rebuild against xserver 1.15RC1
322
323* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
324- Removed incorrect patch (for unexpected key_is_down). Fixes stuck
325  keys bug (bug #989502).
326
327* Thu Sep 19 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-6
328- Fixed typo in 10-libvnc.conf (bug #1009111).
329
330* Wed Sep 18 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-5
331- Better fix for PIDFile problem (bug #983232).
332
333* Mon Aug  5 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-4
334- Fixed doc-related build failure (bug #992790).
335
336* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-3
337- Avoid PIDFile problems in systemd unit file (bug #983232).
338- libvnc.so: don't use unexported key_is_down function.
339- Don't use shebang in vncserver script.
340
341* Fri Jul 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-2
342- Renumbered patches.
343- libvnc.so: don't use unexported GetMaster function (bug #744881 again).
344
345* Mon Jul  8 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-1
346- 1.3.0.
347
348* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.18.20130314svn5065
349- Removed systemd_requires macro in order to fix the build.
350
351* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.17.20130314svn5065
352- Synchronise manpages and --help output (bug #980870).
353
354* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.16.20130314svn5065
355- tigervnc-setcursor-crash.patch: Attempt to paper over a crash in Xvnc when
356  setting the cursor.
357
358* Sat Jun 08 2013 Dennis Gilmore <dennis@ausil.us> 1.2.80-0.15.20130314svn5065
359- bump to rebuild and pick up bugfix causing X to crash on ppc and arm
360
361* Thu May 23 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.14.20130314svn5065
362- Use systemd rpm macros (bug #850340).  Moved systemd requirements
363  from main package to server sub-package.
364- Applied Debian patch to fix busy loop when run from inetd in nowait
365  mode (bug #920373).
366- Added dependency on xorg-x11-xinit to server sub-package so that
367  default window manager can be found (bug #896284, bug #923655).
368- Fixed bogus changelog date.
369
370* Thu Mar 14 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.13.20130314svn5065
371- Less RHEL customization
372
373* Thu Mar 14 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.12.20130314svn5065
374- include /etc/X11/xorg.conf.d/10-libvnc.conf sample configuration (#712482)
375- vncserver now honors specified -geometry parameter (#755947)
376
377* Tue Mar 12 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.11.20130307svn5060
378- update to r5060
379- split icons to separate package to avoid multilib issues
380
381* Tue Feb 19 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.10.20130219svn5047
382- update to r5047 (X.Org 1.14 support)
383
384* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.80-0.9.20121126svn5015
385- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
386
387* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.8.20121126svn5015
388- rebuild due to "jpeg8-ABI" feature drop
389
390* Wed Jan 16 2013 Adam Tkac <atkac redhat com> 1.2.80-0.7.20121126svn5015
391- rebuild
392
393* Tue Dec 04 2012 Adam Tkac <atkac redhat com> 1.2.80-0.6.20121126svn5015
394- rebuild against new fltk
395
396* Mon Nov 26 2012 Adam Tkac <atkac redhat com> 1.2.80-0.5.20121126svn5015
397- update to r5015
398- build with -fpic instead of -fPIC on all archs except s390/sparc
399
400* Wed Nov  7 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.80-0.4.20120905svn4996
401- Build with -fPIC to fix FTBFS on ARM
402
403* Wed Oct 31 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.3.20120905svn4996
404- tigervnc12-xorg113-glx.patch: Fix to only init glx on the first server
405  generation
406
407* Fri Sep 28 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.2.20120905svn4996
408- tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13
409
410* Fri Aug 17 2012 Adam Tkac <atkac redhat com> 1.2.80-0.1.20120905svn4996
411- update to 1.2.80
412- remove deprecated patches
413  - tigervnc-102434.patch
414  - tigervnc-viewer-reparent.patch
415  - tigervnc11-java7.patch
416- patches merged
417  - tigervnc11-xorg111.patch
418  - tigervnc11-xorg112.patch
419
420* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
421- fix build against newer X server
422
423* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
424- Build with the Composite extension for feature parity with other X servers
425
426* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
427- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
428
429* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
430- fix building against X.org 1.13
431
432* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
433- RHEL exclusion for -server-module on ppc* too
434
435* Mon Mar 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-5
436- clean Xvnc's /tmp environment in service file before startup
437- fix building against the latest JAVA 7 and X.Org 1.12
438
439* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-4
440- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
441
442* Tue Nov 22 2011 Adam Tkac <atkac redhat com> - 1.1.0-3
443- don't build X.Org devel docs (#755782)
444- applet: BR generic java-devel instead of java-gcj-devel (#755783)
445- use runuser to start Xvnc in systemd service file (#754259)
446- don't attepmt to restart Xvnc session during update/erase (#753216)
447
448* Fri Nov 11 2011 Adam Tkac <atkac redhat com> - 1.1.0-2
449- libvnc.so: don't use unexported GetMaster function (#744881)
450- remove nasm buildreq
451
452* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
453- update to 1.1.0
454- update the xorg11 patch
455- patches merged
456  - tigervnc11-glx.patch
457  - tigervnc11-CVE-2011-1775.patch
458  - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
459
460* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
461- add systemd service file and remove legacy SysV initscript (#717227)
462
463* Thu May 12 2011 Adam Tkac <atkac redhat com> - 1.0.90-5
464- make Xvnc buildable against X.Org 1.11
465
466* Tue May 10 2011 Adam Tkac <atkac redhat com> - 1.0.90-4
467- viewer can send password without proper validation of X.509 certs
468  (CVE-2011-1775)
469
470* Wed Apr 13 2011 Adam Tkac <atkac redhat com> - 1.0.90-3
471- fix wrong usage of memcpy which caused screen artifacts (#652590)
472- don't point to inaccessible link in sysconfig/vncservers (#644975)
473
474* Fri Apr 08 2011 Adam Tkac <atkac redhat com> - 1.0.90-2
475- improve compatibility with vinagre client (#692048)
476
477* Tue Mar 22 2011 Adam Tkac <atkac redhat com> - 1.0.90-1
478- update to 1.0.90
479
480* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.90-0.32.20110117svn4237
481- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
482
483* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
484- fix libvnc.so module loading
485
486* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
487- update to r4237
488- patches merged
489  - tigervnc11-optionsdialog.patch
490  - tigervnc11-rh607866.patch
491
492* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.29.20101208svn4225
493- improve patch for keyboard issues
494
495* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.28.20101208svn4225
496- attempt to fix various keyboard-related issues (key repeating etc)
497
498* Fri Jan 07 2011 Adam Tkac <atkac redhat com> 1.0.90-0.27.20101208svn4225
499- render "Ok" and "Cancel" buttons in the options dialog correctly
500
501* Wed Dec 15 2010 Jan Görig <jgorig redhat com> 1.0.90-0.26.20101208svn4225
502- added vncserver lock file (#662784)
503
504* Fri Dec 10 2010 Adam Tkac <atkac redhat com> 1.0.90-0.25.20101208svn4225
505- update to r4225
506- patches merged
507  - tigervnc11-rh611677.patch
508  - tigervnc11-rh633931.patch
509  - tigervnc11-xorg1.10.patch
510- enable VeNCrypt and PAM support
511
512* Mon Dec 06 2010 Adam Tkac <atkac redhat com> 1.0.90-0.24.20100813svn4123
513- rebuild against xserver 1.10.X
514- 0001-Return-Success-from-generate_modkeymap-when-max_keys.patch merged
515
516* Wed Sep 29 2010 jkeating - 1.0.90-0.23.20100813svn4123
517- Rebuilt for gcc bug 634757
518
519* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.22.20100420svn4030
520- drop xorg-x11-fonts-misc dependency (#636170)
521
522* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.21.20100420svn4030
523- improve patch for #633645 (fix tcsh incompatibilities)
524
525* Thu Sep 16 2010 Adam Tkac <atkac redhat com> 1.0.90-0.20.20100813svn4123
526- press fake modifiers correctly (#633931)
527- supress unneeded debug information emitted from initscript (#633645)
528
529* Wed Aug 25 2010 Adam Tkac <atkac redhat com> 1.0.90-0.19.20100813svn4123
530- separate Xvnc, vncpasswd and vncconfig to -server-minimal subpkg (#626946)
531- move license to separate subpkg and Requires it from main subpkgs
532- Xvnc: handle situations when no modifiers exist well (#611677)
533
534* Fri Aug 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.18.20100813svn4123
535- update to r4123 (#617973)
536- add perl requires to -server subpkg (#619791)
537
538* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
539- update to r4113
540- patches merged
541  - tigervnc11-rh586406.patch
542  - tigervnc11-libvnc.patch
543  - tigervnc11-rh597172.patch
544  - tigervnc11-rh600070.patch
545  - tigervnc11-options.patch
546- don't own %%{_datadir}/icons directory (#614301)
547- minor improvements in the .desktop file (#616340)
548- bundled libjpeg configure requires nasm; is executed even if system-wide
549  libjpeg is used
550
551* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
552- build against system-wide libjpeg-turbo (#494458)
553- build no longer requires nasm
554
555* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 1.0.90-0.15.20100420svn4030
556- vncserver: accept <+optname> option when specified as the first one
557
558* Thu Jun 24 2010 Adam Tkac <atkac redhat com> 1.0.90-0.14.20100420svn4030
559- fix memory leak in Xvnc input code (#597172)
560- don't crash when receive negative encoding (#600070)
561- explicitly disable udev configuration support
562- add gettext-autopoint to BR
563
564* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 1.0.90-0.13.20100420svn4030
565- update URL about SSH tunneling in the sysconfig file (#601996)
566
567* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 1.0.90-0.12.20100420svn4030
568- use newer gettext
569- autopoint now uses git instead of cvs, adjust BuildRequires appropriately
570
571* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.11.20100420svn4030
572- link libvnc.so "now" to catch "undefined symbol" errors during Xorg startup
573- use always XkbConvertCase instead of XConvertCase (#580159, #586406)
574- don't link libvnc.so against libXi.la, libdix.la and libxkb.la; use symbols
575  from Xorg instead
576
577* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
578- update to r4030 snapshot
579- patches merged to upstream
580  - tigervnc11-rh522369.patch
581  - tigervnc11-rh551262.patch
582  - tigervnc11-r4002.patch
583  - tigervnc11-r4014.patch
584
585* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
586- add server-applet subpackage which contains Java vncviewer applet
587- fix Java applet; it didn't work when run from web browser
588- add xorg-x11-xkb-utils to server Requires
589
590* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
591- add French translation to vncviewer.desktop (thanks to Alain Portal)
592
593* Thu Mar 04 2010 Adam Tkac <atkac redhat com> 1.0.90-0.7.20100219svn3993
594- don't crash during pixel format change (#522369, #551262)
595
596* Mon Mar 01 2010 Adam Tkac <atkac redhat com> 1.0.90-0.6.20100219svn3993
597- add mesa-dri-drivers and xkeyboard-config to -server Requires
598- update to r3993 1.0.90 snapshot
599  - tigervnc11-noexecstack.patch merged
600  - tigervnc11-xorg18.patch merged
601  - xserver18.patch is no longer needed
602
603* Wed Jan 27 2010 Jan Gorig <jgorig redhat com> 1.0.90-0.5.20091221svn3929
604- initscript LSB compliance fixes (#523974)
605
606* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
607- mark stack as non-executable in jpeg ASM code
608- add xorg-x11-xauth to Requires
609- add support for X.Org 1.8
610- drop shave sources, they are no longer needed
611
612* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
613- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
614
615* Thu Jan 07 2010 Adam Tkac <atkac redhat com> 1.0.90-0.2.20091221svn3929
616- add patch for upstream X.Org issue #25909
617- add libXdmcp-devel to build requires to build Xvnc with XDMCP support (#552322)
618
619* Mon Dec 21 2009 Adam Tkac <atkac redhat com> 1.0.90-0.1.20091221svn3929
620- update to 1.0.90 snapshot
621- patches merged
622  - tigervnc10-compat.patch
623  - tigervnc10-rh510185.patch
624  - tigervnc10-rh524340.patch
625  - tigervnc10-rh516274.patch
626
627* Mon Oct 26 2009 Adam Tkac <atkac redhat com> 1.0.0-3
628- create Xvnc keyboard mapping before first keypress (#516274)
629
630* Thu Oct 08 2009 Adam Tkac <atkac redhat com> 1.0.0-2
631- update underlying X source to 1.6.4-0.3.fc11
632- remove bogus '-nohttpd' parameter from /etc/sysconfig/vncservers (#525629)
633- initscript LSB compliance fixes (#523974)
634- improve -LowColorSwitch documentation and handling (#510185)
635- honor dotWhenNoCursor option (and it's changes) every time (#524340)
636
637* Fri Aug 28 2009 Adam Tkac <atkac redhat com> 1.0.0-1
638- update to 1.0.0
639- tigervnc10-rh495457.patch merged to upstream
640
641* Mon Aug 24 2009 Karsten Hopp <karsten@redhat.com> 0.0.91-0.17
642- fix ifnarch s390x for server-module
643
644* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.0.91-0.16
645- rebuilt with new openssl
646
647* Tue Aug 04 2009 Adam Tkac <atkac redhat com> 0.0.91-0.15
648- make Xvnc compilable
649
650* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.91-0.14.1
651- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
652
653* Mon Jul 13 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13.1
654- don't write warning when initscript is called with condrestart param (#508367)
655
656* Tue Jun 23 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13
657- temporary use F11 Xserver base to make Xvnc compilable
658- BuildRequires: libXi-devel
659- don't ship tigervnc-server-module on s390/s390x
660
661* Mon Jun 22 2009 Adam Tkac <atkac redhat com> 0.0.91-0.12
662- fix local rendering of cursor (#495457)
663
664* Thu Jun 18 2009 Adam Tkac <atkac redhat com> 0.0.91-0.11
665- update to 0.0.91 (1.0.0 RC1)
666- patches merged
667  - tigervnc10-rh499401.patch
668  - tigervnc10-rh497592.patch
669  - tigervnc10-rh501832.patch
670- after discusion in upstream drop tigervnc-bounds.patch
671- configure flags cleanup
672
673* Thu May 21 2009 Adam Tkac <atkac redhat com> 0.0.90-0.10
674- rebuild against 1.6.1.901 X server (#497835)
675- disable i18n, vncviewer is not UTF-8 compatible (#501832)
676
677* Mon May 18 2009 Adam Tkac <atkac redhat com> 0.0.90-0.9
678- fix vncpasswd crash on long passwords (#499401)
679- start session dbus daemon correctly (#497592)
680
681* Mon May 11 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8.1
682- remove merged tigervnc-manminor.patch
683
684* Tue May 05 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8
685- update to 0.0.90
686
687* Thu Apr 30 2009 Adam Tkac <atkac redhat com> 0.0.90-0.7.20090427svn3789
688- server package now requires xorg-x11-fonts-misc (#498184)
689
690* Mon Apr 27 2009 Adam Tkac <atkac redhat com> 0.0.90-0.6.20090427svn3789
691- update to r3789
692  - tigervnc-rh494801.patch merged
693- tigervnc-newfbsize.patch is no longer needed
694- fix problems when vncviewer and Xvnc run on different endianess (#496653)
695- UltraVNC and TightVNC clients work fine again (#496786)
696
697* Wed Apr 08 2009 Adam Tkac <atkac redhat com> 0.0.90-0.5.20090403svn3751
698- workaround broken fontpath handling in vncserver script (#494801)
699
700* Fri Apr 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.4.20090403svn3751
701- update to r3751
702- patches merged
703  - tigervnc-xclients.patch
704  - tigervnc-clipboard.patch
705  - tigervnc-rh212985.patch
706- basic RandR support in Xvnc (resize of the desktop)
707- use built-in libjpeg (SSE2/MMX accelerated encoding on x86 platform)
708- use Tight encoding by default
709- use TigerVNC icons
710
711* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.3.20090303svn3631
712- update to r3631
713
714* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.2.20090302svn3621
715- package review related fixes
716
717* Mon Mar 02 2009 Adam Tkac <atkac redhat com> 0.0.90-0.1.20090302svn3621
718- initial package, r3621
Note: See TracBrowser for help on using the repository browser.