source: projects/specs/trunk/t/tigervnc/tigervnc-vl.spec @ 10986

Revision 10986, 26.0 KB checked in by munepi, 7 years ago (diff)

new upstream release

Line 
1Name:           tigervnc
2Version:        1.7.1
3Release:        1%{?_dist_release}
4Summary:        A TigerVNC remote display system
5Group:          User Interface/Desktops
6License:        GPLv2+
7URL:            http://www.tigervnc.com
8
9Source0:        %{name}-%{version}.tar.gz
10Source1:        vncserver.service.upstart
11Source2:        vncserver.sysconfig.upstart
12Source3:        10-libvnc.conf
13Source6:        vncviewer.desktop
14
15#[ad-hoc] xorg-x11-server-source: has no hw/xfree86/Xorg.sh.in
16Source1000:     Xorg.sh.in
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
21Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
22
23BuildRequires:  libX11-devel, automake, autoconf, libtool, gettext
24BuildRequires:  libXext-devel, xorg-x11-server-source, libXi-devel
25BuildRequires:  xorg-x11-xtrans-devel, xorg-x11-util-macros, libXtst-devel
26BuildRequires:  libdrm-devel, libXt-devel, pixman-devel libXfont-devel
27BuildRequires:  libxkbfile-devel, openssl-devel, libpciaccess-devel
28BuildRequires:  mesa-libGL-devel, libXinerama-devel, ImageMagick
29BuildRequires:  freetype2-devel, libXdmcp-devel, libxshmfence-devel
30BuildRequires:  desktop-file-utils, java-devel, jpackage-utils
31BuildRequires:  libjpeg-turbo-devel, gnutls-devel, pam-devel
32BuildRequires:  cmake
33# TigerVNC 1.4.x requires fltk 1.3.3 for keyboard handling support
34# See https://github.com/TigerVNC/tigervnc/issues/8, also bug #1208814
35BuildRequires:  fltk-devel >= 1.3.3
36
37Requires(post): coreutils
38Requires(postun):coreutils
39
40Requires:       hicolor-icon-theme
41
42Patch1:         tigervnc-1.7.0-xserver119-support.patch
43Patch2:         0001-Fix-inetd-not-working-with-xserver-1.19.patch
44Patch3:         tigervnc-libvnc-os.patch
45Patch7:         tigervnc-manpages.patch
46Patch8:         tigervnc-getmaster.patch
47Patch9:         tigervnc-shebang.patch
48Patch14:        tigervnc-xstartup.patch
49Patch18:        tigervnc-utilize-system-crypto-policies.patch
50
51# This is tigervnc-%{version}/unix/xserver116.patch rebased on the latest xorg
52# Patch100:       tigervnc-xserver119.patch
53Patch100:       tigervnc-xserver116-rebased.patch
54
55%description
56Virtual Network Computing (VNC) is a remote display system which
57allows you to view a computing 'desktop' environment not only on the
58machine where it is running, but from anywhere on the Internet and
59from a wide variety of machine architectures.
60This package contains a client which will allow you to connect to
61other desktops running a VNC server.
62
63%package server
64Summary:        A TigerVNC server
65Group:          User Interface/X
66Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
67Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
68Requires:       perl
69Requires:       xorg-x11-xauth, xorg-x11-xinit, xorg-x11-server-Xorg
70Requires:       mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
71Requires(post): chkconfig
72Requires(preun):chkconfig
73Requires(preun):initscripts
74Requires(postun):initscripts
75
76%description server
77The VNC system allows you to access the same desktop from a wide
78variety of platforms. 
79This package includes the following components:
80 - TigerVNC server: It allows others to access the desktop on your machine
81 - set of utilities: It makes usage of TigerVNC server more user friendly
82 - x0vncserver program: It can export your active X session
83
84%package server-applet
85Summary:        Java TigerVNC viewer applet for TigerVNC server
86Group:          User Interface/X
87Requires:       tigervnc-server, java, jpackage-utils
88BuildArch:      noarch
89
90%description server-applet
91The Java TigerVNC viewer applet for web browsers.
92Install this package to allow clients to use web browser when connect
93to the TigerVNC server.
94
95
96%prep
97%setup -q
98
99%patch1 -p1 -b .xserver119
100%patch2 -p1 -b .inetd
101%patch3 -p1 -b .libvnc-os
102
103cp -r /usr/share/xorg-x11-server-source/* unix/xserver || exit 1
104cp -a %{SOURCE1000} unix/xserver/hw/xfree86/ || exit 1
105pushd unix/xserver
106for all in `find . -type f -perm -001`; do
107        chmod -x "$all"
108done
109%patch100 -p1 -b .xserver116-rebased
110popd
111
112# Synchronise manpages and --help output (bug #980870).
113%patch7 -p1 -b .manpages
114
115# libvnc.so: don't use unexported GetMaster function (bug #744881 again).
116%patch8 -p1 -b .getmaster
117
118# Don't use shebang in vncserver script.
119%patch9 -p1 -b .shebang
120
121# Clearer xstartup file (bug #923655).
122%patch14 -p1 -b .xstartup
123
124# Utilize system-wide crypto policies
125%patch18 -p1 -b .utilize-system-crypto-policies.patch
126
127%build
128#export CFLAGS="$RPM_OPT_FLAGS -fpic"
129#export CXXFLAGS="$CFLAGS"
130
131%{cmake} .
132make %{?_smp_mflags}
133
134pushd unix/xserver
135autoreconf -fiv
136%configure \
137        --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
138        --disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
139        --with-pic --disable-static \
140        --with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
141        --with-fontdir=%{_datadir}/X11/fonts \
142        --with-xkb-output=%{_localstatedir}/lib/xkb \
143        --enable-install-libxf86config \
144        --enable-glx --disable-dri --enable-dri2 --enable-dri3 \
145        --disable-unit-tests \
146        --disable-config-hal \
147        --disable-config-udev \
148        --with-dri-driver-path=%{_libdir}/dri \
149        --without-dtrace \
150        --disable-devel-docs \
151        --disable-selective-werror \
152        ;
153
154make %{?_smp_mflags}
155popd
156
157# Build icons
158pushd media
159make
160popd
161
162# Build Java applet
163pushd java
164%{cmake} .
165JAVA_TOOL_OPTIONS="-Dfile.encoding=UTF8" make
166popd
167
168%install
169rm -rf $RPM_BUILD_ROOT
170make install DESTDIR=$RPM_BUILD_ROOT
171rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{README.txt,LICENCE.TXT}
172
173pushd unix/xserver/hw/vnc
174make install DESTDIR=$RPM_BUILD_ROOT
175popd
176
177# Install init stuff
178mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
179mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
180install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/vncserver
181install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/vncservers
182
183# Install desktop stuff
184mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
185
186pushd media/icons
187for s in 16 24 48; do
188install -m644 tigervnc_$s.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x$s/apps/tigervnc.png
189done
190popd
191
192mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
193desktop-file-install \
194        --dir $RPM_BUILD_ROOT%{_datadir}/applications \
195        %{SOURCE6}
196
197# Install Java applet
198pushd java
199mkdir -p $RPM_BUILD_ROOT%{_datadir}/vnc/classes
200install -m755 VncViewer.jar $RPM_BUILD_ROOT%{_datadir}/vnc/classes
201install -m644 com/tigervnc/vncviewer/index.vnc $RPM_BUILD_ROOT%{_datadir}/vnc/classes
202popd
203
204%find_lang %{name} %{name}.lang
205
206# remove unwanted files
207rm -f  $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/libvnc.la
208
209mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
210install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
211
212%clean
213rm -rf $RPM_BUILD_ROOT
214
215%post
216touch -c %{_datadir}/icons/hicolor
217if [ -x %{_bindir}/gtk-update-icon-cache ]; then
218        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
219fi
220
221%postun
222touch -c %{_datadir}/icons/hicolor
223if [ -x %{_bindir}/gtk-update-icon-cache ]; then
224        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
225fi
226
227%post server
228/sbin/chkconfig --add vncserver
229
230%triggerun -- vnc-server < 4.1.3
231/sbin/service vncserver stop &>/dev/null || :
232/sbin/chkconfig --del vncserver >/dev/null 2>&1 || :
233
234%files -f %{name}.lang
235%defattr(-,root,root,-)
236%doc README.txt LICENCE.TXT
237%{_bindir}/vncviewer
238%{_datadir}/applications/*
239%{_mandir}/man1/vncviewer.1*
240%{_datadir}/icons/hicolor/*/apps/*
241
242%files server
243%defattr(-,root,root,-)
244%config(noreplace) %{_sysconfdir}/sysconfig/vncservers
245%config(noreplace) %{_sysconfdir}/init.d/vncserver
246%{_bindir}/x0vncserver
247%{_bindir}/vncserver
248%{_bindir}/vncconfig
249%{_bindir}/vncpasswd
250%{_bindir}/Xvnc
251%{_mandir}/man1/vncserver.1*
252%{_mandir}/man1/x0vncserver.1*
253%{_mandir}/man1/Xvnc.1*
254%{_mandir}/man1/vncpasswd.1*
255%{_mandir}/man1/vncconfig.1*
256%{_libdir}/xorg/modules/extensions/libvnc.so
257%config %{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
258
259%files server-applet
260%defattr(-,root,root,-)
261%doc java/com/tigervnc/vncviewer/README
262%{_datadir}/vnc/classes/*
263
264%changelog
265* Wed Apr  5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.1-1
266- new upstream release
267- added BR: libxshmfence-devel
268
269* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.0-1
270- new upstream release
271
272* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.3-1
273- new upstream release
274
275* Wed Mar  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-2
276- rebuilt
277
278* Sun Jan  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-1
279- initial build based on Fedora rawhide
280
281* Tue Sep  9 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-11
282- Added missing part of xserver114.patch (bug #1137023).
283
284* Wed Sep  3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
285- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
286
287* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
288- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
289
290* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
291- Input reset fixes from upstream (bug #1116956).
292- No longer need ppc64le patch as it's now in xorg-x11-server.
293- Rebased xserver114.patch again.
294
295* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
296- xserver 1.15.99.903 ABI rebuild
297
298* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
299- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
300
301* Thu May 22 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-5
302- Keep pointer in sync when using module (upstream bug #152).
303
304* Mon Apr 28 2014 Adam Jackson <ajax@redhat.com> 1.3.1-4
305- Add version interlocks for -server-module
306
307* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-3
308- xserver 1.15.99-20140428 git snapshot ABI rebuild
309
310* Mon Apr  7 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-2
311- Allow build with dri3 and present extensions (bug #1063392).
312
313* Thu Mar 27 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-1
314- 1.3.1 (bug #1078806).
315- Add ppc64le support (bug #1078495).
316
317* Wed Mar 19 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-15
318- Disable dri3 to enable building (bug #1063392).
319- Fixed heap-based buffer overflow (CVE-2014-0011, bug #1050928).
320
321* Fri Feb 21 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-14
322- Enabled hardened build (bug #955206).
323
324* Mon Feb 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-13
325- Clearer xstartup file (bug #923655).
326
327* Tue Jan 14 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-12
328- Fixed instructions in systemd unit file.
329
330* Fri Jan 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-11
331- Fixed viewer crash when cursor has not been set (bug #1038701).
332
333* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-10
334- Avoid invalid read when ZRLE connection closed (upstream bug #133).
335
336* Tue Dec  3 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-9
337- Fixed build failure with -Werror=format-security (bug #1037358).
338
339* Thu Nov 07 2013 Adam Jackson <ajax@redhat.com> 1.3.0-8
340- Rebuild against xserver 1.15RC1
341
342* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
343- Removed incorrect patch (for unexpected key_is_down). Fixes stuck
344  keys bug (bug #989502).
345
346* Thu Sep 19 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-6
347- Fixed typo in 10-libvnc.conf (bug #1009111).
348
349* Wed Sep 18 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-5
350- Better fix for PIDFile problem (bug #983232).
351
352* Mon Aug  5 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-4
353- Fixed doc-related build failure (bug #992790).
354
355* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-3
356- Avoid PIDFile problems in systemd unit file (bug #983232).
357- libvnc.so: don't use unexported key_is_down function.
358- Don't use shebang in vncserver script.
359
360* Fri Jul 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-2
361- Renumbered patches.
362- libvnc.so: don't use unexported GetMaster function (bug #744881 again).
363
364* Mon Jul  8 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-1
365- 1.3.0.
366
367* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.18.20130314svn5065
368- Removed systemd_requires macro in order to fix the build.
369
370* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.17.20130314svn5065
371- Synchronise manpages and --help output (bug #980870).
372
373* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.16.20130314svn5065
374- tigervnc-setcursor-crash.patch: Attempt to paper over a crash in Xvnc when
375  setting the cursor.
376
377* Sat Jun 08 2013 Dennis Gilmore <dennis@ausil.us> 1.2.80-0.15.20130314svn5065
378- bump to rebuild and pick up bugfix causing X to crash on ppc and arm
379
380* Thu May 23 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.14.20130314svn5065
381- Use systemd rpm macros (bug #850340).  Moved systemd requirements
382  from main package to server sub-package.
383- Applied Debian patch to fix busy loop when run from inetd in nowait
384  mode (bug #920373).
385- Added dependency on xorg-x11-xinit to server sub-package so that
386  default window manager can be found (bug #896284, bug #923655).
387- Fixed bogus changelog date.
388
389* Thu Mar 14 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.13.20130314svn5065
390- Less RHEL customization
391
392* Thu Mar 14 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.12.20130314svn5065
393- include /etc/X11/xorg.conf.d/10-libvnc.conf sample configuration (#712482)
394- vncserver now honors specified -geometry parameter (#755947)
395
396* Tue Mar 12 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.11.20130307svn5060
397- update to r5060
398- split icons to separate package to avoid multilib issues
399
400* Tue Feb 19 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.10.20130219svn5047
401- update to r5047 (X.Org 1.14 support)
402
403* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.80-0.9.20121126svn5015
404- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
405
406* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.8.20121126svn5015
407- rebuild due to "jpeg8-ABI" feature drop
408
409* Wed Jan 16 2013 Adam Tkac <atkac redhat com> 1.2.80-0.7.20121126svn5015
410- rebuild
411
412* Tue Dec 04 2012 Adam Tkac <atkac redhat com> 1.2.80-0.6.20121126svn5015
413- rebuild against new fltk
414
415* Mon Nov 26 2012 Adam Tkac <atkac redhat com> 1.2.80-0.5.20121126svn5015
416- update to r5015
417- build with -fpic instead of -fPIC on all archs except s390/sparc
418
419* Wed Nov  7 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.80-0.4.20120905svn4996
420- Build with -fPIC to fix FTBFS on ARM
421
422* Wed Oct 31 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.3.20120905svn4996
423- tigervnc12-xorg113-glx.patch: Fix to only init glx on the first server
424  generation
425
426* Fri Sep 28 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.2.20120905svn4996
427- tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13
428
429* Fri Aug 17 2012 Adam Tkac <atkac redhat com> 1.2.80-0.1.20120905svn4996
430- update to 1.2.80
431- remove deprecated patches
432  - tigervnc-102434.patch
433  - tigervnc-viewer-reparent.patch
434  - tigervnc11-java7.patch
435- patches merged
436  - tigervnc11-xorg111.patch
437  - tigervnc11-xorg112.patch
438
439* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
440- fix build against newer X server
441
442* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
443- Build with the Composite extension for feature parity with other X servers
444
445* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
446- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
447
448* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
449- fix building against X.org 1.13
450
451* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
452- RHEL exclusion for -server-module on ppc* too
453
454* Mon Mar 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-5
455- clean Xvnc's /tmp environment in service file before startup
456- fix building against the latest JAVA 7 and X.Org 1.12
457
458* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-4
459- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
460
461* Tue Nov 22 2011 Adam Tkac <atkac redhat com> - 1.1.0-3
462- don't build X.Org devel docs (#755782)
463- applet: BR generic java-devel instead of java-gcj-devel (#755783)
464- use runuser to start Xvnc in systemd service file (#754259)
465- don't attepmt to restart Xvnc session during update/erase (#753216)
466
467* Fri Nov 11 2011 Adam Tkac <atkac redhat com> - 1.1.0-2
468- libvnc.so: don't use unexported GetMaster function (#744881)
469- remove nasm buildreq
470
471* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
472- update to 1.1.0
473- update the xorg11 patch
474- patches merged
475  - tigervnc11-glx.patch
476  - tigervnc11-CVE-2011-1775.patch
477  - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
478
479* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
480- add systemd service file and remove legacy SysV initscript (#717227)
481
482* Thu May 12 2011 Adam Tkac <atkac redhat com> - 1.0.90-5
483- make Xvnc buildable against X.Org 1.11
484
485* Tue May 10 2011 Adam Tkac <atkac redhat com> - 1.0.90-4
486- viewer can send password without proper validation of X.509 certs
487  (CVE-2011-1775)
488
489* Wed Apr 13 2011 Adam Tkac <atkac redhat com> - 1.0.90-3
490- fix wrong usage of memcpy which caused screen artifacts (#652590)
491- don't point to inaccessible link in sysconfig/vncservers (#644975)
492
493* Fri Apr 08 2011 Adam Tkac <atkac redhat com> - 1.0.90-2
494- improve compatibility with vinagre client (#692048)
495
496* Tue Mar 22 2011 Adam Tkac <atkac redhat com> - 1.0.90-1
497- update to 1.0.90
498
499* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.90-0.32.20110117svn4237
500- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
501
502* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
503- fix libvnc.so module loading
504
505* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
506- update to r4237
507- patches merged
508  - tigervnc11-optionsdialog.patch
509  - tigervnc11-rh607866.patch
510
511* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.29.20101208svn4225
512- improve patch for keyboard issues
513
514* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.28.20101208svn4225
515- attempt to fix various keyboard-related issues (key repeating etc)
516
517* Fri Jan 07 2011 Adam Tkac <atkac redhat com> 1.0.90-0.27.20101208svn4225
518- render "Ok" and "Cancel" buttons in the options dialog correctly
519
520* Wed Dec 15 2010 Jan Görig <jgorig redhat com> 1.0.90-0.26.20101208svn4225
521- added vncserver lock file (#662784)
522
523* Fri Dec 10 2010 Adam Tkac <atkac redhat com> 1.0.90-0.25.20101208svn4225
524- update to r4225
525- patches merged
526  - tigervnc11-rh611677.patch
527  - tigervnc11-rh633931.patch
528  - tigervnc11-xorg1.10.patch
529- enable VeNCrypt and PAM support
530
531* Mon Dec 06 2010 Adam Tkac <atkac redhat com> 1.0.90-0.24.20100813svn4123
532- rebuild against xserver 1.10.X
533- 0001-Return-Success-from-generate_modkeymap-when-max_keys.patch merged
534
535* Wed Sep 29 2010 jkeating - 1.0.90-0.23.20100813svn4123
536- Rebuilt for gcc bug 634757
537
538* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.22.20100420svn4030
539- drop xorg-x11-fonts-misc dependency (#636170)
540
541* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.21.20100420svn4030
542- improve patch for #633645 (fix tcsh incompatibilities)
543
544* Thu Sep 16 2010 Adam Tkac <atkac redhat com> 1.0.90-0.20.20100813svn4123
545- press fake modifiers correctly (#633931)
546- supress unneeded debug information emitted from initscript (#633645)
547
548* Wed Aug 25 2010 Adam Tkac <atkac redhat com> 1.0.90-0.19.20100813svn4123
549- separate Xvnc, vncpasswd and vncconfig to -server-minimal subpkg (#626946)
550- move license to separate subpkg and Requires it from main subpkgs
551- Xvnc: handle situations when no modifiers exist well (#611677)
552
553* Fri Aug 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.18.20100813svn4123
554- update to r4123 (#617973)
555- add perl requires to -server subpkg (#619791)
556
557* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
558- update to r4113
559- patches merged
560  - tigervnc11-rh586406.patch
561  - tigervnc11-libvnc.patch
562  - tigervnc11-rh597172.patch
563  - tigervnc11-rh600070.patch
564  - tigervnc11-options.patch
565- don't own %%{_datadir}/icons directory (#614301)
566- minor improvements in the .desktop file (#616340)
567- bundled libjpeg configure requires nasm; is executed even if system-wide
568  libjpeg is used
569
570* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
571- build against system-wide libjpeg-turbo (#494458)
572- build no longer requires nasm
573
574* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 1.0.90-0.15.20100420svn4030
575- vncserver: accept <+optname> option when specified as the first one
576
577* Thu Jun 24 2010 Adam Tkac <atkac redhat com> 1.0.90-0.14.20100420svn4030
578- fix memory leak in Xvnc input code (#597172)
579- don't crash when receive negative encoding (#600070)
580- explicitly disable udev configuration support
581- add gettext-autopoint to BR
582
583* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 1.0.90-0.13.20100420svn4030
584- update URL about SSH tunneling in the sysconfig file (#601996)
585
586* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 1.0.90-0.12.20100420svn4030
587- use newer gettext
588- autopoint now uses git instead of cvs, adjust BuildRequires appropriately
589
590* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.11.20100420svn4030
591- link libvnc.so "now" to catch "undefined symbol" errors during Xorg startup
592- use always XkbConvertCase instead of XConvertCase (#580159, #586406)
593- don't link libvnc.so against libXi.la, libdix.la and libxkb.la; use symbols
594  from Xorg instead
595
596* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
597- update to r4030 snapshot
598- patches merged to upstream
599  - tigervnc11-rh522369.patch
600  - tigervnc11-rh551262.patch
601  - tigervnc11-r4002.patch
602  - tigervnc11-r4014.patch
603
604* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
605- add server-applet subpackage which contains Java vncviewer applet
606- fix Java applet; it didn't work when run from web browser
607- add xorg-x11-xkb-utils to server Requires
608
609* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
610- add French translation to vncviewer.desktop (thanks to Alain Portal)
611
612* Thu Mar 04 2010 Adam Tkac <atkac redhat com> 1.0.90-0.7.20100219svn3993
613- don't crash during pixel format change (#522369, #551262)
614
615* Mon Mar 01 2010 Adam Tkac <atkac redhat com> 1.0.90-0.6.20100219svn3993
616- add mesa-dri-drivers and xkeyboard-config to -server Requires
617- update to r3993 1.0.90 snapshot
618  - tigervnc11-noexecstack.patch merged
619  - tigervnc11-xorg18.patch merged
620  - xserver18.patch is no longer needed
621
622* Wed Jan 27 2010 Jan Gorig <jgorig redhat com> 1.0.90-0.5.20091221svn3929
623- initscript LSB compliance fixes (#523974)
624
625* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
626- mark stack as non-executable in jpeg ASM code
627- add xorg-x11-xauth to Requires
628- add support for X.Org 1.8
629- drop shave sources, they are no longer needed
630
631* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
632- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
633
634* Thu Jan 07 2010 Adam Tkac <atkac redhat com> 1.0.90-0.2.20091221svn3929
635- add patch for upstream X.Org issue #25909
636- add libXdmcp-devel to build requires to build Xvnc with XDMCP support (#552322)
637
638* Mon Dec 21 2009 Adam Tkac <atkac redhat com> 1.0.90-0.1.20091221svn3929
639- update to 1.0.90 snapshot
640- patches merged
641  - tigervnc10-compat.patch
642  - tigervnc10-rh510185.patch
643  - tigervnc10-rh524340.patch
644  - tigervnc10-rh516274.patch
645
646* Mon Oct 26 2009 Adam Tkac <atkac redhat com> 1.0.0-3
647- create Xvnc keyboard mapping before first keypress (#516274)
648
649* Thu Oct 08 2009 Adam Tkac <atkac redhat com> 1.0.0-2
650- update underlying X source to 1.6.4-0.3.fc11
651- remove bogus '-nohttpd' parameter from /etc/sysconfig/vncservers (#525629)
652- initscript LSB compliance fixes (#523974)
653- improve -LowColorSwitch documentation and handling (#510185)
654- honor dotWhenNoCursor option (and it's changes) every time (#524340)
655
656* Fri Aug 28 2009 Adam Tkac <atkac redhat com> 1.0.0-1
657- update to 1.0.0
658- tigervnc10-rh495457.patch merged to upstream
659
660* Mon Aug 24 2009 Karsten Hopp <karsten@redhat.com> 0.0.91-0.17
661- fix ifnarch s390x for server-module
662
663* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.0.91-0.16
664- rebuilt with new openssl
665
666* Tue Aug 04 2009 Adam Tkac <atkac redhat com> 0.0.91-0.15
667- make Xvnc compilable
668
669* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.91-0.14.1
670- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
671
672* Mon Jul 13 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13.1
673- don't write warning when initscript is called with condrestart param (#508367)
674
675* Tue Jun 23 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13
676- temporary use F11 Xserver base to make Xvnc compilable
677- BuildRequires: libXi-devel
678- don't ship tigervnc-server-module on s390/s390x
679
680* Mon Jun 22 2009 Adam Tkac <atkac redhat com> 0.0.91-0.12
681- fix local rendering of cursor (#495457)
682
683* Thu Jun 18 2009 Adam Tkac <atkac redhat com> 0.0.91-0.11
684- update to 0.0.91 (1.0.0 RC1)
685- patches merged
686  - tigervnc10-rh499401.patch
687  - tigervnc10-rh497592.patch
688  - tigervnc10-rh501832.patch
689- after discusion in upstream drop tigervnc-bounds.patch
690- configure flags cleanup
691
692* Thu May 21 2009 Adam Tkac <atkac redhat com> 0.0.90-0.10
693- rebuild against 1.6.1.901 X server (#497835)
694- disable i18n, vncviewer is not UTF-8 compatible (#501832)
695
696* Mon May 18 2009 Adam Tkac <atkac redhat com> 0.0.90-0.9
697- fix vncpasswd crash on long passwords (#499401)
698- start session dbus daemon correctly (#497592)
699
700* Mon May 11 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8.1
701- remove merged tigervnc-manminor.patch
702
703* Tue May 05 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8
704- update to 0.0.90
705
706* Thu Apr 30 2009 Adam Tkac <atkac redhat com> 0.0.90-0.7.20090427svn3789
707- server package now requires xorg-x11-fonts-misc (#498184)
708
709* Mon Apr 27 2009 Adam Tkac <atkac redhat com> 0.0.90-0.6.20090427svn3789
710- update to r3789
711  - tigervnc-rh494801.patch merged
712- tigervnc-newfbsize.patch is no longer needed
713- fix problems when vncviewer and Xvnc run on different endianess (#496653)
714- UltraVNC and TightVNC clients work fine again (#496786)
715
716* Wed Apr 08 2009 Adam Tkac <atkac redhat com> 0.0.90-0.5.20090403svn3751
717- workaround broken fontpath handling in vncserver script (#494801)
718
719* Fri Apr 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.4.20090403svn3751
720- update to r3751
721- patches merged
722  - tigervnc-xclients.patch
723  - tigervnc-clipboard.patch
724  - tigervnc-rh212985.patch
725- basic RandR support in Xvnc (resize of the desktop)
726- use built-in libjpeg (SSE2/MMX accelerated encoding on x86 platform)
727- use Tight encoding by default
728- use TigerVNC icons
729
730* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.3.20090303svn3631
731- update to r3631
732
733* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.2.20090302svn3621
734- package review related fixes
735
736* Mon Mar 02 2009 Adam Tkac <atkac redhat com> 0.0.90-0.1.20090302svn3621
737- initial package, r3621
Note: See TracBrowser for help on using the repository browser.