source: projects/specs/trunk/t/tigervnc/tigervnc-vl.spec @ 9940

Revision 9940, 25.9 KB checked in by munepi, 8 years ago (diff)

new upstream release

Line 
1Name:           tigervnc
2Version:        1.6.0
3Release:        1%{?_dist_release}
4Summary:        A TigerVNC remote display system
5Group:          User Interface/Desktops
6License:        GPLv2+
7URL:            http://www.tigervnc.com
8
9Source0:        %{name}-%{version}.tar.gz
10Source1:        vncserver.service.upstart
11Source2:        vncserver.sysconfig.upstart
12Source3:        10-libvnc.conf
13Source6:        vncviewer.desktop
14
15#[ad-hoc] xorg-x11-server-source: has no hw/xfree86/Xorg.sh.in
16Source1000:     Xorg.sh.in
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19
20Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
21Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
22
23BuildRequires:  automake, autoconf, libtool, gettext
24BuildRequires:  libX11-devel
25BuildRequires:  libXext-devel, xorg-x11-server-source, libXi-devel
26BuildRequires:  xorg-x11-xtrans-devel, xorg-x11-util-macros, libXtst-devel
27BuildRequires:  libdrm-devel, libXt-devel, pixman-devel libXfont-devel
28BuildRequires:  libxkbfile-devel, openssl-devel, libpciaccess-devel
29BuildRequires:  mesa-libGL-devel, libXinerama-devel, ImageMagick
30BuildRequires:  freetype2-devel, libXdmcp-devel
31BuildRequires:  desktop-file-utils, java-devel, jpackage-utils
32BuildRequires:  libjpeg-turbo-devel, gnutls-devel, pam-devel
33BuildRequires:  cmake
34# TigerVNC 1.4.x requires fltk 1.3.3 for keyboard handling support
35# See https://github.com/TigerVNC/tigervnc/issues/8, also bug #1208814
36BuildRequires:  fltk-devel >= 1.3.3
37
38Requires(post): coreutils
39Requires(postun):coreutils
40
41Requires:       hicolor-icon-theme
42
43Patch1:         tigervnc-cookie.patch
44Patch3:         tigervnc-libvnc-os.patch
45Patch4:         tigervnc11-rh692048.patch
46Patch5:         tigervnc-inetd-nowait.patch
47Patch7:         tigervnc-manpages.patch
48Patch8:         tigervnc-getmaster.patch
49Patch9:         tigervnc-shebang.patch
50Patch14:        tigervnc-xstartup.patch
51Patch15:        tigervnc-xserver118.patch
52# Patch17:      tigervnc-xorg118-QueueKeyboardEvents.patch
53
54# This is tigervnc-%{version}/unix/xserver116.patch rebased on the latest xorg
55Patch100:       tigervnc-xserver116-rebased.patch
56
57%description
58Virtual Network Computing (VNC) is a remote display system which
59allows you to view a computing 'desktop' environment not only on the
60machine where it is running, but from anywhere on the Internet and
61from a wide variety of machine architectures.
62This package contains a client which will allow you to connect to
63other desktops running a VNC server.
64
65%package server
66Summary:        A TigerVNC server
67Group:          User Interface/X
68Provides:       vnc = 4.1.3, vnc-libs = 4.1.3, vnc-server = 4.1.3
69Obsoletes:      vnc < 4.1.3, vnc-libs < 4.1.3, vnc-server < 4.1.3
70Requires:       perl
71Requires:       xorg-x11-xauth, xorg-x11-xinit, xorg-x11-server-Xorg
72Requires:       mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
73Requires(post): chkconfig
74Requires(preun):chkconfig
75Requires(preun):initscripts
76Requires(postun):initscripts
77
78%description server
79The VNC system allows you to access the same desktop from a wide
80variety of platforms. 
81This package includes the following components:
82 - TigerVNC server: It allows others to access the desktop on your machine
83 - set of utilities: It makes usage of TigerVNC server more user friendly
84 - x0vncserver program: It can export your active X session
85
86%package server-applet
87Summary:        Java TigerVNC viewer applet for TigerVNC server
88Group:          User Interface/X
89Requires:       tigervnc-server, java, jpackage-utils
90BuildArch:      noarch
91
92%description server-applet
93The Java TigerVNC viewer applet for web browsers.
94Install this package to allow clients to use web browser when connect
95to the TigerVNC server.
96
97
98%prep
99%setup -q
100
101%patch1 -p1 -b .cookie
102%patch3 -p1 -b .libvnc-os
103%patch4 -p1 -b .rh692048
104
105cp -r /usr/share/xorg-x11-server-source/* unix/xserver || exit 1
106cp -a %{SOURCE1000} unix/xserver/hw/xfree86/ || exit 1
107pushd unix/xserver
108for all in `find . -type f -perm -001`; do
109        chmod -x "$all"
110done
111%patch100 -p1 -b .xserver116-rebased
112popd
113
114# Applied Debian patch to fix busy loop when run from inetd in nowait
115# mode (bug #920373).
116%patch5 -p1 -b .inetd-nowait
117
118# Synchronise manpages and --help output (bug #980870).
119%patch7 -p1 -b .manpages
120
121# libvnc.so: don't use unexported GetMaster function (bug #744881 again).
122%patch8 -p1 -b .getmaster
123
124# Don't use shebang in vncserver script.
125%patch9 -p1 -b .shebang
126
127# Clearer xstartup file (bug #923655).
128%patch14 -p1 -b .xstartup
129
130# Allow build against xorg-x11-server-1.18.
131%patch15 -p1 -b .xserver118
132
133# %patch17 -p1 -b .xorg118-QueueKeyboardEvents
134
135%build
136#export CFLAGS="$RPM_OPT_FLAGS -fpic"
137#export CXXFLAGS="$CFLAGS"
138
139%{cmake} .
140make %{?_smp_mflags}
141
142pushd unix/xserver
143autoreconf -fiv
144%configure \
145        --disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
146        --disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
147        --with-pic --disable-static \
148        --with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
149        --with-fontdir=%{_datadir}/X11/fonts \
150        --with-xkb-output=%{_localstatedir}/lib/xkb \
151        --enable-install-libxf86config \
152        --enable-glx --disable-dri --enable-dri2 --enable-dri3 \
153        --disable-unit-tests \
154        --disable-config-hal \
155        --disable-config-udev \
156        --with-dri-driver-path=%{_libdir}/dri \
157        --without-dtrace \
158        --disable-devel-docs \
159        --disable-selective-werror \
160        ;
161
162make %{?_smp_mflags}
163popd
164
165# Build icons
166pushd media
167make
168popd
169
170# Build Java applet
171pushd java
172%{cmake} .
173make
174popd
175
176%install
177rm -rf $RPM_BUILD_ROOT
178make install DESTDIR=$RPM_BUILD_ROOT
179rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{README.txt,LICENCE.TXT}
180
181pushd unix/xserver/hw/vnc
182make install DESTDIR=$RPM_BUILD_ROOT
183popd
184
185# Install init stuff
186mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
187mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
188install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/vncserver
189install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/vncservers
190
191# Install desktop stuff
192mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/{16x16,24x24,48x48}/apps
193
194pushd media/icons
195for s in 16 24 48; do
196install -m644 tigervnc_$s.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x$s/apps/tigervnc.png
197done
198popd
199
200mkdir $RPM_BUILD_ROOT%{_datadir}/applications
201desktop-file-install \
202        --dir $RPM_BUILD_ROOT%{_datadir}/applications \
203        %{SOURCE6}
204
205# Install Java applet
206pushd java
207mkdir -p $RPM_BUILD_ROOT%{_datadir}/vnc/classes
208install -m755 VncViewer.jar $RPM_BUILD_ROOT%{_datadir}/vnc/classes
209install -m644 com/tigervnc/vncviewer/index.vnc $RPM_BUILD_ROOT%{_datadir}/vnc/classes
210popd
211
212%find_lang %{name} %{name}.lang
213
214# remove unwanted files
215rm -f  $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/libvnc.la
216
217mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/
218install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
219
220%clean
221rm -rf $RPM_BUILD_ROOT
222
223%post
224touch -c %{_datadir}/icons/hicolor
225if [ -x %{_bindir}/gtk-update-icon-cache ]; then
226        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
227fi
228
229%postun
230touch -c %{_datadir}/icons/hicolor
231if [ -x %{_bindir}/gtk-update-icon-cache ]; then
232        %{_bindir}/gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
233fi
234
235%post server
236/sbin/chkconfig --add vncserver
237
238%triggerun -- vnc-server < 4.1.3
239/sbin/service vncserver stop &>/dev/null || :
240/sbin/chkconfig --del vncserver >/dev/null 2>&1 || :
241
242%files -f %{name}.lang
243%defattr(-,root,root,-)
244%doc README.txt LICENCE.TXT
245%{_bindir}/vncviewer
246%{_datadir}/applications/*
247%{_mandir}/man1/vncviewer.1*
248%{_datadir}/icons/hicolor/*/apps/*
249
250%files server
251%defattr(-,root,root,-)
252%config(noreplace) %{_sysconfdir}/sysconfig/vncservers
253%config(noreplace) %{_sysconfdir}/init.d/vncserver
254%{_bindir}/x0vncserver
255%{_bindir}/vncserver
256%{_bindir}/vncconfig
257%{_bindir}/vncpasswd
258%{_bindir}/Xvnc
259%{_mandir}/man1/vncserver.1*
260%{_mandir}/man1/x0vncserver.1*
261%{_mandir}/man1/Xvnc.1*
262%{_mandir}/man1/vncpasswd.1*
263%{_mandir}/man1/vncconfig.1*
264%{_libdir}/xorg/modules/extensions/libvnc.so
265%config %{_sysconfdir}/X11/xorg.conf.d/10-libvnc.conf
266
267%files server-applet
268%defattr(-,root,root,-)
269%doc java/com/tigervnc/vncviewer/README
270%{_datadir}/vnc/classes/*
271
272%changelog
273* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.0
274- new upstream release
275
276* Sun Mar 22 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.3-1
277- new upstream release
278
279* Wed Mar  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-2
280- rebuilt
281
282* Sun Jan  4 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.1-1
283- initial build based on Fedora rawhide
284
285* Tue Sep  9 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-11
286- Added missing part of xserver114.patch (bug #1137023).
287
288* Wed Sep  3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
289- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
290
291* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
292- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
293
294* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
295- Input reset fixes from upstream (bug #1116956).
296- No longer need ppc64le patch as it's now in xorg-x11-server.
297- Rebased xserver114.patch again.
298
299* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
300- xserver 1.15.99.903 ABI rebuild
301
302* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-6
303- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
304
305* Thu May 22 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-5
306- Keep pointer in sync when using module (upstream bug #152).
307
308* Mon Apr 28 2014 Adam Jackson <ajax@redhat.com> 1.3.1-4
309- Add version interlocks for -server-module
310
311* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-3
312- xserver 1.15.99-20140428 git snapshot ABI rebuild
313
314* Mon Apr  7 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-2
315- Allow build with dri3 and present extensions (bug #1063392).
316
317* Thu Mar 27 2014 Tim Waugh <twaugh@redhat.com> 1.3.1-1
318- 1.3.1 (bug #1078806).
319- Add ppc64le support (bug #1078495).
320
321* Wed Mar 19 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-15
322- Disable dri3 to enable building (bug #1063392).
323- Fixed heap-based buffer overflow (CVE-2014-0011, bug #1050928).
324
325* Fri Feb 21 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-14
326- Enabled hardened build (bug #955206).
327
328* Mon Feb 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-13
329- Clearer xstartup file (bug #923655).
330
331* Tue Jan 14 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-12
332- Fixed instructions in systemd unit file.
333
334* Fri Jan 10 2014 Tim Waugh <twaugh@redhat.com> 1.3.0-11
335- Fixed viewer crash when cursor has not been set (bug #1038701).
336
337* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-10
338- Avoid invalid read when ZRLE connection closed (upstream bug #133).
339
340* Tue Dec  3 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-9
341- Fixed build failure with -Werror=format-security (bug #1037358).
342
343* Thu Nov 07 2013 Adam Jackson <ajax@redhat.com> 1.3.0-8
344- Rebuild against xserver 1.15RC1
345
346* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
347- Removed incorrect patch (for unexpected key_is_down). Fixes stuck
348  keys bug (bug #989502).
349
350* Thu Sep 19 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-6
351- Fixed typo in 10-libvnc.conf (bug #1009111).
352
353* Wed Sep 18 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-5
354- Better fix for PIDFile problem (bug #983232).
355
356* Mon Aug  5 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-4
357- Fixed doc-related build failure (bug #992790).
358
359* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-3
360- Avoid PIDFile problems in systemd unit file (bug #983232).
361- libvnc.so: don't use unexported key_is_down function.
362- Don't use shebang in vncserver script.
363
364* Fri Jul 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-2
365- Renumbered patches.
366- libvnc.so: don't use unexported GetMaster function (bug #744881 again).
367
368* Mon Jul  8 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-1
369- 1.3.0.
370
371* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.18.20130314svn5065
372- Removed systemd_requires macro in order to fix the build.
373
374* Wed Jul  3 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.17.20130314svn5065
375- Synchronise manpages and --help output (bug #980870).
376
377* Mon Jun 17 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.16.20130314svn5065
378- tigervnc-setcursor-crash.patch: Attempt to paper over a crash in Xvnc when
379  setting the cursor.
380
381* Sat Jun 08 2013 Dennis Gilmore <dennis@ausil.us> 1.2.80-0.15.20130314svn5065
382- bump to rebuild and pick up bugfix causing X to crash on ppc and arm
383
384* Thu May 23 2013 Tim Waugh <twaugh@redhat.com> 1.2.80-0.14.20130314svn5065
385- Use systemd rpm macros (bug #850340).  Moved systemd requirements
386  from main package to server sub-package.
387- Applied Debian patch to fix busy loop when run from inetd in nowait
388  mode (bug #920373).
389- Added dependency on xorg-x11-xinit to server sub-package so that
390  default window manager can be found (bug #896284, bug #923655).
391- Fixed bogus changelog date.
392
393* Thu Mar 14 2013 Adam Jackson <ajax@redhat.com> 1.2.80-0.13.20130314svn5065
394- Less RHEL customization
395
396* Thu Mar 14 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.12.20130314svn5065
397- include /etc/X11/xorg.conf.d/10-libvnc.conf sample configuration (#712482)
398- vncserver now honors specified -geometry parameter (#755947)
399
400* Tue Mar 12 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.11.20130307svn5060
401- update to r5060
402- split icons to separate package to avoid multilib issues
403
404* Tue Feb 19 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.10.20130219svn5047
405- update to r5047 (X.Org 1.14 support)
406
407* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.80-0.9.20121126svn5015
408- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
409
410* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 1.2.80-0.8.20121126svn5015
411- rebuild due to "jpeg8-ABI" feature drop
412
413* Wed Jan 16 2013 Adam Tkac <atkac redhat com> 1.2.80-0.7.20121126svn5015
414- rebuild
415
416* Tue Dec 04 2012 Adam Tkac <atkac redhat com> 1.2.80-0.6.20121126svn5015
417- rebuild against new fltk
418
419* Mon Nov 26 2012 Adam Tkac <atkac redhat com> 1.2.80-0.5.20121126svn5015
420- update to r5015
421- build with -fpic instead of -fPIC on all archs except s390/sparc
422
423* Wed Nov  7 2012 Peter Robinson <pbrobinson@fedoraproject.org> 1.2.80-0.4.20120905svn4996
424- Build with -fPIC to fix FTBFS on ARM
425
426* Wed Oct 31 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.3.20120905svn4996
427- tigervnc12-xorg113-glx.patch: Fix to only init glx on the first server
428  generation
429
430* Fri Sep 28 2012 Adam Jackson <ajax@redhat.com> 1.2.80-0.2.20120905svn4996
431- tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13
432
433* Fri Aug 17 2012 Adam Tkac <atkac redhat com> 1.2.80-0.1.20120905svn4996
434- update to 1.2.80
435- remove deprecated patches
436  - tigervnc-102434.patch
437  - tigervnc-viewer-reparent.patch
438  - tigervnc11-java7.patch
439- patches merged
440  - tigervnc11-xorg111.patch
441  - tigervnc11-xorg112.patch
442
443* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
444- fix build against newer X server
445
446* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
447- Build with the Composite extension for feature parity with other X servers
448
449* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
450- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
451
452* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
453- fix building against X.org 1.13
454
455* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
456- RHEL exclusion for -server-module on ppc* too
457
458* Mon Mar 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-5
459- clean Xvnc's /tmp environment in service file before startup
460- fix building against the latest JAVA 7 and X.Org 1.12
461
462* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-4
463- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
464
465* Tue Nov 22 2011 Adam Tkac <atkac redhat com> - 1.1.0-3
466- don't build X.Org devel docs (#755782)
467- applet: BR generic java-devel instead of java-gcj-devel (#755783)
468- use runuser to start Xvnc in systemd service file (#754259)
469- don't attepmt to restart Xvnc session during update/erase (#753216)
470
471* Fri Nov 11 2011 Adam Tkac <atkac redhat com> - 1.1.0-2
472- libvnc.so: don't use unexported GetMaster function (#744881)
473- remove nasm buildreq
474
475* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
476- update to 1.1.0
477- update the xorg11 patch
478- patches merged
479  - tigervnc11-glx.patch
480  - tigervnc11-CVE-2011-1775.patch
481  - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
482
483* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
484- add systemd service file and remove legacy SysV initscript (#717227)
485
486* Thu May 12 2011 Adam Tkac <atkac redhat com> - 1.0.90-5
487- make Xvnc buildable against X.Org 1.11
488
489* Tue May 10 2011 Adam Tkac <atkac redhat com> - 1.0.90-4
490- viewer can send password without proper validation of X.509 certs
491  (CVE-2011-1775)
492
493* Wed Apr 13 2011 Adam Tkac <atkac redhat com> - 1.0.90-3
494- fix wrong usage of memcpy which caused screen artifacts (#652590)
495- don't point to inaccessible link in sysconfig/vncservers (#644975)
496
497* Fri Apr 08 2011 Adam Tkac <atkac redhat com> - 1.0.90-2
498- improve compatibility with vinagre client (#692048)
499
500* Tue Mar 22 2011 Adam Tkac <atkac redhat com> - 1.0.90-1
501- update to 1.0.90
502
503* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.90-0.32.20110117svn4237
504- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
505
506* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
507- fix libvnc.so module loading
508
509* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
510- update to r4237
511- patches merged
512  - tigervnc11-optionsdialog.patch
513  - tigervnc11-rh607866.patch
514
515* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.29.20101208svn4225
516- improve patch for keyboard issues
517
518* Fri Jan 14 2011 Adam Tkac <atkac redhat com> 1.0.90-0.28.20101208svn4225
519- attempt to fix various keyboard-related issues (key repeating etc)
520
521* Fri Jan 07 2011 Adam Tkac <atkac redhat com> 1.0.90-0.27.20101208svn4225
522- render "Ok" and "Cancel" buttons in the options dialog correctly
523
524* Wed Dec 15 2010 Jan Görig <jgorig redhat com> 1.0.90-0.26.20101208svn4225
525- added vncserver lock file (#662784)
526
527* Fri Dec 10 2010 Adam Tkac <atkac redhat com> 1.0.90-0.25.20101208svn4225
528- update to r4225
529- patches merged
530  - tigervnc11-rh611677.patch
531  - tigervnc11-rh633931.patch
532  - tigervnc11-xorg1.10.patch
533- enable VeNCrypt and PAM support
534
535* Mon Dec 06 2010 Adam Tkac <atkac redhat com> 1.0.90-0.24.20100813svn4123
536- rebuild against xserver 1.10.X
537- 0001-Return-Success-from-generate_modkeymap-when-max_keys.patch merged
538
539* Wed Sep 29 2010 jkeating - 1.0.90-0.23.20100813svn4123
540- Rebuilt for gcc bug 634757
541
542* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.22.20100420svn4030
543- drop xorg-x11-fonts-misc dependency (#636170)
544
545* Tue Sep 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.21.20100420svn4030
546- improve patch for #633645 (fix tcsh incompatibilities)
547
548* Thu Sep 16 2010 Adam Tkac <atkac redhat com> 1.0.90-0.20.20100813svn4123
549- press fake modifiers correctly (#633931)
550- supress unneeded debug information emitted from initscript (#633645)
551
552* Wed Aug 25 2010 Adam Tkac <atkac redhat com> 1.0.90-0.19.20100813svn4123
553- separate Xvnc, vncpasswd and vncconfig to -server-minimal subpkg (#626946)
554- move license to separate subpkg and Requires it from main subpkgs
555- Xvnc: handle situations when no modifiers exist well (#611677)
556
557* Fri Aug 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.18.20100813svn4123
558- update to r4123 (#617973)
559- add perl requires to -server subpkg (#619791)
560
561* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
562- update to r4113
563- patches merged
564  - tigervnc11-rh586406.patch
565  - tigervnc11-libvnc.patch
566  - tigervnc11-rh597172.patch
567  - tigervnc11-rh600070.patch
568  - tigervnc11-options.patch
569- don't own %%{_datadir}/icons directory (#614301)
570- minor improvements in the .desktop file (#616340)
571- bundled libjpeg configure requires nasm; is executed even if system-wide
572  libjpeg is used
573
574* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
575- build against system-wide libjpeg-turbo (#494458)
576- build no longer requires nasm
577
578* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 1.0.90-0.15.20100420svn4030
579- vncserver: accept <+optname> option when specified as the first one
580
581* Thu Jun 24 2010 Adam Tkac <atkac redhat com> 1.0.90-0.14.20100420svn4030
582- fix memory leak in Xvnc input code (#597172)
583- don't crash when receive negative encoding (#600070)
584- explicitly disable udev configuration support
585- add gettext-autopoint to BR
586
587* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 1.0.90-0.13.20100420svn4030
588- update URL about SSH tunneling in the sysconfig file (#601996)
589
590* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 1.0.90-0.12.20100420svn4030
591- use newer gettext
592- autopoint now uses git instead of cvs, adjust BuildRequires appropriately
593
594* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.11.20100420svn4030
595- link libvnc.so "now" to catch "undefined symbol" errors during Xorg startup
596- use always XkbConvertCase instead of XConvertCase (#580159, #586406)
597- don't link libvnc.so against libXi.la, libdix.la and libxkb.la; use symbols
598  from Xorg instead
599
600* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
601- update to r4030 snapshot
602- patches merged to upstream
603  - tigervnc11-rh522369.patch
604  - tigervnc11-rh551262.patch
605  - tigervnc11-r4002.patch
606  - tigervnc11-r4014.patch
607
608* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
609- add server-applet subpackage which contains Java vncviewer applet
610- fix Java applet; it didn't work when run from web browser
611- add xorg-x11-xkb-utils to server Requires
612
613* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
614- add French translation to vncviewer.desktop (thanks to Alain Portal)
615
616* Thu Mar 04 2010 Adam Tkac <atkac redhat com> 1.0.90-0.7.20100219svn3993
617- don't crash during pixel format change (#522369, #551262)
618
619* Mon Mar 01 2010 Adam Tkac <atkac redhat com> 1.0.90-0.6.20100219svn3993
620- add mesa-dri-drivers and xkeyboard-config to -server Requires
621- update to r3993 1.0.90 snapshot
622  - tigervnc11-noexecstack.patch merged
623  - tigervnc11-xorg18.patch merged
624  - xserver18.patch is no longer needed
625
626* Wed Jan 27 2010 Jan Gorig <jgorig redhat com> 1.0.90-0.5.20091221svn3929
627- initscript LSB compliance fixes (#523974)
628
629* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
630- mark stack as non-executable in jpeg ASM code
631- add xorg-x11-xauth to Requires
632- add support for X.Org 1.8
633- drop shave sources, they are no longer needed
634
635* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
636- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
637
638* Thu Jan 07 2010 Adam Tkac <atkac redhat com> 1.0.90-0.2.20091221svn3929
639- add patch for upstream X.Org issue #25909
640- add libXdmcp-devel to build requires to build Xvnc with XDMCP support (#552322)
641
642* Mon Dec 21 2009 Adam Tkac <atkac redhat com> 1.0.90-0.1.20091221svn3929
643- update to 1.0.90 snapshot
644- patches merged
645  - tigervnc10-compat.patch
646  - tigervnc10-rh510185.patch
647  - tigervnc10-rh524340.patch
648  - tigervnc10-rh516274.patch
649
650* Mon Oct 26 2009 Adam Tkac <atkac redhat com> 1.0.0-3
651- create Xvnc keyboard mapping before first keypress (#516274)
652
653* Thu Oct 08 2009 Adam Tkac <atkac redhat com> 1.0.0-2
654- update underlying X source to 1.6.4-0.3.fc11
655- remove bogus '-nohttpd' parameter from /etc/sysconfig/vncservers (#525629)
656- initscript LSB compliance fixes (#523974)
657- improve -LowColorSwitch documentation and handling (#510185)
658- honor dotWhenNoCursor option (and it's changes) every time (#524340)
659
660* Fri Aug 28 2009 Adam Tkac <atkac redhat com> 1.0.0-1
661- update to 1.0.0
662- tigervnc10-rh495457.patch merged to upstream
663
664* Mon Aug 24 2009 Karsten Hopp <karsten@redhat.com> 0.0.91-0.17
665- fix ifnarch s390x for server-module
666
667* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.0.91-0.16
668- rebuilt with new openssl
669
670* Tue Aug 04 2009 Adam Tkac <atkac redhat com> 0.0.91-0.15
671- make Xvnc compilable
672
673* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.91-0.14.1
674- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
675
676* Mon Jul 13 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13.1
677- don't write warning when initscript is called with condrestart param (#508367)
678
679* Tue Jun 23 2009 Adam Tkac <atkac redhat com> 0.0.91-0.13
680- temporary use F11 Xserver base to make Xvnc compilable
681- BuildRequires: libXi-devel
682- don't ship tigervnc-server-module on s390/s390x
683
684* Mon Jun 22 2009 Adam Tkac <atkac redhat com> 0.0.91-0.12
685- fix local rendering of cursor (#495457)
686
687* Thu Jun 18 2009 Adam Tkac <atkac redhat com> 0.0.91-0.11
688- update to 0.0.91 (1.0.0 RC1)
689- patches merged
690  - tigervnc10-rh499401.patch
691  - tigervnc10-rh497592.patch
692  - tigervnc10-rh501832.patch
693- after discusion in upstream drop tigervnc-bounds.patch
694- configure flags cleanup
695
696* Thu May 21 2009 Adam Tkac <atkac redhat com> 0.0.90-0.10
697- rebuild against 1.6.1.901 X server (#497835)
698- disable i18n, vncviewer is not UTF-8 compatible (#501832)
699
700* Mon May 18 2009 Adam Tkac <atkac redhat com> 0.0.90-0.9
701- fix vncpasswd crash on long passwords (#499401)
702- start session dbus daemon correctly (#497592)
703
704* Mon May 11 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8.1
705- remove merged tigervnc-manminor.patch
706
707* Tue May 05 2009 Adam Tkac <atkac redhat com> 0.0.90-0.8
708- update to 0.0.90
709
710* Thu Apr 30 2009 Adam Tkac <atkac redhat com> 0.0.90-0.7.20090427svn3789
711- server package now requires xorg-x11-fonts-misc (#498184)
712
713* Mon Apr 27 2009 Adam Tkac <atkac redhat com> 0.0.90-0.6.20090427svn3789
714- update to r3789
715  - tigervnc-rh494801.patch merged
716- tigervnc-newfbsize.patch is no longer needed
717- fix problems when vncviewer and Xvnc run on different endianess (#496653)
718- UltraVNC and TightVNC clients work fine again (#496786)
719
720* Wed Apr 08 2009 Adam Tkac <atkac redhat com> 0.0.90-0.5.20090403svn3751
721- workaround broken fontpath handling in vncserver script (#494801)
722
723* Fri Apr 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.4.20090403svn3751
724- update to r3751
725- patches merged
726  - tigervnc-xclients.patch
727  - tigervnc-clipboard.patch
728  - tigervnc-rh212985.patch
729- basic RandR support in Xvnc (resize of the desktop)
730- use built-in libjpeg (SSE2/MMX accelerated encoding on x86 platform)
731- use Tight encoding by default
732- use TigerVNC icons
733
734* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.3.20090303svn3631
735- update to r3631
736
737* Tue Mar 03 2009 Adam Tkac <atkac redhat com> 0.0.90-0.2.20090302svn3621
738- package review related fixes
739
740* Mon Mar 02 2009 Adam Tkac <atkac redhat com> 0.0.90-0.1.20090302svn3621
741- initial package, r3621
Note: See TracBrowser for help on using the repository browser.