source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 8873

Revision 8873, 32.3 KB checked in by Takemikaduchi, 10 years ago (diff)

fix changelog

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 31.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-esr31
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-31.0-enable-addons.patch
80
81# Vine Patch
82Patch2000:      thunderbird-24.0-vine6.patch
83Patch2001:      thunderbird-31.0-client_mk_objdir.patch
84
85BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
86BuildRequires:  pango-devel
87BuildRequires:  cairo-devel >= %{cairo_version}
88%if %{build_vine7}
89#BuildRequires: nspr-devel >= %{nspr_version}
90#BuildRequires: nss-devel >= %{nss_version}
91BuildRequires:  python-devel
92%endif
93%if %{build_vine6}
94BuildRequires:  python27-devel
95%endif
96BuildRequires:  gstreamer-devel
97BuildRequires:  gstreamer-plugins-base-devel
98BuildRequires:  pulseaudio-libs-devel
99BuildRequires:  pixman-devel
100BuildRequires:  libpng-devel
101BuildRequires:  libjpeg-turbo-devel
102BuildRequires:  gtk2-devel
103BuildRequires:  zlib-devel, gzip, zip, unzip
104BuildRequires:  libIDL-devel
105BuildRequires:  freetype2-devel >= %{freetype_version}
106## disabled libnotify support
107## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
108BuildRequires:  libnotify-devel >= %{libnotify_version}
109BuildRequires:  bzip2-devel
110#BuildRequires: gnome-vfs2-devel
111BuildRequires:  libgnome-devel
112#BuildRequires:  libgnomeui-devel
113BuildRequires:  krb5-devel
114BuildRequires:  pango-devel
115BuildRequires:  libXt-devel
116BuildRequires:  libXrender-devel
117BuildRequires:  curl-devel
118# hunspell is in plus category for vine
119#BuildRequires: hunspell-devel
120%if %{build_vine7}
121BuildRequires:  sqlite3-devel >= %{sqlite_version}
122%endif
123BuildRequires:  startup-notification-devel
124BuildRequires:  desktop-file-utils
125BuildRequires:  alsa-lib-devel
126BuildRequires:  yasm
127BuildRequires:  autoconf213
128%if %{build_vine7}
129Requires:       sqlite3 >= %{sqlite_version}
130%endif
131Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
132Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
133
134Obsoletes:      MozillaThunderbird
135Provides:       MozillaThunderbird = %{version}
136
137Vendor:         Project Vine
138Distribution:   Vine Linux
139Packager:       daisuke, ryoichi, kazutaka, Takemikaduchi
140
141AutoProv: 0
142%define _use_internal_dependency_generator 0
143%define __find_requires %{SOURCE100}
144
145%description
146Thunderbird is a standalone mail and newsgroup client.
147
148%description -l ja
149Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
150
151#===============================================================================
152
153%prep
154%setup -q %{name}-%{version} -c
155cd %{tarballdir}
156
157# Fix for version issue
158sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
159    > version.patch
160%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
161
162cd mozilla
163%patch1 -p1 -b .default-a4
164
165cd -
166%{__rm} -f .mozconfig
167%if %{build_vine6}
168%{__cp} %{SOURCE1010} .mozconfig
169%endif
170%if %{build_vine7}
171%{__cp} %{SOURCE1020} .mozconfig
172%endif
173
174# setup unofficial branding name
175%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
176%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
177
178%patch100 -p1 -b .addons
179%if %{build_vine6}
180%patch2000 -p1 -b .vine
181%endif
182%patch2001 -p1 -b .vine
183
184#===============================================================================
185
186%build
187cd %{tarballdir}
188autoconf-2.13
189
190INTERNAL_GECKO=%{version_internal}
191MOZ_APP_DIR=%{mozappdir}
192
193
194#%if %{build_vine7}
195#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
196#%else
197#%ifarch x86_64
198##MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
199#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
200#%else
201#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
202#%endif
203#%endif
204
205MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | \
206                                %{__sed} -e 's/-Wall//')
207export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
208export CFLAGS="$RPM_OPT_FLAGS"
209#export CFLAGS=""
210export CXXFLAGS="$CFLAGS"
211export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
212
213export PREFIX='%{_prefix}'
214export LIBDIR='%{_libdir}'
215
216MOZ_SMP_FLAGS=-j1
217# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
218# however builds tend to fail on other arches when building in parallel.
219%ifarch %{ix86} x86_64
220[ -z "$RPM_BUILD_NCPUS" ] && \
221     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
222[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
223[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
224[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
225 %endif
226
227export LDFLAGS="-Wl,-rpath,%{ffdir}"
228%__make -f client.mk build STRIP="/bin/true" \
229                           MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
230
231## build locales
232#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
233#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
234#for dir in $LOCALEDIRS
235#do
236#  for lang in %{MOZ_BUILD_LOCALES} ; do
237#    make -C $dir/locales AB_CD=$lang
238#  done
239#done
240
241#===============================================================================
242
243%install
244%{__rm} -rf $RPM_BUILD_ROOT
245cd %{tarballdir}
246
247INTERNAL_GECKO=%{version_internal}
248
249INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
250MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
251
252cd %{moz_objdir}
253DESTDIR=$RPM_BUILD_ROOT make install
254
255# install unofficial icons
256cd -
257
258%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
259%{__cp} mail/branding/aurora/mailicon16.png \
260        $RPM_BUILD_ROOT/%{mozappdir}/icons/
261%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
262%{__cp} mail/branding/aurora/mailicon16.png \
263        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
265%{__cp} mail/branding/aurora/mailicon22.png \
266        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
267%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
268%{__cp} mail/branding/aurora/mailicon24.png \
269        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
270%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
271%{__cp} mail/branding/aurora/mailicon32.png \
272        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
273%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
274%{__cp} mail/branding/aurora/mailicon48.png \
275        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
276%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
277%{__cp} mail/branding/aurora/mailicon256.png \
278        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
279
280desktop-file-install --vendor vine \
281  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
282
283# set up the thunderbird start script
284rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
285%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
286  $RPM_BUILD_ROOT%{_bindir}/thunderbird
287%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
288
289install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
290%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
291
292%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
293                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
294        $RPM_BUILD_ROOT/vine-default-prefs
295%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
296%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
297%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
298
299%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
300
301# own mozilla plugin dir (#135050)
302%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
303
304# own extension directories
305%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
306%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
307
308# install locales
309#for lang in %{MOZ_BUILD_LOCALES} ; do
310#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
311#done
312
313# install ja.xpi to langpacks directory
314#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
315#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
316# also setup unofficial branding name
317#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
318#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
319
320# install ja.xpi to langpack file
321%{__mkdir_p} lang_tmp
322unzip %{SOURCE1} -d lang_tmp
323# also setup unofficial branding name
324%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
325%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
326
327%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
328cd lang_tmp; \
329zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
330
331
332%clean
333%{__rm} -rf $RPM_BUILD_ROOT
334
335#===============================================================================
336
337%post
338update-desktop-database &> /dev/null || :
339touch --no-create %{_datadir}/icons/hicolor
340if [ -x %{_bindir}/gtk-update-icon-cache ]; then
341  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
342fi
343
344%postun
345update-desktop-database &> /dev/null || :
346touch --no-create %{_datadir}/icons/hicolor
347if [ -x %{_bindir}/gtk-update-icon-cache ]; then
348  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
349fi
350
351
352%files
353%defattr(-,root,root,-)
354%attr(755,root,root) %{_bindir}/thunderbird
355%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
356%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
357%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
358%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
359%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
360%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
361%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
362%{mozappdir}
363#%{_libdir}/mozilla
364%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
365%exclude %{_datadir}/idl/%{name}-%{version_internal}
366%exclude %{_includedir}/%{name}-%{version_internal}
367%exclude %{_libdir}/%{name}-devel-%{version_internal}
368
369#===============================================================================
370
371%changelog
372* Thu Jul 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 31.0-1
373- new upstream release
374- add BuildRequires: pulseaudio-libs-devel
375- update Patch100 (thunderbird-31.0-enable-addons.patch)
376- update Source1020 (mozconfig-thunderbird-vine7)
377- add Patch2001 (thunderbird-31.0-client_mk_objdir.patch)
378
379* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.6.0-1
380- new upstream release
381
382* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.5.0-1
383- new upstream release
384
385* Sun Mar 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.4.0-1
386- new upstream release
387
388* Fri Feb 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3.0-1
389- new upstream release
390
391* Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.2.0-1
392- new upstream release
393
394* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.1.1-1
395- new upstream release
396
397* Tue Nov 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.1.0-1
398- new upstream release
399
400* Sat Sep 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0-1
401- new upstream release
402- remove BuildRequires: nspr-devel, nss-devel
403- add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel
404- add Patch2000 (thunderbird-24.0-vine6.patch)
405
406* Tue Aug 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.8-1
407- new upstream release
408
409* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.7-1
410- new upstream release
411
412* Sun May 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.6-1
413- new upstream release
414
415* Wed Mar 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.4-1
416- new upstream release
417
418* Sat Mar 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.3-1
419- new upstream release
420
421* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.2-1
422- new upstream release
423- update Source1010,1020
424- fix %% build
425
426* Wed Nov 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0-1
427- new upstream release
428
429* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
430- use --disable-install-strip instead of --enable-install-strip
431- add --disable-debug-symbols
432
433* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
434- new upstream release
435
436* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
437- new upstream release
438
439* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
440- new upstream release
441
442* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
443- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
444
445* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
446- new upstream release
447
448* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
449- new upstream release
450- add BuildRequires: python-devel (Vine6 only)
451- remove build rule of Vine5
452
453* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
454- new upstream release
455- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
456
457* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
458- new upstream release
459
460* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
461- new upstream release
462- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
463
464* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
465- new upstream release
466
467* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
468- new upstream release
469- update Source1030 (mozconfig-thunderbird-vine7)
470
471* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
472- new upstream release
473- update Source1020 (mozconfig-thunderbird-vine6)
474
475* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
476- new upstream release
477
478* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
479- new upstream release
480
481* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
482- new upstream release
483
484* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
485- new upstream release
486- update Source1
487
488* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
489- new upstream release
490- update Source1
491- add Source1030 (mozconfig-thunderbird-vine7)
492- add Patch100 (thunderbird-9.0-enable-addons.patch)
493
494* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
495- fix %%version_internal
496
497* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
498- new upstream release
499- update Source1
500
501* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
502- new upstream release
503- update Source1,21,1010,1020
504
505* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
506- rebuild with libnotify-0.7
507
508* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
509- enable-install-strip
510
511* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
512- new upstream release
513- drop obsolete patch and renumber patch26 to patch1
514- add BuildRequires: yasm
515- enable libnotify support
516- add --disable-updater and --disable-installer to mozconfig
517- use ja.xpi instead of l10n source
518- update Source21: add step to setup langpack plugin
519- update Source20: add japanese translation
520- add Source42 & Source43 for localized branding
521- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
522  for mozconfig-thunderbird-vine5
523
524* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
525- new upstream release with security fix
526
527* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
528- new upstream release with security fix
529
530* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
531- new upstream release with security fix
532
533* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
534- new upstream release with security fix
535- add patch5 to fix build failure
536
537* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
538- new upstream release
539
540* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
541- new upstream release with security fix
542- add Patch1030 to fix compilation error
543
544* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
545- change mozconfig (Source1030 & 1040): add --enable-jsd
546
547* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
548- new upstream release
549
550* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
551- new upstream release with security fix
552- add Patch0 from fedora development: fix version issue
553- remove BuildRequires: hunspell-devel
554- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
555
556* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
557- add BuildRequires: alsa-lib-devel
558- remove BuildRequires: libnotify-devel
559  (workaround for known bug)
560- update mozconfig to add --disable-libnotify option
561
562* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
563- new upstream release
564- update spec entirely
565- import patches from fedora (Patch1, 2 & 4)
566- drop outdated patches (Patch22, 24)
567- update Sources:
568  - mozconfig (Source1030 & Source1040)
569  - default prefs.js (Source12)
570  - unofficial branding (Source40 & Source41)
571  - japanese translation (Source1000)
572- update Patch1000 (sjis-alias)
573
574* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
575- new upstream release
576
577* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
578- new upstream release
579
580* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
581- don't install official branding logos
582
583* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
584- add necessary icons in %%{tbdir}/chrome/icons/default
585- add Packager tag
586
587* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
588- new upstream release
589
590* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
591- new upstream release
592
593* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
594- new upstream release
595
596* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
597- new upstream release
598
599* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
600- rebuilt for VineSeed
601
602* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
603- new upstream release
604
605* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
606- new upstream release
607- built for Vine Linux 4.x
608- dropped Patch1020 (merged into upstream)
609
610* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
611- added Patch1020 for workaround gcc visibility hidden bugs
612
613* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
614- build with new environment/toolchain
615- add build options to build with external nss/nspr libraries
616    ac_add_options --with-system-nspr
617    ac_add_options --with-system-nss
618
619* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
620- new upstream release
621
622* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
623- new upstream release
624
625* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
626- new upstream release
627
628* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
629- new upstream release
630
631* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
632- new upstream release
633- merge changes from firefox
634  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
635
636* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
637- new upstream release
638- build en-US locale
639- merge changes from firefox
640  - add upstream patches
641  - disable pango rendering by default
642    (workaround fix slow rendering in some page)
643
644* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
645- initial build for Vine Linux based on FC package
646- update to 1.5RC2
647
648* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
649- Fix issue with popup dialogs and other actions causing lockups
650
651* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
652- Update to 1.5 rc1
653
654* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
655- Update to 1.5 beta2
656
657* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
658- Update to 1.5 beta1
659- Bring the install phase of the spec file up to speed
660
661* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
662- Rebuild
663
664* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
665- Add patch to make file chooser dialog modal
666
667* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
668- Update to 1.0.6
669
670* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
671- 1.0.6 Release Candidate
672
673* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
674- Use system NSPR
675- Fix crash on 64bit platforms (#160330)
676
677* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
678- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
679  references, fixing the "no fonts" problem.
680
681* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
682- Change the Exec line in the desktop file to `thunderbird`
683
684* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
685- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
686
687* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
688- Add temporary workaround to not create files in the user's $HOME (#149664)
689
690* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
691- Don't have downloads "disappear" when downloading to desktop (#139015)
692- Fix for some more cursor issues in textareas (149991, 150002, 152089)
693- Add upstream patch to fix bidi justification of pango
694- Add patch to fix launching of helper applications
695- Add patch to properly link against libgfxshared_s.a
696- Fix multilib conflicts
697
698* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
699- correct confusing PANGO vars in startup script
700
701* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
702- Thunderbird 1.0.2
703
704* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
705- Add patch to compile against new fortified glibc macros
706
707* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
708- Rebuild against GCC 4.0
709- Add execshield patches
710- Minor specfile cleanup
711
712* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
713- Rebuild
714
715* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
716- Add RPM version to useragent
717
718* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
719- Port over pango patches from firefox
720
721* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
722- Thunderbird 1.0
723
724* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
725- Fix advanced prefs
726
727* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
728- Make this run on s390(x) now for real
729
730* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
731- Update to 1.0 rc1
732
733* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
734- Add patches to build and run on s390(x)
735
736* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
737- Rebuild to fix file chooser
738
739* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
740- Update to 0.9
741
742* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
743- Prevent inlining of stack direction detection (#135255)
744
745* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
746- More file chooser fixes (same as in firefox)
747- Fix for upstream 28327.
748
749* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
750- Update the pango patch
751
752* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
753- Pull over patches from firefox build:
754  - disable default application dialog
755  - don't include software update since it doesn't work
756  - make external app support work
757
758* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
759- Use pango for rendering
760
761* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
762- Fix for 64 bit crash at startup (b.m.o #256603)
763
764* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
765- Add patches to fix xremote (#135036)
766
767* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
768- Add patch to fix button focus issues (#133507)
769- Add patch for fix IMAP race issues (bmo #246439)
770
771* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
772- filter out library Provides: and internal Requires:
773
774* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
775- Backport the GTK+ File Chooser.
776- Add fix for JS math on x86_64 systems
777- Add pkgconfig patch
778
779* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
780- Update to 0.8.0
781- Remove enigmail
782- Update BuildRequires
783- Remove gcc34 and extension manager patches -- they are upstreamed.
784- Fix for gnome-vfs2 error at component registration
785
786* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
787- Build with --disable-xprint
788
789* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
790- remove all Xvfb-related hacks
791
792* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
793- actually apply psfonts
794- add mozilla gnome-uriloader patch to prevent build failure
795
796* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
797- rawhide import
798- apply NetBSD's freetype 2.1.8 patch
799- apply psfonts patch
800- remove BR on /usr/bin/ex, breaks beehive
801
802* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
803- oops, fix %%install
804
805* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
806- update to Thunderbird 0.7.3 and Enigmail 0.85.0
807- remove XUL.mfasl on startup, add Debian enigmail patches
808- add Xvfb hack for -install-global-extension
809
810* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
811- update to 0.7.2, just because it's there
812- update gcc-3.4 patch (Kaj Niemi)
813- add EM registration patch and remove instdir hack
814
815* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
816- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
817
818* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
819- update to 0.7.1
820- remove Enigmail
821
822* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
823- re-enable Enigmail 0.84.1
824- add gcc-3.4 patch (Kaj Niemi)
825- use official branding (with permission)
826
827* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
828- update to 0.7
829- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
830- specify libdir, change BR for apt (V. Skytt辰, #1617)
831
832* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
833- temporary workaround for enigmail skin "modern" bug
834
835* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
836- update to Enigmail 0.84.0
837- update launch script
838
839* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
840- installation directory now versioned
841- allow root to run the program (for installing extensions)
842- remove unnecessary %%pre and %%post
843- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
844
845* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
846- include Enigmail, re-add release notes
847- delete %{_libdir}/thunderbird in %%pre
848
849* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
850- update to Thunderbird 0.6
851
852* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
853- update to Thunderbird 0.6 RC1
854- add new icon, remove release notes
855
856* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
857- update to latest CVS, update mozconfig and %%build accordingly
858- update to Enigmail 0.83.6
859- remove x-remote and x86_64 patches
860- build with -Os
861
862* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
863- update x-remote patch
864- more startup script fixes
865
866* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
867- startup script fixes, and a minor cleanup
868
869* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
870- Minor cleanups
871
872* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
873- minor improvements to open-browser.sh and startup script
874- update to latest version of Blizzard's x-remote patch
875
876* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
877- update open-browser.sh, startup script, and BuildRequires
878
879* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
880- update open-browser script, modify BuildRequires (Warren)
881- add Blizzard's x-remote patch
882- initial attempt at x-remote-enabled startup script
883
884* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
885- refuse to run with excessive privileges
886
887* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
888- add Mozilla x86_64 patch (Oliver Sontag)
889- Enigmail source filenames now include the version
890- modify BuildRoot
891
892* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
893- use the updated official tarball
894
895* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
896- fix %%prep script
897
898* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
899- update Enigmail to 0.83.3
900- use official source tarball (after removing the CRLFs)
901- package renamed to thunderbird
902
903* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
904- update to 0.5
905- check for lockfile before launching
906
907* Fri Feb 06 2004 David Hill <djh[at]ii.net>
908- update to latest cvs
909- update to Enigmail 0.83.2
910
911* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
912- update to Enigmail 0.83.1
913- removed Mozilla/Firebird script patching
914
915* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
916- add startup notification to .desktop file
917
918* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
919- open-browser.sh release 3
920- patch broken /usr/bin/mozilla script during install
921- dir ownership
922- XXX: Source fails build on x86_64... fix later
923
924* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
925- update to Enigmail 0.82.5
926- add Warren's open-browser.sh (#1113)
927
928* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
929- use Thunderbird's mozilla-xremote-client to launch browser
930
931* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
932- update to 0.4
933- make hyperlinks work (with recent versions of Firebird/Mozilla)
934
935* Thu Dec 04 2003 David Hill <djh[at]ii.net>
936- update to 0.4rc2
937
938* Wed Dec 03 2003 David Hill <djh[at]ii.net>
939- update to 0.4rc1 and Enigmail 0.82.4
940
941* Thu Nov 27 2003 David Hill <djh[at]ii.net>
942- update to latest CVS and Enigmail 0.82.3
943
944* Sun Nov 16 2003 David Hill <djh[at]ii.net>
945- update to latest CVS (0.4a)
946- update Enigmail to 0.82.2
947- alter mozconfig for new build requirements
948- add missing BuildReq (#987)
949
950* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
951- update to 0.3
952
953* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
954- update to 0.3rc3
955- update Enigmail to 0.81.7
956
957* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
958- update to 0.3rc2
959
960* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
961- simplify startup script
962
963* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
964- add GPG support (Enigmail 0.81.6)
965- specfile fixes (#679)
966
967* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
968- update to 0.2
969
970* Mon Sep 01 2003 David Hill <djh[at]ii.net>
971- initial RPM
972  (based on the fedora MozillaFirebird-0.6.1 specfile)
973
Note: See TracBrowser for help on using the repository browser.