source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 7302

Revision 7302, 30.5 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 17.0.2
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
82BuildRequires:  pango-devel
83BuildRequires:  cairo-devel >= %{cairo_version}
84%if %{build_vine7}
85BuildRequires:  nspr-devel >= %{nspr_version}
86BuildRequires:  nss-devel >= %{nss_version}
87BuildRequires:  hunspell-devel
88%endif
89%if %{build_vine6}
90BuildRequires:  hunspell-devel
91BuildRequires:  python-devel
92%endif
93BuildRequires:  pixman-devel
94BuildRequires:  libpng-devel
95BuildRequires:  libjpeg-turbo-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  zlib-devel, gzip, zip, unzip
98BuildRequires:  libIDL-devel
99BuildRequires:  freetype2-devel >= %{freetype_version}
100## disabled libnotify support
101## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
102BuildRequires:  libnotify-devel >= %{libnotify_version}
103BuildRequires:  bzip2-devel
104#BuildRequires: gnome-vfs2-devel
105BuildRequires:  libgnome-devel
106#BuildRequires:  libgnomeui-devel
107BuildRequires:  krb5-devel
108BuildRequires:  pango-devel
109BuildRequires:  libXt-devel
110BuildRequires:  libXrender-devel
111BuildRequires:  curl-devel
112# hunspell is in plus category for vine
113#BuildRequires: hunspell-devel
114%if %{build_vine7}
115BuildRequires:  sqlite3-devel >= %{sqlite_version}
116%endif
117BuildRequires:  startup-notification-devel
118BuildRequires:  desktop-file-utils
119BuildRequires:  alsa-lib-devel
120BuildRequires:  yasm
121BuildRequires:  autoconf213
122%if %{build_vine7}
123Requires:       sqlite3 >= %{sqlite_version}
124%endif
125Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
126Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
127
128Obsoletes:      MozillaThunderbird
129Provides:       MozillaThunderbird = %{version}
130
131Vendor:         Project Vine
132Distribution:   Vine Linux
133Packager:       daisuke, ryoichi, kazutaka
134
135AutoProv: 0
136%define _use_internal_dependency_generator 0
137%define __find_requires %{SOURCE100}
138
139%description
140Thunderbird is a standalone mail and newsgroup client.
141
142%description -l ja
143Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
144
145#===============================================================================
146
147%prep
148%setup -q %{name}-%{version} -c
149cd %{tarballdir}
150
151# Fix for version issue
152sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
153    > version.patch
154%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
155
156cd mozilla
157%patch1 -p1 -b .default-a4
158
159cd -
160%{__rm} -f .mozconfig
161%if %{build_vine6}
162%{__cp} %{SOURCE1010} .mozconfig
163%endif
164%if %{build_vine7}
165%{__cp} %{SOURCE1020} .mozconfig
166%endif
167
168# setup unofficial branding name
169%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
170%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
171
172%patch100 -p1 -b .addons
173
174#===============================================================================
175
176%build
177cd %{tarballdir}
178
179INTERNAL_GECKO=%{version_internal}
180MOZ_APP_DIR=%{mozappdir}
181
182
183#%if %{build_vine7}
184#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
185#%else
186#%ifarch x86_64
187##MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
188#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
189#%else
190#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
191#%endif
192#%endif
193MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
194        %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
195export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
196export CFLAGS="$RPM_OPT_FLAGS"
197#export CFLAGS=""
198export CXXFLAGS="$CFLAGS"
199export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
200
201export PREFIX='%{_prefix}'
202export LIBDIR='%{_libdir}'
203
204MOZ_SMP_FLAGS=-j1
205# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
206# however builds tend to fail on other arches when building in parallel.
207%ifarch %{ix86} x86_64
208[ -z "$RPM_BUILD_NCPUS" ] && \
209     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
210[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
211[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
212[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
213 %endif
214
215%__make -f client.mk build STRIP="/bin/true" \
216                           MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
217
218## build locales
219#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
220#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
221#for dir in $LOCALEDIRS
222#do
223#  for lang in %{MOZ_BUILD_LOCALES} ; do
224#    make -C $dir/locales AB_CD=$lang
225#  done
226#done
227
228#===============================================================================
229
230%install
231%{__rm} -rf $RPM_BUILD_ROOT
232cd %{tarballdir}
233
234INTERNAL_GECKO=%{version_internal}
235
236INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
237MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
238
239cd %{moz_objdir}
240DESTDIR=$RPM_BUILD_ROOT make install
241
242# install unofficial icons
243cd -
244
245%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
246%{__cp} mail/branding/aurora/mailicon16.png \
247        $RPM_BUILD_ROOT/%{mozappdir}/icons/
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
249%{__cp} mail/branding/aurora/mailicon16.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
252%{__cp} mail/branding/aurora/mailicon22.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
254%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
255%{__cp} mail/branding/aurora/mailicon24.png \
256        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
257%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
258%{__cp} mail/branding/aurora/mailicon32.png \
259        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
260%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
261%{__cp} mail/branding/aurora/mailicon48.png \
262        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
263%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
264%{__cp} mail/branding/aurora/mailicon256.png \
265        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
266
267desktop-file-install --vendor vine \
268  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
269
270# set up the thunderbird start script
271rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
272%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
273  $RPM_BUILD_ROOT%{_bindir}/thunderbird
274%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
275
276install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
277%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
278
279%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
280                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
281        $RPM_BUILD_ROOT/vine-default-prefs
282%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
283%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
284%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
285
286%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
287
288# own mozilla plugin dir (#135050)
289%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
290
291# own extension directories
292%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
293%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
294
295# install locales
296#for lang in %{MOZ_BUILD_LOCALES} ; do
297#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
298#done
299
300# install ja.xpi to langpacks directory
301#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
302#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
303# also setup unofficial branding name
304#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
305#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
306
307# install ja.xpi to langpack file
308%{__mkdir_p} lang_tmp
309unzip %{SOURCE1} -d lang_tmp
310# also setup unofficial branding name
311%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
312%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
313
314%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
315cd lang_tmp; \
316zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
317
318
319%clean
320%{__rm} -rf $RPM_BUILD_ROOT
321
322#===============================================================================
323
324%post
325update-desktop-database &> /dev/null || :
326touch --no-create %{_datadir}/icons/hicolor
327if [ -x %{_bindir}/gtk-update-icon-cache ]; then
328  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
329fi
330
331%postun
332update-desktop-database &> /dev/null || :
333touch --no-create %{_datadir}/icons/hicolor
334if [ -x %{_bindir}/gtk-update-icon-cache ]; then
335  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
336fi
337
338
339%files
340%defattr(-,root,root,-)
341%attr(755,root,root) %{_bindir}/thunderbird
342%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
343%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
344%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
345%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
346%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
347%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
348%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
349%{mozappdir}
350#%{_libdir}/mozilla
351%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
352%exclude %{_datadir}/idl/%{name}-%{version_internal}
353%exclude %{_includedir}/%{name}-%{version_internal}
354%exclude %{_libdir}/%{name}-devel-%{version_internal}
355
356#===============================================================================
357
358%changelog
359* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.2-1
360- new upstream release
361- update Source1010,1020
362- fix %% build
363
364* Wed Nov 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0-1
365- new upstream release
366
367* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
368- use --disable-install-strip instead of --enable-install-strip
369- add --disable-debug-symbols
370
371* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
372- new upstream release
373
374* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
375- new upstream release
376
377* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
378- new upstream release
379
380* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
381- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
382
383* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
384- new upstream release
385
386* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
387- new upstream release
388- add BuildRequires: python-devel (Vine6 only)
389- remove build rule of Vine5
390
391* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
392- new upstream release
393- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
394
395* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
396- new upstream release
397
398* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
399- new upstream release
400- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
401
402* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
403- new upstream release
404
405* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
406- new upstream release
407- update Source1030 (mozconfig-thunderbird-vine7)
408
409* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
410- new upstream release
411- update Source1020 (mozconfig-thunderbird-vine6)
412
413* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
414- new upstream release
415
416* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
417- new upstream release
418
419* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
420- new upstream release
421
422* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
423- new upstream release
424- update Source1
425
426* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
427- new upstream release
428- update Source1
429- add Source1030 (mozconfig-thunderbird-vine7)
430- add Patch100 (thunderbird-9.0-enable-addons.patch)
431
432* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
433- fix %%version_internal
434
435* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
436- new upstream release
437- update Source1
438
439* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
440- new upstream release
441- update Source1,21,1010,1020
442
443* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
444- rebuild with libnotify-0.7
445
446* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
447- enable-install-strip
448
449* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
450- new upstream release
451- drop obsolete patch and renumber patch26 to patch1
452- add BuildRequires: yasm
453- enable libnotify support
454- add --disable-updater and --disable-installer to mozconfig
455- use ja.xpi instead of l10n source
456- update Source21: add step to setup langpack plugin
457- update Source20: add japanese translation
458- add Source42 & Source43 for localized branding
459- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
460  for mozconfig-thunderbird-vine5
461
462* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
463- new upstream release with security fix
464
465* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
466- new upstream release with security fix
467
468* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
469- new upstream release with security fix
470
471* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
472- new upstream release with security fix
473- add patch5 to fix build failure
474
475* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
476- new upstream release
477
478* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
479- new upstream release with security fix
480- add Patch1030 to fix compilation error
481
482* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
483- change mozconfig (Source1030 & 1040): add --enable-jsd
484
485* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
486- new upstream release
487
488* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
489- new upstream release with security fix
490- add Patch0 from fedora development: fix version issue
491- remove BuildRequires: hunspell-devel
492- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
493
494* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
495- add BuildRequires: alsa-lib-devel
496- remove BuildRequires: libnotify-devel
497  (workaround for known bug)
498- update mozconfig to add --disable-libnotify option
499
500* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
501- new upstream release
502- update spec entirely
503- import patches from fedora (Patch1, 2 & 4)
504- drop outdated patches (Patch22, 24)
505- update Sources:
506  - mozconfig (Source1030 & Source1040)
507  - default prefs.js (Source12)
508  - unofficial branding (Source40 & Source41)
509  - japanese translation (Source1000)
510- update Patch1000 (sjis-alias)
511
512* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
513- new upstream release
514
515* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
516- new upstream release
517
518* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
519- don't install official branding logos
520
521* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
522- add necessary icons in %%{tbdir}/chrome/icons/default
523- add Packager tag
524
525* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
526- new upstream release
527
528* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
529- new upstream release
530
531* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
532- new upstream release
533
534* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
535- new upstream release
536
537* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
538- rebuilt for VineSeed
539
540* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
541- new upstream release
542
543* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
544- new upstream release
545- built for Vine Linux 4.x
546- dropped Patch1020 (merged into upstream)
547
548* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
549- added Patch1020 for workaround gcc visibility hidden bugs
550
551* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
552- build with new environment/toolchain
553- add build options to build with external nss/nspr libraries
554    ac_add_options --with-system-nspr
555    ac_add_options --with-system-nss
556
557* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
558- new upstream release
559
560* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
561- new upstream release
562
563* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
564- new upstream release
565
566* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
567- new upstream release
568
569* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
570- new upstream release
571- merge changes from firefox
572  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
573
574* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
575- new upstream release
576- build en-US locale
577- merge changes from firefox
578  - add upstream patches
579  - disable pango rendering by default
580    (workaround fix slow rendering in some page)
581
582* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
583- initial build for Vine Linux based on FC package
584- update to 1.5RC2
585
586* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
587- Fix issue with popup dialogs and other actions causing lockups
588
589* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
590- Update to 1.5 rc1
591
592* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
593- Update to 1.5 beta2
594
595* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
596- Update to 1.5 beta1
597- Bring the install phase of the spec file up to speed
598
599* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
600- Rebuild
601
602* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
603- Add patch to make file chooser dialog modal
604
605* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
606- Update to 1.0.6
607
608* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
609- 1.0.6 Release Candidate
610
611* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
612- Use system NSPR
613- Fix crash on 64bit platforms (#160330)
614
615* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
616- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
617  references, fixing the "no fonts" problem.
618
619* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
620- Change the Exec line in the desktop file to `thunderbird`
621
622* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
623- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
624
625* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
626- Add temporary workaround to not create files in the user's $HOME (#149664)
627
628* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
629- Don't have downloads "disappear" when downloading to desktop (#139015)
630- Fix for some more cursor issues in textareas (149991, 150002, 152089)
631- Add upstream patch to fix bidi justification of pango
632- Add patch to fix launching of helper applications
633- Add patch to properly link against libgfxshared_s.a
634- Fix multilib conflicts
635
636* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
637- correct confusing PANGO vars in startup script
638
639* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
640- Thunderbird 1.0.2
641
642* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
643- Add patch to compile against new fortified glibc macros
644
645* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
646- Rebuild against GCC 4.0
647- Add execshield patches
648- Minor specfile cleanup
649
650* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
651- Rebuild
652
653* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
654- Add RPM version to useragent
655
656* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
657- Port over pango patches from firefox
658
659* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
660- Thunderbird 1.0
661
662* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
663- Fix advanced prefs
664
665* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
666- Make this run on s390(x) now for real
667
668* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
669- Update to 1.0 rc1
670
671* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
672- Add patches to build and run on s390(x)
673
674* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
675- Rebuild to fix file chooser
676
677* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
678- Update to 0.9
679
680* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
681- Prevent inlining of stack direction detection (#135255)
682
683* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
684- More file chooser fixes (same as in firefox)
685- Fix for upstream 28327.
686
687* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
688- Update the pango patch
689
690* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
691- Pull over patches from firefox build:
692  - disable default application dialog
693  - don't include software update since it doesn't work
694  - make external app support work
695
696* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
697- Use pango for rendering
698
699* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
700- Fix for 64 bit crash at startup (b.m.o #256603)
701
702* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
703- Add patches to fix xremote (#135036)
704
705* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
706- Add patch to fix button focus issues (#133507)
707- Add patch for fix IMAP race issues (bmo #246439)
708
709* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
710- filter out library Provides: and internal Requires:
711
712* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
713- Backport the GTK+ File Chooser.
714- Add fix for JS math on x86_64 systems
715- Add pkgconfig patch
716
717* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
718- Update to 0.8.0
719- Remove enigmail
720- Update BuildRequires
721- Remove gcc34 and extension manager patches -- they are upstreamed.
722- Fix for gnome-vfs2 error at component registration
723
724* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
725- Build with --disable-xprint
726
727* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
728- remove all Xvfb-related hacks
729
730* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
731- actually apply psfonts
732- add mozilla gnome-uriloader patch to prevent build failure
733
734* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
735- rawhide import
736- apply NetBSD's freetype 2.1.8 patch
737- apply psfonts patch
738- remove BR on /usr/bin/ex, breaks beehive
739
740* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
741- oops, fix %%install
742
743* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
744- update to Thunderbird 0.7.3 and Enigmail 0.85.0
745- remove XUL.mfasl on startup, add Debian enigmail patches
746- add Xvfb hack for -install-global-extension
747
748* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
749- update to 0.7.2, just because it's there
750- update gcc-3.4 patch (Kaj Niemi)
751- add EM registration patch and remove instdir hack
752
753* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
754- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
755
756* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
757- update to 0.7.1
758- remove Enigmail
759
760* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
761- re-enable Enigmail 0.84.1
762- add gcc-3.4 patch (Kaj Niemi)
763- use official branding (with permission)
764
765* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
766- update to 0.7
767- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
768- specify libdir, change BR for apt (V. Skytt辰, #1617)
769
770* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
771- temporary workaround for enigmail skin "modern" bug
772
773* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
774- update to Enigmail 0.84.0
775- update launch script
776
777* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
778- installation directory now versioned
779- allow root to run the program (for installing extensions)
780- remove unnecessary %%pre and %%post
781- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
782
783* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
784- include Enigmail, re-add release notes
785- delete %{_libdir}/thunderbird in %%pre
786
787* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
788- update to Thunderbird 0.6
789
790* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
791- update to Thunderbird 0.6 RC1
792- add new icon, remove release notes
793
794* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
795- update to latest CVS, update mozconfig and %%build accordingly
796- update to Enigmail 0.83.6
797- remove x-remote and x86_64 patches
798- build with -Os
799
800* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
801- update x-remote patch
802- more startup script fixes
803
804* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
805- startup script fixes, and a minor cleanup
806
807* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
808- Minor cleanups
809
810* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
811- minor improvements to open-browser.sh and startup script
812- update to latest version of Blizzard's x-remote patch
813
814* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
815- update open-browser.sh, startup script, and BuildRequires
816
817* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
818- update open-browser script, modify BuildRequires (Warren)
819- add Blizzard's x-remote patch
820- initial attempt at x-remote-enabled startup script
821
822* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
823- refuse to run with excessive privileges
824
825* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
826- add Mozilla x86_64 patch (Oliver Sontag)
827- Enigmail source filenames now include the version
828- modify BuildRoot
829
830* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
831- use the updated official tarball
832
833* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
834- fix %%prep script
835
836* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
837- update Enigmail to 0.83.3
838- use official source tarball (after removing the CRLFs)
839- package renamed to thunderbird
840
841* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
842- update to 0.5
843- check for lockfile before launching
844
845* Fri Feb 06 2004 David Hill <djh[at]ii.net>
846- update to latest cvs
847- update to Enigmail 0.83.2
848
849* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
850- update to Enigmail 0.83.1
851- removed Mozilla/Firebird script patching
852
853* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
854- add startup notification to .desktop file
855
856* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
857- open-browser.sh release 3
858- patch broken /usr/bin/mozilla script during install
859- dir ownership
860- XXX: Source fails build on x86_64... fix later
861
862* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
863- update to Enigmail 0.82.5
864- add Warren's open-browser.sh (#1113)
865
866* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
867- use Thunderbird's mozilla-xremote-client to launch browser
868
869* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
870- update to 0.4
871- make hyperlinks work (with recent versions of Firebird/Mozilla)
872
873* Thu Dec 04 2003 David Hill <djh[at]ii.net>
874- update to 0.4rc2
875
876* Wed Dec 03 2003 David Hill <djh[at]ii.net>
877- update to 0.4rc1 and Enigmail 0.82.4
878
879* Thu Nov 27 2003 David Hill <djh[at]ii.net>
880- update to latest CVS and Enigmail 0.82.3
881
882* Sun Nov 16 2003 David Hill <djh[at]ii.net>
883- update to latest CVS (0.4a)
884- update Enigmail to 0.82.2
885- alter mozconfig for new build requirements
886- add missing BuildReq (#987)
887
888* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
889- update to 0.3
890
891* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
892- update to 0.3rc3
893- update Enigmail to 0.81.7
894
895* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
896- update to 0.3rc2
897
898* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
899- simplify startup script
900
901* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
902- add GPG support (Enigmail 0.81.6)
903- specfile fixes (#679)
904
905* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
906- update to 0.2
907
908* Mon Sep 01 2003 David Hill <djh[at]ii.net>
909- initial RPM
910  (based on the fedora MozillaFirebird-0.6.1 specfile)
911
Note: See TracBrowser for help on using the repository browser.