source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 7136

Revision 7136, 29.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 17.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
82BuildRequires:  pango-devel
83BuildRequires:  cairo-devel >= %{cairo_version}
84%if %{build_vine7}
85BuildRequires:  nspr-devel >= %{nspr_version}
86BuildRequires:  nss-devel >= %{nss_version}
87BuildRequires:  hunspell-devel
88%endif
89%if %{build_vine6}
90BuildRequires:  hunspell-devel
91BuildRequires:  python-devel
92%endif
93BuildRequires:  pixman-devel
94BuildRequires:  libpng-devel
95BuildRequires:  libjpeg-turbo-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  zlib-devel, gzip, zip, unzip
98BuildRequires:  libIDL-devel
99BuildRequires:  freetype2-devel >= %{freetype_version}
100## disabled libnotify support
101## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
102BuildRequires:  libnotify-devel >= %{libnotify_version}
103BuildRequires:  bzip2-devel
104BuildRequires:  gnome-vfs2-devel
105BuildRequires:  libgnome-devel
106BuildRequires:  libgnomeui-devel
107BuildRequires:  krb5-devel
108BuildRequires:  pango-devel
109BuildRequires:  libXt-devel
110BuildRequires:  libXrender-devel
111# hunspell is in plus category for vine
112#BuildRequires: hunspell-devel
113BuildRequires:  sqlite3-devel >= %{sqlite_version}
114BuildRequires:  startup-notification-devel
115BuildRequires:  desktop-file-utils
116BuildRequires:  alsa-lib-devel
117BuildRequires:  yasm
118Requires:       sqlite3 >= %{sqlite_version}
119Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
120Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
121
122Obsoletes:      MozillaThunderbird
123Provides:       MozillaThunderbird = %{version}
124
125Vendor:         Project Vine
126Distribution:   Vine Linux
127Packager:       daisuke, ryoichi, kazutaka
128
129AutoProv: 0
130%define _use_internal_dependency_generator 0
131%define __find_requires %{SOURCE100}
132
133%description
134Thunderbird is a standalone mail and newsgroup client.
135
136%description -l ja
137Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
138
139#===============================================================================
140
141%prep
142%setup -q %{name}-%{version} -c
143cd %{tarballdir}
144
145# Fix for version issue
146sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
147    > version.patch
148%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
149
150cd mozilla
151%patch1 -p1 -b .default-a4
152
153cd -
154%{__rm} -f .mozconfig
155%if %{build_vine6}
156%{__cp} %{SOURCE1010} .mozconfig
157%endif
158%if %{build_vine7}
159%{__cp} %{SOURCE1020} .mozconfig
160%endif
161
162# setup unofficial branding name
163%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
164%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
165
166%patch100 -p1 -b .addons
167
168#===============================================================================
169
170%build
171cd %{tarballdir}
172
173INTERNAL_GECKO=%{version_internal}
174MOZ_APP_DIR=%{mozappdir}
175
176
177%if %{build_vine7}
178MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
179%else
180%ifarch x86_64
181#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
182MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
183%else
184MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
185%endif
186%endif
187export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
188export CFLAGS="$RPM_OPT_FLAGS"
189#export CFLAGS=""
190export CXXFLAGS="$CFLAGS"
191export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
192
193%ifarch ppc ppc64 s390 s390x
194%define moz_make_flags -j1
195%else
196%define moz_make_flags %{?_smp_mflags}
197%endif
198
199export PREFIX='%{_prefix}'
200export LIBDIR='%{_libdir}'
201
202export LDFLAGS="-Wl,-rpath,%{mozappdir}"
203export MAKE="gmake %{moz_make_flags}"
204%{__make} -f client.mk build
205
206## build locales
207#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
208#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
209#for dir in $LOCALEDIRS
210#do
211#  for lang in %{MOZ_BUILD_LOCALES} ; do
212#    make -C $dir/locales AB_CD=$lang
213#  done
214#done
215
216#===============================================================================
217
218%install
219%{__rm} -rf $RPM_BUILD_ROOT
220cd %{tarballdir}
221
222INTERNAL_GECKO=%{version_internal}
223
224INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
225MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
226
227cd %{moz_objdir}
228DESTDIR=$RPM_BUILD_ROOT make install
229
230# install unofficial icons
231cd -
232
233%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
234%{__cp} mail/branding/aurora/mailicon16.png \
235        $RPM_BUILD_ROOT/%{mozappdir}/icons/
236%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
237%{__cp} mail/branding/aurora/mailicon16.png \
238        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
239%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
240%{__cp} mail/branding/aurora/mailicon22.png \
241        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
242%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
243%{__cp} mail/branding/aurora/mailicon24.png \
244        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
245%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
246%{__cp} mail/branding/aurora/mailicon32.png \
247        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
249%{__cp} mail/branding/aurora/mailicon48.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
252%{__cp} mail/branding/aurora/mailicon256.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
254
255desktop-file-install --vendor vine \
256  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
257
258# set up the thunderbird start script
259rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
260%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
261  $RPM_BUILD_ROOT%{_bindir}/thunderbird
262%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
263
264install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
265%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
266
267%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
268                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
269        $RPM_BUILD_ROOT/vine-default-prefs
270%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
271%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
272%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
273
274%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
275
276# own mozilla plugin dir (#135050)
277%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
278
279# own extension directories
280%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
281%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
282
283# install locales
284#for lang in %{MOZ_BUILD_LOCALES} ; do
285#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
286#done
287
288# install ja.xpi to langpacks directory
289#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
290#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
291# also setup unofficial branding name
292#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
293#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
294
295# install ja.xpi to langpack file
296%{__mkdir_p} lang_tmp
297unzip %{SOURCE1} -d lang_tmp
298# also setup unofficial branding name
299%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
300%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
301
302%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
303cd lang_tmp; \
304zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
305
306
307%clean
308%{__rm} -rf $RPM_BUILD_ROOT
309
310#===============================================================================
311
312%post
313update-desktop-database &> /dev/null || :
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x %{_bindir}/gtk-update-icon-cache ]; then
316  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
317fi
318
319%postun
320update-desktop-database &> /dev/null || :
321touch --no-create %{_datadir}/icons/hicolor
322if [ -x %{_bindir}/gtk-update-icon-cache ]; then
323  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
324fi
325
326
327%files
328%defattr(-,root,root,-)
329%attr(755,root,root) %{_bindir}/thunderbird
330%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
331%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
332%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
333%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
334%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
335%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
336%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
337%{mozappdir}
338#%{_libdir}/mozilla
339%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
340%exclude %{_datadir}/idl/%{name}-%{version_internal}
341%exclude %{_includedir}/%{name}-%{version_internal}
342%exclude %{_libdir}/%{name}-devel-%{version_internal}
343
344#===============================================================================
345
346%changelog
347* Wed Nov 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0-1
348- new upstream release
349
350* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
351- use --disable-install-strip instead of --enable-install-strip
352- add --disable-debug-symbols
353
354* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
355- new upstream release
356
357* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
358- new upstream release
359
360* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
361- new upstream release
362
363* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
364- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
365
366* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
367- new upstream release
368
369* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
370- new upstream release
371- add BuildRequires: python-devel (Vine6 only)
372- remove build rule of Vine5
373
374* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
375- new upstream release
376- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
377
378* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
379- new upstream release
380
381* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
382- new upstream release
383- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
384
385* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
386- new upstream release
387
388* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
389- new upstream release
390- update Source1030 (mozconfig-thunderbird-vine7)
391
392* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
393- new upstream release
394- update Source1020 (mozconfig-thunderbird-vine6)
395
396* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
397- new upstream release
398
399* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
400- new upstream release
401
402* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
403- new upstream release
404
405* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
406- new upstream release
407- update Source1
408
409* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
410- new upstream release
411- update Source1
412- add Source1030 (mozconfig-thunderbird-vine7)
413- add Patch100 (thunderbird-9.0-enable-addons.patch)
414
415* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
416- fix %%version_internal
417
418* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
419- new upstream release
420- update Source1
421
422* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
423- new upstream release
424- update Source1,21,1010,1020
425
426* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
427- rebuild with libnotify-0.7
428
429* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
430- enable-install-strip
431
432* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
433- new upstream release
434- drop obsolete patch and renumber patch26 to patch1
435- add BuildRequires: yasm
436- enable libnotify support
437- add --disable-updater and --disable-installer to mozconfig
438- use ja.xpi instead of l10n source
439- update Source21: add step to setup langpack plugin
440- update Source20: add japanese translation
441- add Source42 & Source43 for localized branding
442- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
443  for mozconfig-thunderbird-vine5
444
445* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
446- new upstream release with security fix
447
448* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
449- new upstream release with security fix
450
451* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
452- new upstream release with security fix
453
454* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
455- new upstream release with security fix
456- add patch5 to fix build failure
457
458* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
459- new upstream release
460
461* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
462- new upstream release with security fix
463- add Patch1030 to fix compilation error
464
465* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
466- change mozconfig (Source1030 & 1040): add --enable-jsd
467
468* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
469- new upstream release
470
471* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
472- new upstream release with security fix
473- add Patch0 from fedora development: fix version issue
474- remove BuildRequires: hunspell-devel
475- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
476
477* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
478- add BuildRequires: alsa-lib-devel
479- remove BuildRequires: libnotify-devel
480  (workaround for known bug)
481- update mozconfig to add --disable-libnotify option
482
483* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
484- new upstream release
485- update spec entirely
486- import patches from fedora (Patch1, 2 & 4)
487- drop outdated patches (Patch22, 24)
488- update Sources:
489  - mozconfig (Source1030 & Source1040)
490  - default prefs.js (Source12)
491  - unofficial branding (Source40 & Source41)
492  - japanese translation (Source1000)
493- update Patch1000 (sjis-alias)
494
495* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
496- new upstream release
497
498* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
499- new upstream release
500
501* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
502- don't install official branding logos
503
504* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
505- add necessary icons in %%{tbdir}/chrome/icons/default
506- add Packager tag
507
508* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
509- new upstream release
510
511* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
512- new upstream release
513
514* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
515- new upstream release
516
517* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
518- new upstream release
519
520* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
521- rebuilt for VineSeed
522
523* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
524- new upstream release
525
526* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
527- new upstream release
528- built for Vine Linux 4.x
529- dropped Patch1020 (merged into upstream)
530
531* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
532- added Patch1020 for workaround gcc visibility hidden bugs
533
534* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
535- build with new environment/toolchain
536- add build options to build with external nss/nspr libraries
537    ac_add_options --with-system-nspr
538    ac_add_options --with-system-nss
539
540* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
541- new upstream release
542
543* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
544- new upstream release
545
546* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
547- new upstream release
548
549* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
550- new upstream release
551
552* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
553- new upstream release
554- merge changes from firefox
555  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
556
557* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
558- new upstream release
559- build en-US locale
560- merge changes from firefox
561  - add upstream patches
562  - disable pango rendering by default
563    (workaround fix slow rendering in some page)
564
565* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
566- initial build for Vine Linux based on FC package
567- update to 1.5RC2
568
569* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
570- Fix issue with popup dialogs and other actions causing lockups
571
572* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
573- Update to 1.5 rc1
574
575* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
576- Update to 1.5 beta2
577
578* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
579- Update to 1.5 beta1
580- Bring the install phase of the spec file up to speed
581
582* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
583- Rebuild
584
585* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
586- Add patch to make file chooser dialog modal
587
588* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
589- Update to 1.0.6
590
591* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
592- 1.0.6 Release Candidate
593
594* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
595- Use system NSPR
596- Fix crash on 64bit platforms (#160330)
597
598* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
599- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
600  references, fixing the "no fonts" problem.
601
602* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
603- Change the Exec line in the desktop file to `thunderbird`
604
605* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
606- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
607
608* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
609- Add temporary workaround to not create files in the user's $HOME (#149664)
610
611* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
612- Don't have downloads "disappear" when downloading to desktop (#139015)
613- Fix for some more cursor issues in textareas (149991, 150002, 152089)
614- Add upstream patch to fix bidi justification of pango
615- Add patch to fix launching of helper applications
616- Add patch to properly link against libgfxshared_s.a
617- Fix multilib conflicts
618
619* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
620- correct confusing PANGO vars in startup script
621
622* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
623- Thunderbird 1.0.2
624
625* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
626- Add patch to compile against new fortified glibc macros
627
628* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
629- Rebuild against GCC 4.0
630- Add execshield patches
631- Minor specfile cleanup
632
633* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
634- Rebuild
635
636* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
637- Add RPM version to useragent
638
639* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
640- Port over pango patches from firefox
641
642* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
643- Thunderbird 1.0
644
645* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
646- Fix advanced prefs
647
648* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
649- Make this run on s390(x) now for real
650
651* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
652- Update to 1.0 rc1
653
654* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
655- Add patches to build and run on s390(x)
656
657* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
658- Rebuild to fix file chooser
659
660* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
661- Update to 0.9
662
663* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
664- Prevent inlining of stack direction detection (#135255)
665
666* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
667- More file chooser fixes (same as in firefox)
668- Fix for upstream 28327.
669
670* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
671- Update the pango patch
672
673* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
674- Pull over patches from firefox build:
675  - disable default application dialog
676  - don't include software update since it doesn't work
677  - make external app support work
678
679* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
680- Use pango for rendering
681
682* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
683- Fix for 64 bit crash at startup (b.m.o #256603)
684
685* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
686- Add patches to fix xremote (#135036)
687
688* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
689- Add patch to fix button focus issues (#133507)
690- Add patch for fix IMAP race issues (bmo #246439)
691
692* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
693- filter out library Provides: and internal Requires:
694
695* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
696- Backport the GTK+ File Chooser.
697- Add fix for JS math on x86_64 systems
698- Add pkgconfig patch
699
700* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
701- Update to 0.8.0
702- Remove enigmail
703- Update BuildRequires
704- Remove gcc34 and extension manager patches -- they are upstreamed.
705- Fix for gnome-vfs2 error at component registration
706
707* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
708- Build with --disable-xprint
709
710* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
711- remove all Xvfb-related hacks
712
713* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
714- actually apply psfonts
715- add mozilla gnome-uriloader patch to prevent build failure
716
717* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
718- rawhide import
719- apply NetBSD's freetype 2.1.8 patch
720- apply psfonts patch
721- remove BR on /usr/bin/ex, breaks beehive
722
723* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
724- oops, fix %%install
725
726* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
727- update to Thunderbird 0.7.3 and Enigmail 0.85.0
728- remove XUL.mfasl on startup, add Debian enigmail patches
729- add Xvfb hack for -install-global-extension
730
731* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
732- update to 0.7.2, just because it's there
733- update gcc-3.4 patch (Kaj Niemi)
734- add EM registration patch and remove instdir hack
735
736* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
737- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
738
739* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
740- update to 0.7.1
741- remove Enigmail
742
743* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
744- re-enable Enigmail 0.84.1
745- add gcc-3.4 patch (Kaj Niemi)
746- use official branding (with permission)
747
748* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
749- update to 0.7
750- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
751- specify libdir, change BR for apt (V. Skytt辰, #1617)
752
753* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
754- temporary workaround for enigmail skin "modern" bug
755
756* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
757- update to Enigmail 0.84.0
758- update launch script
759
760* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
761- installation directory now versioned
762- allow root to run the program (for installing extensions)
763- remove unnecessary %%pre and %%post
764- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
765
766* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
767- include Enigmail, re-add release notes
768- delete %{_libdir}/thunderbird in %%pre
769
770* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
771- update to Thunderbird 0.6
772
773* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
774- update to Thunderbird 0.6 RC1
775- add new icon, remove release notes
776
777* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
778- update to latest CVS, update mozconfig and %%build accordingly
779- update to Enigmail 0.83.6
780- remove x-remote and x86_64 patches
781- build with -Os
782
783* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
784- update x-remote patch
785- more startup script fixes
786
787* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
788- startup script fixes, and a minor cleanup
789
790* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
791- Minor cleanups
792
793* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
794- minor improvements to open-browser.sh and startup script
795- update to latest version of Blizzard's x-remote patch
796
797* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
798- update open-browser.sh, startup script, and BuildRequires
799
800* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
801- update open-browser script, modify BuildRequires (Warren)
802- add Blizzard's x-remote patch
803- initial attempt at x-remote-enabled startup script
804
805* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
806- refuse to run with excessive privileges
807
808* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
809- add Mozilla x86_64 patch (Oliver Sontag)
810- Enigmail source filenames now include the version
811- modify BuildRoot
812
813* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
814- use the updated official tarball
815
816* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
817- fix %%prep script
818
819* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
820- update Enigmail to 0.83.3
821- use official source tarball (after removing the CRLFs)
822- package renamed to thunderbird
823
824* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
825- update to 0.5
826- check for lockfile before launching
827
828* Fri Feb 06 2004 David Hill <djh[at]ii.net>
829- update to latest cvs
830- update to Enigmail 0.83.2
831
832* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
833- update to Enigmail 0.83.1
834- removed Mozilla/Firebird script patching
835
836* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
837- add startup notification to .desktop file
838
839* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
840- open-browser.sh release 3
841- patch broken /usr/bin/mozilla script during install
842- dir ownership
843- XXX: Source fails build on x86_64... fix later
844
845* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
846- update to Enigmail 0.82.5
847- add Warren's open-browser.sh (#1113)
848
849* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
850- use Thunderbird's mozilla-xremote-client to launch browser
851
852* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
853- update to 0.4
854- make hyperlinks work (with recent versions of Firebird/Mozilla)
855
856* Thu Dec 04 2003 David Hill <djh[at]ii.net>
857- update to 0.4rc2
858
859* Wed Dec 03 2003 David Hill <djh[at]ii.net>
860- update to 0.4rc1 and Enigmail 0.82.4
861
862* Thu Nov 27 2003 David Hill <djh[at]ii.net>
863- update to latest CVS and Enigmail 0.82.3
864
865* Sun Nov 16 2003 David Hill <djh[at]ii.net>
866- update to latest CVS (0.4a)
867- update Enigmail to 0.82.2
868- alter mozconfig for new build requirements
869- add missing BuildReq (#987)
870
871* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
872- update to 0.3
873
874* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
875- update to 0.3rc3
876- update Enigmail to 0.81.7
877
878* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
879- update to 0.3rc2
880
881* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
882- simplify startup script
883
884* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
885- add GPG support (Enigmail 0.81.6)
886- specfile fixes (#679)
887
888* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
889- update to 0.2
890
891* Mon Sep 01 2003 David Hill <djh[at]ii.net>
892- initial RPM
893  (based on the fedora MozillaFirebird-0.6.1 specfile)
894
Note: See TracBrowser for help on using the repository browser.