source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 7065

Revision 7065, 29.7 KB checked in by Takemikaduchi, 12 years ago (diff)

thunderbird: change configure options
others: new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 16.0.2
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 2%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
82BuildRequires:  pango-devel
83BuildRequires:  cairo-devel >= %{cairo_version}
84%if %{build_vine7}
85BuildRequires:  nspr-devel >= %{nspr_version}
86BuildRequires:  nss-devel >= %{nss_version}
87BuildRequires:  hunspell-devel
88%endif
89%if %{build_vine6}
90BuildRequires:  hunspell-devel
91BuildRequires:  python-devel
92%endif
93BuildRequires:  pixman-devel
94BuildRequires:  libpng-devel
95BuildRequires:  libjpeg-turbo-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  zlib-devel, gzip, zip, unzip
98BuildRequires:  libIDL-devel
99BuildRequires:  freetype2-devel >= %{freetype_version}
100## disabled libnotify support
101## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
102BuildRequires:  libnotify-devel >= %{libnotify_version}
103BuildRequires:  bzip2-devel
104BuildRequires:  gnome-vfs2-devel
105BuildRequires:  libgnome-devel
106BuildRequires:  libgnomeui-devel
107BuildRequires:  krb5-devel
108BuildRequires:  pango-devel
109BuildRequires:  libXt-devel
110BuildRequires:  libXrender-devel
111# hunspell is in plus category for vine
112#BuildRequires: hunspell-devel
113BuildRequires:  sqlite3-devel >= %{sqlite_version}
114BuildRequires:  startup-notification-devel
115BuildRequires:  desktop-file-utils
116BuildRequires:  alsa-lib-devel
117BuildRequires:  yasm
118Requires:       sqlite3 >= %{sqlite_version}
119Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
120Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
121
122Obsoletes:      MozillaThunderbird
123Provides:       MozillaThunderbird = %{version}
124
125Vendor:         Project Vine
126Distribution:   Vine Linux
127Packager:       daisuke, ryoichi, kazutaka
128
129AutoProv: 0
130%define _use_internal_dependency_generator 0
131%define __find_requires %{SOURCE100}
132
133%description
134Thunderbird is a standalone mail and newsgroup client.
135
136%description -l ja
137Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
138
139#===============================================================================
140
141%prep
142%setup -q %{name}-%{version} -c
143cd %{tarballdir}
144
145# Fix for version issue
146sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
147    > version.patch
148%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
149
150cd mozilla
151%patch1 -p1 -b .default-a4
152
153cd -
154%{__rm} -f .mozconfig
155%if %{build_vine6}
156%{__cp} %{SOURCE1010} .mozconfig
157%endif
158%if %{build_vine7}
159%{__cp} %{SOURCE1020} .mozconfig
160%endif
161
162# setup unofficial branding name
163%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
164%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
165
166%patch100 -p1 -b .addons
167
168#===============================================================================
169
170%build
171cd %{tarballdir}
172
173INTERNAL_GECKO=%{version_internal}
174MOZ_APP_DIR=%{mozappdir}
175
176
177%if %{build_vine7}
178MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
179%else
180%ifarch x86_64
181#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
182MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
183%else
184MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
185%endif
186%endif
187export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
188export CFLAGS="$RPM_OPT_FLAGS"
189#export CFLAGS=""
190export CXXFLAGS="$CFLAGS"
191export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
192
193%ifarch ppc ppc64 s390 s390x
194%define moz_make_flags -j1
195%else
196%define moz_make_flags %{?_smp_mflags}
197%endif
198
199export PREFIX='%{_prefix}'
200export LIBDIR='%{_libdir}'
201
202export LDFLAGS="-Wl,-rpath,%{mozappdir}"
203export MAKE="gmake %{moz_make_flags}"
204%{__make} -f client.mk build
205
206## build locales
207#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
208#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
209#for dir in $LOCALEDIRS
210#do
211#  for lang in %{MOZ_BUILD_LOCALES} ; do
212#    make -C $dir/locales AB_CD=$lang
213#  done
214#done
215
216#===============================================================================
217
218%install
219%{__rm} -rf $RPM_BUILD_ROOT
220cd %{tarballdir}
221
222INTERNAL_GECKO=%{version_internal}
223
224INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
225MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
226
227cd %{moz_objdir}
228DESTDIR=$RPM_BUILD_ROOT make install
229
230# install unofficial icons
231cd -
232
233%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
234%{__cp} mail/branding/aurora/mailicon16.png \
235        $RPM_BUILD_ROOT/%{mozappdir}/icons/
236%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
237%{__cp} mail/branding/aurora/mailicon16.png \
238        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
239%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
240%{__cp} mail/branding/aurora/mailicon22.png \
241        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
242%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
243%{__cp} mail/branding/aurora/mailicon24.png \
244        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
245%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
246%{__cp} mail/branding/aurora/mailicon32.png \
247        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
249%{__cp} mail/branding/aurora/mailicon48.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
252%{__cp} mail/branding/aurora/mailicon256.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
254
255desktop-file-install --vendor vine \
256  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
257
258# set up the thunderbird start script
259rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
260%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
261  $RPM_BUILD_ROOT%{_bindir}/thunderbird
262%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
263
264install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
265%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
266
267%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
268                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
269        $RPM_BUILD_ROOT/vine-default-prefs
270%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
271%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
272%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
273
274%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
275
276# own mozilla plugin dir (#135050)
277%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
278
279# own extension directories
280%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
281%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
282
283# install locales
284#for lang in %{MOZ_BUILD_LOCALES} ; do
285#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
286#done
287
288# install ja.xpi to langpacks directory
289#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
290#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
291# also setup unofficial branding name
292#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
293#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
294
295# install ja.xpi to langpack file
296%{__mkdir_p} lang_tmp
297unzip %{SOURCE1} -d lang_tmp
298# also setup unofficial branding name
299%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
300%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
301
302%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
303cd lang_tmp; \
304zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
305
306
307%clean
308%{__rm} -rf $RPM_BUILD_ROOT
309
310#===============================================================================
311
312%post
313update-desktop-database &> /dev/null || :
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x %{_bindir}/gtk-update-icon-cache ]; then
316  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
317fi
318
319%postun
320update-desktop-database &> /dev/null || :
321touch --no-create %{_datadir}/icons/hicolor
322if [ -x %{_bindir}/gtk-update-icon-cache ]; then
323  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
324fi
325
326
327%files
328%defattr(-,root,root,-)
329%attr(755,root,root) %{_bindir}/thunderbird
330%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
331%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
332%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
333%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
334%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
335%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
336%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
337%{mozappdir}
338#%{_libdir}/mozilla
339%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
340%exclude %{_datadir}/idl/%{name}-%{version_internal}
341%exclude %{_includedir}/%{name}-%{version_internal}
342%exclude %{_libdir}/%{name}-devel-%{version_internal}
343
344#===============================================================================
345
346%changelog
347* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
348- use --disable-install-strip instead of --enable-install-strip
349- add --disable-debug-symbols
350
351* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
352- new upstream release
353
354* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
355- new upstream release
356
357* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
358- new upstream release
359
360* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
361- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
362
363* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
364- new upstream release
365
366* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
367- new upstream release
368- add BuildRequires: python-devel (Vine6 only)
369- remove build rule of Vine5
370
371* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
372- new upstream release
373- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
374
375* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
376- new upstream release
377
378* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
379- new upstream release
380- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
381
382* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
383- new upstream release
384
385* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
386- new upstream release
387- update Source1030 (mozconfig-thunderbird-vine7)
388
389* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
390- new upstream release
391- update Source1020 (mozconfig-thunderbird-vine6)
392
393* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
394- new upstream release
395
396* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
397- new upstream release
398
399* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
400- new upstream release
401
402* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
403- new upstream release
404- update Source1
405
406* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
407- new upstream release
408- update Source1
409- add Source1030 (mozconfig-thunderbird-vine7)
410- add Patch100 (thunderbird-9.0-enable-addons.patch)
411
412* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
413- fix %%version_internal
414
415* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
416- new upstream release
417- update Source1
418
419* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
420- new upstream release
421- update Source1,21,1010,1020
422
423* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
424- rebuild with libnotify-0.7
425
426* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
427- enable-install-strip
428
429* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
430- new upstream release
431- drop obsolete patch and renumber patch26 to patch1
432- add BuildRequires: yasm
433- enable libnotify support
434- add --disable-updater and --disable-installer to mozconfig
435- use ja.xpi instead of l10n source
436- update Source21: add step to setup langpack plugin
437- update Source20: add japanese translation
438- add Source42 & Source43 for localized branding
439- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
440  for mozconfig-thunderbird-vine5
441
442* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
443- new upstream release with security fix
444
445* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
446- new upstream release with security fix
447
448* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
449- new upstream release with security fix
450
451* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
452- new upstream release with security fix
453- add patch5 to fix build failure
454
455* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
456- new upstream release
457
458* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
459- new upstream release with security fix
460- add Patch1030 to fix compilation error
461
462* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
463- change mozconfig (Source1030 & 1040): add --enable-jsd
464
465* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
466- new upstream release
467
468* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
469- new upstream release with security fix
470- add Patch0 from fedora development: fix version issue
471- remove BuildRequires: hunspell-devel
472- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
473
474* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
475- add BuildRequires: alsa-lib-devel
476- remove BuildRequires: libnotify-devel
477  (workaround for known bug)
478- update mozconfig to add --disable-libnotify option
479
480* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
481- new upstream release
482- update spec entirely
483- import patches from fedora (Patch1, 2 & 4)
484- drop outdated patches (Patch22, 24)
485- update Sources:
486  - mozconfig (Source1030 & Source1040)
487  - default prefs.js (Source12)
488  - unofficial branding (Source40 & Source41)
489  - japanese translation (Source1000)
490- update Patch1000 (sjis-alias)
491
492* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
493- new upstream release
494
495* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
496- new upstream release
497
498* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
499- don't install official branding logos
500
501* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
502- add necessary icons in %%{tbdir}/chrome/icons/default
503- add Packager tag
504
505* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
506- new upstream release
507
508* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
509- new upstream release
510
511* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
512- new upstream release
513
514* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
515- new upstream release
516
517* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
518- rebuilt for VineSeed
519
520* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
521- new upstream release
522
523* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
524- new upstream release
525- built for Vine Linux 4.x
526- dropped Patch1020 (merged into upstream)
527
528* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
529- added Patch1020 for workaround gcc visibility hidden bugs
530
531* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
532- build with new environment/toolchain
533- add build options to build with external nss/nspr libraries
534    ac_add_options --with-system-nspr
535    ac_add_options --with-system-nss
536
537* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
538- new upstream release
539
540* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
541- new upstream release
542
543* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
544- new upstream release
545
546* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
547- new upstream release
548
549* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
550- new upstream release
551- merge changes from firefox
552  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
553
554* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
555- new upstream release
556- build en-US locale
557- merge changes from firefox
558  - add upstream patches
559  - disable pango rendering by default
560    (workaround fix slow rendering in some page)
561
562* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
563- initial build for Vine Linux based on FC package
564- update to 1.5RC2
565
566* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
567- Fix issue with popup dialogs and other actions causing lockups
568
569* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
570- Update to 1.5 rc1
571
572* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
573- Update to 1.5 beta2
574
575* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
576- Update to 1.5 beta1
577- Bring the install phase of the spec file up to speed
578
579* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
580- Rebuild
581
582* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
583- Add patch to make file chooser dialog modal
584
585* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
586- Update to 1.0.6
587
588* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
589- 1.0.6 Release Candidate
590
591* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
592- Use system NSPR
593- Fix crash on 64bit platforms (#160330)
594
595* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
596- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
597  references, fixing the "no fonts" problem.
598
599* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
600- Change the Exec line in the desktop file to `thunderbird`
601
602* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
603- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
604
605* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
606- Add temporary workaround to not create files in the user's $HOME (#149664)
607
608* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
609- Don't have downloads "disappear" when downloading to desktop (#139015)
610- Fix for some more cursor issues in textareas (149991, 150002, 152089)
611- Add upstream patch to fix bidi justification of pango
612- Add patch to fix launching of helper applications
613- Add patch to properly link against libgfxshared_s.a
614- Fix multilib conflicts
615
616* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
617- correct confusing PANGO vars in startup script
618
619* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
620- Thunderbird 1.0.2
621
622* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
623- Add patch to compile against new fortified glibc macros
624
625* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
626- Rebuild against GCC 4.0
627- Add execshield patches
628- Minor specfile cleanup
629
630* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
631- Rebuild
632
633* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
634- Add RPM version to useragent
635
636* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
637- Port over pango patches from firefox
638
639* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
640- Thunderbird 1.0
641
642* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
643- Fix advanced prefs
644
645* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
646- Make this run on s390(x) now for real
647
648* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
649- Update to 1.0 rc1
650
651* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
652- Add patches to build and run on s390(x)
653
654* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
655- Rebuild to fix file chooser
656
657* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
658- Update to 0.9
659
660* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
661- Prevent inlining of stack direction detection (#135255)
662
663* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
664- More file chooser fixes (same as in firefox)
665- Fix for upstream 28327.
666
667* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
668- Update the pango patch
669
670* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
671- Pull over patches from firefox build:
672  - disable default application dialog
673  - don't include software update since it doesn't work
674  - make external app support work
675
676* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
677- Use pango for rendering
678
679* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
680- Fix for 64 bit crash at startup (b.m.o #256603)
681
682* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
683- Add patches to fix xremote (#135036)
684
685* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
686- Add patch to fix button focus issues (#133507)
687- Add patch for fix IMAP race issues (bmo #246439)
688
689* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
690- filter out library Provides: and internal Requires:
691
692* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
693- Backport the GTK+ File Chooser.
694- Add fix for JS math on x86_64 systems
695- Add pkgconfig patch
696
697* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
698- Update to 0.8.0
699- Remove enigmail
700- Update BuildRequires
701- Remove gcc34 and extension manager patches -- they are upstreamed.
702- Fix for gnome-vfs2 error at component registration
703
704* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
705- Build with --disable-xprint
706
707* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
708- remove all Xvfb-related hacks
709
710* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
711- actually apply psfonts
712- add mozilla gnome-uriloader patch to prevent build failure
713
714* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
715- rawhide import
716- apply NetBSD's freetype 2.1.8 patch
717- apply psfonts patch
718- remove BR on /usr/bin/ex, breaks beehive
719
720* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
721- oops, fix %%install
722
723* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
724- update to Thunderbird 0.7.3 and Enigmail 0.85.0
725- remove XUL.mfasl on startup, add Debian enigmail patches
726- add Xvfb hack for -install-global-extension
727
728* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
729- update to 0.7.2, just because it's there
730- update gcc-3.4 patch (Kaj Niemi)
731- add EM registration patch and remove instdir hack
732
733* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
734- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
735
736* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
737- update to 0.7.1
738- remove Enigmail
739
740* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
741- re-enable Enigmail 0.84.1
742- add gcc-3.4 patch (Kaj Niemi)
743- use official branding (with permission)
744
745* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
746- update to 0.7
747- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
748- specify libdir, change BR for apt (V. Skytt辰, #1617)
749
750* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
751- temporary workaround for enigmail skin "modern" bug
752
753* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
754- update to Enigmail 0.84.0
755- update launch script
756
757* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
758- installation directory now versioned
759- allow root to run the program (for installing extensions)
760- remove unnecessary %%pre and %%post
761- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
762
763* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
764- include Enigmail, re-add release notes
765- delete %{_libdir}/thunderbird in %%pre
766
767* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
768- update to Thunderbird 0.6
769
770* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
771- update to Thunderbird 0.6 RC1
772- add new icon, remove release notes
773
774* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
775- update to latest CVS, update mozconfig and %%build accordingly
776- update to Enigmail 0.83.6
777- remove x-remote and x86_64 patches
778- build with -Os
779
780* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
781- update x-remote patch
782- more startup script fixes
783
784* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
785- startup script fixes, and a minor cleanup
786
787* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
788- Minor cleanups
789
790* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
791- minor improvements to open-browser.sh and startup script
792- update to latest version of Blizzard's x-remote patch
793
794* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
795- update open-browser.sh, startup script, and BuildRequires
796
797* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
798- update open-browser script, modify BuildRequires (Warren)
799- add Blizzard's x-remote patch
800- initial attempt at x-remote-enabled startup script
801
802* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
803- refuse to run with excessive privileges
804
805* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
806- add Mozilla x86_64 patch (Oliver Sontag)
807- Enigmail source filenames now include the version
808- modify BuildRoot
809
810* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
811- use the updated official tarball
812
813* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
814- fix %%prep script
815
816* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
817- update Enigmail to 0.83.3
818- use official source tarball (after removing the CRLFs)
819- package renamed to thunderbird
820
821* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
822- update to 0.5
823- check for lockfile before launching
824
825* Fri Feb 06 2004 David Hill <djh[at]ii.net>
826- update to latest cvs
827- update to Enigmail 0.83.2
828
829* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
830- update to Enigmail 0.83.1
831- removed Mozilla/Firebird script patching
832
833* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
834- add startup notification to .desktop file
835
836* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
837- open-browser.sh release 3
838- patch broken /usr/bin/mozilla script during install
839- dir ownership
840- XXX: Source fails build on x86_64... fix later
841
842* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
843- update to Enigmail 0.82.5
844- add Warren's open-browser.sh (#1113)
845
846* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
847- use Thunderbird's mozilla-xremote-client to launch browser
848
849* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
850- update to 0.4
851- make hyperlinks work (with recent versions of Firebird/Mozilla)
852
853* Thu Dec 04 2003 David Hill <djh[at]ii.net>
854- update to 0.4rc2
855
856* Wed Dec 03 2003 David Hill <djh[at]ii.net>
857- update to 0.4rc1 and Enigmail 0.82.4
858
859* Thu Nov 27 2003 David Hill <djh[at]ii.net>
860- update to latest CVS and Enigmail 0.82.3
861
862* Sun Nov 16 2003 David Hill <djh[at]ii.net>
863- update to latest CVS (0.4a)
864- update Enigmail to 0.82.2
865- alter mozconfig for new build requirements
866- add missing BuildReq (#987)
867
868* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
869- update to 0.3
870
871* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
872- update to 0.3rc3
873- update Enigmail to 0.81.7
874
875* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
876- update to 0.3rc2
877
878* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
879- simplify startup script
880
881* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
882- add GPG support (Enigmail 0.81.6)
883- specfile fixes (#679)
884
885* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
886- update to 0.2
887
888* Mon Sep 01 2003 David Hill <djh[at]ii.net>
889- initial RPM
890  (based on the fedora MozillaFirebird-0.6.1 specfile)
891
Note: See TracBrowser for help on using the repository browser.