source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 521

Revision 521, 20.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 2.0
3%define tbversion %{tbmajor}.0.23
4%define tbdir %{_libdir}/thunderbird-%{tbmajor}
5
6%define build_vineseed 0
7%define build_vine4 0
8%define build_vine3 0
9
10%if "%{?_dist_release}" == "vl5"
11%define build_vineseed 1
12%endif
13%if "%{?_dist_release}" == "vl4"
14%define build_vine4 1
15%endif
16%if "%{?_dist_release}" == "vl3"
17%define build_vine3 1
18%endif
19
20%define tbrelease 1%{?_dist_release}
21
22# Temporary until this works again
23ExcludeArch:    ppc64
24
25%define desktop_file_utils_version 0.6
26%define cairo_version 1.0
27%define nspr_version 4.6.7
28%define nss_version 3.11.5
29
30Summary:        Thunderbird Community Edition, Mail/newsgroup client
31Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
32Name:           thunderbird
33Version:        %{tbversion}
34Release:        %{tbrelease}
35URL:            http://www.mozilla.org/projects/thunderbird/
36License:        MPL
37Group:          Applications/Internet
38
39Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}-source.tar.bz2
40Source1010:     mozconfig-thunderbird-vine3
41Source1020:     mozconfig-thunderbird-vine4
42Source1030:     mozconfig-thunderbird-vine5
43Source12:       thunderbird-vine-default-prefs.js
44Source20:       thunderbird.desktop
45Source21:       thunderbird.vine.sh.in
46Source22:       thunderbird.png
47Source30:       thunderbird-open-browser.sh
48Source100:      find-external-requires
49
50# locale sources
51%define MOZ_BUILD_LOCALES "ja"
52Source1000:     thunderbird-2.0.0.0-ja.tar.bz2
53
54# upstream patch
55
56
57# build patches
58Patch1:         firefox-2.0-link-layout.patch
59
60# customization patches
61Patch22:        firefox-1.0-psfonts.patch
62Patch24:        thunderbird-2.0-default-applications.patch
63Patch25:        thunderbird-1.1-software-update.patch
64Patch26:        firefox-1.5-default-a4-paper.patch
65
66# font system fixes
67#Patch81:        firefox-nopangoxft.patch
68
69## Vine patch
70# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
71Patch1000:    firefox-1.5-sjisalias.patch
72
73# use /proc/net/netstat for random seed instead of netstat command.
74#Patch1010:      firefox-nss-no_netstat.patch
75
76# workaround gcc visibility hidden bugs (see gcc#26905)
77Patch1020:      firefox-2.0.0.3-visibility.patch
78
79BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
80%if !%{build_vine3}
81BuildRequires:  pango-devel
82BuildRequires:  cairo-devel >= %{cairo_version}
83%if !%{build_vine4}
84BuildRequires:  nspr-devel >= %{nspr_version}
85BuildRequires:  nss-devel >= %{nss_version}
86BuildRequires:  pixman-devel
87%endif
88%endif
89BuildRequires:  libpng-devel, libjpeg-devel, gtk2-devel
90BuildRequires:  zlib-devel, gzip, zip, unzip
91BuildRequires:  libIDL-devel
92BuildRequires:  tcsh
93BuildRequires:  freetype2-devel
94
95Prereq:         desktop-file-utils >= %{desktop_file_utils_version}
96%if %{build_vineseed}
97Requires:       nspr >= %{nspr_version}
98Requires:       nss >= %{nss_version}
99%endif
100Obsoletes:      MozillaThunderbird
101Provides:       MozillaThunderbird = %{version}
102
103Packager:       daisuke, ryoichi, kazutaka
104
105AutoProv: 0
106%define _use_internal_dependency_generator 0
107%define __find_requires %{SOURCE100}
108
109%description
110Thunderbird is a standalone mail and newsgroup client.
111
112%description -l ja
113Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
114
115#===============================================================================
116
117%prep
118%setup -q -n %{name}-%{version} -c -b 1000
119cd mozilla
120
121%patch1 -p1 -b .link-layout
122
123%patch22 -p1
124%patch24 -p1
125#%patch25 -p0
126%patch26 -p1
127#%if !%{build_vine3}
128#%patch81 -p1
129#%endif
130
131%patch1000 -p0
132#%patch1010 -p1
133#patch1020 -p1
134
135
136%{__rm} -f .mozconfig
137%if %{build_vine3}
138%{__cp} %{SOURCE1010} .mozconfig
139%endif
140%if %{build_vine4}
141%{__cp} %{SOURCE1020} .mozconfig
142%endif
143%if %{build_vineseed}
144%{__cp} %{SOURCE1030} .mozconfig
145%endif
146
147#===============================================================================
148
149%build
150cd mozilla
151autoconf-2.13
152
153#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
154MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
155export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
156export CFLAGS="$RPM_OPT_FLAGS"
157export CXXFLAGS="$CFLAGS"
158export BUILD_OFFICIAL=1
159export MOZILLA_OFFICIAL=1
160
161%ifarch ppc ppc64 s390 s390x
162%define moz_mflags -j1
163%else
164%define moz_mflags %{?_smp_mflags}
165%endif
166
167export LDFLAGS="-Wl,-rpath,%{ffdir}"
168export MAKE="gmake %{moz_mflags}"
169%__make -f client.mk build
170
171# build locales
172LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
173            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
174for dir in $LOCALEDIRS
175do
176  for lang in %{MOZ_BUILD_LOCALES} ; do
177    make -C $dir/locales AB_CD=$lang
178  done
179done
180
181#===============================================================================
182
183%install
184cd mozilla
185%{__rm} -rf $RPM_BUILD_ROOT
186
187cd xpinstall/packager/
188%{__make} STRIP=/bin/true
189cd -
190
191%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
192
193%{__tar} -C $RPM_BUILD_ROOT%{_libdir}/ -xzf dist/%{name}-*linux*.tar.gz
194%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name} $RPM_BUILD_ROOT%{tbdir}
195
196%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}-*linux*.tar
197
198%{__install} -p -D %{SOURCE22} $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png
199
200desktop-file-install --vendor vine \
201  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
202  --add-category Application \
203  --add-category Network \
204  %{SOURCE20}
205
206# set up the thunderbird start script
207%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{tbdir},g' > \
208  $RPM_BUILD_ROOT%{_bindir}/thunderbird
209%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
210
211install -m755 %{SOURCE30} $RPM_BUILD_ROOT/%{tbdir}/open-browser.sh
212perl -pi -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{tbdir}/open-browser.sh
213
214%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
215                                -e 's,COMMAND,%{tbdir}/open-browser.sh,g' > \
216        $RPM_BUILD_ROOT/vine-default-prefs
217%{__cp} $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{tbdir}/greprefs/all-vine.js
218%{__cp} $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{tbdir}/defaults/pref/all-vine.js
219%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
220
221# own mozilla plugin dir (#135050)
222%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
223
224%{__rm} -f $RPM_BUILD_ROOT%{tbdir}/thunderbird-config
225
226cd $RPM_BUILD_ROOT%{tbdir}/chrome
227find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf \{\} \;
228cd -
229
230# install locales
231for lang in %{MOZ_BUILD_LOCALES} ; do
232  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{tbdir}/chrome/
233done
234
235# install default icons
236# refer https://bugzilla.redhat.com/show_bug.cgi?id=177823
237%{__mkdir_p} $RPM_BUILD_ROOT%{tbdir}/chrome/icons/default
238install -m644 dist/thunderbird/chrome/icons/default/* \
239         $RPM_BUILD_ROOT%{tbdir}/chrome/icons/default/
240
241
242%clean
243%{__rm} -rf $RPM_BUILD_ROOT
244
245%post
246update-desktop-database %{_datadir}/applications >& /dev/null ||:
247
248%postun
249update-desktop-database %{_datadir}/applications >& /dev/null ||:
250
251
252%files
253%defattr(-,root,root,-)
254%attr(755,root,root) %{_bindir}/thunderbird
255%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
256%attr(644,root,root) %{_datadir}/pixmaps/thunderbird.png
257%{tbdir}
258
259#===============================================================================
260
261%changelog
262* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
263- new upstream release
264
265* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
266- new upstream release
267
268* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
269- don't install official branding logos
270
271* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
272- add necessary icons in %%{tbdir}/chrome/icons/default
273- add Packager tag
274
275* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
276- new upstream release
277
278* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
279- new upstream release
280
281* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
282- new upstream release
283
284* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
285- new upstream release
286
287* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
288- rebuilt for VineSeed
289
290* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
291- new upstream release
292
293* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
294- new upstream release
295- built for Vine Linux 4.x
296- dropped Patch1020 (merged into upstream)
297
298* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
299- added Patch1020 for workaround gcc visibility hidden bugs
300
301* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
302- build with new environment/toolchain
303- add build options to build with external nss/nspr libraries
304    ac_add_options --with-system-nspr
305    ac_add_options --with-system-nss
306
307* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
308- new upstream release
309
310* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
311- new upstream release
312
313* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
314- new upstream release
315
316* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
317- new upstream release
318
319* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
320- new upstream release
321- merge changes from firefox
322  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
323
324* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
325- new upstream release
326- build en-US locale
327- merge changes from firefox
328  - add upstream patches
329  - disable pango rendering by default
330    (workaround fix slow rendering in some page)
331
332* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
333- initial build for Vine Linux based on FC package
334- update to 1.5RC2
335
336* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
337- Fix issue with popup dialogs and other actions causing lockups
338
339* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
340- Update to 1.5 rc1
341
342* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
343- Update to 1.5 beta2
344
345* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
346- Update to 1.5 beta1
347- Bring the install phase of the spec file up to speed
348
349* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
350- Rebuild
351
352* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
353- Add patch to make file chooser dialog modal
354
355* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
356- Update to 1.0.6
357
358* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
359- 1.0.6 Release Candidate
360
361* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
362- Use system NSPR
363- Fix crash on 64bit platforms (#160330)
364
365* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
366- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
367  references, fixing the "no fonts" problem.
368
369* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
370- Change the Exec line in the desktop file to `thunderbird`
371
372* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
373- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
374
375* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
376- Add temporary workaround to not create files in the user's $HOME (#149664)
377
378* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
379- Don't have downloads "disappear" when downloading to desktop (#139015)
380- Fix for some more cursor issues in textareas (149991, 150002, 152089)
381- Add upstream patch to fix bidi justification of pango
382- Add patch to fix launching of helper applications
383- Add patch to properly link against libgfxshared_s.a
384- Fix multilib conflicts
385
386* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
387- correct confusing PANGO vars in startup script
388
389* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
390- Thunderbird 1.0.2
391
392* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
393- Add patch to compile against new fortified glibc macros
394
395* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
396- Rebuild against GCC 4.0
397- Add execshield patches
398- Minor specfile cleanup
399
400* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
401- Rebuild
402
403* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
404- Add RPM version to useragent
405
406* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
407- Port over pango patches from firefox
408
409* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
410- Thunderbird 1.0
411
412* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
413- Fix advanced prefs
414
415* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
416- Make this run on s390(x) now for real
417
418* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
419- Update to 1.0 rc1
420
421* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
422- Add patches to build and run on s390(x)
423
424* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
425- Rebuild to fix file chooser
426
427* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
428- Update to 0.9
429
430* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
431- Prevent inlining of stack direction detection (#135255)
432
433* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
434- More file chooser fixes (same as in firefox)
435- Fix for upstream 28327.
436
437* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
438- Update the pango patch
439
440* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
441- Pull over patches from firefox build:
442  - disable default application dialog
443  - don't include software update since it doesn't work
444  - make external app support work
445
446* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
447- Use pango for rendering
448
449* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
450- Fix for 64 bit crash at startup (b.m.o #256603)
451
452* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
453- Add patches to fix xremote (#135036)
454
455* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
456- Add patch to fix button focus issues (#133507)
457- Add patch for fix IMAP race issues (bmo #246439)
458
459* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
460- filter out library Provides: and internal Requires:
461
462* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
463- Backport the GTK+ File Chooser.
464- Add fix for JS math on x86_64 systems
465- Add pkgconfig patch
466
467* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
468- Update to 0.8.0
469- Remove enigmail
470- Update BuildRequires
471- Remove gcc34 and extension manager patches -- they are upstreamed.
472- Fix for gnome-vfs2 error at component registration
473
474* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
475- Build with --disable-xprint
476
477* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
478- remove all Xvfb-related hacks
479
480* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
481- actually apply psfonts
482- add mozilla gnome-uriloader patch to prevent build failure
483
484* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
485- rawhide import
486- apply NetBSD's freetype 2.1.8 patch
487- apply psfonts patch
488- remove BR on /usr/bin/ex, breaks beehive
489
490* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
491- oops, fix %%install
492
493* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
494- update to Thunderbird 0.7.3 and Enigmail 0.85.0
495- remove XUL.mfasl on startup, add Debian enigmail patches
496- add Xvfb hack for -install-global-extension
497
498* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
499- update to 0.7.2, just because it's there
500- update gcc-3.4 patch (Kaj Niemi)
501- add EM registration patch and remove instdir hack
502
503* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
504- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
505
506* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
507- update to 0.7.1
508- remove Enigmail
509
510* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
511- re-enable Enigmail 0.84.1
512- add gcc-3.4 patch (Kaj Niemi)
513- use official branding (with permission)
514
515* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
516- update to 0.7
517- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
518- specify libdir, change BR for apt (V. Skytt辰, #1617)
519
520* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
521- temporary workaround for enigmail skin "modern" bug
522
523* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
524- update to Enigmail 0.84.0
525- update launch script
526
527* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
528- installation directory now versioned
529- allow root to run the program (for installing extensions)
530- remove unnecessary %%pre and %%post
531- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
532
533* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
534- include Enigmail, re-add release notes
535- delete %{_libdir}/thunderbird in %%pre
536
537* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
538- update to Thunderbird 0.6
539
540* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
541- update to Thunderbird 0.6 RC1
542- add new icon, remove release notes
543
544* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
545- update to latest CVS, update mozconfig and %%build accordingly
546- update to Enigmail 0.83.6
547- remove x-remote and x86_64 patches
548- build with -Os
549
550* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
551- update x-remote patch
552- more startup script fixes
553
554* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
555- startup script fixes, and a minor cleanup
556
557* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
558- Minor cleanups
559
560* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
561- minor improvements to open-browser.sh and startup script
562- update to latest version of Blizzard's x-remote patch
563
564* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
565- update open-browser.sh, startup script, and BuildRequires
566
567* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
568- update open-browser script, modify BuildRequires (Warren)
569- add Blizzard's x-remote patch
570- initial attempt at x-remote-enabled startup script
571
572* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
573- refuse to run with excessive privileges
574
575* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
576- add Mozilla x86_64 patch (Oliver Sontag)
577- Enigmail source filenames now include the version
578- modify BuildRoot
579
580* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
581- use the updated official tarball
582
583* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
584- fix %%prep script
585
586* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
587- update Enigmail to 0.83.3
588- use official source tarball (after removing the CRLFs)
589- package renamed to thunderbird
590
591* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
592- update to 0.5
593- check for lockfile before launching
594
595* Fri Feb 06 2004 David Hill <djh[at]ii.net>
596- update to latest cvs
597- update to Enigmail 0.83.2
598
599* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
600- update to Enigmail 0.83.1
601- removed Mozilla/Firebird script patching
602
603* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
604- add startup notification to .desktop file
605
606* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
607- open-browser.sh release 3
608- patch broken /usr/bin/mozilla script during install
609- dir ownership
610- XXX: Source fails build on x86_64... fix later
611
612* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
613- update to Enigmail 0.82.5
614- add Warren's open-browser.sh (#1113)
615
616* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
617- use Thunderbird's mozilla-xremote-client to launch browser
618
619* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
620- update to 0.4
621- make hyperlinks work (with recent versions of Firebird/Mozilla)
622
623* Thu Dec 04 2003 David Hill <djh[at]ii.net>
624- update to 0.4rc2
625
626* Wed Dec 03 2003 David Hill <djh[at]ii.net>
627- update to 0.4rc1 and Enigmail 0.82.4
628
629* Thu Nov 27 2003 David Hill <djh[at]ii.net>
630- update to latest CVS and Enigmail 0.82.3
631
632* Sun Nov 16 2003 David Hill <djh[at]ii.net>
633- update to latest CVS (0.4a)
634- update Enigmail to 0.82.2
635- alter mozconfig for new build requirements
636- add missing BuildReq (#987)
637
638* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
639- update to 0.3
640
641* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
642- update to 0.3rc3
643- update Enigmail to 0.81.7
644
645* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
646- update to 0.3rc2
647
648* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
649- simplify startup script
650
651* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
652- add GPG support (Enigmail 0.81.6)
653- specfile fixes (#679)
654
655* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
656- update to 0.2
657
658* Mon Sep 01 2003 David Hill <djh[at]ii.net>
659- initial RPM
660  (based on the fedora MozillaFirebird-0.6.1 specfile)
661
Note: See TracBrowser for help on using the repository browser.