source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 5920

Revision 5920, 28.5 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 11.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30%define build_vine5 0
31
32%if "%{?_dist_release}" >= "vl7"
33%define build_vine7 1
34%endif
35%if "%{?_dist_release}" == "vl6"
36%define build_vine6 1
37%endif
38%if "%{?_dist_release}" == "vl5"
39%define build_vine5 1
40%endif
41
42
43Summary:        Thunderbird Community Edition, Mail/newsgroup client
44Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
45Name:           thunderbird
46Version:        %{tbversion}
47Release:        %{tbrelease}
48URL:            http://www.mozilla.org/projects/thunderbird/
49License:        MPL
50Group:          Applications/Internet
51
52Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
53Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
54Source1010:     mozconfig-thunderbird-vine5
55Source1020:     mozconfig-thunderbird-vine6
56Source1030:     mozconfig-thunderbird-vine7
57Source12:       thunderbird-vine-default-prefs.js
58Source20:       thunderbird.desktop
59Source21:       thunderbird.vine.sh.in
60Source30:       thunderbird-open-browser.sh
61Source40:       thunderbird-unofficial-brandig-tb-brand.properties
62Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
63Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
64Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
65Source100:      find-external-requires
66
67# locale sources
68#%define MOZ_BUILD_LOCALES "ja"
69# get from mercurial repository with command,
70# mkdir l10n
71# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
72#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
73
74
75# upstream patch
76
77# Fix for version issues
78Patch0:         thunderbird-version.patch
79
80# customization patches
81Patch1:         firefox-1.5-default-a4-paper.patch
82
83# Linux specific
84Patch100:       thunderbird-9.0-enable-addons.patch
85
86BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
87BuildRequires:  pango-devel
88BuildRequires:  cairo-devel >= %{cairo_version}
89%if %{build_vine7}
90BuildRequires:  nspr-devel >= %{nspr_version}
91BuildRequires:  nss-devel >= %{nss_version}
92BuildRequires:  hunspell-devel
93%endif
94%if %{build_vine6}
95BuildRequires:  hunspell-devel
96%endif
97BuildRequires:  pixman-devel
98BuildRequires:  libpng-devel
99%if %{build_vine5}
100BuildRequires:  libjpeg-devel
101%else
102BuildRequires:  libjpeg-turbo-devel
103%endif
104BuildRequires:  gtk2-devel
105BuildRequires:  zlib-devel, gzip, zip, unzip
106BuildRequires:  libIDL-devel
107BuildRequires:  freetype2-devel >= %{freetype_version}
108## disabled libnotify support
109## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
110BuildRequires:  libnotify-devel >= %{libnotify_version}
111BuildRequires:  bzip2-devel
112BuildRequires:  gnome-vfs2-devel
113BuildRequires:  libgnome-devel
114BuildRequires:  libgnomeui-devel
115BuildRequires:  krb5-devel
116BuildRequires:  pango-devel
117BuildRequires:  libXt-devel
118BuildRequires:  libXrender-devel
119# hunspell is in plus category for vine
120#BuildRequires: hunspell-devel
121BuildRequires:  sqlite3-devel >= %{sqlite_version}
122BuildRequires:  startup-notification-devel
123BuildRequires:  desktop-file-utils
124BuildRequires:  alsa-lib-devel
125BuildRequires:  yasm
126Requires:       sqlite3 >= %{sqlite_version}
127Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
128Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
129
130Obsoletes:      MozillaThunderbird
131Provides:       MozillaThunderbird = %{version}
132
133Vendor:         Project Vine
134Distribution:   Vine Linux
135Packager:       daisuke, ryoichi, kazutaka
136
137AutoProv: 0
138%define _use_internal_dependency_generator 0
139%define __find_requires %{SOURCE100}
140
141%description
142Thunderbird is a standalone mail and newsgroup client.
143
144%description -l ja
145Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
146
147#===============================================================================
148
149%prep
150%setup -q %{name}-%{version} -c
151cd %{tarballdir}
152
153# Fix for version issue
154sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
155    > version.patch
156%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
157
158cd mozilla
159%patch1 -p1 -b .default-a4
160
161cd -
162%{__rm} -f .mozconfig
163%if %{build_vine5}
164%{__cp} %{SOURCE1010} .mozconfig
165%endif
166%if %{build_vine6}
167%{__cp} %{SOURCE1020} .mozconfig
168%endif
169%if %{build_vine7}
170%{__cp} %{SOURCE1030} .mozconfig
171%endif
172
173# setup unofficial branding name
174%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
175%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
176
177%patch100 -p1 -b .addons
178
179#===============================================================================
180
181%build
182cd %{tarballdir}
183
184INTERNAL_GECKO=%{version_internal}
185MOZ_APP_DIR=%{mozappdir}
186
187
188%if %{build_vine7}
189MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
190%else
191%ifarch x86_64
192#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
193MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
194%else
195MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
196%endif
197%endif
198export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
199export CFLAGS="$RPM_OPT_FLAGS"
200#export CFLAGS=""
201export CXXFLAGS="$CFLAGS"
202export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
203
204%ifarch ppc ppc64 s390 s390x
205%define moz_make_flags -j1
206%else
207%define moz_make_flags %{?_smp_mflags}
208%endif
209
210export PREFIX='%{_prefix}'
211export LIBDIR='%{_libdir}'
212
213export LDFLAGS="-Wl,-rpath,%{mozappdir}"
214export MAKE="gmake %{moz_make_flags}"
215%{__make} -f client.mk build
216
217## build locales
218#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
219#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
220#for dir in $LOCALEDIRS
221#do
222#  for lang in %{MOZ_BUILD_LOCALES} ; do
223#    make -C $dir/locales AB_CD=$lang
224#  done
225#done
226
227#===============================================================================
228
229%install
230%{__rm} -rf $RPM_BUILD_ROOT
231cd %{tarballdir}
232
233INTERNAL_GECKO=%{version_internal}
234
235INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
236MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
237
238cd %{moz_objdir}
239DESTDIR=$RPM_BUILD_ROOT make install
240
241# install unofficial icons
242cd -
243
244%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
245%{__cp} mail/branding/aurora/mailicon16.png \
246        $RPM_BUILD_ROOT/%{mozappdir}/icons/
247%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
248%{__cp} mail/branding/aurora/mailicon16.png \
249        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
250%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
251%{__cp} mail/branding/aurora/mailicon22.png \
252        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
253%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
254%{__cp} mail/branding/aurora/mailicon24.png \
255        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
256%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
257%{__cp} mail/branding/aurora/mailicon32.png \
258        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
259%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
260%{__cp} mail/branding/aurora/mailicon48.png \
261        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
262%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
263%{__cp} mail/branding/aurora/mailicon256.png \
264        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
265
266desktop-file-install --vendor vine \
267  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
268
269# set up the thunderbird start script
270rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
271%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
272  $RPM_BUILD_ROOT%{_bindir}/thunderbird
273%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
274
275install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
276%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
277
278%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
279                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
280        $RPM_BUILD_ROOT/vine-default-prefs
281%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
282%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
283%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
284
285%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
286
287# own mozilla plugin dir (#135050)
288%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
289
290# own extension directories
291%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
292%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
293
294# install locales
295#for lang in %{MOZ_BUILD_LOCALES} ; do
296#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
297#done
298
299# install ja.xpi to langpacks directory
300#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
301#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
302# also setup unofficial branding name
303#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
304#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
305
306# install ja.xpi to langpack file
307%{__mkdir_p} lang_tmp
308unzip %{SOURCE1} -d lang_tmp
309# also setup unofficial branding name
310%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
311%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
312
313%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
314cd lang_tmp; \
315zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
316
317
318%clean
319%{__rm} -rf $RPM_BUILD_ROOT
320
321#===============================================================================
322
323%post
324update-desktop-database &> /dev/null || :
325touch --no-create %{_datadir}/icons/hicolor
326if [ -x %{_bindir}/gtk-update-icon-cache ]; then
327  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
328fi
329
330%postun
331update-desktop-database &> /dev/null || :
332touch --no-create %{_datadir}/icons/hicolor
333if [ -x %{_bindir}/gtk-update-icon-cache ]; then
334  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
335fi
336
337
338%files
339%defattr(-,root,root,-)
340%attr(755,root,root) %{_bindir}/thunderbird
341%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
342%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
343%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
344%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
345%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
346%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
347%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
348%{mozappdir}
349#%{_libdir}/mozilla
350%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
351%exclude %{_datadir}/idl/%{name}-%{version_internal}
352%exclude %{_includedir}/%{name}-%{version_internal}
353%exclude %{_libdir}/%{name}-devel-%{version_internal}
354
355#===============================================================================
356
357%changelog
358* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
359- new upstream release
360- update Source1020 (mozconfig-thunderbird-vine6)
361
362* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
363- new upstream release
364
365* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
366- new upstream release
367
368* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
369- new upstream release
370
371* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
372- new upstream release
373- update Source1
374
375* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
376- new upstream release
377- update Source1
378- add Source1030 (mozconfig-thunderbird-vine7)
379- add Patch100 (thunderbird-9.0-enable-addons.patch)
380
381* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
382- fix %%version_internal
383
384* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
385- new upstream release
386- update Source1
387
388* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
389- new upstream release
390- update Source1,21,1010,1020
391
392* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
393- rebuild with libnotify-0.7
394
395* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
396- enable-install-strip
397
398* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
399- new upstream release
400- drop obsolete patch and renumber patch26 to patch1
401- add BuildRequires: yasm
402- enable libnotify support
403- add --disable-updater and --disable-installer to mozconfig
404- use ja.xpi instead of l10n source
405- update Source21: add step to setup langpack plugin
406- update Source20: add japanese translation
407- add Source42 & Source43 for localized branding
408- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
409  for mozconfig-thunderbird-vine5
410
411* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
412- new upstream release with security fix
413
414* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
415- new upstream release with security fix
416
417* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
418- new upstream release with security fix
419
420* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
421- new upstream release with security fix
422- add patch5 to fix build failure
423
424* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
425- new upstream release
426
427* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
428- new upstream release with security fix
429- add Patch1030 to fix compilation error
430
431* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
432- change mozconfig (Source1030 & 1040): add --enable-jsd
433
434* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
435- new upstream release
436
437* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
438- new upstream release with security fix
439- add Patch0 from fedora development: fix version issue
440- remove BuildRequires: hunspell-devel
441- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
442
443* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
444- add BuildRequires: alsa-lib-devel
445- remove BuildRequires: libnotify-devel
446  (workaround for known bug)
447- update mozconfig to add --disable-libnotify option
448
449* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
450- new upstream release
451- update spec entirely
452- import patches from fedora (Patch1, 2 & 4)
453- drop outdated patches (Patch22, 24)
454- update Sources:
455  - mozconfig (Source1030 & Source1040)
456  - default prefs.js (Source12)
457  - unofficial branding (Source40 & Source41)
458  - japanese translation (Source1000)
459- update Patch1000 (sjis-alias)
460
461* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
462- new upstream release
463
464* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
465- new upstream release
466
467* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
468- don't install official branding logos
469
470* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
471- add necessary icons in %%{tbdir}/chrome/icons/default
472- add Packager tag
473
474* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
475- new upstream release
476
477* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
478- new upstream release
479
480* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
481- new upstream release
482
483* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
484- new upstream release
485
486* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
487- rebuilt for VineSeed
488
489* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
490- new upstream release
491
492* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
493- new upstream release
494- built for Vine Linux 4.x
495- dropped Patch1020 (merged into upstream)
496
497* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
498- added Patch1020 for workaround gcc visibility hidden bugs
499
500* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
501- build with new environment/toolchain
502- add build options to build with external nss/nspr libraries
503    ac_add_options --with-system-nspr
504    ac_add_options --with-system-nss
505
506* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
507- new upstream release
508
509* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
510- new upstream release
511
512* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
513- new upstream release
514
515* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
516- new upstream release
517
518* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
519- new upstream release
520- merge changes from firefox
521  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
522
523* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
524- new upstream release
525- build en-US locale
526- merge changes from firefox
527  - add upstream patches
528  - disable pango rendering by default
529    (workaround fix slow rendering in some page)
530
531* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
532- initial build for Vine Linux based on FC package
533- update to 1.5RC2
534
535* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
536- Fix issue with popup dialogs and other actions causing lockups
537
538* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
539- Update to 1.5 rc1
540
541* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
542- Update to 1.5 beta2
543
544* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
545- Update to 1.5 beta1
546- Bring the install phase of the spec file up to speed
547
548* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
549- Rebuild
550
551* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
552- Add patch to make file chooser dialog modal
553
554* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
555- Update to 1.0.6
556
557* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
558- 1.0.6 Release Candidate
559
560* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
561- Use system NSPR
562- Fix crash on 64bit platforms (#160330)
563
564* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
565- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
566  references, fixing the "no fonts" problem.
567
568* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
569- Change the Exec line in the desktop file to `thunderbird`
570
571* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
572- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
573
574* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
575- Add temporary workaround to not create files in the user's $HOME (#149664)
576
577* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
578- Don't have downloads "disappear" when downloading to desktop (#139015)
579- Fix for some more cursor issues in textareas (149991, 150002, 152089)
580- Add upstream patch to fix bidi justification of pango
581- Add patch to fix launching of helper applications
582- Add patch to properly link against libgfxshared_s.a
583- Fix multilib conflicts
584
585* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
586- correct confusing PANGO vars in startup script
587
588* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
589- Thunderbird 1.0.2
590
591* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
592- Add patch to compile against new fortified glibc macros
593
594* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
595- Rebuild against GCC 4.0
596- Add execshield patches
597- Minor specfile cleanup
598
599* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
600- Rebuild
601
602* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
603- Add RPM version to useragent
604
605* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
606- Port over pango patches from firefox
607
608* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
609- Thunderbird 1.0
610
611* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
612- Fix advanced prefs
613
614* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
615- Make this run on s390(x) now for real
616
617* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
618- Update to 1.0 rc1
619
620* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
621- Add patches to build and run on s390(x)
622
623* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
624- Rebuild to fix file chooser
625
626* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
627- Update to 0.9
628
629* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
630- Prevent inlining of stack direction detection (#135255)
631
632* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
633- More file chooser fixes (same as in firefox)
634- Fix for upstream 28327.
635
636* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
637- Update the pango patch
638
639* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
640- Pull over patches from firefox build:
641  - disable default application dialog
642  - don't include software update since it doesn't work
643  - make external app support work
644
645* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
646- Use pango for rendering
647
648* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
649- Fix for 64 bit crash at startup (b.m.o #256603)
650
651* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
652- Add patches to fix xremote (#135036)
653
654* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
655- Add patch to fix button focus issues (#133507)
656- Add patch for fix IMAP race issues (bmo #246439)
657
658* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
659- filter out library Provides: and internal Requires:
660
661* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
662- Backport the GTK+ File Chooser.
663- Add fix for JS math on x86_64 systems
664- Add pkgconfig patch
665
666* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
667- Update to 0.8.0
668- Remove enigmail
669- Update BuildRequires
670- Remove gcc34 and extension manager patches -- they are upstreamed.
671- Fix for gnome-vfs2 error at component registration
672
673* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
674- Build with --disable-xprint
675
676* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
677- remove all Xvfb-related hacks
678
679* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
680- actually apply psfonts
681- add mozilla gnome-uriloader patch to prevent build failure
682
683* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
684- rawhide import
685- apply NetBSD's freetype 2.1.8 patch
686- apply psfonts patch
687- remove BR on /usr/bin/ex, breaks beehive
688
689* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
690- oops, fix %%install
691
692* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
693- update to Thunderbird 0.7.3 and Enigmail 0.85.0
694- remove XUL.mfasl on startup, add Debian enigmail patches
695- add Xvfb hack for -install-global-extension
696
697* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
698- update to 0.7.2, just because it's there
699- update gcc-3.4 patch (Kaj Niemi)
700- add EM registration patch and remove instdir hack
701
702* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
703- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
704
705* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
706- update to 0.7.1
707- remove Enigmail
708
709* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
710- re-enable Enigmail 0.84.1
711- add gcc-3.4 patch (Kaj Niemi)
712- use official branding (with permission)
713
714* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
715- update to 0.7
716- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
717- specify libdir, change BR for apt (V. Skytt辰, #1617)
718
719* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
720- temporary workaround for enigmail skin "modern" bug
721
722* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
723- update to Enigmail 0.84.0
724- update launch script
725
726* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
727- installation directory now versioned
728- allow root to run the program (for installing extensions)
729- remove unnecessary %%pre and %%post
730- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
731
732* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
733- include Enigmail, re-add release notes
734- delete %{_libdir}/thunderbird in %%pre
735
736* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
737- update to Thunderbird 0.6
738
739* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
740- update to Thunderbird 0.6 RC1
741- add new icon, remove release notes
742
743* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
744- update to latest CVS, update mozconfig and %%build accordingly
745- update to Enigmail 0.83.6
746- remove x-remote and x86_64 patches
747- build with -Os
748
749* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
750- update x-remote patch
751- more startup script fixes
752
753* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
754- startup script fixes, and a minor cleanup
755
756* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
757- Minor cleanups
758
759* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
760- minor improvements to open-browser.sh and startup script
761- update to latest version of Blizzard's x-remote patch
762
763* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
764- update open-browser.sh, startup script, and BuildRequires
765
766* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
767- update open-browser script, modify BuildRequires (Warren)
768- add Blizzard's x-remote patch
769- initial attempt at x-remote-enabled startup script
770
771* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
772- refuse to run with excessive privileges
773
774* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
775- add Mozilla x86_64 patch (Oliver Sontag)
776- Enigmail source filenames now include the version
777- modify BuildRoot
778
779* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
780- use the updated official tarball
781
782* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
783- fix %%prep script
784
785* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
786- update Enigmail to 0.83.3
787- use official source tarball (after removing the CRLFs)
788- package renamed to thunderbird
789
790* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
791- update to 0.5
792- check for lockfile before launching
793
794* Fri Feb 06 2004 David Hill <djh[at]ii.net>
795- update to latest cvs
796- update to Enigmail 0.83.2
797
798* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
799- update to Enigmail 0.83.1
800- removed Mozilla/Firebird script patching
801
802* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
803- add startup notification to .desktop file
804
805* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
806- open-browser.sh release 3
807- patch broken /usr/bin/mozilla script during install
808- dir ownership
809- XXX: Source fails build on x86_64... fix later
810
811* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
812- update to Enigmail 0.82.5
813- add Warren's open-browser.sh (#1113)
814
815* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
816- use Thunderbird's mozilla-xremote-client to launch browser
817
818* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
819- update to 0.4
820- make hyperlinks work (with recent versions of Firebird/Mozilla)
821
822* Thu Dec 04 2003 David Hill <djh[at]ii.net>
823- update to 0.4rc2
824
825* Wed Dec 03 2003 David Hill <djh[at]ii.net>
826- update to 0.4rc1 and Enigmail 0.82.4
827
828* Thu Nov 27 2003 David Hill <djh[at]ii.net>
829- update to latest CVS and Enigmail 0.82.3
830
831* Sun Nov 16 2003 David Hill <djh[at]ii.net>
832- update to latest CVS (0.4a)
833- update Enigmail to 0.82.2
834- alter mozconfig for new build requirements
835- add missing BuildReq (#987)
836
837* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
838- update to 0.3
839
840* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
841- update to 0.3rc3
842- update Enigmail to 0.81.7
843
844* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
845- update to 0.3rc2
846
847* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
848- simplify startup script
849
850* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
851- add GPG support (Enigmail 0.81.6)
852- specfile fixes (#679)
853
854* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
855- update to 0.2
856
857* Mon Sep 01 2003 David Hill <djh[at]ii.net>
858- initial RPM
859  (based on the fedora MozillaFirebird-0.6.1 specfile)
860
Note: See TracBrowser for help on using the repository browser.