source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 1520

Revision 1520, 25.4 KB checked in by kazutaka, 14 years ago (diff)

update mozconfig to add --enable-jsd option

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 3.1
3%define tbversion %{tbmajor}.2
4%define tbrelease 2%{?_dist_release}
5
6# The tarball is pretty inconsistent with directory structure.
7# Sometimes there is a top level directory.  That goes here.
8#
9# IMPORTANT: If there is no top level directory, this should be
10# set to the cwd, ie: '.'
11#%define tarballdir .
12%define tarballdir comm-1.9.2
13
14%define mozappdir %{_libdir}/%{name}-%{version_internal}
15%define moz_objdir objdir-tb
16%define version_internal 3.1
17%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
18
19%define desktop_file_utils_version 0.6
20%define nspr_version 4.8
21%define nss_version 3.12.6
22%define cairo_version 1.6.0
23%define freetype_version 2.1.9
24%define sqlite_version 3.6.14
25%define libnotify_version 0.4
26
27%define build_vineseed 0
28%define build_vine5 0
29
30%if "%{?_dist_release}" == "vl6"
31%define build_vineseed 1
32%endif
33%if "%{?_dist_release}" == "vl5"
34%define build_vine5 1
35%endif
36
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48#Source1010:    mozconfig-thunderbird-vine3
49#Source1020:    mozconfig-thunderbird-vine4
50Source1030:     mozconfig-thunderbird-vine5
51Source1040:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55#Source22:      thunderbird.png
56Source30:       thunderbird-open-browser.sh
57Source40:       thunderbird-unofficial-brandig-tb-brand.properties
58Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73# Fix for jemalloc
74Patch1:         mozilla-jemalloc.patch
75# Fix for installation fail when building with dynamic linked libraries
76Patch2:         thunderbird-shared-error.patch
77# Fixes gcc complain that nsFrame::delete is protected
78Patch4:         xulrunner-1.9.2.1-build.patch
79
80# customization patches
81#Patch22:        firefox-1.0-psfonts.patch
82#Patch24:        thunderbird-2.0-default-applications.patch
83#Patch25:        thunderbird-1.1-software-update.patch
84Patch26:        firefox-1.5-default-a4-paper.patch
85
86# font system fixes
87#Patch81:        firefox-nopangoxft.patch
88
89## Vine patch
90# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
91Patch1000:      thunderbird-3.1-sjisalias.patch
92
93# use /proc/net/netstat for random seed instead of netstat command.
94#Patch1010:      firefox-nss-no_netstat.patch
95
96# workaround gcc visibility hidden bugs (see gcc#26905)
97Patch1020:      firefox-2.0.0.3-visibility.patch
98
99BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
100BuildRequires:  pango-devel
101BuildRequires:  cairo-devel >= %{cairo_version}
102%if %{build_vineseed}
103BuildRequires:  nspr-devel >= %{nspr_version}
104BuildRequires:  nss-devel >= %{nss_version}
105%endif
106BuildRequires:  pixman-devel
107BuildRequires:  libpng-devel
108BuildRequires:  libjpeg-devel
109BuildRequires:  gtk2-devel
110BuildRequires:  zlib-devel, gzip, zip, unzip
111BuildRequires:  libIDL-devel
112BuildRequires:  freetype2-devel >= %{freetype_version}
113## disabled libnotify support
114## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
115#BuildRequires:  libnotify-devel >= %{libnotify_version}
116BuildRequires:  bzip2-devel
117BuildRequires:  gnome-vfs2-devel
118BuildRequires:  libgnome-devel
119BuildRequires:  libgnomeui-devel
120BuildRequires:  krb5-devel
121BuildRequires:  pango-devel
122BuildRequires:  libXt-devel
123BuildRequires:  libXrender-devel
124# hunspell is in plus category for vine
125#BuildRequires: hunspell-devel
126BuildRequires:  sqlite3-devel >= %{sqlite_version}
127BuildRequires:  startup-notification-devel
128BuildRequires:  desktop-file-utils
129BuildRequires:  alsa-lib-devel
130Requires:       sqlite3 >= %{sqlite_version}
131Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
132Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
133
134Obsoletes:      MozillaThunderbird
135Provides:       MozillaThunderbird = %{version}
136
137Packager:       daisuke, ryoichi, kazutaka
138
139AutoProv: 0
140%define _use_internal_dependency_generator 0
141%define __find_requires %{SOURCE100}
142
143%description
144Thunderbird is a standalone mail and newsgroup client.
145
146%description -l ja
147Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
148
149#===============================================================================
150
151%prep
152%setup -q %{name}-%{version} -c -b 1000
153cd %{tarballdir}
154
155# Fix for version issue
156sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
157    > version.patch
158%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
159
160%patch1 -p0 -b .jemalloc
161%patch2 -p1 -b .shared-error
162%patch4 -p1 -b .protected
163
164cd mozilla
165
166#%patch22 -p1
167#%patch24 -p1
168#%patch25 -p0
169%patch26 -p1 -b .default-a4
170%patch1000 -p1 -b .sjis-alias
171
172cd -
173%{__rm} -f .mozconfig
174%if %{build_vine5}
175%{__cp} %{SOURCE1030} .mozconfig
176%endif
177%if %{build_vineseed}
178%{__cp} %{SOURCE1040} .mozconfig
179# cannot build with xulrunner (yet)
180# see tracking bugs.
181#   https://bugzilla.mozilla.org/show_bug.cgi?id=306324
182#   https://bugzilla.mozilla.org/show_bug.cgi?id=377319
183#echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
184%endif
185
186# setup unofficial branding name
187%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
188%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
189
190#===============================================================================
191
192%build
193cd %{tarballdir}
194
195INTERNAL_GECKO=%{version_internal}
196MOZ_APP_DIR=%{mozappdir}
197
198
199#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
200MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
201export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
202export CFLAGS="$RPM_OPT_FLAGS"
203export CXXFLAGS="$CFLAGS"
204export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
205
206%ifarch ppc ppc64 s390 s390x
207%define moz_make_flags -j1
208%else
209%define moz_make_flags %{?_smp_mflags}
210%endif
211
212export PREFIX='%{_prefix}'
213export LIBDIR='%{_libdir}'
214
215export LDFLAGS="-Wl,-rpath,%{mozappdir}"
216export MAKE="gmake %{moz_make_flags}"
217%{__make} -f client.mk build
218
219# build locales
220LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
221            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
222for dir in $LOCALEDIRS
223do
224  for lang in %{MOZ_BUILD_LOCALES} ; do
225    make -C $dir/locales AB_CD=$lang
226  done
227done
228
229#===============================================================================
230
231%install
232%{__rm} -rf $RPM_BUILD_ROOT
233cd %{tarballdir}
234
235INTERNAL_GECKO=%{version_internal}
236
237INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
238MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
239
240cd %{moz_objdir}
241DESTDIR=$RPM_BUILD_ROOT make install
242
243# install unofficial icons
244cd -
245%{__cp} mail/branding/unofficial/mailicon16.png \
246        $RPM_BUILD_ROOT/%{mozappdir}/icons/
247%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
248%{__cp} mail/branding/unofficial/mailicon16.png \
249        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
250%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
251%{__cp} mail/branding/unofficial/mailicon22.png \
252        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
253%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
254%{__cp} mail/branding/unofficial//mailicon24.png \
255        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
256%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
257%{__cp} mail/branding/unofficial/mailicon32.png \
258        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
259%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
260%{__cp} mail/branding/unofficial/mailicon48.png \
261        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
262%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
263%{__cp} mail/branding/unofficial/mailicon256.png \
264        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
265
266desktop-file-install --vendor vine \
267  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
268  --add-category Application \
269  --add-category Network \
270  %{SOURCE20}
271
272# set up the thunderbird start script
273rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
274%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
275  $RPM_BUILD_ROOT%{_bindir}/thunderbird
276%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
277
278install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
279%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
280
281%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
282                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
283        $RPM_BUILD_ROOT/vine-default-prefs
284%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
285%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
286%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
287
288%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
289
290# own mozilla plugin dir (#135050)
291%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
292
293# own extension directories
294%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
295%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
296
297# install locales
298for lang in %{MOZ_BUILD_LOCALES} ; do
299  %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
300done
301
302
303%clean
304%{__rm} -rf $RPM_BUILD_ROOT
305
306#===============================================================================
307
308%post
309update-desktop-database &> /dev/null || :
310touch --no-create %{_datadir}/icons/hicolor
311if [ -x %{_bindir}/gtk-update-icon-cache ]; then
312  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
313fi
314
315%postun
316update-desktop-database &> /dev/null || :
317touch --no-create %{_datadir}/icons/hicolor
318if [ -x %{_bindir}/gtk-update-icon-cache ]; then
319  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
320fi
321
322
323%files
324%defattr(-,root,root,-)
325%attr(755,root,root) %{_bindir}/thunderbird
326%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
327%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
328%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
329%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
330%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
331%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
332%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
333%{mozappdir}
334
335#===============================================================================
336
337%changelog
338* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
339- change mozconfig (Source1030 & 1040): add --enable-jsd
340
341* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
342- new upstream release
343
344* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
345- new upstream release with security fix
346- add Patch0 from fedora development: fix version issue
347- remove BuildRequires: hunspell-devel
348- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
349
350* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
351- add BuildRequires: alsa-lib-devel
352- remove BuildRequires: libnotify-devel
353  (workaround for known bug)
354- update mozconfig to add --disable-libnotify option
355
356* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
357- new upstream release
358- update spec entirely
359- import patches from fedora (Patch1, 2 & 4)
360- drop outdated patches (Patch22, 24)
361- update Sources:
362  - mozconfig (Source1030 & Source1040)
363  - default prefs.js (Source12)
364  - unofficial branding (Source40 & Source41)
365  - japanese translation (Source1000)
366- update Patch1000 (sjis-alias)
367
368* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
369- new upstream release
370
371* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
372- new upstream release
373
374* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
375- don't install official branding logos
376
377* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
378- add necessary icons in %%{tbdir}/chrome/icons/default
379- add Packager tag
380
381* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
382- new upstream release
383
384* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
385- new upstream release
386
387* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
388- new upstream release
389
390* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
391- new upstream release
392
393* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
394- rebuilt for VineSeed
395
396* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
397- new upstream release
398
399* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
400- new upstream release
401- built for Vine Linux 4.x
402- dropped Patch1020 (merged into upstream)
403
404* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
405- added Patch1020 for workaround gcc visibility hidden bugs
406
407* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
408- build with new environment/toolchain
409- add build options to build with external nss/nspr libraries
410    ac_add_options --with-system-nspr
411    ac_add_options --with-system-nss
412
413* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
414- new upstream release
415
416* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
417- new upstream release
418
419* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
420- new upstream release
421
422* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
423- new upstream release
424
425* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
426- new upstream release
427- merge changes from firefox
428  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
429
430* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
431- new upstream release
432- build en-US locale
433- merge changes from firefox
434  - add upstream patches
435  - disable pango rendering by default
436    (workaround fix slow rendering in some page)
437
438* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
439- initial build for Vine Linux based on FC package
440- update to 1.5RC2
441
442* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
443- Fix issue with popup dialogs and other actions causing lockups
444
445* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
446- Update to 1.5 rc1
447
448* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
449- Update to 1.5 beta2
450
451* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
452- Update to 1.5 beta1
453- Bring the install phase of the spec file up to speed
454
455* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
456- Rebuild
457
458* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
459- Add patch to make file chooser dialog modal
460
461* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
462- Update to 1.0.6
463
464* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
465- 1.0.6 Release Candidate
466
467* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
468- Use system NSPR
469- Fix crash on 64bit platforms (#160330)
470
471* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
472- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
473  references, fixing the "no fonts" problem.
474
475* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
476- Change the Exec line in the desktop file to `thunderbird`
477
478* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
479- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
480
481* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
482- Add temporary workaround to not create files in the user's $HOME (#149664)
483
484* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
485- Don't have downloads "disappear" when downloading to desktop (#139015)
486- Fix for some more cursor issues in textareas (149991, 150002, 152089)
487- Add upstream patch to fix bidi justification of pango
488- Add patch to fix launching of helper applications
489- Add patch to properly link against libgfxshared_s.a
490- Fix multilib conflicts
491
492* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
493- correct confusing PANGO vars in startup script
494
495* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
496- Thunderbird 1.0.2
497
498* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
499- Add patch to compile against new fortified glibc macros
500
501* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
502- Rebuild against GCC 4.0
503- Add execshield patches
504- Minor specfile cleanup
505
506* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
507- Rebuild
508
509* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
510- Add RPM version to useragent
511
512* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
513- Port over pango patches from firefox
514
515* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
516- Thunderbird 1.0
517
518* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
519- Fix advanced prefs
520
521* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
522- Make this run on s390(x) now for real
523
524* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
525- Update to 1.0 rc1
526
527* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
528- Add patches to build and run on s390(x)
529
530* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
531- Rebuild to fix file chooser
532
533* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
534- Update to 0.9
535
536* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
537- Prevent inlining of stack direction detection (#135255)
538
539* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
540- More file chooser fixes (same as in firefox)
541- Fix for upstream 28327.
542
543* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
544- Update the pango patch
545
546* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
547- Pull over patches from firefox build:
548  - disable default application dialog
549  - don't include software update since it doesn't work
550  - make external app support work
551
552* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
553- Use pango for rendering
554
555* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
556- Fix for 64 bit crash at startup (b.m.o #256603)
557
558* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
559- Add patches to fix xremote (#135036)
560
561* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
562- Add patch to fix button focus issues (#133507)
563- Add patch for fix IMAP race issues (bmo #246439)
564
565* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
566- filter out library Provides: and internal Requires:
567
568* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
569- Backport the GTK+ File Chooser.
570- Add fix for JS math on x86_64 systems
571- Add pkgconfig patch
572
573* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
574- Update to 0.8.0
575- Remove enigmail
576- Update BuildRequires
577- Remove gcc34 and extension manager patches -- they are upstreamed.
578- Fix for gnome-vfs2 error at component registration
579
580* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
581- Build with --disable-xprint
582
583* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
584- remove all Xvfb-related hacks
585
586* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
587- actually apply psfonts
588- add mozilla gnome-uriloader patch to prevent build failure
589
590* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
591- rawhide import
592- apply NetBSD's freetype 2.1.8 patch
593- apply psfonts patch
594- remove BR on /usr/bin/ex, breaks beehive
595
596* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
597- oops, fix %%install
598
599* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
600- update to Thunderbird 0.7.3 and Enigmail 0.85.0
601- remove XUL.mfasl on startup, add Debian enigmail patches
602- add Xvfb hack for -install-global-extension
603
604* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
605- update to 0.7.2, just because it's there
606- update gcc-3.4 patch (Kaj Niemi)
607- add EM registration patch and remove instdir hack
608
609* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
610- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
611
612* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
613- update to 0.7.1
614- remove Enigmail
615
616* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
617- re-enable Enigmail 0.84.1
618- add gcc-3.4 patch (Kaj Niemi)
619- use official branding (with permission)
620
621* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
622- update to 0.7
623- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
624- specify libdir, change BR for apt (V. Skytt辰, #1617)
625
626* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
627- temporary workaround for enigmail skin "modern" bug
628
629* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
630- update to Enigmail 0.84.0
631- update launch script
632
633* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
634- installation directory now versioned
635- allow root to run the program (for installing extensions)
636- remove unnecessary %%pre and %%post
637- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
638
639* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
640- include Enigmail, re-add release notes
641- delete %{_libdir}/thunderbird in %%pre
642
643* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
644- update to Thunderbird 0.6
645
646* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
647- update to Thunderbird 0.6 RC1
648- add new icon, remove release notes
649
650* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
651- update to latest CVS, update mozconfig and %%build accordingly
652- update to Enigmail 0.83.6
653- remove x-remote and x86_64 patches
654- build with -Os
655
656* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
657- update x-remote patch
658- more startup script fixes
659
660* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
661- startup script fixes, and a minor cleanup
662
663* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
664- Minor cleanups
665
666* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
667- minor improvements to open-browser.sh and startup script
668- update to latest version of Blizzard's x-remote patch
669
670* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
671- update open-browser.sh, startup script, and BuildRequires
672
673* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
674- update open-browser script, modify BuildRequires (Warren)
675- add Blizzard's x-remote patch
676- initial attempt at x-remote-enabled startup script
677
678* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
679- refuse to run with excessive privileges
680
681* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
682- add Mozilla x86_64 patch (Oliver Sontag)
683- Enigmail source filenames now include the version
684- modify BuildRoot
685
686* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
687- use the updated official tarball
688
689* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
690- fix %%prep script
691
692* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
693- update Enigmail to 0.83.3
694- use official source tarball (after removing the CRLFs)
695- package renamed to thunderbird
696
697* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
698- update to 0.5
699- check for lockfile before launching
700
701* Fri Feb 06 2004 David Hill <djh[at]ii.net>
702- update to latest cvs
703- update to Enigmail 0.83.2
704
705* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
706- update to Enigmail 0.83.1
707- removed Mozilla/Firebird script patching
708
709* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
710- add startup notification to .desktop file
711
712* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
713- open-browser.sh release 3
714- patch broken /usr/bin/mozilla script during install
715- dir ownership
716- XXX: Source fails build on x86_64... fix later
717
718* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
719- update to Enigmail 0.82.5
720- add Warren's open-browser.sh (#1113)
721
722* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
723- use Thunderbird's mozilla-xremote-client to launch browser
724
725* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
726- update to 0.4
727- make hyperlinks work (with recent versions of Firebird/Mozilla)
728
729* Thu Dec 04 2003 David Hill <djh[at]ii.net>
730- update to 0.4rc2
731
732* Wed Dec 03 2003 David Hill <djh[at]ii.net>
733- update to 0.4rc1 and Enigmail 0.82.4
734
735* Thu Nov 27 2003 David Hill <djh[at]ii.net>
736- update to latest CVS and Enigmail 0.82.3
737
738* Sun Nov 16 2003 David Hill <djh[at]ii.net>
739- update to latest CVS (0.4a)
740- update Enigmail to 0.82.2
741- alter mozconfig for new build requirements
742- add missing BuildReq (#987)
743
744* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
745- update to 0.3
746
747* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
748- update to 0.3rc3
749- update Enigmail to 0.81.7
750
751* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
752- update to 0.3rc2
753
754* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
755- simplify startup script
756
757* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
758- add GPG support (Enigmail 0.81.6)
759- specfile fixes (#679)
760
761* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
762- update to 0.2
763
764* Mon Sep 01 2003 David Hill <djh[at]ii.net>
765- initial RPM
766  (based on the fedora MozillaFirebird-0.6.1 specfile)
767
Note: See TracBrowser for help on using the repository browser.