source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 5135

Revision 5135, 27.3 KB checked in by Takemikaduchi, 13 years ago (diff)

fix version_internal

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 8.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 2%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal 8.0
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.12.6
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine6 0
29%define build_vine5 0
30
31%if "%{?_dist_release}" >= "vl6"
32%define build_vine6 1
33%endif
34%if "%{?_dist_release}" == "vl5"
35%define build_vine5 1
36%endif
37
38
39Summary:        Thunderbird Community Edition, Mail/newsgroup client
40Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
41Name:           thunderbird
42Version:        %{tbversion}
43Release:        %{tbrelease}
44URL:            http://www.mozilla.org/projects/thunderbird/
45License:        MPL
46Group:          Applications/Internet
47
48Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
49Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
50Source1010:     mozconfig-thunderbird-vine5
51Source1020:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55Source30:       thunderbird-open-browser.sh
56Source40:       thunderbird-unofficial-brandig-tb-brand.properties
57Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
58Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
59Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
60Source100:      find-external-requires
61
62# locale sources
63#%define MOZ_BUILD_LOCALES "ja"
64# get from mercurial repository with command,
65# mkdir l10n
66# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
67#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
68
69
70# upstream patch
71
72# Fix for version issues
73Patch0:         thunderbird-version.patch
74
75# customization patches
76Patch1:        firefox-1.5-default-a4-paper.patch
77
78BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
79BuildRequires:  pango-devel
80BuildRequires:  cairo-devel >= %{cairo_version}
81%if %{build_vine6}
82BuildRequires:  nspr-devel >= %{nspr_version}
83BuildRequires:  nss-devel >= %{nss_version}
84BuildRequires:  hunspell-devel
85%endif
86BuildRequires:  pixman-devel
87BuildRequires:  libpng-devel
88%if %{build_vine5}
89BuildRequires:  libjpeg-devel
90%else
91BuildRequires:  libjpeg-turbo-devel
92%endif
93BuildRequires:  gtk2-devel
94BuildRequires:  zlib-devel, gzip, zip, unzip
95BuildRequires:  libIDL-devel
96BuildRequires:  freetype2-devel >= %{freetype_version}
97## disabled libnotify support
98## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
99BuildRequires:  libnotify-devel >= %{libnotify_version}
100BuildRequires:  bzip2-devel
101BuildRequires:  gnome-vfs2-devel
102BuildRequires:  libgnome-devel
103BuildRequires:  libgnomeui-devel
104BuildRequires:  krb5-devel
105BuildRequires:  pango-devel
106BuildRequires:  libXt-devel
107BuildRequires:  libXrender-devel
108# hunspell is in plus category for vine
109#BuildRequires: hunspell-devel
110BuildRequires:  sqlite3-devel >= %{sqlite_version}
111BuildRequires:  startup-notification-devel
112BuildRequires:  desktop-file-utils
113BuildRequires:  alsa-lib-devel
114BuildRequires:  yasm
115Requires:       sqlite3 >= %{sqlite_version}
116Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
117Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
118
119Obsoletes:      MozillaThunderbird
120Provides:       MozillaThunderbird = %{version}
121
122Vendor:         Project Vine
123Distribution:   Vine Linux
124Packager:       daisuke, ryoichi, kazutaka
125
126AutoProv: 0
127%define _use_internal_dependency_generator 0
128%define __find_requires %{SOURCE100}
129
130%description
131Thunderbird is a standalone mail and newsgroup client.
132
133%description -l ja
134Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
135
136#===============================================================================
137
138%prep
139%setup -q %{name}-%{version} -c
140cd %{tarballdir}
141
142# Fix for version issue
143sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
144    > version.patch
145%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
146
147cd mozilla
148%patch1 -p1 -b .default-a4
149
150cd -
151%{__rm} -f .mozconfig
152%if %{build_vine5}
153%{__cp} %{SOURCE1010} .mozconfig
154%endif
155%if %{build_vine6}
156%{__cp} %{SOURCE1020} .mozconfig
157%endif
158
159# setup unofficial branding name
160%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
161%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
162
163#===============================================================================
164
165%build
166cd %{tarballdir}
167
168INTERNAL_GECKO=%{version_internal}
169MOZ_APP_DIR=%{mozappdir}
170
171
172#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
173MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
174export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
175export CFLAGS="$RPM_OPT_FLAGS"
176export CXXFLAGS="$CFLAGS"
177export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
178
179%ifarch ppc ppc64 s390 s390x
180%define moz_make_flags -j1
181%else
182%define moz_make_flags %{?_smp_mflags}
183%endif
184
185export PREFIX='%{_prefix}'
186export LIBDIR='%{_libdir}'
187
188export LDFLAGS="-Wl,-rpath,%{mozappdir}"
189export MAKE="gmake %{moz_make_flags}"
190%{__make} -f client.mk build
191
192## build locales
193#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
194#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
195#for dir in $LOCALEDIRS
196#do
197#  for lang in %{MOZ_BUILD_LOCALES} ; do
198#    make -C $dir/locales AB_CD=$lang
199#  done
200#done
201
202#===============================================================================
203
204%install
205%{__rm} -rf $RPM_BUILD_ROOT
206cd %{tarballdir}
207
208INTERNAL_GECKO=%{version_internal}
209
210INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
211MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
212
213cd %{moz_objdir}
214DESTDIR=$RPM_BUILD_ROOT make install
215
216# install unofficial icons
217cd -
218
219%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
220%{__cp} mail/branding/aurora/mailicon16.png \
221        $RPM_BUILD_ROOT/%{mozappdir}/icons/
222%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
223%{__cp} mail/branding/aurora/mailicon16.png \
224        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
225%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
226%{__cp} mail/branding/aurora/mailicon22.png \
227        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
228%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
229%{__cp} mail/branding/aurora/mailicon24.png \
230        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
231%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
232%{__cp} mail/branding/aurora/mailicon32.png \
233        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
234%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
235%{__cp} mail/branding/aurora/mailicon48.png \
236        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
237%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
238%{__cp} mail/branding/aurora/mailicon256.png \
239        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
240
241desktop-file-install --vendor vine \
242  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
243
244# set up the thunderbird start script
245rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
246%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
247  $RPM_BUILD_ROOT%{_bindir}/thunderbird
248%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
249
250install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
251%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
252
253%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
254                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
255        $RPM_BUILD_ROOT/vine-default-prefs
256%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
257%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
258%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
259
260%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
261
262# own mozilla plugin dir (#135050)
263%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
264
265# own extension directories
266%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
267%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
268
269# install locales
270#for lang in %{MOZ_BUILD_LOCALES} ; do
271#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
272#done
273
274# install ja.xpi to langpacks directory
275#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
276#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
277# also setup unofficial branding name
278#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
279#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
280
281# install ja.xpi to langpack file
282%{__mkdir_p} lang_tmp
283unzip %{SOURCE1} -d lang_tmp
284# also setup unofficial branding name
285%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
286%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
287
288%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
289cd lang_tmp; \
290zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
291
292
293%clean
294%{__rm} -rf $RPM_BUILD_ROOT
295
296#===============================================================================
297
298%post
299update-desktop-database &> /dev/null || :
300touch --no-create %{_datadir}/icons/hicolor
301if [ -x %{_bindir}/gtk-update-icon-cache ]; then
302  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
303fi
304
305%postun
306update-desktop-database &> /dev/null || :
307touch --no-create %{_datadir}/icons/hicolor
308if [ -x %{_bindir}/gtk-update-icon-cache ]; then
309  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
310fi
311
312
313%files
314%defattr(-,root,root,-)
315%attr(755,root,root) %{_bindir}/thunderbird
316%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
317%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
318%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
319%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
320%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
321%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
322%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
323%{mozappdir}
324#%{_libdir}/mozilla
325%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
326%exclude %{_datadir}/idl/%{name}-%{version_internal}
327%exclude %{_includedir}/%{name}-%{version_internal}
328%exclude %{_libdir}/%{name}-devel-%{version_internal}
329
330#===============================================================================
331
332%changelog
333* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
334- fix %%version_internal
335
336* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
337- new upstream release
338- update Source1
339
340* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
341- new upstream release
342- update Source1,21,1010,1020
343
344* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
345- rebuild with libnotify-0.7
346
347* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
348- enable-install-strip
349
350* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
351- new upstream release
352- drop obsolete patch and renumber patch26 to patch1
353- add BuildRequires: yasm
354- enable libnotify support
355- add --disable-updater and --disable-installer to mozconfig
356- use ja.xpi instead of l10n source
357- update Source21: add step to setup langpack plugin
358- update Source20: add japanese translation
359- add Source42 & Source43 for localized branding
360- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
361  for mozconfig-thunderbird-vine5
362
363* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
364- new upstream release with security fix
365
366* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
367- new upstream release with security fix
368
369* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
370- new upstream release with security fix
371
372* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
373- new upstream release with security fix
374- add patch5 to fix build failure
375
376* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
377- new upstream release
378
379* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
380- new upstream release with security fix
381- add Patch1030 to fix compilation error
382
383* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
384- change mozconfig (Source1030 & 1040): add --enable-jsd
385
386* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
387- new upstream release
388
389* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
390- new upstream release with security fix
391- add Patch0 from fedora development: fix version issue
392- remove BuildRequires: hunspell-devel
393- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
394
395* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
396- add BuildRequires: alsa-lib-devel
397- remove BuildRequires: libnotify-devel
398  (workaround for known bug)
399- update mozconfig to add --disable-libnotify option
400
401* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
402- new upstream release
403- update spec entirely
404- import patches from fedora (Patch1, 2 & 4)
405- drop outdated patches (Patch22, 24)
406- update Sources:
407  - mozconfig (Source1030 & Source1040)
408  - default prefs.js (Source12)
409  - unofficial branding (Source40 & Source41)
410  - japanese translation (Source1000)
411- update Patch1000 (sjis-alias)
412
413* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
414- new upstream release
415
416* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
417- new upstream release
418
419* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
420- don't install official branding logos
421
422* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
423- add necessary icons in %%{tbdir}/chrome/icons/default
424- add Packager tag
425
426* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
427- new upstream release
428
429* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
430- new upstream release
431
432* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
433- new upstream release
434
435* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
436- new upstream release
437
438* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
439- rebuilt for VineSeed
440
441* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
442- new upstream release
443
444* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
445- new upstream release
446- built for Vine Linux 4.x
447- dropped Patch1020 (merged into upstream)
448
449* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
450- added Patch1020 for workaround gcc visibility hidden bugs
451
452* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
453- build with new environment/toolchain
454- add build options to build with external nss/nspr libraries
455    ac_add_options --with-system-nspr
456    ac_add_options --with-system-nss
457
458* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
459- new upstream release
460
461* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
462- new upstream release
463
464* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
465- new upstream release
466
467* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
468- new upstream release
469
470* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
471- new upstream release
472- merge changes from firefox
473  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
474
475* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
476- new upstream release
477- build en-US locale
478- merge changes from firefox
479  - add upstream patches
480  - disable pango rendering by default
481    (workaround fix slow rendering in some page)
482
483* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
484- initial build for Vine Linux based on FC package
485- update to 1.5RC2
486
487* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
488- Fix issue with popup dialogs and other actions causing lockups
489
490* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
491- Update to 1.5 rc1
492
493* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
494- Update to 1.5 beta2
495
496* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
497- Update to 1.5 beta1
498- Bring the install phase of the spec file up to speed
499
500* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
501- Rebuild
502
503* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
504- Add patch to make file chooser dialog modal
505
506* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
507- Update to 1.0.6
508
509* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
510- 1.0.6 Release Candidate
511
512* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
513- Use system NSPR
514- Fix crash on 64bit platforms (#160330)
515
516* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
517- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
518  references, fixing the "no fonts" problem.
519
520* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
521- Change the Exec line in the desktop file to `thunderbird`
522
523* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
524- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
525
526* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
527- Add temporary workaround to not create files in the user's $HOME (#149664)
528
529* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
530- Don't have downloads "disappear" when downloading to desktop (#139015)
531- Fix for some more cursor issues in textareas (149991, 150002, 152089)
532- Add upstream patch to fix bidi justification of pango
533- Add patch to fix launching of helper applications
534- Add patch to properly link against libgfxshared_s.a
535- Fix multilib conflicts
536
537* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
538- correct confusing PANGO vars in startup script
539
540* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
541- Thunderbird 1.0.2
542
543* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
544- Add patch to compile against new fortified glibc macros
545
546* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
547- Rebuild against GCC 4.0
548- Add execshield patches
549- Minor specfile cleanup
550
551* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
552- Rebuild
553
554* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
555- Add RPM version to useragent
556
557* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
558- Port over pango patches from firefox
559
560* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
561- Thunderbird 1.0
562
563* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
564- Fix advanced prefs
565
566* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
567- Make this run on s390(x) now for real
568
569* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
570- Update to 1.0 rc1
571
572* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
573- Add patches to build and run on s390(x)
574
575* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
576- Rebuild to fix file chooser
577
578* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
579- Update to 0.9
580
581* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
582- Prevent inlining of stack direction detection (#135255)
583
584* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
585- More file chooser fixes (same as in firefox)
586- Fix for upstream 28327.
587
588* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
589- Update the pango patch
590
591* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
592- Pull over patches from firefox build:
593  - disable default application dialog
594  - don't include software update since it doesn't work
595  - make external app support work
596
597* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
598- Use pango for rendering
599
600* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
601- Fix for 64 bit crash at startup (b.m.o #256603)
602
603* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
604- Add patches to fix xremote (#135036)
605
606* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
607- Add patch to fix button focus issues (#133507)
608- Add patch for fix IMAP race issues (bmo #246439)
609
610* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
611- filter out library Provides: and internal Requires:
612
613* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
614- Backport the GTK+ File Chooser.
615- Add fix for JS math on x86_64 systems
616- Add pkgconfig patch
617
618* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
619- Update to 0.8.0
620- Remove enigmail
621- Update BuildRequires
622- Remove gcc34 and extension manager patches -- they are upstreamed.
623- Fix for gnome-vfs2 error at component registration
624
625* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
626- Build with --disable-xprint
627
628* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
629- remove all Xvfb-related hacks
630
631* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
632- actually apply psfonts
633- add mozilla gnome-uriloader patch to prevent build failure
634
635* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
636- rawhide import
637- apply NetBSD's freetype 2.1.8 patch
638- apply psfonts patch
639- remove BR on /usr/bin/ex, breaks beehive
640
641* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
642- oops, fix %%install
643
644* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
645- update to Thunderbird 0.7.3 and Enigmail 0.85.0
646- remove XUL.mfasl on startup, add Debian enigmail patches
647- add Xvfb hack for -install-global-extension
648
649* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
650- update to 0.7.2, just because it's there
651- update gcc-3.4 patch (Kaj Niemi)
652- add EM registration patch and remove instdir hack
653
654* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
655- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
656
657* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
658- update to 0.7.1
659- remove Enigmail
660
661* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
662- re-enable Enigmail 0.84.1
663- add gcc-3.4 patch (Kaj Niemi)
664- use official branding (with permission)
665
666* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
667- update to 0.7
668- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
669- specify libdir, change BR for apt (V. Skytt辰, #1617)
670
671* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
672- temporary workaround for enigmail skin "modern" bug
673
674* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
675- update to Enigmail 0.84.0
676- update launch script
677
678* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
679- installation directory now versioned
680- allow root to run the program (for installing extensions)
681- remove unnecessary %%pre and %%post
682- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
683
684* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
685- include Enigmail, re-add release notes
686- delete %{_libdir}/thunderbird in %%pre
687
688* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
689- update to Thunderbird 0.6
690
691* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
692- update to Thunderbird 0.6 RC1
693- add new icon, remove release notes
694
695* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
696- update to latest CVS, update mozconfig and %%build accordingly
697- update to Enigmail 0.83.6
698- remove x-remote and x86_64 patches
699- build with -Os
700
701* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
702- update x-remote patch
703- more startup script fixes
704
705* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
706- startup script fixes, and a minor cleanup
707
708* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
709- Minor cleanups
710
711* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
712- minor improvements to open-browser.sh and startup script
713- update to latest version of Blizzard's x-remote patch
714
715* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
716- update open-browser.sh, startup script, and BuildRequires
717
718* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
719- update open-browser script, modify BuildRequires (Warren)
720- add Blizzard's x-remote patch
721- initial attempt at x-remote-enabled startup script
722
723* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
724- refuse to run with excessive privileges
725
726* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
727- add Mozilla x86_64 patch (Oliver Sontag)
728- Enigmail source filenames now include the version
729- modify BuildRoot
730
731* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
732- use the updated official tarball
733
734* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
735- fix %%prep script
736
737* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
738- update Enigmail to 0.83.3
739- use official source tarball (after removing the CRLFs)
740- package renamed to thunderbird
741
742* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
743- update to 0.5
744- check for lockfile before launching
745
746* Fri Feb 06 2004 David Hill <djh[at]ii.net>
747- update to latest cvs
748- update to Enigmail 0.83.2
749
750* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
751- update to Enigmail 0.83.1
752- removed Mozilla/Firebird script patching
753
754* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
755- add startup notification to .desktop file
756
757* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
758- open-browser.sh release 3
759- patch broken /usr/bin/mozilla script during install
760- dir ownership
761- XXX: Source fails build on x86_64... fix later
762
763* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
764- update to Enigmail 0.82.5
765- add Warren's open-browser.sh (#1113)
766
767* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
768- use Thunderbird's mozilla-xremote-client to launch browser
769
770* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
771- update to 0.4
772- make hyperlinks work (with recent versions of Firebird/Mozilla)
773
774* Thu Dec 04 2003 David Hill <djh[at]ii.net>
775- update to 0.4rc2
776
777* Wed Dec 03 2003 David Hill <djh[at]ii.net>
778- update to 0.4rc1 and Enigmail 0.82.4
779
780* Thu Nov 27 2003 David Hill <djh[at]ii.net>
781- update to latest CVS and Enigmail 0.82.3
782
783* Sun Nov 16 2003 David Hill <djh[at]ii.net>
784- update to latest CVS (0.4a)
785- update Enigmail to 0.82.2
786- alter mozconfig for new build requirements
787- add missing BuildReq (#987)
788
789* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
790- update to 0.3
791
792* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
793- update to 0.3rc3
794- update Enigmail to 0.81.7
795
796* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
797- update to 0.3rc2
798
799* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
800- simplify startup script
801
802* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
803- add GPG support (Enigmail 0.81.6)
804- specfile fixes (#679)
805
806* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
807- update to 0.2
808
809* Mon Sep 01 2003 David Hill <djh[at]ii.net>
810- initial RPM
811  (based on the fedora MozillaFirebird-0.6.1 specfile)
812
Note: See TracBrowser for help on using the repository browser.