source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 1422

Revision 1422, 25.2 KB checked in by kazutaka, 14 years ago (diff)

Import from latest srpm

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 3.1
3%define tbversion %{tbmajor}.1
4%define tbrelease 1%{?_dist_release}
5
6# The tarball is pretty inconsistent with directory structure.
7# Sometimes there is a top level directory.  That goes here.
8#
9# IMPORTANT: If there is no top level directory, this should be
10# set to the cwd, ie: '.'
11#%define tarballdir .
12%define tarballdir comm-1.9.2
13
14%define mozappdir %{_libdir}/%{name}-%{version_internal}
15%define moz_objdir objdir-tb
16%define version_internal 3.1
17%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
18
19%define desktop_file_utils_version 0.6
20%define nspr_version 4.8
21%define nss_version 3.12.6
22%define cairo_version 1.6.0
23%define freetype_version 2.1.9
24%define sqlite_version 3.6.14
25%define libnotify_version 0.4
26
27%define build_vineseed 0
28%define build_vine5 0
29
30%if "%{?_dist_release}" == "vl6"
31%define build_vineseed 1
32%endif
33%if "%{?_dist_release}" == "vl5"
34%define build_vine5 1
35%endif
36
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48#Source1010:    mozconfig-thunderbird-vine3
49#Source1020:    mozconfig-thunderbird-vine4
50Source1030:     mozconfig-thunderbird-vine5
51Source1040:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55#Source22:      thunderbird.png
56Source30:       thunderbird-open-browser.sh
57Source40:       thunderbird-unofficial-brandig-tb-brand.properties
58Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73# Fix for jemalloc
74Patch1:         mozilla-jemalloc.patch
75# Fix for installation fail when building with dynamic linked libraries
76Patch2:         thunderbird-shared-error.patch
77# Fixes gcc complain that nsFrame::delete is protected
78Patch4:         xulrunner-1.9.2.1-build.patch
79
80# customization patches
81#Patch22:        firefox-1.0-psfonts.patch
82#Patch24:        thunderbird-2.0-default-applications.patch
83#Patch25:        thunderbird-1.1-software-update.patch
84Patch26:        firefox-1.5-default-a4-paper.patch
85
86# font system fixes
87#Patch81:        firefox-nopangoxft.patch
88
89## Vine patch
90# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
91Patch1000:      thunderbird-3.1-sjisalias.patch
92
93# use /proc/net/netstat for random seed instead of netstat command.
94#Patch1010:      firefox-nss-no_netstat.patch
95
96# workaround gcc visibility hidden bugs (see gcc#26905)
97Patch1020:      firefox-2.0.0.3-visibility.patch
98
99BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
100BuildRequires:  pango-devel
101BuildRequires:  cairo-devel >= %{cairo_version}
102%if %{build_vineseed}
103BuildRequires:  nspr-devel >= %{nspr_version}
104BuildRequires:  nss-devel >= %{nss_version}
105%endif
106BuildRequires:  pixman-devel
107BuildRequires:  libpng-devel
108BuildRequires:  libjpeg-devel
109BuildRequires:  gtk2-devel
110BuildRequires:  zlib-devel, gzip, zip, unzip
111BuildRequires:  libIDL-devel
112BuildRequires:  freetype2-devel >= %{freetype_version}
113## disabled libnotify support
114## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
115#BuildRequires:  libnotify-devel >= %{libnotify_version}
116BuildRequires:  bzip2-devel
117BuildRequires:  gnome-vfs2-devel
118BuildRequires:  libgnome-devel
119BuildRequires:  libgnomeui-devel
120BuildRequires:  krb5-devel
121BuildRequires:  pango-devel
122BuildRequires:  libXt-devel
123BuildRequires:  libXrender-devel
124# hunspell is in plus category for vine
125#BuildRequires: hunspell-devel
126BuildRequires:  sqlite3-devel >= %{sqlite_version}
127BuildRequires:  startup-notification-devel
128BuildRequires:  desktop-file-utils
129BuildRequires:  alsa-lib-devel
130Requires:       sqlite3 >= %{sqlite_version}
131Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
132Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
133
134Obsoletes:      MozillaThunderbird
135Provides:       MozillaThunderbird = %{version}
136
137Packager:       daisuke, ryoichi, kazutaka
138
139AutoProv: 0
140%define _use_internal_dependency_generator 0
141%define __find_requires %{SOURCE100}
142
143%description
144Thunderbird is a standalone mail and newsgroup client.
145
146%description -l ja
147Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
148
149#===============================================================================
150
151%prep
152%setup -q %{name}-%{version} -c -b 1000
153cd %{tarballdir}
154
155# Fix for version issue
156sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
157    > version.patch
158%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
159
160%patch1 -p0 -b .jemalloc
161%patch2 -p1 -b .shared-error
162%patch4 -p1 -b .protected
163
164cd mozilla
165
166#%patch22 -p1
167#%patch24 -p1
168#%patch25 -p0
169%patch26 -p1 -b .default-a4
170%patch1000 -p1 -b .sjis-alias
171
172cd -
173%{__rm} -f .mozconfig
174%if %{build_vine5}
175%{__cp} %{SOURCE1030} .mozconfig
176%endif
177%if %{build_vineseed}
178%{__cp} %{SOURCE1040} .mozconfig
179# cannot build with xulrunner (yet)
180# see tracking bugs.
181#   https://bugzilla.mozilla.org/show_bug.cgi?id=306324
182#   https://bugzilla.mozilla.org/show_bug.cgi?id=377319
183#echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
184%endif
185
186# setup unofficial branding name
187%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
188%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
189
190#===============================================================================
191
192%build
193cd %{tarballdir}
194
195INTERNAL_GECKO=%{version_internal}
196MOZ_APP_DIR=%{mozappdir}
197
198
199#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
200MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
201export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
202export CFLAGS="$RPM_OPT_FLAGS"
203export CXXFLAGS="$CFLAGS"
204export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
205
206%ifarch ppc ppc64 s390 s390x
207%define moz_make_flags -j1
208%else
209%define moz_make_flags %{?_smp_mflags}
210%endif
211
212export PREFIX='%{_prefix}'
213export LIBDIR='%{_libdir}'
214
215export LDFLAGS="-Wl,-rpath,%{mozappdir}"
216export MAKE="gmake %{moz_make_flags}"
217%{__make} -f client.mk build
218
219# build locales
220LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
221            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
222for dir in $LOCALEDIRS
223do
224  for lang in %{MOZ_BUILD_LOCALES} ; do
225    make -C $dir/locales AB_CD=$lang
226  done
227done
228
229#===============================================================================
230
231%install
232%{__rm} -rf $RPM_BUILD_ROOT
233cd %{tarballdir}
234
235INTERNAL_GECKO=%{version_internal}
236
237INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
238MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
239
240cd %{moz_objdir}
241DESTDIR=$RPM_BUILD_ROOT make install
242
243# install unofficial icons
244cd -
245%{__cp} mail/branding/unofficial/mailicon16.png \
246        $RPM_BUILD_ROOT/%{mozappdir}/icons/
247%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
248%{__cp} mail/branding/unofficial/mailicon16.png \
249        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
250%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
251%{__cp} mail/branding/unofficial/mailicon22.png \
252        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
253%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
254%{__cp} mail/branding/unofficial//mailicon24.png \
255        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
256%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
257%{__cp} mail/branding/unofficial/mailicon32.png \
258        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
259%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
260%{__cp} mail/branding/unofficial/mailicon48.png \
261        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
262%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
263%{__cp} mail/branding/unofficial/mailicon256.png \
264        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
265
266desktop-file-install --vendor vine \
267  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
268  --add-category Application \
269  --add-category Network \
270  %{SOURCE20}
271
272# set up the thunderbird start script
273rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
274%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
275  $RPM_BUILD_ROOT%{_bindir}/thunderbird
276%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
277
278install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
279%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
280
281%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
282                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
283        $RPM_BUILD_ROOT/vine-default-prefs
284%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
285%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
286%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
287
288%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
289
290# own mozilla plugin dir (#135050)
291%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
292
293# own extension directories
294%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
295%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
296
297# install locales
298for lang in %{MOZ_BUILD_LOCALES} ; do
299  %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
300done
301
302
303%clean
304%{__rm} -rf $RPM_BUILD_ROOT
305
306#===============================================================================
307
308%post
309update-desktop-database &> /dev/null || :
310touch --no-create %{_datadir}/icons/hicolor
311if [ -x %{_bindir}/gtk-update-icon-cache ]; then
312  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
313fi
314
315%postun
316update-desktop-database &> /dev/null || :
317touch --no-create %{_datadir}/icons/hicolor
318if [ -x %{_bindir}/gtk-update-icon-cache ]; then
319  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
320fi
321
322
323%files
324%defattr(-,root,root,-)
325%attr(755,root,root) %{_bindir}/thunderbird
326%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
327%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
328%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
329%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
330%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
331%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
332%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
333%{mozappdir}
334
335#===============================================================================
336
337%changelog
338* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
339- new upstream release with security fix
340- add Patch0 from fedora development: fix version issue
341- remove BuildRequires: hunspell-devel
342- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
343
344* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
345- add BuildRequires: alsa-lib-devel
346- remove BuildRequires: libnotify-devel
347  (workaround for known bug)
348- update mozconfig to add --disable-libnotify option
349
350* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
351- new upstream release
352- update spec entirely
353- import patches from fedora (Patch1, 2 & 4)
354- drop outdated patches (Patch22, 24)
355- update Sources:
356  - mozconfig (Source1030 & Source1040)
357  - default prefs.js (Source12)
358  - unofficial branding (Source40 & Source41)
359  - japanese translation (Source1000)
360- update Patch1000 (sjis-alias)
361
362* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
363- new upstream release
364
365* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
366- new upstream release
367
368* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
369- don't install official branding logos
370
371* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
372- add necessary icons in %%{tbdir}/chrome/icons/default
373- add Packager tag
374
375* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
376- new upstream release
377
378* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
379- new upstream release
380
381* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
382- new upstream release
383
384* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
385- new upstream release
386
387* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
388- rebuilt for VineSeed
389
390* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
391- new upstream release
392
393* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
394- new upstream release
395- built for Vine Linux 4.x
396- dropped Patch1020 (merged into upstream)
397
398* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
399- added Patch1020 for workaround gcc visibility hidden bugs
400
401* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
402- build with new environment/toolchain
403- add build options to build with external nss/nspr libraries
404    ac_add_options --with-system-nspr
405    ac_add_options --with-system-nss
406
407* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
408- new upstream release
409
410* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
411- new upstream release
412
413* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
414- new upstream release
415
416* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
417- new upstream release
418
419* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
420- new upstream release
421- merge changes from firefox
422  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
423
424* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
425- new upstream release
426- build en-US locale
427- merge changes from firefox
428  - add upstream patches
429  - disable pango rendering by default
430    (workaround fix slow rendering in some page)
431
432* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
433- initial build for Vine Linux based on FC package
434- update to 1.5RC2
435
436* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
437- Fix issue with popup dialogs and other actions causing lockups
438
439* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
440- Update to 1.5 rc1
441
442* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
443- Update to 1.5 beta2
444
445* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
446- Update to 1.5 beta1
447- Bring the install phase of the spec file up to speed
448
449* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
450- Rebuild
451
452* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
453- Add patch to make file chooser dialog modal
454
455* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
456- Update to 1.0.6
457
458* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
459- 1.0.6 Release Candidate
460
461* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
462- Use system NSPR
463- Fix crash on 64bit platforms (#160330)
464
465* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
466- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
467  references, fixing the "no fonts" problem.
468
469* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
470- Change the Exec line in the desktop file to `thunderbird`
471
472* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
473- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
474
475* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
476- Add temporary workaround to not create files in the user's $HOME (#149664)
477
478* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
479- Don't have downloads "disappear" when downloading to desktop (#139015)
480- Fix for some more cursor issues in textareas (149991, 150002, 152089)
481- Add upstream patch to fix bidi justification of pango
482- Add patch to fix launching of helper applications
483- Add patch to properly link against libgfxshared_s.a
484- Fix multilib conflicts
485
486* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
487- correct confusing PANGO vars in startup script
488
489* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
490- Thunderbird 1.0.2
491
492* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
493- Add patch to compile against new fortified glibc macros
494
495* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
496- Rebuild against GCC 4.0
497- Add execshield patches
498- Minor specfile cleanup
499
500* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
501- Rebuild
502
503* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
504- Add RPM version to useragent
505
506* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
507- Port over pango patches from firefox
508
509* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
510- Thunderbird 1.0
511
512* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
513- Fix advanced prefs
514
515* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
516- Make this run on s390(x) now for real
517
518* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
519- Update to 1.0 rc1
520
521* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
522- Add patches to build and run on s390(x)
523
524* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
525- Rebuild to fix file chooser
526
527* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
528- Update to 0.9
529
530* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
531- Prevent inlining of stack direction detection (#135255)
532
533* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
534- More file chooser fixes (same as in firefox)
535- Fix for upstream 28327.
536
537* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
538- Update the pango patch
539
540* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
541- Pull over patches from firefox build:
542  - disable default application dialog
543  - don't include software update since it doesn't work
544  - make external app support work
545
546* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
547- Use pango for rendering
548
549* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
550- Fix for 64 bit crash at startup (b.m.o #256603)
551
552* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
553- Add patches to fix xremote (#135036)
554
555* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
556- Add patch to fix button focus issues (#133507)
557- Add patch for fix IMAP race issues (bmo #246439)
558
559* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
560- filter out library Provides: and internal Requires:
561
562* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
563- Backport the GTK+ File Chooser.
564- Add fix for JS math on x86_64 systems
565- Add pkgconfig patch
566
567* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
568- Update to 0.8.0
569- Remove enigmail
570- Update BuildRequires
571- Remove gcc34 and extension manager patches -- they are upstreamed.
572- Fix for gnome-vfs2 error at component registration
573
574* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
575- Build with --disable-xprint
576
577* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
578- remove all Xvfb-related hacks
579
580* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
581- actually apply psfonts
582- add mozilla gnome-uriloader patch to prevent build failure
583
584* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
585- rawhide import
586- apply NetBSD's freetype 2.1.8 patch
587- apply psfonts patch
588- remove BR on /usr/bin/ex, breaks beehive
589
590* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
591- oops, fix %%install
592
593* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
594- update to Thunderbird 0.7.3 and Enigmail 0.85.0
595- remove XUL.mfasl on startup, add Debian enigmail patches
596- add Xvfb hack for -install-global-extension
597
598* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
599- update to 0.7.2, just because it's there
600- update gcc-3.4 patch (Kaj Niemi)
601- add EM registration patch and remove instdir hack
602
603* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
604- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
605
606* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
607- update to 0.7.1
608- remove Enigmail
609
610* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
611- re-enable Enigmail 0.84.1
612- add gcc-3.4 patch (Kaj Niemi)
613- use official branding (with permission)
614
615* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
616- update to 0.7
617- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
618- specify libdir, change BR for apt (V. Skytt辰, #1617)
619
620* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
621- temporary workaround for enigmail skin "modern" bug
622
623* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
624- update to Enigmail 0.84.0
625- update launch script
626
627* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
628- installation directory now versioned
629- allow root to run the program (for installing extensions)
630- remove unnecessary %%pre and %%post
631- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
632
633* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
634- include Enigmail, re-add release notes
635- delete %{_libdir}/thunderbird in %%pre
636
637* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
638- update to Thunderbird 0.6
639
640* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
641- update to Thunderbird 0.6 RC1
642- add new icon, remove release notes
643
644* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
645- update to latest CVS, update mozconfig and %%build accordingly
646- update to Enigmail 0.83.6
647- remove x-remote and x86_64 patches
648- build with -Os
649
650* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
651- update x-remote patch
652- more startup script fixes
653
654* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
655- startup script fixes, and a minor cleanup
656
657* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
658- Minor cleanups
659
660* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
661- minor improvements to open-browser.sh and startup script
662- update to latest version of Blizzard's x-remote patch
663
664* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
665- update open-browser.sh, startup script, and BuildRequires
666
667* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
668- update open-browser script, modify BuildRequires (Warren)
669- add Blizzard's x-remote patch
670- initial attempt at x-remote-enabled startup script
671
672* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
673- refuse to run with excessive privileges
674
675* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
676- add Mozilla x86_64 patch (Oliver Sontag)
677- Enigmail source filenames now include the version
678- modify BuildRoot
679
680* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
681- use the updated official tarball
682
683* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
684- fix %%prep script
685
686* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
687- update Enigmail to 0.83.3
688- use official source tarball (after removing the CRLFs)
689- package renamed to thunderbird
690
691* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
692- update to 0.5
693- check for lockfile before launching
694
695* Fri Feb 06 2004 David Hill <djh[at]ii.net>
696- update to latest cvs
697- update to Enigmail 0.83.2
698
699* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
700- update to Enigmail 0.83.1
701- removed Mozilla/Firebird script patching
702
703* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
704- add startup notification to .desktop file
705
706* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
707- open-browser.sh release 3
708- patch broken /usr/bin/mozilla script during install
709- dir ownership
710- XXX: Source fails build on x86_64... fix later
711
712* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
713- update to Enigmail 0.82.5
714- add Warren's open-browser.sh (#1113)
715
716* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
717- use Thunderbird's mozilla-xremote-client to launch browser
718
719* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
720- update to 0.4
721- make hyperlinks work (with recent versions of Firebird/Mozilla)
722
723* Thu Dec 04 2003 David Hill <djh[at]ii.net>
724- update to 0.4rc2
725
726* Wed Dec 03 2003 David Hill <djh[at]ii.net>
727- update to 0.4rc1 and Enigmail 0.82.4
728
729* Thu Nov 27 2003 David Hill <djh[at]ii.net>
730- update to latest CVS and Enigmail 0.82.3
731
732* Sun Nov 16 2003 David Hill <djh[at]ii.net>
733- update to latest CVS (0.4a)
734- update Enigmail to 0.82.2
735- alter mozconfig for new build requirements
736- add missing BuildReq (#987)
737
738* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
739- update to 0.3
740
741* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
742- update to 0.3rc3
743- update Enigmail to 0.81.7
744
745* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
746- update to 0.3rc2
747
748* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
749- simplify startup script
750
751* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
752- add GPG support (Enigmail 0.81.6)
753- specfile fixes (#679)
754
755* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
756- update to 0.2
757
758* Mon Sep 01 2003 David Hill <djh[at]ii.net>
759- initial RPM
760  (based on the fedora MozillaFirebird-0.6.1 specfile)
761
Note: See TracBrowser for help on using the repository browser.