source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 1276

Revision 1276, 24.6 KB checked in by kazutaka, 14 years ago (diff)

--disable-libnotify を追加し BuildRequires? を調整

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 3.1
3%define tbversion %{tbmajor}
4%define tbrelease 2%{?_dist_release}
5
6# The tarball is pretty inconsistent with directory structure.
7# Sometimes there is a top level directory.  That goes here.
8#
9# IMPORTANT: If there is no top level directory, this should be
10# set to the cwd, ie: '.'
11#%define tarballdir .
12%define tarballdir comm-1.9.2
13
14%define mozappdir %{_libdir}/%{name}-%{version_internal}
15%define moz_objdir objdir-tb
16%define version_internal 3.1
17%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
18
19%define desktop_file_utils_version 0.6
20%define nspr_version 4.8
21%define nss_version 3.12.6
22%define cairo_version 1.6.0
23%define freetype_version 2.1.9
24%define sqlite_version 3.6.14
25%define libnotify_version 0.4
26
27%define build_vineseed 0
28%define build_vine5 0
29
30%if "%{?_dist_release}" == "vl6"
31%define build_vineseed 1
32%endif
33%if "%{?_dist_release}" == "vl5"
34%define build_vine5 1
35%endif
36
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48#Source1010:    mozconfig-thunderbird-vine3
49#Source1020:    mozconfig-thunderbird-vine4
50Source1030:     mozconfig-thunderbird-vine5
51Source1040:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55#Source22:      thunderbird.png
56Source30:       thunderbird-open-browser.sh
57Source40:       thunderbird-unofficial-brandig-tb-brand.properties
58Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n
65Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
66
67
68# upstream patch
69
70# Fix for jemalloc
71Patch1:         mozilla-jemalloc.patch
72# Fix for installation fail when building with dynamic linked libraries
73Patch2:         thunderbird-shared-error.patch
74# Fixes gcc complain that nsFrame::delete is protected
75Patch4:         xulrunner-1.9.2.1-build.patch
76
77# customization patches
78#Patch22:        firefox-1.0-psfonts.patch
79#Patch24:        thunderbird-2.0-default-applications.patch
80#Patch25:        thunderbird-1.1-software-update.patch
81Patch26:        firefox-1.5-default-a4-paper.patch
82
83# font system fixes
84#Patch81:        firefox-nopangoxft.patch
85
86## Vine patch
87# http://bugzilla.mozilla.org/show_bug.cgi?id=179248
88Patch1000:      thunderbird-3.1-sjisalias.patch
89
90# use /proc/net/netstat for random seed instead of netstat command.
91#Patch1010:      firefox-nss-no_netstat.patch
92
93# workaround gcc visibility hidden bugs (see gcc#26905)
94Patch1020:      firefox-2.0.0.3-visibility.patch
95
96BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
97BuildRequires:  pango-devel
98BuildRequires:  cairo-devel >= %{cairo_version}
99%if %{build_vineseed}
100BuildRequires:  nspr-devel >= %{nspr_version}
101BuildRequires:  nss-devel >= %{nss_version}
102%endif
103BuildRequires:  pixman-devel
104BuildRequires:  libpng-devel
105BuildRequires:  libjpeg-devel
106BuildRequires:  gtk2-devel
107BuildRequires:  zlib-devel, gzip, zip, unzip
108BuildRequires:  libIDL-devel
109BuildRequires:  freetype2-devel >= %{freetype_version}
110## disabled libnotify support
111## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
112#BuildRequires:  libnotify-devel >= %{libnotify_version}
113BuildRequires:  bzip2-devel
114BuildRequires:  gnome-vfs2-devel
115BuildRequires:  libgnome-devel
116BuildRequires:  libgnomeui-devel
117BuildRequires:  krb5-devel
118BuildRequires:  pango-devel
119BuildRequires:  libXt-devel
120BuildRequires:  libXrender-devel
121BuildRequires:  hunspell-devel
122BuildRequires:  sqlite3-devel >= %{sqlite_version}
123BuildRequires:  startup-notification-devel
124BuildRequires:  desktop-file-utils
125BuildRequires:  alsa-lib-devel
126Requires:       sqlite3 >= %{sqlite_version}
127Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
128Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
129
130Obsoletes:      MozillaThunderbird
131Provides:       MozillaThunderbird = %{version}
132
133Packager:       daisuke, ryoichi, kazutaka
134
135AutoProv: 0
136%define _use_internal_dependency_generator 0
137%define __find_requires %{SOURCE100}
138
139%description
140Thunderbird is a standalone mail and newsgroup client.
141
142%description -l ja
143Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
144
145#===============================================================================
146
147%prep
148%setup -q %{name}-%{version} -c -b 1000
149cd %{tarballdir}
150
151%patch1 -p0 -b .jemalloc
152%patch2 -p1 -b .shared-error
153%patch4 -p1 -b .protected
154
155cd mozilla
156
157#%patch22 -p1
158#%patch24 -p1
159#%patch25 -p0
160%patch26 -p1 -b .default-a4
161%patch1000 -p1 -b .sjis-alias
162
163cd -
164%{__rm} -f .mozconfig
165%if %{build_vine5}
166%{__cp} %{SOURCE1030} .mozconfig
167%endif
168%if %{build_vineseed}
169%{__cp} %{SOURCE1040} .mozconfig
170# cat not build with xulrunner (yet)
171# see tracking bugs.
172#   https://bugzilla.mozilla.org/show_bug.cgi?id=306324
173#   https://bugzilla.mozilla.org/show_bug.cgi?id=377319
174#echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
175%endif
176
177# setup unofficial branding name
178%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
179%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
180
181#===============================================================================
182
183%build
184cd %{tarballdir}
185
186INTERNAL_GECKO=%{version_internal}
187MOZ_APP_DIR=%{mozappdir}
188
189
190#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
191MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
192export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
193export CFLAGS="$RPM_OPT_FLAGS"
194export CXXFLAGS="$CFLAGS"
195export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
196
197%ifarch ppc ppc64 s390 s390x
198%define moz_make_flags -j1
199%else
200%define moz_make_flags %{?_smp_mflags}
201%endif
202
203export PREFIX='%{_prefix}'
204export LIBDIR='%{_libdir}'
205
206export LDFLAGS="-Wl,-rpath,%{mozappdir}"
207export MAKE="gmake %{moz_make_flags}"
208%{__make} -f client.mk build
209
210# build locales
211LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
212            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
213for dir in $LOCALEDIRS
214do
215  for lang in %{MOZ_BUILD_LOCALES} ; do
216    make -C $dir/locales AB_CD=$lang
217  done
218done
219
220#===============================================================================
221
222%install
223%{__rm} -rf $RPM_BUILD_ROOT
224cd %{tarballdir}
225
226INTERNAL_GECKO=%{version_internal}
227
228INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
229MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
230
231cd %{moz_objdir}
232DESTDIR=$RPM_BUILD_ROOT make install
233
234# install unofficial icons
235cd -
236%{__cp} mail/branding/unofficial/mailicon16.png \
237        $RPM_BUILD_ROOT/%{mozappdir}/icons/
238%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
239%{__cp} mail/branding/unofficial/mailicon16.png \
240        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
241%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
242%{__cp} mail/branding/unofficial/mailicon22.png \
243        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
244%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
245%{__cp} mail/branding/unofficial//mailicon24.png \
246        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
247%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
248%{__cp} mail/branding/unofficial/mailicon32.png \
249        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
250%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
251%{__cp} mail/branding/unofficial/mailicon48.png \
252        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
253%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
254%{__cp} mail/branding/unofficial/mailicon256.png \
255        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
256
257desktop-file-install --vendor vine \
258  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
259  --add-category Application \
260  --add-category Network \
261  %{SOURCE20}
262
263# set up the thunderbird start script
264rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
265%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
266  $RPM_BUILD_ROOT%{_bindir}/thunderbird
267%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
268
269install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
270%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
271
272%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
273                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
274        $RPM_BUILD_ROOT/vine-default-prefs
275%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
276%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
277%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
278
279%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
280
281# own mozilla plugin dir (#135050)
282%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
283
284# own extension directories
285%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
286%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
287
288# install locales
289for lang in %{MOZ_BUILD_LOCALES} ; do
290  %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
291done
292
293
294%clean
295%{__rm} -rf $RPM_BUILD_ROOT
296
297#===============================================================================
298
299%post
300update-desktop-database &> /dev/null || :
301touch --no-create %{_datadir}/icons/hicolor
302if [ -x %{_bindir}/gtk-update-icon-cache ]; then
303  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
304fi
305
306%postun
307update-desktop-database &> /dev/null || :
308touch --no-create %{_datadir}/icons/hicolor
309if [ -x %{_bindir}/gtk-update-icon-cache ]; then
310  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
311fi
312
313
314%files
315%defattr(-,root,root,-)
316%attr(755,root,root) %{_bindir}/thunderbird
317%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
318%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
319%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
320%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
321%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
322%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
323%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
324%{mozappdir}
325
326#===============================================================================
327
328%changelog
329* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
330- add BuildRequires: alsa-lib-devel
331- remove BuildRequires: libnotify-devel
332  (workaround for known bug)
333- update mozconfig to add --disable-libnotify option
334
335* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
336- new upstream release
337- update spec entirely
338- import patches from fedora (Patch1, 2 & 4)
339- drop outdated patches (Patch22, 24)
340- update Sources:
341  - mozconfig (Source1030 & Source1040)
342  - default prefs.js (Source12)
343  - unofficial branding (Source40 & Source41)
344  - japanese translation (Source1000)
345- update Patch1000 (sjis-alias)
346
347* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
348- new upstream release
349
350* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
351- new upstream release
352
353* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
354- don't install official branding logos
355
356* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
357- add necessary icons in %%{tbdir}/chrome/icons/default
358- add Packager tag
359
360* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
361- new upstream release
362
363* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
364- new upstream release
365
366* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
367- new upstream release
368
369* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
370- new upstream release
371
372* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
373- rebuilt for VineSeed
374
375* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
376- new upstream release
377
378* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
379- new upstream release
380- built for Vine Linux 4.x
381- dropped Patch1020 (merged into upstream)
382
383* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
384- added Patch1020 for workaround gcc visibility hidden bugs
385
386* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
387- build with new environment/toolchain
388- add build options to build with external nss/nspr libraries
389    ac_add_options --with-system-nspr
390    ac_add_options --with-system-nss
391
392* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
393- new upstream release
394
395* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
396- new upstream release
397
398* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
399- new upstream release
400
401* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
402- new upstream release
403
404* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
405- new upstream release
406- merge changes from firefox
407  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
408
409* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
410- new upstream release
411- build en-US locale
412- merge changes from firefox
413  - add upstream patches
414  - disable pango rendering by default
415    (workaround fix slow rendering in some page)
416
417* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
418- initial build for Vine Linux based on FC package
419- update to 1.5RC2
420
421* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
422- Fix issue with popup dialogs and other actions causing lockups
423
424* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
425- Update to 1.5 rc1
426
427* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
428- Update to 1.5 beta2
429
430* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
431- Update to 1.5 beta1
432- Bring the install phase of the spec file up to speed
433
434* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
435- Rebuild
436
437* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
438- Add patch to make file chooser dialog modal
439
440* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
441- Update to 1.0.6
442
443* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
444- 1.0.6 Release Candidate
445
446* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
447- Use system NSPR
448- Fix crash on 64bit platforms (#160330)
449
450* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
451- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
452  references, fixing the "no fonts" problem.
453
454* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
455- Change the Exec line in the desktop file to `thunderbird`
456
457* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
458- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
459
460* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
461- Add temporary workaround to not create files in the user's $HOME (#149664)
462
463* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
464- Don't have downloads "disappear" when downloading to desktop (#139015)
465- Fix for some more cursor issues in textareas (149991, 150002, 152089)
466- Add upstream patch to fix bidi justification of pango
467- Add patch to fix launching of helper applications
468- Add patch to properly link against libgfxshared_s.a
469- Fix multilib conflicts
470
471* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
472- correct confusing PANGO vars in startup script
473
474* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
475- Thunderbird 1.0.2
476
477* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
478- Add patch to compile against new fortified glibc macros
479
480* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
481- Rebuild against GCC 4.0
482- Add execshield patches
483- Minor specfile cleanup
484
485* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
486- Rebuild
487
488* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
489- Add RPM version to useragent
490
491* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
492- Port over pango patches from firefox
493
494* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
495- Thunderbird 1.0
496
497* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
498- Fix advanced prefs
499
500* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
501- Make this run on s390(x) now for real
502
503* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
504- Update to 1.0 rc1
505
506* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
507- Add patches to build and run on s390(x)
508
509* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
510- Rebuild to fix file chooser
511
512* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
513- Update to 0.9
514
515* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
516- Prevent inlining of stack direction detection (#135255)
517
518* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
519- More file chooser fixes (same as in firefox)
520- Fix for upstream 28327.
521
522* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
523- Update the pango patch
524
525* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
526- Pull over patches from firefox build:
527  - disable default application dialog
528  - don't include software update since it doesn't work
529  - make external app support work
530
531* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
532- Use pango for rendering
533
534* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
535- Fix for 64 bit crash at startup (b.m.o #256603)
536
537* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
538- Add patches to fix xremote (#135036)
539
540* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
541- Add patch to fix button focus issues (#133507)
542- Add patch for fix IMAP race issues (bmo #246439)
543
544* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
545- filter out library Provides: and internal Requires:
546
547* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
548- Backport the GTK+ File Chooser.
549- Add fix for JS math on x86_64 systems
550- Add pkgconfig patch
551
552* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
553- Update to 0.8.0
554- Remove enigmail
555- Update BuildRequires
556- Remove gcc34 and extension manager patches -- they are upstreamed.
557- Fix for gnome-vfs2 error at component registration
558
559* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
560- Build with --disable-xprint
561
562* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
563- remove all Xvfb-related hacks
564
565* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
566- actually apply psfonts
567- add mozilla gnome-uriloader patch to prevent build failure
568
569* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
570- rawhide import
571- apply NetBSD's freetype 2.1.8 patch
572- apply psfonts patch
573- remove BR on /usr/bin/ex, breaks beehive
574
575* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
576- oops, fix %%install
577
578* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
579- update to Thunderbird 0.7.3 and Enigmail 0.85.0
580- remove XUL.mfasl on startup, add Debian enigmail patches
581- add Xvfb hack for -install-global-extension
582
583* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
584- update to 0.7.2, just because it's there
585- update gcc-3.4 patch (Kaj Niemi)
586- add EM registration patch and remove instdir hack
587
588* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
589- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
590
591* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
592- update to 0.7.1
593- remove Enigmail
594
595* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
596- re-enable Enigmail 0.84.1
597- add gcc-3.4 patch (Kaj Niemi)
598- use official branding (with permission)
599
600* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
601- update to 0.7
602- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
603- specify libdir, change BR for apt (V. Skytt辰, #1617)
604
605* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
606- temporary workaround for enigmail skin "modern" bug
607
608* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
609- update to Enigmail 0.84.0
610- update launch script
611
612* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
613- installation directory now versioned
614- allow root to run the program (for installing extensions)
615- remove unnecessary %%pre and %%post
616- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
617
618* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
619- include Enigmail, re-add release notes
620- delete %{_libdir}/thunderbird in %%pre
621
622* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
623- update to Thunderbird 0.6
624
625* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
626- update to Thunderbird 0.6 RC1
627- add new icon, remove release notes
628
629* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
630- update to latest CVS, update mozconfig and %%build accordingly
631- update to Enigmail 0.83.6
632- remove x-remote and x86_64 patches
633- build with -Os
634
635* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
636- update x-remote patch
637- more startup script fixes
638
639* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
640- startup script fixes, and a minor cleanup
641
642* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
643- Minor cleanups
644
645* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
646- minor improvements to open-browser.sh and startup script
647- update to latest version of Blizzard's x-remote patch
648
649* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
650- update open-browser.sh, startup script, and BuildRequires
651
652* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
653- update open-browser script, modify BuildRequires (Warren)
654- add Blizzard's x-remote patch
655- initial attempt at x-remote-enabled startup script
656
657* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
658- refuse to run with excessive privileges
659
660* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
661- add Mozilla x86_64 patch (Oliver Sontag)
662- Enigmail source filenames now include the version
663- modify BuildRoot
664
665* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
666- use the updated official tarball
667
668* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
669- fix %%prep script
670
671* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
672- update Enigmail to 0.83.3
673- use official source tarball (after removing the CRLFs)
674- package renamed to thunderbird
675
676* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
677- update to 0.5
678- check for lockfile before launching
679
680* Fri Feb 06 2004 David Hill <djh[at]ii.net>
681- update to latest cvs
682- update to Enigmail 0.83.2
683
684* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
685- update to Enigmail 0.83.1
686- removed Mozilla/Firebird script patching
687
688* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
689- add startup notification to .desktop file
690
691* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
692- open-browser.sh release 3
693- patch broken /usr/bin/mozilla script during install
694- dir ownership
695- XXX: Source fails build on x86_64... fix later
696
697* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
698- update to Enigmail 0.82.5
699- add Warren's open-browser.sh (#1113)
700
701* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
702- use Thunderbird's mozilla-xremote-client to launch browser
703
704* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
705- update to 0.4
706- make hyperlinks work (with recent versions of Firebird/Mozilla)
707
708* Thu Dec 04 2003 David Hill <djh[at]ii.net>
709- update to 0.4rc2
710
711* Wed Dec 03 2003 David Hill <djh[at]ii.net>
712- update to 0.4rc1 and Enigmail 0.82.4
713
714* Thu Nov 27 2003 David Hill <djh[at]ii.net>
715- update to latest CVS and Enigmail 0.82.3
716
717* Sun Nov 16 2003 David Hill <djh[at]ii.net>
718- update to latest CVS (0.4a)
719- update Enigmail to 0.82.2
720- alter mozconfig for new build requirements
721- add missing BuildReq (#987)
722
723* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
724- update to 0.3
725
726* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
727- update to 0.3rc3
728- update Enigmail to 0.81.7
729
730* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
731- update to 0.3rc2
732
733* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
734- simplify startup script
735
736* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
737- add GPG support (Enigmail 0.81.6)
738- specfile fixes (#679)
739
740* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
741- update to 0.2
742
743* Mon Sep 01 2003 David Hill <djh[at]ii.net>
744- initial RPM
745  (based on the fedora MozillaFirebird-0.6.1 specfile)
746
Note: See TracBrowser for help on using the repository browser.