source: projects/specs/trunk/t/thread/thread-vl.spec @ 521

Revision 521, 12.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tclmajor 8.4
2%define majorver 2.6
3
4Summary: A Tcl/Tk development environment: thread
5Summary(ja): Tcl/Tk 開発環境: thread
6Name: thread
7Version: %{majorver}.5
8Release: 1%{?_dist_release}
9License: BSD
10Group: Development/Languages
11BuildRequires: libtool, util-linux, perl, gdbm
12BuildRequires: tcl >= %{tclmajor}
13BuildRequires: tk >= %{tclmajor}
14Requires: tcl >= %{tclmajor}
15Requires: tk >= %{tclmajor}
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17URL: http://tcl.sourceforge.net/
18Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
19
20%description
21You can use this extension to gain script-level access to Tcl threading capabilities.
22
23%prep
24
25%setup -q -n %{name}%{version}
26
27%build
28chmod 755 ./configure
29%configure \
30--with-tcl=%{_libdir} --with-tk=%{_libdir}  --enable-shared \
31--enable-threads --enable-64bit
32make %{?_smp_mflags}
33
34%install
35rm -rf ${RPM_BUILD_ROOT}
36%makeinstall
37
38echo "%%defattr(-,root,root)" > thread.files
39(find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
40 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
41        | sort | uniq -u >> thread.files
42
43set +x +H
44for n in `cat thread.files`; do
45        test -f $n || continue
46        head -1 $n | grep -q ^#! || continue
47        chmod u+w $n
48        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
49done
50set -x -H
51
52#
53# post process the *.files list, removing build sys references and mark
54# which are directories
55set +x
56for n in *.files; do
57        mv $n $n.in
58        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
59            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
60                echo -n '%dir '
61            fi
62            echo $file
63        done > $n
64        rm -f $n.in
65done
66set -x
67
68#
69# Man pages can be compressed
70perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
71
72%post -p /sbin/ldconfig -n thread
73
74%postun -p /sbin/ldconfig -n thread
75
76%clean
77rm -rf ${RPM_BUILD_ROOT}
78rm -f *.files
79
80%files -f thread.files -n thread
81
82%changelog
83* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
84- applied new versioning policy and spec in utf-8
85
86* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
87- rebuild with tcl/tk-8.4.18
88
89* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
90- rebuild with tcl/tk-8.4.16
91
92* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
93- update thread to 2.6.5
94- rebuilt with new toolchain
95
96* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
97- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
98
99* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
100- update thread to 2.6.2
101- rebuilt for tcl/tk-8.4.11
102
103* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
104- rebuild for tcl/tk-8.4.6
105
106* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
107- source update
108
109* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
110- modified for Vine Linux
111- splite source package
112
113* Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
114- update Tcl/Tk 8.4.2
115
116* Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
117- update thread 2.5
118- update expect-20030203 (nightly-cvs)
119- remove xotcl
120
121* Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
122- add config patch for Trf
123- add static libraries of Tcl and Tk
124- add tbcload and tclcompiler again
125
126* Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
127- build on RH 8.0
128- update expect 5.38.0
129- remove tcllib module, which will be separate RPM from this.
130- remove tbcload module, which will be separate RPM from this.
131- remove tclcompiler module, which will be separate RPM from this.
132- add XOTcl 1.0
133- add Tcl-Trf 2.1p2
134- add Memchan 2.2a4
135
136* Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
137- fix to make XIC free, and eliminate XCloseIM when exiting Tk.
138
139* Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
140- update Tcl/Tk 8.4.1.
141
142* Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
143- correct install sequence in Tk.
144
145* Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
146- add TclPro tools:
147- tbcload CVS
148- tclcompiler CVS
149
150* Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
151- add iwidgets4.0.1.
152- correct symbolic link
153
154* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
155- fix stub problem in itcl.
156
157* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
158- adjust libary names to meet compatibility.
159
160* Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
161- update Tcl/Tk 8.4.0.
162- update TclX 8.4.
163- update tcllib 1.3.
164- add thread2.4.
165
166* Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
167- update tcllib 1.2.
168
169* Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
170- correct to install all of message catalogs for Img.
171
172* Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
173- add tcl-8.3.4-encoding.patch for JIS encoding
174
175* Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
176- update itcl 3.2.1
177
178* Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
179- add link for tclth8.3 and wish8.3
180- add img 1.2.4
181
182* Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
183- update Tcl/Tk 8.3.4
184- update tcllib 1.1
185- update patch tcl-8.3.4-cruft.patch
186- update patch tcl-8.3.4-makecfg.patch
187- update patch tk-8.3.4-makecfg.patch
188
189* Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
190- hard-coded the compat symlink for tix libdir. (bug 52812)
191
192* Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
193- fixed itkwish/itclsh lib problem (bug 52608)
194- make itcl install not need tclsh/wish during config/make (bug 52606)
195- expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
196
197* Mon Aug  8 2001 Adrian Havill <havill@redhat.com>
198- changed rev for tcllib to 1.0
199- added execute bit mode for itclsh and itksh compat shells
200- re-enable glibc string and math inlines; recent gcc is a-ok.
201- optimize at -O2 instead of -O
202- rename "soname" patches related to makefile/autoconf changes
203- added elf "needed" for tk, tclx, tix, itk
204- removed warnings from tclX
205
206* Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
207- added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
208- fixed 64 bit RPM provides for dependencies
209
210* Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
211- updated tclX to the latest version
212- fixed tclX 8.3's busted help install
213- eliminated make TK_LIB kludge for multiple math libs for tclX
214- used %%makeinstall to brute force fix any remaining unflexible makefile dirs
215- fixed bad ref count release in tcl (bug 49406)
216- improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
217- revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
218- fixed DirTree in Tix (bug 45570)
219
220* Sun Jul  8 2001 Adrian Havill <havill@redhat.com>
221- refresh all sources to latest stable (TODO: separate expect/expectk)
222- massage out some build stuff to patches (TODO: libtoolize hacked constants)
223- remove patches already rolled into the upstream
224- remove unneeded autopasswd
225- removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
226- changed shared object filenames to something less gross
227- fixed tclX shell's argv parsing (bug 47710)
228- reenable threads which seem to work now
229- added all necessary header files for itcl (bug 41374)
230- fixed spawn/eof read problem with expect (bug 43310)
231- made compile-friendly for IA64
232
233* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
234- Bump release + rebuild for 7.2.
235
236* Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
237- bzip2 sources
238
239* Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
240- build with -D_GNU_SOURCE - fixes expect on ia64
241
242* Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
243- build fix from ahavill.
244
245* Wed Feb 21 2001 Tim Powers <timp@redhat.com>
246- fixed weather expect script using wrong server (#28505)
247
248* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
249- added "ja_JP.eucJP" to locale list for tcl
250
251* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
252- rebuild so make check passes
253
254* Fri Oct 20 2000 Than Ngo <than@redhat.com>
255- rebuild with -O0 on alpha (bug #19461)
256
257* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
258- summaries from specspo.
259
260* Tue Aug  8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
261- remove symlink to libtixsam.so
262
263* Thu Aug  3 2000 Jeff Johnson <jbj@redhat.com>
264- merge "best known" patches from searching, stubs were broken.
265- tix needs -fwritable-strings (#14352).
266- create tixwish symlink.
267
268* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
269- rebuild against "working" util-linux col.
270
271* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
272- automatic rebuild
273
274* Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
275- make sure that tix shared libraries are installed.
276- don't mess with %%{_libdir}, it's gonna be a FHS pita.
277
278* Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
279- move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
280
281* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
282- tclX had wrong version.
283
284* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
285- FHS packaging changes.
286- revert --enable-threads, linux is not ready (yet) (#11789).
287- tcl/tk: update to 8.3.1 (#10779).
288- expect: update to 5.31.7+ (#11595).
289- add tcllib-0.4.
290- abstract major tcltk version for soname expansion etc.
291
292* Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
293- update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
294- use perl to drill out pre-pended RPM_BUILD_ROOT.
295- configure with --enable-threads (experimental).
296- improved version of autopasswd (#4788).
297- autopasswd needs to handle password starting with hyphen (#9917).
298- handle 553 ftp status in rftp expect script (#7869).
299- remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
300- correct hierarchy spelling (#7082).
301- fix "expect -d ...", format string had int printed as string (#7775).
302
303* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
304- rebuild for sparc baud rates > 38400.
305
306* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
307- handle compressed manpages
308
309* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
310- Make changes from bug number 7602
311- Apply patch from bug number 7537
312- Apply fix from bug number 7157
313- Add fixes from bug #7601 to the runtcl patch
314
315* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
316- fix descriptions
317- man pages are compressed (whatapain)
318
319* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
320- fix tclX symlinks.
321- compile on systems where SIGPWR == SIGLOST.
322
323* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
324- update tcl/tk to 8.0.5.
325- avoid "containing" in Tix (#2332).
326
327* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
328- use /usr/bin/write in kibitz (#1320).
329- use cirrus.sprl.umich.edu in weather (#1926).
330
331* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
332- auto rebuild in the new build environment (release 28)
333
334* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
335- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
336
337* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
338- expect does unaligned access on alpha (#989)
339- upgrade tcl/tk/tclX to 8.0.4
340- upgrade expect to 5.28.
341- add itcl 3.0.1
342
343* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
344- call libtoolize to allow building on the arm
345- build for glibc 2.1
346- strip binaries
347
348* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
349- update tcl/tk/tclX to 8.0.3, expect is updated also.
350
351* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
352- expect: mkpasswd needs delay before sending password (problem #576)
353
354* Thu May 07 1998 Prospector System <bugs@redhat.com>
355- translations modified for de, fr, tr
356
357* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
358- fixed expect binaries exec permissions
359
360* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
361- updated to Tix 4.1.0.006
362- updated version numbers of tcl/tk to relflect includsion of p2
363
364* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
365- updated tcl/tk to patch level 2
366- updated tclX to 8.0.2
367
368* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
369- fixed filelist for tix... replacing path to the expect binary in scripts
370  was leaving junk files around.
371
372* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
373- added patch to remove libieee test in configure.in for tcl and tk.
374  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
375  solution for all systems
376- fixed src urls
377
378* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
379- removed version numbers from descriptions
380
381* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
382- updated to tcl/tk 8.0 and related versions of packages
383
384* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
385- built against glibc
386- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.