source: projects/specs/trunk/t/thread/thread-vl.spec @ 1262

Revision 1262, 12.2 KB checked in by owa, 14 years ago (diff)

updated tcl/tk

Line 
1%define tclmajor 8.4
2%define majorver 2.6
3
4Summary: A Tcl/Tk development environment: thread
5Summary(ja): Tcl/Tk 開発環境: thread
6Name: thread
7Version: %{majorver}.5
8Release: 2%{?_dist_release}
9License: BSD
10Group: Development/Languages
11BuildRequires: libtool, util-linux, perl, gdbm
12BuildRequires: tcl >= %{tclmajor}
13BuildRequires: tk >= %{tclmajor}
14Requires: tcl >= %{tclmajor}
15Requires: tk >= %{tclmajor}
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17URL: http://tcl.sourceforge.net/
18Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
19
20%description
21You can use this extension to gain script-level access to Tcl threading capabilities.
22
23%prep
24
25%setup -q -n %{name}%{version}
26
27%build
28chmod 755 ./configure
29%configure \
30--with-tcl=%{_libdir} --with-tk=%{_libdir}  --enable-shared \
31--enable-threads --enable-64bit
32make %{?_smp_mflags}
33
34%install
35rm -rf ${RPM_BUILD_ROOT}
36%makeinstall
37
38echo "%%defattr(-,root,root)" > thread.files
39(find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
40 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
41        | sort | uniq -u >> thread.files
42
43set +x +H
44for n in `cat thread.files`; do
45        test -f $n || continue
46        head -1 $n | grep -q ^#! || continue
47        chmod u+w $n
48        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
49done
50set -x -H
51
52#
53# post process the *.files list, removing build sys references and mark
54# which are directories
55set +x
56for n in *.files; do
57        mv $n $n.in
58        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
59            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
60                echo -n '%dir '
61            fi
62            echo $file
63        done > $n
64        rm -f $n.in
65done
66set -x
67
68#
69# Man pages can be compressed
70perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
71
72%post -p /sbin/ldconfig -n thread
73
74%postun -p /sbin/ldconfig -n thread
75
76%clean
77rm -rf ${RPM_BUILD_ROOT}
78rm -f *.files
79
80%files -f thread.files -n thread
81
82%changelog
83* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
84- rebuilt with new environment
85
86* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
87- applied new versioning policy and spec in utf-8
88
89* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
90- rebuild with tcl/tk-8.4.18
91
92* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
93- rebuild with tcl/tk-8.4.16
94
95* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
96- update thread to 2.6.5
97- rebuilt with new toolchain
98
99* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
100- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
101
102* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
103- update thread to 2.6.2
104- rebuilt for tcl/tk-8.4.11
105
106* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
107- rebuild for tcl/tk-8.4.6
108
109* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
110- source update
111
112* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
113- modified for Vine Linux
114- splite source package
115
116* Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
117- update Tcl/Tk 8.4.2
118
119* Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
120- update thread 2.5
121- update expect-20030203 (nightly-cvs)
122- remove xotcl
123
124* Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
125- add config patch for Trf
126- add static libraries of Tcl and Tk
127- add tbcload and tclcompiler again
128
129* Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
130- build on RH 8.0
131- update expect 5.38.0
132- remove tcllib module, which will be separate RPM from this.
133- remove tbcload module, which will be separate RPM from this.
134- remove tclcompiler module, which will be separate RPM from this.
135- add XOTcl 1.0
136- add Tcl-Trf 2.1p2
137- add Memchan 2.2a4
138
139* Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
140- fix to make XIC free, and eliminate XCloseIM when exiting Tk.
141
142* Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
143- update Tcl/Tk 8.4.1.
144
145* Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
146- correct install sequence in Tk.
147
148* Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
149- add TclPro tools:
150- tbcload CVS
151- tclcompiler CVS
152
153* Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
154- add iwidgets4.0.1.
155- correct symbolic link
156
157* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
158- fix stub problem in itcl.
159
160* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
161- adjust libary names to meet compatibility.
162
163* Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
164- update Tcl/Tk 8.4.0.
165- update TclX 8.4.
166- update tcllib 1.3.
167- add thread2.4.
168
169* Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
170- update tcllib 1.2.
171
172* Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
173- correct to install all of message catalogs for Img.
174
175* Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
176- add tcl-8.3.4-encoding.patch for JIS encoding
177
178* Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
179- update itcl 3.2.1
180
181* Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
182- add link for tclth8.3 and wish8.3
183- add img 1.2.4
184
185* Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
186- update Tcl/Tk 8.3.4
187- update tcllib 1.1
188- update patch tcl-8.3.4-cruft.patch
189- update patch tcl-8.3.4-makecfg.patch
190- update patch tk-8.3.4-makecfg.patch
191
192* Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
193- hard-coded the compat symlink for tix libdir. (bug 52812)
194
195* Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
196- fixed itkwish/itclsh lib problem (bug 52608)
197- make itcl install not need tclsh/wish during config/make (bug 52606)
198- expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
199
200* Mon Aug  8 2001 Adrian Havill <havill@redhat.com>
201- changed rev for tcllib to 1.0
202- added execute bit mode for itclsh and itksh compat shells
203- re-enable glibc string and math inlines; recent gcc is a-ok.
204- optimize at -O2 instead of -O
205- rename "soname" patches related to makefile/autoconf changes
206- added elf "needed" for tk, tclx, tix, itk
207- removed warnings from tclX
208
209* Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
210- added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
211- fixed 64 bit RPM provides for dependencies
212
213* Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
214- updated tclX to the latest version
215- fixed tclX 8.3's busted help install
216- eliminated make TK_LIB kludge for multiple math libs for tclX
217- used %%makeinstall to brute force fix any remaining unflexible makefile dirs
218- fixed bad ref count release in tcl (bug 49406)
219- improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
220- revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
221- fixed DirTree in Tix (bug 45570)
222
223* Sun Jul  8 2001 Adrian Havill <havill@redhat.com>
224- refresh all sources to latest stable (TODO: separate expect/expectk)
225- massage out some build stuff to patches (TODO: libtoolize hacked constants)
226- remove patches already rolled into the upstream
227- remove unneeded autopasswd
228- removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
229- changed shared object filenames to something less gross
230- fixed tclX shell's argv parsing (bug 47710)
231- reenable threads which seem to work now
232- added all necessary header files for itcl (bug 41374)
233- fixed spawn/eof read problem with expect (bug 43310)
234- made compile-friendly for IA64
235
236* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
237- Bump release + rebuild for 7.2.
238
239* Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
240- bzip2 sources
241
242* Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
243- build with -D_GNU_SOURCE - fixes expect on ia64
244
245* Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
246- build fix from ahavill.
247
248* Wed Feb 21 2001 Tim Powers <timp@redhat.com>
249- fixed weather expect script using wrong server (#28505)
250
251* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
252- added "ja_JP.eucJP" to locale list for tcl
253
254* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
255- rebuild so make check passes
256
257* Fri Oct 20 2000 Than Ngo <than@redhat.com>
258- rebuild with -O0 on alpha (bug #19461)
259
260* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
261- summaries from specspo.
262
263* Tue Aug  8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
264- remove symlink to libtixsam.so
265
266* Thu Aug  3 2000 Jeff Johnson <jbj@redhat.com>
267- merge "best known" patches from searching, stubs were broken.
268- tix needs -fwritable-strings (#14352).
269- create tixwish symlink.
270
271* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
272- rebuild against "working" util-linux col.
273
274* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
275- automatic rebuild
276
277* Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
278- make sure that tix shared libraries are installed.
279- don't mess with %%{_libdir}, it's gonna be a FHS pita.
280
281* Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
282- move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
283
284* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
285- tclX had wrong version.
286
287* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
288- FHS packaging changes.
289- revert --enable-threads, linux is not ready (yet) (#11789).
290- tcl/tk: update to 8.3.1 (#10779).
291- expect: update to 5.31.7+ (#11595).
292- add tcllib-0.4.
293- abstract major tcltk version for soname expansion etc.
294
295* Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
296- update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
297- use perl to drill out pre-pended RPM_BUILD_ROOT.
298- configure with --enable-threads (experimental).
299- improved version of autopasswd (#4788).
300- autopasswd needs to handle password starting with hyphen (#9917).
301- handle 553 ftp status in rftp expect script (#7869).
302- remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
303- correct hierarchy spelling (#7082).
304- fix "expect -d ...", format string had int printed as string (#7775).
305
306* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
307- rebuild for sparc baud rates > 38400.
308
309* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
310- handle compressed manpages
311
312* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
313- Make changes from bug number 7602
314- Apply patch from bug number 7537
315- Apply fix from bug number 7157
316- Add fixes from bug #7601 to the runtcl patch
317
318* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
319- fix descriptions
320- man pages are compressed (whatapain)
321
322* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
323- fix tclX symlinks.
324- compile on systems where SIGPWR == SIGLOST.
325
326* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
327- update tcl/tk to 8.0.5.
328- avoid "containing" in Tix (#2332).
329
330* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
331- use /usr/bin/write in kibitz (#1320).
332- use cirrus.sprl.umich.edu in weather (#1926).
333
334* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
335- auto rebuild in the new build environment (release 28)
336
337* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
338- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
339
340* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
341- expect does unaligned access on alpha (#989)
342- upgrade tcl/tk/tclX to 8.0.4
343- upgrade expect to 5.28.
344- add itcl 3.0.1
345
346* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
347- call libtoolize to allow building on the arm
348- build for glibc 2.1
349- strip binaries
350
351* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
352- update tcl/tk/tclX to 8.0.3, expect is updated also.
353
354* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
355- expect: mkpasswd needs delay before sending password (problem #576)
356
357* Thu May 07 1998 Prospector System <bugs@redhat.com>
358- translations modified for de, fr, tr
359
360* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
361- fixed expect binaries exec permissions
362
363* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
364- updated to Tix 4.1.0.006
365- updated version numbers of tcl/tk to relflect includsion of p2
366
367* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
368- updated tcl/tk to patch level 2
369- updated tclX to 8.0.2
370
371* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
372- fixed filelist for tix... replacing path to the expect binary in scripts
373  was leaving junk files around.
374
375* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
376- added patch to remove libieee test in configure.in for tcl and tk.
377  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
378  solution for all systems
379- fixed src urls
380
381* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
382- removed version numbers from descriptions
383
384* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
385- updated to tcl/tk 8.0 and related versions of packages
386
387* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
388- built against glibc
389- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.