source: projects/specs/trunk/t/tgif/tgif-vl.spec @ 521

Revision 521, 9.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: 2-D drawling tool
2Summary(ja): 2次元ドローイングソフト
3Name: tgif
4%define eversion 4.2.2
5Version: %{eversion}
6Release: 1%{?_dist_release}
7
8Source0: ftp://bourbon.cs.umd.edu/pub/tgif/tgif-QPL-%{eversion}.tar.gz
9Source1: Tgif.ad.ja
10Source2: tgif-4.1.45.ja.po
11Source3: tgif.desktop
12Source4: tgif.png
13
14# http://tyche.pu-toyama.ac.jp/~a-urasim/tgif/
15Patch10: tgif-textcursor-a-urasim.patch
16Patch101: tgif-QPL-4.1.45-size-debug.patch
17
18URL: http://bourbon.usc.edu/tgif/
19License: QPL
20Group: Applications/Multimedia
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: imake
23BuildRequires: gettext, desktop-file-utils
24BuildRequires: libXmu-devel
25Requires(post): desktop-file-utils
26Requires(postun): desktop-file-utils
27Requires: ghostscript
28Requires: netpbm-progs
29Requires: xorg-x11-fonts-75dpi
30Requires: xorg-x11-fonts-ISO8859-1-75dpi
31Requires: xorg-x11-jpfonts
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37tgif  -  Xlib based interactive 2-D drawing facility under
38X11.  Supports hierarchical construction of  drawings  and
39easy  navigation  between  sets  of drawings.  It's also a
40hyper-graphics (or hyper-structured-graphics)  browser  on
41the World-Wide-Web.
42
43%description -l ja
44X 上で動くドローイングソフト tgif です. EPS, PostScript, X11 bitmap
45形式等で出力できます. kinput2 や xwnmo を使えば日本語を入力することが
46できます.
47
48%prep
49rm -rf ${RPM_BUILD_ROOT}
50%setup -q -n %{name}-QPL-%{eversion}
51%patch10 -p0 -b textcursor
52#%patch101 -p1 -b .size
53
54rm -f po/ja/ja.po
55cp %{SOURCE2} po/ja/ja.po
56
57cp -f %{SOURCE1} po/ja/Tgif.ad
58
59%build
60rm -rf Tgif.tmpl
61cp Tgif.tmpl-linux Tgif.tmpl
62xmkmf
63make MOREDEFINES="-DOVERTHESPOT -DUSE_XT_INITIALIZE -D_ENABLE_NLS \
64        -DPRINT_CMD=\\\"lpr\\\" -DA4PAPER" TGIFDIR=%{_datadir}/tgif \
65        LOCAL_LIBRARIES="-lXmu -lXt -lX11" tgif
66
67(cd po
68xmkmf
69make Makefile LIBDIR="%{_datadir}/X11"
70make Makefiles LIBDIR="%{_datadir}/X11"
71make depend
72make all
73)
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make DESTDIR=$RPM_BUILD_ROOT \
78     BINDIR=%{_libexecdir}/ \
79     TGIFDIR=%{_datadir}/tgif/ \
80     DATADIR=%{_datadir} \
81     MANPATH=%{_mandir} \
82     install \
83     install.man
84
85%{__mkdir_p} $RPM_BUILD_ROOT%{_bindir}/
86%{__install} -cpm 0755 po/ja/tgif-wrapper.sh \
87        $RPM_BUILD_ROOT%{_bindir}/%{name}
88
89rm -f $RPM_BUILD_ROOT%{_datadir}/tgif/*.obj
90install -m 644 *.obj $RPM_BUILD_ROOT%{_datadir}/tgif
91
92mkdir -p $RPM_BUILD_ROOT%{_datadir}/X11/ja/app-defaults/
93install -m 644 po/ja/Tgif.ad $RPM_BUILD_ROOT%{_datadir}/X11/ja/app-defaults/Tgif
94
95(cd po
96#install -d $RPM_BUILD_ROOT%{_datadir}/locale/ja/LC_MESSAGES
97#install -m644 ja/ja.mo $RPM_BUILD_ROOT%{_datadir}/locale/ja/LC_MESSAGES/tgif.mo
98make DESTDIR=$RPM_BUILD_ROOT install
99)
100
101# desktop file & icon
102%__mkdir_p %{buildroot}%{_datadir}/applications
103%__install -p -m644 %{SOURCE3} %{buildroot}%{_datadir}/applications/
104%__mkdir_p %{buildroot}%{_datadir}/pixmaps
105%__install -p -m644 %{SOURCE4} %{buildroot}%{_datadir}/pixmaps/tgif.png
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post
111%{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1 ||:
112for i in vlgothic ipafont
113do
114  if [ ! -d /etc/X11/fontpath.d/TreuType-$i ]; then
115    sudo ln -sf ../../../usr/share/fonts/TrueType-$i /etc/X11/fontpath.d/
116  fi
117done
118
119%postun
120[ "$1" = "1" ] && exit
121%{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1 ||:
122
123%files
124%defattr(-,root,root)
125%doc Copyright HISTORY README* VMS_MAKE_TGIF.COM example.tex
126%doc po/ja/README.jp License
127%{_bindir}/tgif
128%{_libexecdir}/tgif
129%{_mandir}/man1/tgif.1x*
130%{_datadir}/tgif
131%{_datadir}/locale/*/LC_MESSAGES/tgif.mo
132%{_datadir}/X11/ja/app-defaults/Tgif
133%{_datadir}/pixmaps/*.png
134%{_datadir}/applications/*.desktop
135
136%changelog
137* Sat Mar 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.2-1
138- new upstream release
139  - all patches except textcursor-patch are merged in upstream
140- update ja/Tgif.ad
141
142* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.45-1
143- new upstream release
144- install ja resources
145- fix BR:
146- add R: xorg-x11-fonts-ISO8859-1-75dpi, xorg-x11-fonts-75dpi
147- add R: xorg-x11-jpfonts
148- add tgif.sh to force ja_JP.eucJP on ja locale
149- update ja/Tgif.ad
150- add fontpath tweaks to %%post script
151
152* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.44-1vl5
153- applied new versioning policy, spec in utf-8
154- built with xorg-x11-devel
155- updated obsolete directories /usr/X11R6/...
156- updated scripts to build tgif.mo
157
158* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.44-0vl6
159- add Patch20 to fix problems with {scim,uim}-anthy (<BTS:512>)
160
161* Wed Dec 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.44-0vl5
162- add tgificon.png (source4)
163- update tgif.desktop (source3)
164
165* Wed Oct 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.44-0vl4
166- add Patch10 to fix text cursor problem (<BTS:250>)
167  http://tyche.pu-toyama.ac.jp/~a-urasim/tgif/
168
169* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.44-0vl3
170- add and update desktop file (source3)
171- move desktop file to %{_datadir}/applications
172- exec update-desktop-database at %%post,%%postun
173- add Requires(post,postun): desktop-file-utils
174
175* Sat Sep 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.44-0vl2
176- add BuildRequires: XOrg-devel
177
178* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.44-0vl1
179- switch to QPL version
180
181* Thu Jun 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1.43-0vl1
182- source update
183
184* Thu Jun 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.42-0vl2
185- rebuild with new toolchains
186
187* Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 4.1.41-0vl3
188- add Tate-gaki entry for Ricoh fonts
189
190* Sun Mar 17 2002 Shoji Matsumoto <shom@vinelinux.org> 4.1.41-0vl2
191- refine Tgif.ad for Vine 2.5
192
193* Fri Oct 19 2001 Jun Nishii <jun@vinelinux.org> 4.1.41-0vl1
194- ver.up
195
196* Thu Jul 28 2001 Shoji Matsumoto <shom@vinelinux.org>
197- 4.1.40-0vl2
198- tgif-4.1ja6 (-aliastt-{mincho,gothic}- -> -alias-{mincho,gothic}-)
199
200* Thu Dec  7 2000 Jun Nishii <jun@vinelinux.org>
201- 4.1.40-0vl1
202
203* Tue Oct  3 2000 Jun Nishii <jun@vinelinux.org>
204- 4.1.39-0vl2
205- added documents
206
207* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
208- 4.1.39-0vl1
209
210* Thu Aug 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
211- added overthespot_fix patch for XIM with OverTheSpot style.
212
213* Fri Aug 11 2000 Jun Nishii <jun@vinelinux.org>
214- 4.1.36-0vl1
215
216* Mon Aug  7 2000 Jun Nishii <jun@vinelinux.org>
217- 4.1.35-0vl1
218
219* Sat Jul 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
220- 4.1.34-0vl2
221- modified %files section to handle compressed man page
222
223* Mon May  8 2000 Jun Nishii <jun@vinelinux.org>
224- updated 4.0.33
225
226* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
227- updated 4.0.29
228- modified fontcheck patch to check signgle byte font, too.
229
230* Thu Mar  9 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
231- updated 4.0.28
232
233* Mon Feb 28 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
234- updated 4.0.27
235
236* Thu Feb 24 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
237- added tgif wmconfig, desktop file
238
239* Fri Feb 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
240- added xim unofficial patch from fj.sources to fix a bug about XIM.
241
242* Wed Feb 16 2000 Jun Nishii <jun@vinelinux.org>
243- 4.1.26-0vl3
244- bug fix in tgif-4.1.26-fontcheck.patch
245
246* Mon Feb 14 2000 Jun Nishii <jun@vinelinux.org>
247- 4.1.26-0vl2
248- merge tgif-4.1.26-fontcheck.patch by Mr. Yasuyuki Furukawa
249  which obsoletes trigger for Dynafonts and TrueTypeFonts !
250
251* Thu Jan 20 2000 Jun Nishii <jun@vinelinux.org>
252- 4.1.26-0vl2
253- added trigger for Dynafonts and TrueTypeFonts
254
255* Thu Jan 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
256- updated to 4.1.26
257- change ja resource from ja_JP.ujis/app-defaults to ja/app-defaults
258- modified font setting
259
260* Wed Nov 17 1999 Jun Nishii <jun@flatout.org>
261- updated to 4.1.25
262
263* Thu Nov 4 1999 Jun Nishii <jun@flatout.org>
264- updated to 4.1.23
265
266* Thu Oct 28 1999 Jun Nishii <jun@flatout.org>
267- rel.4
268- update ja.po
269- more gettextize in choice.c and menu.c
270
271* Wed Oct 27 1999 Jun Nishii <jun@flatout.org>
272- rel.3
273- merge messages in strtbl.c and added japanese catalog
274
275* Tue Oct 26 1999 Jun Nishii <jun@flatout.org>
276- rel.2
277- enable nls in status buffer and added japanese catalog
278
279* Tue Oct 26 1999 Jun Nishii <jun@flatout.org>
280- updated to 4.1.22
281
282* Sun Aug 8 1999 Norihito Ohmori <ohmori@flatout.org>
283- archive format change to bzip2
284- rebuild for glibc-2.1.x
285
286* Wed Jun 30 1999 Jun Nishii <jun@flatout.org>
287- updated to 4.1.16
288
289* Tue Apr 15 1999 Jun Nishii <jun@flatout.org>
290- updated to 4.1.7
291
292* Tue Apr 8 1999 Jun Nishii <jun@flatout.org>
293- updated to 4.1.6
294- Our menufontset-nls patch and xim patch were merged in original source!
295
296* Tue Mar  9 1999 MATSUMOTO Shoji <vine@flatout.org>
297- vertical font indicator bug fix
298- modify resource and tgif.sh
299
300* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
301- updated to 4.1
302
303* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
304- bug fix in showing shortcut key in menu
305- modify document
306
307* Wed Mar  4 1999 MATSUMOTO Shoji <vine@flatout.org>
308- set Tgif.InitialFont Ryumin
309
310* Wed Mar  3 1999 MATSUMOTO Shoji <vine@flatout.org>
311- add XIM OverTheSpot patch
312- modify Tgif-ja.ad
313
314* Mon Mar 2 1999 Jun Nishii <jun@flatout.org>
315- updated to 4.0.18
316
317* Mon Mar 1 1999 Jun Nishii <jun@flatout.org>
318- make patch to support fontset and nls
319- change version name as 4.0.17_jp
320
321* Sat Feb 27 1999 Jun Nishii <jun@flatout.org>
322- modify Tgif-ja.ad (use A4,cm,color-icon,etc...)
323- correct document
324
325* Wed Feb 24 1999 Jun Nishii <jun@flatout.org>
326- updated to ver. 4.0.17
327- make wrapper to read Tgif-ja
328
329* Sat Feb 20 1999 Jun Nishii <jun@flatout.org>
330- updated to ver. 4.0.16
331
332* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
333- build ver. 4.0.14 for Vine Linux
Note: See TracBrowser for help on using the repository browser.