source: projects/specs/trunk/t/tgif/tgif-vl.spec @ 9492

Revision 9492, 10.4 KB checked in by inagaki, 9 years ago (diff)

2015-04-05 Ryoichi INAGAKI <ryo1@…>

  • cadaver, freetds, iverlog: rebuilt
  • tgif: updated


Line 
1%define eversion 4.2.5
2
3Name:           tgif
4Version:        4.2.5
5Release:        1%{?_dist_release}
6Summary:        2-D drawing tool
7Summary(ja):    2次元ドローイングソフト
8
9Group:          Applications/Multimedia
10License:        QPL
11URL:            http://bourbon.usc.edu/tgif/
12
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-QPL-%{version}.tar.gz
14Source1:        Tgif.ad.ja
15Source2:        tgif-4.1.45.ja.po
16Source3:        tgif.desktop
17
18# http://tyche.pu-toyama.ac.jp/~a-urasim/tgif/
19Patch10:        tgif-textcursor-a-urasim.patch
20# http://ayapin-film.sakura.ne.jp/Tgif/utf8.html
21Patch20:        tgif-utf8conv2euc.patch
22# Check below later
23Patch101:       tgif-QPL-4.1.45-size-debug.patch
24Patch102:       tgif-QPL-4.2.5-format-security.patch
25
26Buildroot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  imake
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext
30BuildRequires:  libXmu-devel
31BuildRequires:  libidn-devel
32BuildRequires:  zlib-devel
33Requires:       ghostscript
34Requires:       netpbm-progs
35Requires:       xorg-x11-fonts-75dpi
36Requires:       xorg-x11-fonts-ISO8859-1-75dpi
37Requires:       xorg-x11-jpfonts
38Requires:       sudo
39Requires(post):   desktop-file-utils
40Requires(postun): desktop-file-utils
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44
45%description
46tgif  -  Xlib based interactive 2-D drawing facility under
47X11.  Supports hierarchical construction of  drawings  and
48easy  navigation  between  sets  of drawings.  It's also a
49hyper-graphics (or hyper-structured-graphics)  browser  on
50the World-Wide-Web.
51
52%description -l ja
53Tgif は X 上で動くドローイングソフトです. EPS, PostScript, X11 bitmap
54形式等で出力できます.
55#'
56
57%prep
58%setup -q -n %{name}-QPL-%{eversion}
59# Upstream says the below is wrong, for now dropping
60#%%patch10 -p0 -b textcursor
61%patch20 -p0 -b .utf8conv2euc
62# Check later
63#%%patch101 -p1 -b .size
64%patch102 -p1 -b .format
65
66rm -f po/ja/ja.po
67cp %{SOURCE2} po/ja/ja.po
68
69cp -f %{SOURCE1} po/ja/Tgif.ad
70
71# Fix encoding
72sed -i -e 's|eucJP|utf8|' po/ja/tgif-wrapper.sh
73
74# Fix installation path for icon files
75sed -i.path \
76        -e '/InstallNonExec.*hicolor/s|\$(TGIFDIR)|\$(DATADIR)/icons/|' \
77        -e '/MakeDirectories.*hicolor/s|\$(TGIFDIR)|\$(DATADIR)/icons/|' \
78        Imakefile
79
80%build
81cp -pf Tgif.tmpl-linux Tgif.tmpl
82sed -i.mode -e 's|0664|0644|' Tgif.tmpl
83
84xmkmf
85sed -i.mode -e 's|0444|0644|' Makefile
86
87DEFOPTS='-DOVERTHESPOT -DUSE_XT_INITIALIZE -D_ENABLE_NLS -DPRINT_CMD=\"lpr\" -DA4PAPER'
88%{__make} %{?_smp_mflags} \
89        CC="%{__cc} %{optflags}" \
90        MOREDEFINES="$DEFOPTS" \
91        TGIFDIR=%{_datadir}/tgif/ \
92        LOCAL_LIBRARIES="-lXmu -lXt -lX11" \
93        tgif
94
95pushd po
96xmkmf
97sed -i.mode -e 's|0444|0644|' Makefile
98make Makefile LIBDIR="%{_datadir}/X11"
99make Makefiles LIBDIR="%{_datadir}/X11"
100make depend
101make all
102popd
103
104%install
105rm -rf $RPM_BUILD_ROOT
106make DESTDIR=$RPM_BUILD_ROOT \
107     BINDIR=%{_libexecdir}/ \
108     TGIFDIR=%{_datadir}/tgif/ \
109     DATADIR=%{_datadir} \
110     MANPATH=%{_mandir} \
111     INSTALLFLAGS="-cp" \
112     install \
113     install.man
114
115# wrap tgif
116mkdir -p $RPM_BUILD_ROOT%{_bindir}/
117install -cpm 0755 po/ja/tgif-wrapper.sh \
118        $RPM_BUILD_ROOT%{_bindir}/%{name}
119
120rm -f $RPM_BUILD_ROOT%{_datadir}/tgif/*.obj
121install -m 644 *.obj $RPM_BUILD_ROOT%{_datadir}/tgif
122
123mkdir -p $RPM_BUILD_ROOT%{_datadir}/X11/ja/app-defaults/
124install -m 644 po/ja/Tgif.ad $RPM_BUILD_ROOT%{_datadir}/X11/ja/app-defaults/Tgif
125
126pushd po
127make DESTDIR=$RPM_BUILD_ROOT INSTALLFLAGS="-cp" install
128popd
129
130# desktop file
131mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
132install -p -m644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/applications/
133
134%{find_lang} tgif
135
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post
141touch --no-create %{_datadir}/icons/hicolor
142%{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1 ||:
143for i in vlgothic ipafont
144do
145  if [ ! -d /etc/X11/fontpath.d/TreuType-$i ]; then
146    sudo ln -sf ../../../usr/share/fonts/TrueType-$i /etc/X11/fontpath.d/
147  fi
148done
149
150%postun
151[ "$1" = "1" ] && exit
152touch --no-create %{_datadir}/icons/hicolor
153%{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1 ||:
154
155%posttrans
156gtk-update-icon-cache -q %{_datadir}/icons/hicolor
157
158%files  -f %{name}.lang
159%defattr(-,root,root)
160%doc Copyright HISTORY README* VMS_MAKE_TGIF.COM example.tex
161%doc po/ja/README.jp License
162%{_bindir}/tgif
163%{_libexecdir}/tgif
164%{_mandir}/man1/tgif.1x*
165%{_datadir}/tgif
166%{_datadir}/X11/ja/app-defaults/Tgif
167#{_datadir}/pixmaps/*.png
168%{_datadir}/icons/hicolor/*/apps/*.png
169%{_datadir}/applications/*.desktop
170
171%changelog
172* Sat Mar  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.2.5-1
173- updated to 4.2.5
174- updated Source1 and Source3
175- dropt Patch10 and 101
176- added Patch20 for input Japanese under utf8 environment
177
178* Sun Feb 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.2-2
179- rebuild with Vine6 environment
180- add BuildRequires: libidn-devel, zlib-devel
181
182* Sat Mar 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.2-1
183- new upstream release
184  - all patches except textcursor-patch are merged in upstream
185- update ja/Tgif.ad
186
187* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.45-1
188- new upstream release
189- install ja resources
190- fix BR:
191- add R: xorg-x11-fonts-ISO8859-1-75dpi, xorg-x11-fonts-75dpi
192- add R: xorg-x11-jpfonts
193- add tgif.sh to force ja_JP.eucJP on ja locale
194- update ja/Tgif.ad
195- add fontpath tweaks to %%post script
196
197* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.44-1vl5
198- applied new versioning policy, spec in utf-8
199- built with xorg-x11-devel
200- updated obsolete directories /usr/X11R6/...
201- updated scripts to build tgif.mo
202
203* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.44-0vl6
204- add Patch20 to fix problems with {scim,uim}-anthy (<BTS:512>)
205
206* Wed Dec 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.44-0vl5
207- add tgificon.png (source4)
208- update tgif.desktop (source3)
209
210* Wed Oct 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.44-0vl4
211- add Patch10 to fix text cursor problem (<BTS:250>)
212  http://tyche.pu-toyama.ac.jp/~a-urasim/tgif/
213
214* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.44-0vl3
215- add and update desktop file (source3)
216- move desktop file to %{_datadir}/applications
217- exec update-desktop-database at %%post,%%postun
218- add Requires(post,postun): desktop-file-utils
219
220* Sat Sep 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.1.44-0vl2
221- add BuildRequires: XOrg-devel
222
223* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.44-0vl1
224- switch to QPL version
225
226* Thu Jun 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1.43-0vl1
227- source update
228
229* Thu Jun 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.42-0vl2
230- rebuild with new toolchains
231
232* Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 4.1.41-0vl3
233- add Tate-gaki entry for Ricoh fonts
234
235* Sun Mar 17 2002 Shoji Matsumoto <shom@vinelinux.org> 4.1.41-0vl2
236- refine Tgif.ad for Vine 2.5
237
238* Fri Oct 19 2001 Jun Nishii <jun@vinelinux.org> 4.1.41-0vl1
239- ver.up
240
241* Thu Jul 28 2001 Shoji Matsumoto <shom@vinelinux.org>
242- 4.1.40-0vl2
243- tgif-4.1ja6 (-aliastt-{mincho,gothic}- -> -alias-{mincho,gothic}-)
244
245* Thu Dec  7 2000 Jun Nishii <jun@vinelinux.org>
246- 4.1.40-0vl1
247
248* Tue Oct  3 2000 Jun Nishii <jun@vinelinux.org>
249- 4.1.39-0vl2
250- added documents
251
252* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
253- 4.1.39-0vl1
254
255* Thu Aug 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
256- added overthespot_fix patch for XIM with OverTheSpot style.
257
258* Fri Aug 11 2000 Jun Nishii <jun@vinelinux.org>
259- 4.1.36-0vl1
260
261* Mon Aug  7 2000 Jun Nishii <jun@vinelinux.org>
262- 4.1.35-0vl1
263
264* Sat Jul 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
265- 4.1.34-0vl2
266- modified %files section to handle compressed man page
267
268* Mon May  8 2000 Jun Nishii <jun@vinelinux.org>
269- updated 4.0.33
270
271* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
272- updated 4.0.29
273- modified fontcheck patch to check signgle byte font, too.
274
275* Thu Mar  9 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
276- updated 4.0.28
277
278* Mon Feb 28 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
279- updated 4.0.27
280
281* Thu Feb 24 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
282- added tgif wmconfig, desktop file
283
284* Fri Feb 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
285- added xim unofficial patch from fj.sources to fix a bug about XIM.
286
287* Wed Feb 16 2000 Jun Nishii <jun@vinelinux.org>
288- 4.1.26-0vl3
289- bug fix in tgif-4.1.26-fontcheck.patch
290
291* Mon Feb 14 2000 Jun Nishii <jun@vinelinux.org>
292- 4.1.26-0vl2
293- merge tgif-4.1.26-fontcheck.patch by Mr. Yasuyuki Furukawa
294  which obsoletes trigger for Dynafonts and TrueTypeFonts !
295
296* Thu Jan 20 2000 Jun Nishii <jun@vinelinux.org>
297- 4.1.26-0vl2
298- added trigger for Dynafonts and TrueTypeFonts
299
300* Thu Jan 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
301- updated to 4.1.26
302- change ja resource from ja_JP.ujis/app-defaults to ja/app-defaults
303- modified font setting
304
305* Wed Nov 17 1999 Jun Nishii <jun@flatout.org>
306- updated to 4.1.25
307
308* Thu Nov 4 1999 Jun Nishii <jun@flatout.org>
309- updated to 4.1.23
310
311* Thu Oct 28 1999 Jun Nishii <jun@flatout.org>
312- rel.4
313- update ja.po
314- more gettextize in choice.c and menu.c
315
316* Wed Oct 27 1999 Jun Nishii <jun@flatout.org>
317- rel.3
318- merge messages in strtbl.c and added japanese catalog
319
320* Tue Oct 26 1999 Jun Nishii <jun@flatout.org>
321- rel.2
322- enable nls in status buffer and added japanese catalog
323
324* Tue Oct 26 1999 Jun Nishii <jun@flatout.org>
325- updated to 4.1.22
326
327* Sun Aug 8 1999 Norihito Ohmori <ohmori@flatout.org>
328- archive format change to bzip2
329- rebuild for glibc-2.1.x
330
331* Wed Jun 30 1999 Jun Nishii <jun@flatout.org>
332- updated to 4.1.16
333
334* Tue Apr 15 1999 Jun Nishii <jun@flatout.org>
335- updated to 4.1.7
336
337* Tue Apr 8 1999 Jun Nishii <jun@flatout.org>
338- updated to 4.1.6
339- Our menufontset-nls patch and xim patch were merged in original source!
340
341* Tue Mar  9 1999 MATSUMOTO Shoji <vine@flatout.org>
342- vertical font indicator bug fix
343- modify resource and tgif.sh
344
345* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
346- updated to 4.1
347
348* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
349- bug fix in showing shortcut key in menu
350- modify document
351
352* Wed Mar  4 1999 MATSUMOTO Shoji <vine@flatout.org>
353- set Tgif.InitialFont Ryumin
354
355* Wed Mar  3 1999 MATSUMOTO Shoji <vine@flatout.org>
356- add XIM OverTheSpot patch
357- modify Tgif-ja.ad
358
359* Mon Mar 2 1999 Jun Nishii <jun@flatout.org>
360- updated to 4.0.18
361
362* Mon Mar 1 1999 Jun Nishii <jun@flatout.org>
363- make patch to support fontset and nls
364- change version name as 4.0.17_jp
365
366* Sat Feb 27 1999 Jun Nishii <jun@flatout.org>
367- modify Tgif-ja.ad (use A4,cm,color-icon,etc...)
368- correct document
369
370* Wed Feb 24 1999 Jun Nishii <jun@flatout.org>
371- updated to ver. 4.0.17
372- make wrapper to read Tgif-ja
373
374* Sat Feb 20 1999 Jun Nishii <jun@flatout.org>
375- updated to ver. 4.0.16
376
377* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
378- build ver. 4.0.14 for Vine Linux
Note: See TracBrowser for help on using the repository browser.