source: projects/specs/trunk/t/tftp/tftp-vl.spec @ 9461

Revision 9461, 7.1 KB checked in by inagaki, 9 years ago (diff)

2015-03-22 Ryoichi INAGAKI <ryo1@…>

  • ftp, tftp: rebuilt without readline
  • gftp, lftp, lua, python, python3, sqlite, sqlite3: rebuilt


Line 
1%bcond_with readline
2
3Name: tftp
4Version: 5.2
5Release: 1%{?_dist_release}
6Summary: The client for the Trivial File Transfer Protocol (TFTP).
7Summary(ja): TFTP (Trivial File Transfer Protocol) クライアント
8
9License: BSD
10Group: Applications/Internet
11URL: http://www.kernel.org/pub/software/network/tftp/
12
13Source: http://www.kernel.org/pub/software/network/tftp/tftp-hpa-%{version}.tar.bz2
14
15Patch0: tftp-0.40-remap.patch
16Patch2: tftp-hpa-0.39-tzfix.patch
17Patch3: tftp-0.42-tftpboot.patch
18Patch4: tftp-0.49-chk_retcodes.patch
19Patch5: tftp-hpa-0.49-fortify-strcpy-crash.patch
20Patch6: tftp-0.49-cmd_arg.patch
21Patch7: tftp-hpa-0.49-stats.patch
22Patch8: tftp-hpa-5.2-pktinfo.patch
23Patch9: tftp-doc.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: autoconf
27%if %{with readline}
28BuildRequires: readline-devel
29%endif
30BuildRequires: sed
31BuildRequires: tcp_wrappers
32
33%description
34The Trivial File Transfer Protocol (TFTP) is normally used only for
35booting diskless workstations.  The tftp package provides the user
36interface for TFTP, which allows users to transfer files to and from a
37remote machine.  This program and TFTP provide very little security,
38and should not be enabled unless it is expressly needed.
39
40%description -l ja
41TFTP (Trivial File Transfer Protocol) は通常
42ディスクレスワークステーションの起動時にのみ使われます。
43tftp パッケージはこの TFTP のインタフェースを提供し、リモート機から
44ファイルを転送することが出来ます。このプログラムと TFTP は
45セキュリティ面に於いて非常に弱いので、どうしても必要な場合以外は
46使わない方が良いでしょう。
47
48
49%package server
50Group: System Environment/Daemons
51Summary: The server for the Trivial File Transfer Protocol (TFTP).
52Summary(ja): TFTP (Trivial File Transfer Protocol) サーバ
53Requires: xinetd
54
55%description server
56The Trivial File Transfer Protocol (TFTP) is normally used only for
57booting diskless workstations.  The tftp-server package provides the
58server for TFTP, which allows users to transfer files to and from a
59remote machine. TFTP provides very little security, and should not be
60enabled unless it is expressly needed.  The TFTP server is run from
61%{_sysconfdir}/xinetd.d/tftp, and is disabled by default.
62
63%description server -l ja
64TFTP (Trivial File Transfer Protocol) は通常
65ディスクレスワークステーションの起動時にのみ使われます。
66tftp-server パッケージには TFTP のサーバプログラムが収められており、
67リモート機間とのファイル転送を可能にします。このプログラムと TFTP は
68セキュリティ面に於いて非常に弱いので、どうしても必要な場合以外は
69使わない方が良いでしょう。TFTP サーバは /etc/xinetd.d/tftp から起動され、
70デフォルトでは オフにされています。
71
72
73%prep
74%setup -q -n tftp-hpa-%{version}
75%patch0 -p1 -b .zero
76%patch2 -p1 -b .tzfix
77%patch3 -p1 -b .tftpboot
78%patch4 -p1 -b .chk_retcodes
79%patch5 -p1 -b .fortify-strcpy-crash
80%patch6 -p1 -b .cmd_arg
81%patch7 -p1 -b .stats
82%patch8 -p1 -b .pktinfo
83%patch9 -p1 -b .doc
84
85%build
86autoreconf
87%configure \
88    %if %{without readline}
89    --without-readline \
90%endif
91    ;
92   
93make %{?_smp_mflags}
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
99mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
100mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
101mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/lib/tftpboot
102
103make INSTALLROOT=${RPM_BUILD_ROOT} SBINDIR=%{_sbindir} MANDIR=%{_mandir} INSTALL='install -p' install
104install -m755 -d -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xinetd.d/ ${RPM_BUILD_ROOT}%{_localstatedir}/lib/tftpboot
105sed -e 's:/var:%{_localstatedir}:' -e 's:/usr/sbin:%{_sbindir}:' \
106    tftp-xinetd > ${RPM_BUILD_ROOT}%{_sysconfdir}/xinetd.d/tftp
107touch -r tftp-xinetd ${RPM_BUILD_ROOT}%{_sysconfdir}/xinetd.d/tftp
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%post server
115/sbin/service xinetd reload > /dev/null 2>&1 || :
116
117
118%postun server
119if [ $1 = 0 ]; then
120    /sbin/service xinetd reload > /dev/null 2>&1 || :
121fi
122
123
124%files
125%defattr(-,root,root,-)
126%doc README README.security CHANGES
127%{_bindir}/tftp
128%{_mandir}/man1/*
129
130
131%files server
132%defattr(-,root,root,-)
133%doc README README.security CHANGES
134%config(noreplace) %{_sysconfdir}/xinetd.d/tftp
135%dir %{_localstatedir}/lib/tftpboot
136%{_sbindir}/in.tftpd
137%{_mandir}/man8/*
138
139
140%changelog
141* Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.2-1
142- updated to 5.2
143- built without readline to avoid GPL infection
144- added Patch8 and 9 from Fedora
145  * Fri Apr 19 2013 Jan Synáček <jsynacek@redhat.com> - 5.2-8
146  - documentation fixes
147  * Wed Jan 04 2012 Jiri Skala <jskala@redhat.com> - 5.2-2
148  - fixes #739534 - TFTP to an IP alias of FC15 tftp server failed
149
150* Sat Mar 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.49-2
151- Fixed Requires on server subpackage (s/inetd/xinetd)
152
153* Sat Mar 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.49-1
154- updated to 0.49; patches added and revised based on Fedora 0.49-8
155- restored the config file for xinetd
156- s/BuildPreReq/BuildRequires/
157
158* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.42-4vl5
159- applied new versioning policy, spec in utf-8
160
161* Sat Apr 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-3vl1
162- rebuilt with readline 5.1
163- new upstream release
164- added patches from Fedora
165  * Mon Apr 10 2006 Radek Vok叩l <rvokal@redhat.com> 0.42-3
166  - show localtime instead of GMT (#172274)
167  * Wed Mar 22 2006 Radek Vok叩l <rvokal@redhat.com> 0.42-2
168  - fix double free error when hitting ^C (#186201)
169
170* Sat May 28 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-6vl1
171- updated to 0.40 based on Fedora
172  * Tue Apr 19 2005 Radek Vokal <rvokal@redhat.com> 0.40-6
173  - fix remap rules convert error <pjones@redhat.com>
174- changed tftp Group
175
176* Thu Jul 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.33-2vl1
177- updated to 0.33
178- rebuild with new toolchains
179- s/Copyright/License/
180- add BuildPreReq on tcp_wrappers (based on Rawhide)
181
182* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
183- 0.16-5vl1
184- use better macros (%%{_bindir},%%{_sbindir},%%{_mandir})
185- added Japanese summary and description
186
187* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
188- fix description
189
190* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
191- compress man pages (again).
192
193* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
194- man pages are compressed
195- fix description and summary
196
197* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
198- split client and server
199
200* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
201- update to 0.16.
202
203* Sat Aug 28 1999 Jeff Johnson <jbj@redhat.com>
204- update to 0.15.
205
206* Wed Apr  7 1999 Jeff Johnson <jbj@redhat.com>
207- tftpd should truncate file when overwriting (#412)
208
209* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
210- auto rebuild in the new build environment (release 22)
211
212* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
213- compile for 6.0.
214
215* Fri Aug  7 1998 Jeff Johnson <jbj@redhat.com>
216- build root
217
218* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
219- translations modified for de, fr, tr
220
221* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
222- added check for getpwnam() failure
223
224* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
225- initial build
Note: See TracBrowser for help on using the repository browser.