source: projects/specs/trunk/t/texmacro-otf/texmacro-otf-vl.spec @ 6070

Revision 6070, 8.2 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1%define tlversion       2011
2
3%define hirapropver     0.3
4%define kokanaver       1.0b2
5%define otfver          1.7
6%define otfbetaver      b5
7
8%define texmf           %{_datadir}/texmf
9%define texvf           %{texmf}/fonts/vf/public
10%define texofm          %{texmf}/fonts/ofm/public
11%define textfm          %{texmf}/fonts/tfm/public
12%define mapdir          %{texmf}/fonts/map/dvipdfm/otf
13%define build_texmf     %{buildroot}%{texmf}
14%define build_texvf     %{buildroot}%{texvf}
15%define build_texofm    %{buildroot}%{texofm}
16%define build_textfm    %{buildroot}%{textfm}
17%define build_mapdir    %{buildroot}%{mapdir}
18%define dvipdfmconfig   %{texmf}/dvipdfm/config
19
20%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
21%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys 2> /dev/null
22%define exec_updmap_otf [ -x %{_bindir}/updmap-otf ] && %{_bindir}/env - %{_bindir}/updmap-otf auto 2> /dev/null
23
24Summary: TeX Live macro packages for "VF for OpenType Fonts" by S. Saito
25Summary(ja): TeX Live で使うマクロパッケージ (齋藤修三郎氏による「OpenType Font用VF」)
26Name: texmacro-otf
27Version: %{otfver}
28Release: 3%{?otfbetaver:.%otfbetaver}%{?_dist_release}
29BuildArch: noarch
30
31Source0: http://psitau.kitunebi.com/otf%{version}%{?otfbetaver:%otfbetaver}.zip
32#Source1: http://psitau.at.infoseek.co.jp/hiraprop.zip
33Source1: hiraprop-%{hirapropver}.tar.bz2
34#Source2: http://psitau.at.infoseek.co.jp/kokana.zip
35Source2: kokana-%{kokanaver}.tar.bz2
36
37Source3: http://psitau.at.infoseek.co.jp/otfmanual.pdf
38Source4: http://psitau.at.infoseek.co.jp/kitunetuki.pdf
39Source5: http://psitau.at.infoseek.co.jp/meijinden.pdf
40
41#Source10: updmap-otf
42#NOTE: we renamed http://www.logic.at/people/preining/texlive/updmap-otf with updmap-otf.sh.v0.9.1
43Source10: updmap-otf.sh.v0.9.1
44# Source20: otf-noEmbed.map
45# Source21: otf-cktx.map
46
47Patch1: texmacro-otf-RmlGbm.patch
48
49URL: http://psitau.kitunebi.com/otf.html
50License: BSD
51Group:  Applications/Publishing
52BuildRequires: texlive = %{tlversion}
53BuildRequires: perl, nkf
54Requires:     texlive = %{tlversion}
55Requires:     ghostscript
56
57Buildroot:    %{_tmppath}/%{name}-%{version}-root
58
59Obsoletes: texlive-texmacro-otf <= 1.5.6.1
60
61Distribution: Vine Linux
62Vendor:       Project Vine
63
64%description
65TeX Live macro packages of VF for OpenType Fonts by SAITO Shuzaburo
66Users can use these macros on platex.
67Including
68        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
69        otfaltkana.sty redeffont.sty
70
71%description -l ja
72齋藤修三郎氏作成の TeX Live で用いる追加マクロパッケージです。
73LaTeX(pLaTeX2e)でOpen Type Fontを有効に利用するための
74VF およびスタイルファイルです。
75platex 上で利用できます。
76以下のマクロが含まれています。
77        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
78        otfaltkana.sty redeffont.sty
79
80%prep
81%setup -q -c -n %{name}-%{version} -a 1 -a 2
82
83##
84(cd otfbeta
85    chmod +x makeotf
86    %__sed -i -e "s/ovp2ovf/wovp2ovf/" mkjvf && chmod +x mkjvf || exit 1
87    for x in script/*.pl; do
88        %__sed -i -e "s/ovp2ovf/wovp2ovf/" $x && chmod +x $x || exit 1
89    done
90)
91
92## rename from pltotf to ppltotf
93%__sed -i -e "s,^pltotf,ppltotf,g" kokana-%{kokanaver}/makealtkana || exit 1
94
95%build
96
97###### otf #####
98(cd otfbeta
99./makeotf
100)
101
102###### kokana #####
103pushd kokana-%{kokanaver}
104nkf -be basepl/base-h.pl > base-h.pl
105nkf -be basepl/base-v.pl > base-v.pl
106%__mv -f base-[hv].pl basepl
107./makealtkana
108popd
109
110%install
111%__rm -rf %{buildroot}
112
113%__mkdir fontmap test pdf
114%__mkdir_p %{buildroot}%{_bindir}
115%__mkdir_p %{build_texmf}/tex/platex/otf
116#%__mkdir_p %{build_texmf}-var/updmap-otf
117%__mkdir_p %{build_texvf}/otf
118%__mkdir_p %{build_textfm}/otf
119%__mkdir_p %{build_mapdir}
120
121%__install -m 644 %{SOURCE3} %{SOURCE4} %{SOURCE5} pdf
122%__install -m 755 %{SOURCE10} %{buildroot}%{_bindir}/updmap-otf
123
124###### otfstable #####
125(cd otfbeta
126%__install -m 644 sty/* %{build_texmf}/tex/platex/otf
127%__install -m 644 vf/* %{build_texvf}/otf
128%__install -m 644 tfm/* %{build_textfm}/otf
129
130%__install -m 644 readme.txt ../readme-otf.txt
131%__install -m 644 test/*.tex ../test
132)
133
134###### hiraprop #####
135%__mkdir_p %{build_texmf}/tex/platex/hiraprop
136%__mkdir_p %{build_texvf}/hiraprop
137%__mkdir_p %{build_texofm}/hiraprop
138%__mkdir_p %{build_textfm}/hiraprop
139
140pushd hiraprop-%{hirapropver}
141%__install -m 644 sty/* %{build_texmf}/tex/platex/hiraprop
142%__install -m 644 vf/hiraprop/* %{build_texvf}/hiraprop
143%__install -m 644 ofm/hiraprop/* %{build_texofm}/hiraprop
144%__install -m 644 tfm/hiraprop/* %{build_textfm}/hiraprop
145
146%__install -m 644 *.tex ../test
147%__install -m 644 readme.txt ../readme-hiraprop.txt
148popd
149
150###### kokana #####
151pushd kokana-%{kokanaver}
152%__install -m 644 otfaltkana.sty %{build_texmf}/tex/platex/otf
153%__install -m 644 vf/* %{build_texvf}/otf
154%__install -m 644 tfm/* %{build_textfm}/otf
155
156%__install -m 644 sample/kokanatest.tex ../test
157%__install -m 644 readme.txt ../readme-kokana.txt
158popd
159
160
161%post
162%{exec_texhash}
163
164#%{exec_updmap}
165
166%{exec_updmap_otf}
167exit 0
168
169%postun
170if [ "$1" = 0 ]; then
171    #%__rm -rf %{texmf}-var/updmap-otf
172
173    %{exec_texhash}
174
175    %{exec_updmap}
176fi
177exit 0
178
179%clean
180%__rm -rf %{buildroot}
181
182%files
183%defattr(-,root,root)
184%doc readme* fontmap test pdf
185#%dir %{texmf}-var/updmap-otf
186%{_bindir}/updmap-otf
187%{texmf}/tex/platex/otf
188%{texmf}/tex/platex/hiraprop
189%{texvf}
190%{textfm}
191%{texofm}
192%{mapdir}
193
194%changelog
195* Sun Apr 15 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-3.b5
196- updated to 1.7b5
197
198* Sun Dec  4 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-2.b3
199- defined %%exec_texhash
200
201* Sat Nov 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.7-1.b3
202- new upstream release
203  - changed Url, License tags
204- TeX Linux 2011
205 
206* Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-4
207- fixed updmap-otf
208  - changed $$MAPDIR to $${TEXMF}/fonts/map/dvipdfm/otf
209
210* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-3
211- changed %%mapdir to %%{texmf}/fonts/map/dvipdfm/otf
212
213* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-2
214- added Obsoletes: texlive-texmacro-otf <= 1.5.6.1
215  - for TeX Live 2009 of VinePlus/5, supported texlive-texmacro-otf
216
217* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-1
218- new upstream release
219- TeX Linux 2009
220
221* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-3
222- added otf-ps-morisawax{-noEmbed}.map
223
224* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-2
225- spec in utf8
226
227* Tue Aug 05 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-1
228- applied new versioning policy
229
230* Sun Apr 07 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-0vl1
231- new upstream release
232
233* Sat May 27 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl2
234- updmap-otf v0.9: use noEmbed.map instead of noEmbeddedFont.map
235
236* Fri May 12 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl1
237- resync with ptetex3-20060506
238
239* Sun Nov 06 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl3
240- resync with ptetex3-20051102
241
242* Wed Aug 31 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl2
243- resync with ptetex3-20050830
244
245* Sat Jun 18 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl1
246- source update
247- modified for teTeX3
248
249* Thu Feb 03 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.6-0vl1
250- source update
251
252* Thu Jan 20 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.5-0vl1
253- source update
254
255* Sun Nov 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl5
256- updmap-0.7
257
258* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl4
259- updmap-0.6
260
261* Mon Oct 11 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl3
262- updmap-0.5
263
264* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl2
265- fixed updmap
266
267* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl1
268- source update
269- updmap-0.4
270
271* Thu Apr 08 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl4
272- update updmap-otf: take over before setting in "auto" target
273- remove requires texmacro-sfujita
274
275* Sat Apr 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl3
276- fix postun
277
278* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl2
279- drop extrafonts and added hiraprop
280- update updmap-otf and *-udvips.map
281
282* Sun Mar 28 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl1
283- source update
284- added updmap-otf
285
286* Wed Feb 04 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.9-0vl1
287- first release
Note: See TracBrowser for help on using the repository browser.