source: projects/specs/trunk/t/texmacro-ipsj/texmacro-ipsj-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
2%define texmf           %{_datadir}/texmf
3%define build_texmf     %{buildroot}%{texmf}
4
5%define altplatex       platex --kanji=euc
6%define makepdf(%1)     %altplatex %1 && %altplatex %1 && %altplatex %1 && dvipdfmx %1;
7
8%define reldate 20090225
9
10Summary: teTeX macro packages of writing manuscript for the Information Processing Society of Japan
11Summary(ja): teTeX で使うマクロパッケージ 情報処理学会論文原稿作成用
12Name: texmacro-ipsj
13Version: 1.0.%{reldate}
14Release: 1%{?_dist_release}
15BuildArch: noarch
16#Source0: ftp://ftp.ipsj.or.jp/pub/toukou/ipsj-sty-unix.tgz
17Source0: ftp://ftp.ipsj.or.jp/pub/toukou/ipsj-unix.tgz
18URL: http://www.ipsj.or.jp/08editt/journal/shippitsu/wabun.html
19License: distributable
20Group:  Applications/Publishing
21BuildPrereq: tetex
22Buildroot: %{_tmppath}/%{name}-%{version}-root
23
24Distribution: Vine Linux
25Vendor: Project Vine
26
27%description
28teTeX macro packages of writing manuscript for the
29Information Processing Society of Japan.
30Users can use this macro specifying "ipsjpapers" class.
31
32Including
33        ipsjcommon.sty
34        ipsjdrafts.sty
35        ipsjpapers.cls
36        ipsjpapers.sty
37        ipsjsort-e.bst
38        ipsjsort.bst
39        ipsjunsrt-e.bst
40        ipsjunsrt.bst     
41
42%description -l ja
43情報処理学会論文原稿作成用の teTeX 追加マクロパッケージです。
44ipsjpapers クラスを指定して使用します。
45
46このパッケージには以下のマクロが含まれています。
47        ipsjcommon.sty
48        ipsjdrafts.sty
49        ipsjpapers.cls
50        ipsjpapers.sty
51        ipsjsort-e.bst
52        ipsjsort.bst
53        ipsjunsrt-e.bst
54        ipsjunsrt.bst     
55
56%prep
57%setup -q -c -n %{name}-%{version}/
58
59%build
60
61pushd ipsj_UNIX
62
63for i in sample dsample esample desample ; do
64    %makepdf $i
65done
66
67popd
68
69%__rm -f *.{aux,dvi,log,toc,bbl,blg,end}
70
71cd -
72
73%install
74%__rm -rf %{buildroot}
75
76%__mkdir_p %{build_texmf}/ptex/platex/ipsj
77%__mkdir_p %{build_texmf}/bibtex/bst/ipsj
78
79%__install -p -m644 ipsj_UNIX/*.{cls,sty} %{build_texmf}/ptex/platex/ipsj
80%__install -p -m644 ipsj_UNIX/*.bst %{build_texmf}/bibtex/bst/ipsj
81
82%post
83%{exec_texhash}
84exit 0
85
86%postun
87%{exec_texhash}
88exit 0
89
90%clean
91%__rm -rf %{buildroot}
92
93%files
94%defattr(-,root,root)
95%doc ipsj_UNIX/README ipsj_UNIX/*.{tex,bib,pdf}
96%{texmf}/ptex/platex/ipsj
97%{texmf}/bibtex/bst/ipsj
98
99%changelog
100* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.20090225-1
101- update source to 20090225
102- new versioning policy
103- spec in utf8
104
105* Thu Dec 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.20060418-0vl1
106- update source to 20060418
107- use release date as micro version
108
109* Sat Jun 25 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0-0vl5
110- update source
111- update source-URL
112- docs
113  - compile only with native mode
114  - convert to pdf instead of ps
115
116* Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0-0vl4
117- s/Copyright/License/
118- update URL
119- use %%{_bindir} instead of %%{_prefix}/bin
120- use %%{_datadir} instead of %%{_prefix}/share
121- compile {sample,esample}.tex with platex209
122- fix desample2e.tex to include esample.tex (Patch0)
123
124* Thu Jan 30 2003 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl3
125- fix file access permissions
126- use %%{texmf} at %%files instead of /usr/share/texmf
127
128* Sat Jan 18 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl2
129- compile docs
130
131* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl1
132- first release
Note: See TracBrowser for help on using the repository browser.