source: projects/specs/trunk/t/texmacro-ieice/texmacro-ieice-vl.spec @ 6287

Revision 6287, 4.2 KB checked in by munepi, 12 years ago (diff)

updated texmacro-ieice-vl.spec

Line 
1%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
2%define texmf           %{_datadir}/texmf
3%define build_texmf     %{buildroot}%{texmf}
4
5%define altplatex       platex --kanji=utf8
6%define makepdf(%1)     %altplatex %1 && %altplatex %1 && %altplatex %1 && dvipdfmx %1;
7
8Summary: TeX Live macro packages of writing manuscript for the Institute of Electronics, Information and Communication Engineers
9Summary(ja): TeX Live で使うマクロパッケージ 電子情報通信学会論文原稿、技術研究報告作成用
10Name: texmacro-ieice
11Version: 1.6
12Release: 1%{?_dist_release}
13BuildArch: noarch
14Source0: http://www.ieice.org/ftp/tex/ieicej/LaTeX2e/ieicej1.6a.tgz
15Source1: http://www.ieice.org/ftp/tex/ieice/LaTeX2e/ieice1.8.tgz
16URL: http://www.ieice.org/ftp/
17License: distributable
18Group: Applications/Publishing
19BuildRequires: texlive-common
20Requires: texlive-common
21Requires(post): texlive
22Requires(postun): texlive
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24
25Distribution: Vine Linux
26Vendor: Project Vine
27
28%description
29TeX Live macro packages of writing manuscript for the
30Institute of Electronics, Information and Communication Engineers.
31Users can use this macro specifying "ieicej" class (in Japanese)
32or "ieice" class (in English).
33Including
34        ieice.cls  1.8
35        ieicej.cls 1.6a
36
37%description -l ja
38電子情報通信学会の技術研究報告(研究会発表論文)和・英論文誌 原稿作成用
39の TeX Live で用いる追加マクロパッケージです。
40和文は ieicej クラスを、英文は ieice クラスを指定します。
41以下のマクロが含まれています
42        ieice.cls  1.8
43        ieicej.cls 1.6a
44
45
46%prep
47%setup -T -c %{name}-%{version}
48
49tar xzf %{SOURCE0}
50%__mv ieicej1.6a/UNIXEUC jp
51%__rm -rf ieicej1.6a
52
53tar xzf %{SOURCE1}
54%__mv ieice1.8/UNIXEUC en
55%__rm -rf ieice1.8
56
57%build
58
59(cd jp
60    for x in *.cls *.tex readme.1st *.bst; do
61        nkf -w --overwrite ${x} || exit 1
62    done
63    for i in *.tex; do
64        ft=$(basename ${i} .tex)
65        # if [ "${ft}" != "chklist" -a "${ft}" != "template" ]; then
66        #     # %__sed -i -e "s/\documentclass\[\(.*\)\]{ieicej}/\documentclass\[\1,tombo\]{ieicej}/" -e "s/\documentclass{ieicej}/\documentclass\[tombo\]{ieicej}/" ${i} || exit 1
67        #     # %__sed -i -e "s/\documentclass\[\(.*\)\]{ieicej}/\documentclass\[\1,mentuke\]{ieicej}/" -e "s/\documentclass{ieicej}/\documentclass\[mentuke\]{ieicej}/" ${i} || exit 1
68        # fi
69        %makepdf ${ft}
70        ##!! override to fix paper size/position
71    done
72)
73
74(cd en
75    for x in *.cls *.tex ; do
76        nkf -w --overwrite ${x} || exit 1
77    done
78    for i in *.tex; do
79        ft=$(basename ${i} .tex)
80        %makepdf ${ft}
81    done
82)
83
84
85%install
86%__rm -rf %{buildroot}
87
88%__mkdir_p %{build_texmf}/ptex/platex/ieice
89%__cp -a */*.cls %{build_texmf}/ptex/platex/ieice
90
91%__mkdir_p %{build_texmf}/bibtex/bst/ieice
92%__cp -a */*.bst %{build_texmf}/bibtex/bst/ieice
93
94%post
95%{exec_texhash}
96exit 0
97
98%postun
99%{exec_texhash}
100exit 0
101
102%clean
103%__rm -rf %{buildroot}
104
105%files
106%defattr(-,root,root)
107%doc jp/*.{tex,pdf} jp/readme.1st
108%doc en/*.{tex,pdf} en/readme-e.1st
109%{texmf}/ptex/platex/ieice
110%{texmf}/bibtex/bst/ieice
111
112
113%changelog
114* Thu Jun  7 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.6-1
115- merged the following changes <BTS:wishes:307>;
116  Thanks to Masaki Kawamura <kawamura@is.sci.yamaguchi-u.ac.jp>
117  - update sources: ieicej1.6a.tgz and ieice1.8.tgz
118  - convert EUC to UTF8 for ieicej.cls
119
120* Thu Jun 07 2012  1.6-1
121- change %%{texmf} from %%{_datadir}/texmf to %%{_datadir}/texmf-local
122
123* Sun Jul 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5-2
124- TeX Live 2009
125
126* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.5-1
127- update sources
128- new versioning policy
129- spec in utf8
130
131* Tue Apr 27 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3-0vl1
132- update sources
133- drop tech_2e_euc.tgz
134- drop BuildRequires: nkf
135- install ieicetr.bst
136- s/Copyright/License/
137- use %%{_bindir} instead of %%{_prefix}/bin
138- use %%{_datadir} instead of %%{_prefix}/share
139
140* Thu Jan 30 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl2
141- fix file access permissions
142- use %%{texmf} at %%files instead of /usr/share/texmf
143
144* Sat Jan 18 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl1
145- update Source2
146
147* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl1
148- first release
Note: See TracBrowser for help on using the repository browser.