source: projects/specs/trunk/t/texmacro-ieice/texmacro-ieice-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
2%define texmf           %{_datadir}/texmf
3%define build_texmf     %{buildroot}%{texmf}
4
5%define altplatex       platex --kanji=euc
6%define makepdf(%1)     %altplatex %1 && %altplatex %1 && %altplatex %1 && dvipdfmx %1;
7
8Summary: teTeX macro packages of writing manuscript for the Institute of Electronics, Information and Communication Engineers
9Summary(ja): teTeX で使うマクロパッケージ 電子情報通信学会論文原稿、技術研究報告作成用
10Name: texmacro-ieice
11Version: 1.5
12Release: 1%{?_dist_release}
13BuildArch: noarch
14Source0: http://www.ieice.org/ftp/tex/ieicej/LaTeX2e/ieicej15.tar.gz
15Source1: http://www.ieice.org/ftp/tex/ieice/LaTeX2e/latex2e.tar.gz
16URL: http://www.ieice.org/ftp/
17License: distributable
18Group: Applications/Publishing
19BuildRequires: tetex
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21
22Distribution: Vine Linux
23Vendor: Project Vine
24
25%description
26teTeX macro packages of writing manuscript for the
27Institute of Electronics, Information and Communication Engineers.
28Users can use this macro specifying "ieicej" class (in Japanese)
29or "ieice" class (in English).
30Including
31        ieice.cls
32        ieicej.cls
33
34%description -l ja
35電子情報通信学会の技術研究報告(研究会発表論文)和・英論文誌 原稿作成用
36の teTeX で用いる追加マクロパッケージです。
37和文は ieicej クラスを、英文は ieice クラスを指定します。
38以下のマクロが含まれています
39        ieice.cls
40        ieicej.cls
41
42
43%prep
44%setup -T -c %{name}-%{version}
45
46tar xzf %{SOURCE0}
47mv ieicej15/UNIXEUC jp
48rm -rf ieicej15
49
50tar xzf %{SOURCE1}
51mv latex2e/UNIXEUC en
52rm -rf latex2e
53
54%build
55
56( cd jp
57for i in readme tecrep chklist ; do
58        # platex $i
59        # platex $i
60        # dvips $i
61        %makepdf $i
62        rm -f *.{aux,dvi,log}
63done )
64
65( cd en
66for i in readme-e readme-j ; do
67        # platex $i
68        # platex $i
69        # dvips $i
70        %makepdf $i
71        rm -f *.{aux,dvi,log}
72done )
73
74%install
75rm -rf %{buildroot}
76
77#InstallClass(){
78#target=$1; shift
79#(cd $target
80#bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
81#rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
82#if [ -f src/$target.ins ]; then
83#    cp src/* .
84#fi
85#latex $target.ins
86#mkdir -p %{build_texmf}/tex/latex/$target
87#cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
88#if [ ! -z "$*" ]; then
89#    cp -d $* %{build_texmf}/tex/latex/$target || :
90#fi
91#if [ -n "`ls *.bst`" ]; then
92#    mkdir -p %{build_texmf}/bibtex/bst/$target
93#    cp *.bst %{build_texmf}/bibtex/bst/$target || :
94#fi
95#)
96#}
97#
98#mkdir -p %{build_texmf}/packages/
99
100mkdir -p %{build_texmf}/ptex/platex/ieice
101mv */*.cls %{build_texmf}/ptex/platex/ieice
102
103mkdir -p %{build_texmf}/bibtex/bst/ieice
104mv en/*.bst %{build_texmf}/bibtex/bst/ieice
105
106%post
107%{exec_texhash}
108exit 0
109
110%postun
111%{exec_texhash}
112exit 0
113
114%clean
115rm -rf %{buildroot}
116
117%files
118%defattr(-,root,root)
119%doc jp
120%doc en
121%{texmf}/ptex/platex/ieice
122%{texmf}/bibtex/bst/ieice
123
124
125%changelog
126* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.5-1
127- update sources
128- new versioning policy
129- spec in utf8
130
131* Tue Apr 27 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3-0vl1
132- update sources
133- drop tech_2e_euc.tgz
134- drop BuildRequires: nkf
135- install ieicetr.bst
136- s/Copyright/License/
137- use %%{_bindir} instead of %%{_prefix}/bin
138- use %%{_datadir} instead of %%{_prefix}/share
139
140* Thu Jan 30 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl2
141- fix file access permissions
142- use %%{texmf} at %%files instead of /usr/share/texmf
143
144* Sat Jan 18 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl1
145- update Source2
146
147* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl1
148- first release
Note: See TracBrowser for help on using the repository browser.