source: projects/specs/trunk/t/texmacro-his/texmacro-his-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define exec_texhash    [ -x %{_prefix}/bin/texhash ] && /usr/bin/env - %{_prefix}/bin/texhash 2> /dev/null
2%define texmf           %{_prefix}/share/texmf
3%define build_texmf     %{buildroot}%{texmf}
4
5%define altplatex       platex --kanji=euc
6%define makepdf(%1)     %altplatex %1 && %altplatex %1 && %altplatex %1 && dvipdfmx %1;
7
8Summary: teTeX macro packages of writing manuscript for the Transactions of Human Interface Society
9Summary(ja): tetex で使うマクロパッケージ ヒューマンインタフェース学会論文原稿作成用
10Name: texmacro-his
11Version: 1.0
12Release: 3%{?_dist_release}
13BuildArch: noarch
14Source0: http://www.his.gr.jp/download/paper/latex2e-euc/hisset.tar.gz
15Source1: http://www.his.gr.jp/download/meeting/latex2e-euc/hiskenset2e.tar.gz
16# hissympset.gz は hissympset.tar.gz にリネームしてあります.
17# Source2: http://www.his.gr.jp/download/his/latex2e-euc/hissympset.gz
18Source2: http://www.his.gr.jp/download/his/latex2e-euc/hissympset.tar.gz
19URL: http://www.his.gr.jp/download/index.html
20License: distributable
21Group:  Applications/Publishing
22BuildPrereq: tetex
23Buildroot: %{_tmppath}/%{name}-root
24
25Distribution: Vine Linux
26Vendor: Project Vine
27
28%description
29teTeX macro packages of writing manuscript for the journal of
30the Transactions of Human Interface Society
31Users can use this macro specifying "his" class (in Japanese)
32or "ehis"  class (in English).
33Including the following class files:
34        his.cls
35        ehis.cls
36        hisken.cls
37        ehisken.cls
38        hissymp.cls
39        ehissymp.cls
40
41%description -l ja
42ヒューマンインタフェース学会論文原稿作成用の tetex で用いる追加マクロパッケージです.
43his クラスを指定して使用します。
44英文は ehis クラスを指定します。
45以下のクラスファイルが含まれています。
46        his.cls
47        ehis.cls
48        hisken.cls
49        ehisken.cls
50        hissymp.cls
51        ehissymp.cls
52
53%prep
54%setup -q -c -n %{name}-%{version} -a 1 -a 2
55
56%build
57
58(cd hisset
59sed -i s/dviout/dvips/ format.tex
60%makepdf format
61)
62(cd hiskenset_2eeuc
63%makepdf ken
64)
65(cd hissympset_euc
66%makepdf symptebiki
67)
68
69%install
70rm -rf %{buildroot}
71
72#InstallClass(){
73#target=$1; shift
74#(cd $target
75#bzip2 -dc ${RPM_SOURCE_DIR}/$target.tar.bz2 | tar xf - -C %{build_texmf}/packages/
76#rm %{build_texmf}/packages/$target/*.{ins,def,bst,rtx,sty,cls,ltx,fnt,cyr,fdd} || :
77#if [ -f src/$target.ins ]; then
78#    cp src/* .
79#fi
80#latex $target.ins
81#mkdir -p %{build_texmf}/tex/latex/$target
82#cp *.{ldf,sty,def,cls,rtx} %{build_texmf}/tex/latex/$target || :
83#if [ ! -z "$*" ]; then
84#    cp -d $* %{build_texmf}/tex/latex/$target || :
85#fi
86#if [ -n "`ls *.bst`" ]; then
87#    mkdir -p %{build_texmf}/bibtex/bst/$target
88#    cp *.bst %{build_texmf}/bibtex/bst/$target || :
89#fi
90#)
91#}
92#
93#mkdir -p %{build_texmf}/packages/
94
95%__mkdir_p %{build_texmf}/ptex/platex/his
96%__cp -af */*.cls %{build_texmf}/ptex/platex/his/
97
98%post
99%{exec_texhash}
100exit 0
101
102%postun
103%{exec_texhash}
104exit 0
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(-,root,root)
111%doc */*.{tex,pdf} hisset/fig1.* hissympset_euc/fig1.bb
112%{texmf}/ptex/platex/his/
113
114%changelog
115* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3
116- source update as his.cls Version 1.0 2006-12-15
117- new versioning policy
118- spec in utf8
119- s/Copyright/License/
120
121* Sat Jan 18 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl2
122- update as of 2002.12.6
123
124* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl1
125- first release
Note: See TracBrowser for help on using the repository browser.