source: projects/specs/trunk/t/texlive-sources/texlive-sources-vl.spec @ 1533

Revision 1533, 3.0 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2%define texlivesrcver   20091107
3%define texlivever      20091107
4
5%define texlivedir      %{_datadir}/texlive
6%define build_texlive_src       %{buildroot}%{texlivedir}-sources
7
8%define pkgname         texlive
9
10%define __find_provides %{nil}
11%define __find_requires %{nil}
12%define __perl_provides %{nil}
13%define __perl_requires %{nil}
14
15Summary: A collection of sources for TeX Live packages
16Summary(ja): TeX Live のソース集
17Name: texlive-sources
18Version: 2009
19Release: 1%{?_dist_release}
20License: distributable
21Group: Applications/Publishing
22URL: http://www.tug.org/texlive/
23
24## original TeX Live sources
25Source1: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivesrcver}-source.tar.xz
26Source2: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-texmf.tar.xz
27Source3: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-extra.tar.xz
28# Source4: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-bin.tar.xz
29
30# ## from texlive2009.iso:/tlpkg/texlive.tlpdb
31# Source10: texlive2009.tlpdb
32
33%{?nosrc:NoSource: 1}
34%{?nosrc:NoSource: 2}
35%{?nosrc:NoSource: 3}
36
37BuildRequires: tar
38%if %{?_dist_release} == "vl6"
39BuildRequires: xz
40%endif
41%if %{?_dist_release} == "vl5"
42BuildRequires: lzma
43%endif
44
45BuildArch:      noarch
46BuildRoot:      %{_tmppath}/%{name}-%{version}-root
47
48Vendor:       Project Vine
49Distribution: Vine Linux
50Packager:     munepi
51
52%description
53This package is a collection of sources for TeX Live packages.
54It contains
55  %{pkgname}-%{texlivesrcver}-source.tar.xz,
56  %{pkgname}-%{texlivever}-texmf.tar.xz,
57  %{pkgname}-%{texlivever}-extra.tar.xz
58on ftp://tug.org/historic/systems/texlive/2009/.
59
60This package is used to build texlive package and its related packages
61of Vine Linux.
62
63
64%description -l ja
65このパッケージは TeX Live のソース集です。
66ftp://tug.org/historic/systems/texlive/2009/ 上の
67  %{pkgname}-%{texlivesrcver}-source.tar.xz,
68  %{pkgname}-%{texlivever}-texmf.tar.xz,
69  %{pkgname}-%{texlivever}-extra.tar.xz
70を含んでいます。
71
72このパッケージは Vine Linux の texlive パッケージやその関連パッケージを
73ビルドするために使われます。
74
75
76%prep
77[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
78
79%build
80
81%install
82[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
83
84%__mkdir_p %{build_texlive_src}
85(cd %{build_texlive_src}
86    %__mkdir_p source || exit 1
87    %__install -m0644 %{SOURCE1} source/ || exit 1
88
89    %__tar Jxf %{SOURCE2} || exit 1
90    %__mv %{pkgname}-%{texlivever}-texmf/* . || exit 1
91    %__tar Jxf %{SOURCE3}  || exit 1
92    %__mv %{pkgname}-%{texlivever}-extra/* . || exit 1
93
94    # %__mkdir_p tlpkg || exit 1
95    # %__install -m0644 %{SOURCE10} tlpkg/texlive.tlpdb || exit 1
96
97    %__rm -r %{pkgname}-%{texlivever}-{texmf,extra} || exit 1
98)
99
100%clean
101%__rm -rf %{buildroot}
102
103%files
104%defattr(-,root,root)
105%{texlivedir}-sources
106
107%changelog
108* Sun May 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
109- TeX Live 2009
110
Note: See TracBrowser for help on using the repository browser.