source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 8476

Revision 8476, 10.3 KB checked in by munepi, 10 years ago (diff)

TeX Live 2014

Line 
1## -*- coding: utf-8-unix -*-
2%define jlisting_ver    0.2
3%define bkmk2uni        convert-bkmk2uni
4
5%define list_macros \
6        jlisting-%{jlisting_ver}
7
8Summary:        A collection of useful macro packages for TeX Live
9Summary(ja):    TeX Live の便利なマクロパッケージ集
10Name:           texlive-macros
11Version:        2014
12Release:        1%{?_dist_release}
13License:        distributable
14Group:          Applications/Publishing
15
16## Vine Linux
17
18## jlisting
19Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
20
21## misc
22Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
23Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
24
25#Requires:      perl
26Requires:       texlive-common = %{version}
27BuildRequires:  texlive-vtlpkg = %{version}
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildArch: noarch
31
32Obsoletes:      tetex-macros
33Obsoletes:      pLaTeX2e_Macros
34
35Distribution:   Vine Linux
36Vendor:         Project Vine
37Packager:       munepi
38
39
40%description
41A collection of useful macro packages for texlive package, including
42  jlisting
43  jtygm.sty
44  cmex.enc
45
46# This package contained a perl script
47#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
48
49%description -l ja
50TeX Live の便利なマクロパッケージ集です。
51以下のマクロを収録しています。
52  jlisting
53  jtygm.sty
54  cmex.enc
55
56# このパッケージには prosper, powerdot 用に
57# PDF ブックマークの文字化けを修正するための perl スクリプト
58#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
59# を同梱しています.
60
61%prep
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
63
64%build
65
66%install
67%__rm -rf %{buildroot}
68
69# nkf --utf8 %{SOURCE25} | \
70#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
71#     %{buildroot}%{_bindir}/%{bkmk2uni}
72# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
73
74## install jlisting
75%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
76%__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
77bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
78
79## install jtygm.sty
80%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
81%__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
82## install cmex.enc
83%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
84%__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
85
86%post
87%_tl_touch_run texhash
88exit 0
89
90%postun
91if [ "$1" = 0 ]; then
92   %_tl_touch_run texhash
93fi
94exit 0
95
96%posttrans
97%{_tl_exec_texhash}
98exit 0
99
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106#%{_bindir}/%{bkmk2uni}
107%{_tl_texmfvine}/tex/latex/jlisting
108%{_tl_texmfvine}/tex/platex/base/jtygm.sty
109%{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
110
111%changelog
112* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
113- TeX Live 2014
114
115* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
116- rebuilt
117
118* Sun Nov  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
119- s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
120
121* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
122- TeX Live 2013
123- dropped jsclasses: texlive-collection-langcjk provides jsclasses
124- dropped kanjifonts-3.1: obsolete
125
126* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
127- TeX Live 2012
128
129* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
130- move jlisting package to %%{texmf}/tex/latex/jlisting
131
132* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
133- updated jsclasses to 110510
134  - mistook to change %%jsclasses_ver at 2011-1
135
136* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
137- TeX Live 2011
138- updated jsclasses to 110510
139
140* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
141- dropped BuildRequires: jvf
142- for vl5, added Conflicts: tetex-macros
143
144* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
145- removed %%{exec_updmap} in %%post and %%postun
146
147* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
148- ported from tetex-macros-3.0-7
149- TeX Live 2009
150
151* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
152- added BuildRequires: unzip
153- updated jsclasses to 090826
154- updated pict2e to 0.2x
155
156* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
157- dropped epsbox.sty, eclepsf.sty
158  (bacause there style files for platex209 are obsolete)
159
160* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
161- added jlisting v0.2
162- defined list_macros
163  - used %%{list_macros} in %%description and %%description -l ja
164
165* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
166- dropped convert-euc.txt
167
168* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
169- updated prosper
170  - added some contrib themes from CTAN
171  - added prosper.cls v1.6 from CVS HEAD
172  - added a perl script: convert-euc.txt
173- added powerdot v1.3
174  - added xkeyval v2.5d
175- added beamer v3.07
176  - added pgf v2.00
177- added pict2e v0.2w
178
179* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
180- updated jsclasses to 20090222
181- updated jsclasses/index.html to 2009-02-22
182- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
183
184* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
185- applied new versioning policy, spec in utf-8
186
187* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
188- update jsclasses/index.html to 2006-11-06.
189
190* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
191- update jsclasses/index.html to 2006-02-12.
192
193* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
194- update jsclasses/index.html to 2005-10-26.
195
196* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
197- update jsclasses/index.html to 2005-4-30.
198- added breqn
199
200* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
201- update jsclasses/index.html to 2004-12-29.
202
203* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
204- add missing files in kanjifonts-3.0
205
206* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
207- update to kanjifonts.sty-3.0.
208
209* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
210- update jsclasses/index.html to 2004-11-03.
211
212* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
213- update jsclasses/index.html to 2004-09-27.
214
215* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
216- update jsclasses/index.html to 2004-02-25.
217- added eclepsf.sty.
218- removed epsf.sty (symlink to epsbox.sty).
219- removed geometry, which is in tetex-2.0.
220
221* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
222- update jsclasses/index.html to 2003-04-18.
223- added morisawa.dvi.
224
225* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
226- update jsclasses/index.html to 2003-03-06
227
228* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
229- remove natbib, which is in tetex-2.0
230- let version number same as tetex
231- added Requires: tetex
232
233* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
234- update jsclasses/index.html to 2003-01-16
235
236* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
237- update jsclasses to 2003-01-05
238- update index.html to 2003-01-12
239
240* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
241- update jsclasses and index.html to 2002-11-27
242
243* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
244- update jsclasses and index.html to 2002-11-01
245
246* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
247- oops, packager was incorrect
248
249* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
250- update jsclasses to 2002-06-29
251- update index.html to 2002-07-03
252
253* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
254- update jsclasses to 2002-04-21
255- update index.html to 2002-04-09
256
257* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
258- added MORISAWA basic 5 fonts
259
260* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
261- update to kanjifonts-1.1
262
263* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
264- update jsclasses and index.html to 2002-02-07
265
266* Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
267- update jsclasses and index.html to 2002-01-27
268- fix typo in changelog
269
270* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
271- update jsclasses and index.html to 2002-01-18
272
273* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
274- update index.html (jsclasses)
275
276* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
277- update jsclasses to 2001-11-29
278
279* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
280- fixed spec file for Prosper and jsclasses
281- use RPM macro in %files
282- added BuildPrereq: jvf
283
284* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
285- move revtex4 to texmacro-aps package
286
287* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
288- added prosper jsclasses
289
290* Thu Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
291- added revtex4 natbib
292
293* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
294- remove prereq tetex to avoid dependency-loop
295
296* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
297- tetex-macros-1.0-0vl1
298
299* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
300- 2.0-2
301- added kanjifonts-1.0 and removed jisfontsmetric
302
303* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
304- 2.0-1
305- install ldf in babel
306
307* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
308- added jisfontmetric.tex
309
310* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
311- change group.
312
313* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
314- added babel
315
316* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
317- added hoekwater
318
319* Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
320- added psfrag
321
322* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
323- added psnfss
324- Change directory tree according to the suggestion by Dr.Okumura.
325- remove many files from packages directory except documentations
326- disable mktexlsr and erase ls-R
327
328* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
329- added url.sty
330
331* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
332- pLaTeX2e_Macros-1-2
333- added fancyhdr.sty, boxedminipage.sty
334- added graphics.cfg, color.cfg (use dvips as default)
335- symlink from epsbox to epsf
336
337* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
338- pLaTeX2e_Macros-1-1
339  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
340- added def files of graphics
341- added tools and hyperref
342- check the existence of mktexlsr
343
344* Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
345- buildarch: noarch
346- added requires
347
348* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
349- tiny bug fix and add %defattr
350
351* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
352- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.