source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 8176

Revision 8176, 10.2 KB checked in by munepi, 10 years ago (diff)

rebuilt

Line 
1## -*- coding: utf-8-unix -*-
2%define jlisting_ver    0.2
3%define bkmk2uni        convert-bkmk2uni
4
5%define list_macros \
6        jlisting-%{jlisting_ver}
7
8Summary:        A collection of useful macro packages for TeX Live
9Summary(ja):    TeX Live の便利なマクロパッケージ集
10Name:           texlive-macros
11Version:        2013
12Release:        3%{?_dist_release}
13License:        distributable
14Group:          Applications/Publishing
15
16## Vine Linux
17
18## jlisting
19Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
20
21## misc
22Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
23Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
24
25#Requires:      perl
26Requires:       texlive-common = %{version}
27BuildRequires:  texlive-vtlpkg = %{version}
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildArch: noarch
31
32Obsoletes:      tetex-macros
33Obsoletes:      pLaTeX2e_Macros
34
35Distribution:   Vine Linux
36Vendor:         Project Vine
37Packager:       munepi
38
39
40%description
41A collection of useful macro packages for texlive package, including
42  jlisting
43  jtygm.sty
44  cmex.enc
45
46# This package contained a perl script
47#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
48
49%description -l ja
50TeX Live の便利なマクロパッケージ集です。
51以下のマクロを収録しています。
52  jlisting
53  jtygm.sty
54  cmex.enc
55
56# このパッケージには prosper, powerdot 用に
57# PDF ブックマークの文字化けを修正するための perl スクリプト
58#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
59# を同梱しています.
60
61%prep
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
63
64%build
65
66%install
67%__rm -rf %{buildroot}
68
69# nkf --utf8 %{SOURCE25} | \
70#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
71#     %{buildroot}%{_bindir}/%{bkmk2uni}
72# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
73
74## install jlisting
75%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
76%__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
77bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
78
79## install jtygm.sty
80%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
81%__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
82## install cmex.enc
83%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
84%__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
85
86%post
87%_tl_touch_run texhash
88exit 0
89
90%postun
91if [ "$1" = 0 ]; then
92   %_tl_touch_run texhash
93fi
94exit 0
95
96%posttrans
97%{_tl_exec_texhash}
98exit 0
99
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106#%{_bindir}/%{bkmk2uni}
107%{_tl_texmfvine}/tex/latex/jlisting
108%{_tl_texmfvine}/tex/platex/base/jtygm.sty
109%{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
110
111%changelog
112* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
113- rebuilt
114
115* Sun Nov  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
116- s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
117
118* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
119- TeX Live 2013
120- dropped jsclasses: texlive-collection-langcjk provides jsclasses
121- dropped kanjifonts-3.1: obsolete
122
123* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
124- TeX Live 2012
125
126* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
127- move jlisting package to %%{texmf}/tex/latex/jlisting
128
129* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
130- updated jsclasses to 110510
131  - mistook to change %%jsclasses_ver at 2011-1
132
133* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
134- TeX Live 2011
135- updated jsclasses to 110510
136
137* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
138- dropped BuildRequires: jvf
139- for vl5, added Conflicts: tetex-macros
140
141* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
142- removed %%{exec_updmap} in %%post and %%postun
143
144* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
145- ported from tetex-macros-3.0-7
146- TeX Live 2009
147
148* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
149- added BuildRequires: unzip
150- updated jsclasses to 090826
151- updated pict2e to 0.2x
152
153* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
154- dropped epsbox.sty, eclepsf.sty
155  (bacause there style files for platex209 are obsolete)
156
157* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
158- added jlisting v0.2
159- defined list_macros
160  - used %%{list_macros} in %%description and %%description -l ja
161
162* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
163- dropped convert-euc.txt
164
165* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
166- updated prosper
167  - added some contrib themes from CTAN
168  - added prosper.cls v1.6 from CVS HEAD
169  - added a perl script: convert-euc.txt
170- added powerdot v1.3
171  - added xkeyval v2.5d
172- added beamer v3.07
173  - added pgf v2.00
174- added pict2e v0.2w
175
176* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
177- updated jsclasses to 20090222
178- updated jsclasses/index.html to 2009-02-22
179- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
180
181* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
182- applied new versioning policy, spec in utf-8
183
184* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
185- update jsclasses/index.html to 2006-11-06.
186
187* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
188- update jsclasses/index.html to 2006-02-12.
189
190* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
191- update jsclasses/index.html to 2005-10-26.
192
193* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
194- update jsclasses/index.html to 2005-4-30.
195- added breqn
196
197* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
198- update jsclasses/index.html to 2004-12-29.
199
200* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
201- add missing files in kanjifonts-3.0
202
203* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
204- update to kanjifonts.sty-3.0.
205
206* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
207- update jsclasses/index.html to 2004-11-03.
208
209* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
210- update jsclasses/index.html to 2004-09-27.
211
212* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
213- update jsclasses/index.html to 2004-02-25.
214- added eclepsf.sty.
215- removed epsf.sty (symlink to epsbox.sty).
216- removed geometry, which is in tetex-2.0.
217
218* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
219- update jsclasses/index.html to 2003-04-18.
220- added morisawa.dvi.
221
222* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
223- update jsclasses/index.html to 2003-03-06
224
225* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
226- remove natbib, which is in tetex-2.0
227- let version number same as tetex
228- added Requires: tetex
229
230* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
231- update jsclasses/index.html to 2003-01-16
232
233* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
234- update jsclasses to 2003-01-05
235- update index.html to 2003-01-12
236
237* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
238- update jsclasses and index.html to 2002-11-27
239
240* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
241- update jsclasses and index.html to 2002-11-01
242
243* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
244- oops, packager was incorrect
245
246* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
247- update jsclasses to 2002-06-29
248- update index.html to 2002-07-03
249
250* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
251- update jsclasses to 2002-04-21
252- update index.html to 2002-04-09
253
254* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
255- added MORISAWA basic 5 fonts
256
257* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
258- update to kanjifonts-1.1
259
260* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
261- update jsclasses and index.html to 2002-02-07
262
263* Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
264- update jsclasses and index.html to 2002-01-27
265- fix typo in changelog
266
267* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
268- update jsclasses and index.html to 2002-01-18
269
270* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
271- update index.html (jsclasses)
272
273* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
274- update jsclasses to 2001-11-29
275
276* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
277- fixed spec file for Prosper and jsclasses
278- use RPM macro in %files
279- added BuildPrereq: jvf
280
281* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
282- move revtex4 to texmacro-aps package
283
284* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
285- added prosper jsclasses
286
287* Thu Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
288- added revtex4 natbib
289
290* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
291- remove prereq tetex to avoid dependency-loop
292
293* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
294- tetex-macros-1.0-0vl1
295
296* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
297- 2.0-2
298- added kanjifonts-1.0 and removed jisfontsmetric
299
300* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
301- 2.0-1
302- install ldf in babel
303
304* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
305- added jisfontmetric.tex
306
307* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
308- change group.
309
310* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
311- added babel
312
313* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
314- added hoekwater
315
316* Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
317- added psfrag
318
319* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
320- added psnfss
321- Change directory tree according to the suggestion by Dr.Okumura.
322- remove many files from packages directory except documentations
323- disable mktexlsr and erase ls-R
324
325* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
326- added url.sty
327
328* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
329- pLaTeX2e_Macros-1-2
330- added fancyhdr.sty, boxedminipage.sty
331- added graphics.cfg, color.cfg (use dvips as default)
332- symlink from epsbox to epsf
333
334* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
335- pLaTeX2e_Macros-1-1
336  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
337- added def files of graphics
338- added tools and hyperref
339- check the existence of mktexlsr
340
341* Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
342- buildarch: noarch
343- added requires
344
345* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
346- tiny bug fix and add %defattr
347
348* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
349- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.