source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 7956

Revision 7956, 10.1 KB checked in by munepi, 11 years ago (diff)

updated

Line 
1## -*- coding: utf-8-unix -*-
2%define jlisting_ver    0.2
3%define bkmk2uni        convert-bkmk2uni
4
5%define list_macros \
6        jlisting-%{jlisting_ver}
7
8Summary:        A collection of useful macro packages for TeX Live
9Summary(ja):    TeX Live の便利なマクロパッケージ集
10Name:           texlive-macros
11Version:        2013
12Release:        2%{?_dist_release}
13License:        distributable
14Group:          Applications/Publishing
15
16## Vine Linux
17
18## jlisting
19Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
20
21## misc
22Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
23Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
24
25#Requires:      perl
26Requires:       texlive-common = %{version}
27BuildRequires:  texlive-vtlpkg = %{version}
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildArch: noarch
31
32Obsoletes:      tetex-macros
33Obsoletes:      pLaTeX2e_Macros
34
35Distribution:   Vine Linux
36Vendor:         Project Vine
37Packager:       munepi
38
39
40%description
41A collection of useful macro packages for texlive package, including
42  jlisting
43  jtygm.sty
44  cmex.enc
45
46# This package contained a perl script
47#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
48
49%description -l ja
50TeX Live の便利なマクロパッケージ集です。
51以下のマクロを収録しています。
52  jlisting
53  jtygm.sty
54  cmex.enc
55
56# このパッケージには prosper, powerdot 用に
57# PDF ブックマークの文字化けを修正するための perl スクリプト
58#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
59# を同梱しています.
60
61%prep
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
63
64%build
65
66%install
67%__rm -rf %{buildroot}
68
69# nkf --utf8 %{SOURCE25} | \
70#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
71#     %{buildroot}%{_bindir}/%{bkmk2uni}
72# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
73
74## install jlisting
75%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
76%__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
77bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
78
79## install jtygm.sty
80%__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
81%__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
82## install cmex.enc
83%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
84%__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
85
86%post
87%_tl_touch_run texhash
88exit 0
89
90%postun
91if [ "$1" = 0 ]; then
92   %_tl_touch_run texhash
93fi
94exit 0
95
96%posttrans
97%{_tl_exec_texhash}
98exit 0
99
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root)
106#%{_bindir}/%{bkmk2uni}
107%{_tl_texmfvine}/tex/latex/jlisting
108%{_tl_texmfvine}/tex/platex/base/jtygm.sty
109%{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
110
111%changelog
112* Sun Nov  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
113- s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
114
115* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
116- TeX Live 2013
117- dropped jsclasses: texlive-collection-langcjk provides jsclasses
118- dropped kanjifonts-3.1: obsolete
119
120* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
121- TeX Live 2012
122
123* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
124- move jlisting package to %%{texmf}/tex/latex/jlisting
125
126* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
127- updated jsclasses to 110510
128  - mistook to change %%jsclasses_ver at 2011-1
129
130* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
131- TeX Live 2011
132- updated jsclasses to 110510
133
134* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
135- dropped BuildRequires: jvf
136- for vl5, added Conflicts: tetex-macros
137
138* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
139- removed %%{exec_updmap} in %%post and %%postun
140
141* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
142- ported from tetex-macros-3.0-7
143- TeX Live 2009
144
145* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
146- added BuildRequires: unzip
147- updated jsclasses to 090826
148- updated pict2e to 0.2x
149
150* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
151- dropped epsbox.sty, eclepsf.sty
152  (bacause there style files for platex209 are obsolete)
153
154* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
155- added jlisting v0.2
156- defined list_macros
157  - used %%{list_macros} in %%description and %%description -l ja
158
159* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
160- dropped convert-euc.txt
161
162* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
163- updated prosper
164  - added some contrib themes from CTAN
165  - added prosper.cls v1.6 from CVS HEAD
166  - added a perl script: convert-euc.txt
167- added powerdot v1.3
168  - added xkeyval v2.5d
169- added beamer v3.07
170  - added pgf v2.00
171- added pict2e v0.2w
172
173* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
174- updated jsclasses to 20090222
175- updated jsclasses/index.html to 2009-02-22
176- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
177
178* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
179- applied new versioning policy, spec in utf-8
180
181* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
182- update jsclasses/index.html to 2006-11-06.
183
184* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
185- update jsclasses/index.html to 2006-02-12.
186
187* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
188- update jsclasses/index.html to 2005-10-26.
189
190* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
191- update jsclasses/index.html to 2005-4-30.
192- added breqn
193
194* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
195- update jsclasses/index.html to 2004-12-29.
196
197* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
198- add missing files in kanjifonts-3.0
199
200* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
201- update to kanjifonts.sty-3.0.
202
203* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
204- update jsclasses/index.html to 2004-11-03.
205
206* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
207- update jsclasses/index.html to 2004-09-27.
208
209* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
210- update jsclasses/index.html to 2004-02-25.
211- added eclepsf.sty.
212- removed epsf.sty (symlink to epsbox.sty).
213- removed geometry, which is in tetex-2.0.
214
215* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
216- update jsclasses/index.html to 2003-04-18.
217- added morisawa.dvi.
218
219* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
220- update jsclasses/index.html to 2003-03-06
221
222* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
223- remove natbib, which is in tetex-2.0
224- let version number same as tetex
225- added Requires: tetex
226
227* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
228- update jsclasses/index.html to 2003-01-16
229
230* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
231- update jsclasses to 2003-01-05
232- update index.html to 2003-01-12
233
234* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
235- update jsclasses and index.html to 2002-11-27
236
237* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
238- update jsclasses and index.html to 2002-11-01
239
240* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
241- oops, packager was incorrect
242
243* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
244- update jsclasses to 2002-06-29
245- update index.html to 2002-07-03
246
247* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
248- update jsclasses to 2002-04-21
249- update index.html to 2002-04-09
250
251* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
252- added MORISAWA basic 5 fonts
253
254* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
255- update to kanjifonts-1.1
256
257* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
258- update jsclasses and index.html to 2002-02-07
259
260* Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
261- update jsclasses and index.html to 2002-01-27
262- fix typo in changelog
263
264* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
265- update jsclasses and index.html to 2002-01-18
266
267* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
268- update index.html (jsclasses)
269
270* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
271- update jsclasses to 2001-11-29
272
273* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
274- fixed spec file for Prosper and jsclasses
275- use RPM macro in %files
276- added BuildPrereq: jvf
277
278* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
279- move revtex4 to texmacro-aps package
280
281* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
282- added prosper jsclasses
283
284* Thu Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
285- added revtex4 natbib
286
287* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
288- remove prereq tetex to avoid dependency-loop
289
290* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
291- tetex-macros-1.0-0vl1
292
293* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
294- 2.0-2
295- added kanjifonts-1.0 and removed jisfontsmetric
296
297* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
298- 2.0-1
299- install ldf in babel
300
301* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
302- added jisfontmetric.tex
303
304* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
305- change group.
306
307* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
308- added babel
309
310* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
311- added hoekwater
312
313* Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
314- added psfrag
315
316* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
317- added psnfss
318- Change directory tree according to the suggestion by Dr.Okumura.
319- remove many files from packages directory except documentations
320- disable mktexlsr and erase ls-R
321
322* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
323- added url.sty
324
325* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
326- pLaTeX2e_Macros-1-2
327- added fancyhdr.sty, boxedminipage.sty
328- added graphics.cfg, color.cfg (use dvips as default)
329- symlink from epsbox to epsf
330
331* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
332- pLaTeX2e_Macros-1-1
333  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
334- added def files of graphics
335- added tools and hyperref
336- check the existence of mktexlsr
337
338* Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
339- buildarch: noarch
340- added requires
341
342* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
343- tiny bug fix and add %defattr
344
345* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
346- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.