source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 7150

Revision 7150, 12.6 KB checked in by munepi, 11 years ago (diff)

fixed texlive-macros and texmacro-otf

Line 
1## -*- coding: utf-8-unix -*-
2%define tex_destdir     %{_datadir}
3%define texmf           %{_prefix}/share/texmf
4%define texlive_src     %{tex_destdir}/texlive-sources
5%define build_tex_destdir       %{buildroot}%{tex_destdir}
6%define build_texmf     %{buildroot}%{texmf}
7%define build_texlive_src       %{buildroot}%{tex_destdir}-sources
8
9%define knjfonts        kanjifonts-3.1
10%define jsclasses_ver   110510
11%define jlisting_ver    0.2
12%define bkmk2uni        convert-bkmk2uni
13
14%define list_macros \
15        jsclasses-%{jsclasses_ver} \
16        jlisting-%{jlisting_ver}
17
18## use some macros for %post, %posttrans
19%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
20}
21%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
22    %{_sbindir}/update-defaultfont 2> /dev/null
23%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
24    [ -x %{_bindir}/texhash ] && \\\
25    echo -n "    "; echo -n "Running texhash... "; \\\
26    %{_bindir}/texhash 2> /dev/null; \\\
27    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
28%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
29    [ -x %{_bindir}/mtxrun ] && \\\
30    echo -n "    "; echo -n "Running mtxrun... "; \\\
31    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
32    %{_bindir}/mtxrun --generate &> /dev/null; \\\
33    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
34%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
35    [ -x %{_bindir}/fmtutil-sys ] && \\\
36    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
37    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
38    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
39%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
40    [ -x %{_bindir}/updmap-sys ] && \\\
41    echo -n "    "; echo -n "Running updmap-sys... "; \\\
42    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
43    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
44
45Summary:        A collection of useful macro packages for texlive package
46Summary(ja):    texlive パッケージで使うマクロパッケージ集
47Name:           texlive-macros
48Version:        2012
49Release:        1%{?_dist_release}
50License:        distributable
51Group:          Applications/Publishing
52
53## Vine Linux
54Source0:        %{knjfonts}.tar.bz2
55Source1:        sample.tex
56
57## jsclasses
58Source10:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
59Source11:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
60
61## jlisting
62Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
63
64
65Requires:       perl
66Requires:       texlive-common = %{version}
67BuildRequires:  texlive-common = %{version}
68BuildRequires:  nkf unzip
69
70Buildroot: %{_tmppath}/%{name}-%{version}-root
71BuildArch: noarch
72
73Obsoletes:      tetex-macros
74Obsoletes:      pLaTeX2e_Macros
75
76Distribution:   Vine Linux
77Vendor:         Project Vine
78Packager:       munepi
79
80
81%description
82A collection of useful macro packages for texlive package, including
83        kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
84%{list_macros}
85
86# This package contained a perl script
87#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
88
89%description -l ja
90texlive パッケージで使うマクロパッケージ集です。
91以下のマクロを収録しています。
92        kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
93%{list_macros}
94
95# このパッケージには prosper, powerdot 用に
96# PDF ブックマークの文字化けを修正するための perl スクリプト
97#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
98# を同梱しています.
99
100%prep
101[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
102%setup -q -c -n %{name}-%{version}
103
104%__mkdir_p jsclasses
105(cd jsclasses
106    %__mkdir_p jsclasses
107    %__unzip -a -qq %{SOURCE10}
108    %__cp -p %{SOURCE11} ./jsclasses/README.html
109)
110
111# get rid of unwanted files
112find . -type d -name CVS | xargs -r %__rm -frv
113find . -type f -name .cvsignore | xargs -r %__rm -fv
114
115(cd jsclasses
116    %__mkdir_p tmp
117    for i in *.*; do nkf $i > tmp/$i; done
118    %__mv tmp/* .
119    %__rm -rf tmp
120)
121
122
123%build
124
125(cd jsclasses
126    for i in jsclasses okumacro okuverb morisawa; do
127        platex ${i}.dtx && platex ${i}.dtx || exit 1
128    done
129    for i in jsclasses okumacro okuverb; do
130        dvipdfmx $i || exit 1
131    done
132    %__cp *.dvi *.pdf jsclasses
133)
134
135%install
136%__rm -rf %{buildroot}
137
138%__mkdir_p %{build_texmf}/packages/
139
140## install kanjifonts
141%__mkdir_p %{build_texmf}/tex/platex/kanjifonts
142%__mv %{knjfonts}/*.sty %{build_texmf}/tex/platex/kanjifonts
143%__mv %{knjfonts}/*.def %{build_texmf}/tex/platex/kanjifonts
144
145# nkf --utf8 %{SOURCE25} | \
146#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
147#     %{buildroot}%{_bindir}/%{bkmk2uni}
148# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
149
150## install jsclasses
151(cd jsclasses
152    %__mkdir_p %{build_texmf}/tex/platex/jsclasses
153    %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/tex/platex/jsclasses/
154)
155
156## install jlisting
157%__mkdir_p %{build_texmf}/tex/latex/jlisting
158%__install -m 644 %{SOURCE20} %{build_texmf}/tex/latex/jlisting/
159bunzip2 %{build_texmf}/tex/latex/jlisting/jlisting.sty.bz2
160
161
162%post
163%touch_run texhash
164exit 0
165
166%postun
167if [ "$1" = 0 ]; then
168   %touch_run texhash
169fi
170exit 0
171
172%posttrans
173%{exec_texhash}
174exit 0
175
176%clean
177%__rm -rf $RPM_BUILD_ROOT
178
179
180%files
181%defattr(-,root,root)
182%doc %{knjfonts}
183%doc jsclasses/jsclasses
184#%{_bindir}/%{bkmk2uni}
185%{texmf}/tex/platex/kanjifonts/kanjifonts.sty
186%{texmf}/tex/platex/kanjifonts/*.def
187%{texmf}/tex/platex/jsclasses
188%{texmf}/tex/latex/jlisting
189
190
191%changelog
192* Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
193- TeX Live 2012
194
195* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
196- move jlisting package to %%{texmf}/tex/latex/jlisting
197
198* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
199- updated jsclasses to 110510
200  - mistook to change %%jsclasses_ver at 2011-1
201
202* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
203- TeX Live 2011
204- updated jsclasses to 110510
205
206* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
207- dropped BuildRequires: jvf
208- for vl5, added Conflicts: tetex-macros
209
210* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
211- removed %%{exec_updmap} in %%post and %%postun
212
213* Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
214- ported from tetex-macros-3.0-7
215- TeX Live 2009
216
217* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
218- added BuildRequires: unzip
219- updated jsclasses to 090826
220- updated pict2e to 0.2x
221
222* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
223- dropped epsbox.sty, eclepsf.sty
224  (bacause there style files for platex209 are obsolete)
225
226* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
227- added jlisting v0.2
228- defined list_macros
229  - used %%{list_macros} in %%description and %%description -l ja
230
231* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
232- dropped convert-euc.txt
233
234* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
235- updated prosper
236  - added some contrib themes from CTAN
237  - added prosper.cls v1.6 from CVS HEAD
238  - added a perl script: convert-euc.txt
239- added powerdot v1.3
240  - added xkeyval v2.5d
241- added beamer v3.07
242  - added pgf v2.00
243- added pict2e v0.2w
244
245* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
246- updated jsclasses to 20090222
247- updated jsclasses/index.html to 2009-02-22
248- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
249
250* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
251- applied new versioning policy, spec in utf-8
252
253* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
254- update jsclasses/index.html to 2006-11-06.
255
256* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
257- update jsclasses/index.html to 2006-02-12.
258
259* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
260- update jsclasses/index.html to 2005-10-26.
261
262* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
263- update jsclasses/index.html to 2005-4-30.
264- added breqn
265
266* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
267- update jsclasses/index.html to 2004-12-29.
268
269* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
270- add missing files in kanjifonts-3.0
271
272* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
273- update to kanjifonts.sty-3.0.
274
275* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
276- update jsclasses/index.html to 2004-11-03.
277
278* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
279- update jsclasses/index.html to 2004-09-27.
280
281* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
282- update jsclasses/index.html to 2004-02-25.
283- added eclepsf.sty.
284- removed epsf.sty (symlink to epsbox.sty).
285- removed geometry, which is in tetex-2.0.
286
287* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
288- update jsclasses/index.html to 2003-04-18.
289- added morisawa.dvi.
290
291* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
292- update jsclasses/index.html to 2003-03-06
293
294* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
295- remove natbib, which is in tetex-2.0
296- let version number same as tetex
297- added Requires: tetex
298
299* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
300- update jsclasses/index.html to 2003-01-16
301
302* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
303- update jsclasses to 2003-01-05
304- update index.html to 2003-01-12
305
306* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
307- update jsclasses and index.html to 2002-11-27
308
309* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
310- update jsclasses and index.html to 2002-11-01
311
312* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
313- oops, packager was incorrect
314
315* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
316- update jsclasses to 2002-06-29
317- update index.html to 2002-07-03
318
319* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
320- update jsclasses to 2002-04-21
321- update index.html to 2002-04-09
322
323* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
324- added MORISAWA basic 5 fonts
325
326* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
327- update to kanjifonts-1.1
328
329* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
330- update jsclasses and index.html to 2002-02-07
331
332* Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
333- update jsclasses and index.html to 2002-01-27
334- fix typo in changelog
335
336* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
337- update jsclasses and index.html to 2002-01-18
338
339* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
340- update index.html (jsclasses)
341
342* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
343- update jsclasses to 2001-11-29
344
345* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
346- fixed spec file for Prosper and jsclasses
347- use RPM macro in %files
348- added BuildPrereq: jvf
349
350* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
351- move revtex4 to texmacro-aps package
352
353* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
354- added prosper jsclasses
355
356* Mon Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
357- added revtex4 natbib
358
359* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
360- remove prereq tetex to avoid dependency-loop
361
362* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
363- tetex-macros-1.0-0vl1
364
365* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
366- 2.0-2
367- added kanjifonts-1.0 and removed jisfontsmetric
368
369* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
370- 2.0-1
371- install ldf in babel
372
373* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
374- added jisfontmetric.tex
375
376* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
377- change group.
378
379* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
380- added babel
381
382* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
383- added hoekwater
384
385* Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
386- added psfrag
387
388* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
389- added psnfss
390- Change directory tree according to the suggestion by Dr.Okumura.
391- remove many files from packages directory except documentations
392- disable mktexlsr and erase ls-R
393
394* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
395- added url.sty
396
397* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
398- pLaTeX2e_Macros-1-2
399- added fancyhdr.sty, boxedminipage.sty
400- added graphics.cfg, color.cfg (use dvips as default)
401- symlink from epsbox to epsf
402
403* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
404- pLaTeX2e_Macros-1-1
405  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
406- added def files of graphics
407- added tools and hyperref
408- check the existence of mktexlsr
409
410* Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
411- buildarch: noarch
412- added requires
413
414* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
415- tiny bug fix and add %defattr
416
417* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
418- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.