source: projects/specs/trunk/t/texlive-macros/texlive-macros-vl.spec @ 5598

Revision 5598, 11.3 KB checked in by munepi, 12 years ago (diff)

updated texlive-macros-vl.spec

Line 
1## -*- coding: utf-8-unix -*-
2%define tex_destdir     %{_datadir}
3%define texmf           %{_prefix}/share/texmf
4%define texlive_src     %{tex_destdir}/texlive-sources
5%define build_tex_destdir       %{buildroot}%{tex_destdir}
6%define build_texmf     %{buildroot}%{texmf}
7%define build_texlive_src       %{buildroot}%{tex_destdir}-sources
8
9%define knjfonts        kanjifonts-3.1
10%define jsclasses_ver   110510
11%define jlisting_ver    0.2
12%define bkmk2uni        convert-bkmk2uni
13
14%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
15%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys 2> /dev/null
16
17%define list_macros \
18        jsclasses-%{jsclasses_ver} \
19        jlisting-%{jlisting_ver}
20
21
22Summary:        A collection of useful macro packages for texlive package
23Summary(ja):    texlive パッケージで使うマクロパッケージ集
24Name:           texlive-macros
25Version:        2011
26Release:        3%{?_dist_release}
27License:        distributable
28Group:          Applications/Publishing
29
30## Vine Linux
31Source0:        %{knjfonts}.tar.bz2
32Source1:        sample.tex
33
34## jsclasses
35Source10:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/jsclasses-%{jsclasses_ver}.zip
36Source11:       http://oku.edu.mie-u.ac.jp/~okumura/jsclasses/index.html
37
38## jlisting
39Source20:       http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
40
41
42Requires:       perl
43Requires:       texlive-common = %{version}
44BuildRequires:  texlive-common = %{version}
45BuildRequires:  nkf unzip
46
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48BuildArch: noarch
49
50Obsoletes:      tetex-macros
51Obsoletes:      pLaTeX2e_Macros
52
53Distribution:   Vine Linux
54Vendor:         Project Vine
55Packager:       munepi
56
57
58%description
59A collection of useful macro packages for texlive package, including
60        kanjifonts-3.1 (for Ricoh Fonts/DynaLab Fonts and JIS font metric)
61%{list_macros}
62
63# This package contained a perl script
64#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
65
66%description -l ja
67texlive パッケージで使うマクロパッケージ集です。
68以下のマクロを収録しています。
69        kanjifonts-3.1 (Vine Linux 3.1R 付属のリコーフォント/ダイナフォントやJISフォントメトリックを使う)
70%{list_macros}
71
72# このパッケージには prosper, powerdot 用に
73# PDF ブックマークの文字化けを修正するための perl スクリプト
74#   http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
75# を同梱しています.
76
77%prep
78[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
79%setup -q -c -n %{name}-%{version}
80
81%__mkdir_p jsclasses
82(cd jsclasses
83    %__mkdir_p jsclasses
84    %__unzip -a -qq %{SOURCE10}
85    %__cp -p %{SOURCE11} ./jsclasses/README.html
86)
87
88# get rid of unwanted files
89find . -type d -name CVS | xargs -r %__rm -frv
90find . -type f -name .cvsignore | xargs -r %__rm -fv
91
92(cd jsclasses
93    %__mkdir_p tmp
94    for i in *.*; do nkf $i > tmp/$i; done
95    %__mv tmp/* .
96    %__rm -rf tmp
97)
98
99
100%build
101
102(cd jsclasses
103    for i in jsclasses okumacro okuverb morisawa; do
104        platex ${i}.dtx && platex ${i}.dtx || exit 1
105    done
106    for i in jsclasses okumacro okuverb; do
107        dvipdfmx $i || exit 1
108    done
109    %__cp *.dvi *.pdf jsclasses
110)
111
112%install
113%__rm -rf %{buildroot}
114
115%__mkdir_p %{build_texmf}/packages/
116
117## install kanjifonts
118%__mkdir_p %{build_texmf}/tex/platex/kanjifonts
119%__mv %{knjfonts}/*.sty %{build_texmf}/tex/platex/kanjifonts
120%__mv %{knjfonts}/*.def %{build_texmf}/tex/platex/kanjifonts
121
122# nkf --utf8 %{SOURCE25} | \
123#     sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
124#     %{buildroot}%{_bindir}/%{bkmk2uni}
125# chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
126
127## install jsclasses
128(cd jsclasses
129    %__mkdir_p %{build_texmf}/tex/platex/jsclasses
130    %__cp -fp *.dtx *.ins *.cls *.sty %{build_texmf}/tex/platex/jsclasses/
131)
132
133## install jlisting
134%__mkdir_p %{build_texmf}/tex/latex/jlisting
135%__install -m 644 %{SOURCE20} %{build_texmf}/tex/latex/jlisting/
136bunzip2 %{build_texmf}/tex/latex/jlisting/jlisting.sty.bz2
137
138
139%post
140%{exec_texhash}
141# %{exec_updmap}
142exit 0
143
144
145%postun
146if [ "$1" = 0 ]; then
147    %{exec_texhash}
148    # %{exec_updmap}
149fi
150exit 0
151
152
153%clean
154%__rm -rf $RPM_BUILD_ROOT
155
156
157%files
158%defattr(-,root,root)
159%doc %{knjfonts}
160%doc jsclasses/jsclasses
161#%{_bindir}/%{bkmk2uni}
162%{texmf}/tex/platex/kanjifonts/kanjifonts.sty
163%{texmf}/tex/platex/kanjifonts/*.def
164%{texmf}/tex/platex/jsclasses
165%{texmf}/tex/latex/jlisting
166
167
168%changelog
169* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
170- move jlisting package to %%{texmf}/tex/latex/jlisting
171
172* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
173- updated jsclasses to 110510
174  - mistook to change %%jsclasses_ver at 2011-1
175
176* Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
177- TeX Live 2011
178- updated jsclasses to 110510
179
180* Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
181- dropped BuildRequires: jvf
182- for vl5, added Conflicts: tetex-macros
183
184* Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
185- removed %%{exec_updmap} in %%post and %%postun
186
187* Tue May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
188- ported from tetex-macros-3.0-7
189- TeX Live 2009
190
191* Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
192- added BuildRequires: unzip
193- updated jsclasses to 090826
194- updated pict2e to 0.2x
195
196* Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
197- dropped epsbox.sty, eclepsf.sty
198  (bacause there style files for platex209 are obsolete)
199
200* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
201- added jlisting v0.2
202- defined list_macros
203  - used %%{list_macros} in %%description and %%description -l ja
204
205* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
206- dropped convert-euc.txt
207
208* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
209- updated prosper
210  - added some contrib themes from CTAN
211  - added prosper.cls v1.6 from CVS HEAD
212  - added a perl script: convert-euc.txt
213- added powerdot v1.3
214  - added xkeyval v2.5d
215- added beamer v3.07
216  - added pgf v2.00
217- added pict2e v0.2w
218
219* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
220- updated jsclasses to 20090222
221- updated jsclasses/index.html to 2009-02-22
222- removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
223
224* Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
225- applied new versioning policy, spec in utf-8
226
227* Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
228- update jsclasses/index.html to 2006-11-06.
229
230* Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
231- update jsclasses/index.html to 2006-02-12.
232
233* Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
234- update jsclasses/index.html to 2005-10-26.
235
236* Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
237- update jsclasses/index.html to 2005-4-30.
238- added breqn
239
240* Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
241- update jsclasses/index.html to 2004-12-29.
242
243* Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
244- add missing files in kanjifonts-3.0
245
246* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
247- update to kanjifonts.sty-3.0.
248
249* Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
250- update jsclasses/index.html to 2004-11-03.
251
252* Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
253- update jsclasses/index.html to 2004-09-27.
254
255* Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
256- update jsclasses/index.html to 2004-02-25.
257- added eclepsf.sty.
258- removed epsf.sty (symlink to epsbox.sty).
259- removed geometry, which is in tetex-2.0.
260
261* Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
262- update jsclasses/index.html to 2003-04-18.
263- added morisawa.dvi.
264
265* Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
266- update jsclasses/index.html to 2003-03-06
267
268* Mon Feb  3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
269- remove natbib, which is in tetex-2.0
270- let version number same as tetex
271- added Requires: tetex
272
273* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
274- update jsclasses/index.html to 2003-01-16
275
276* Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
277- update jsclasses to 2003-01-05
278- update index.html to 2003-01-12
279
280* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
281- update jsclasses and index.html to 2002-11-27
282
283* Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
284- update jsclasses and index.html to 2002-11-01
285
286* Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
287- oops, packager was incorrect
288
289* Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
290- update jsclasses to 2002-06-29
291- update index.html to 2002-07-03
292
293* Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
294- update jsclasses to 2002-04-21
295- update index.html to 2002-04-09
296
297* Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
298- added MORISAWA basic 5 fonts
299
300* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
301- update to kanjifonts-1.1
302
303* Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
304- update jsclasses and index.html to 2002-02-07
305
306* Tue Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
307- update jsclasses and index.html to 2002-01-27
308- fix typo in changelog
309
310* Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
311- update jsclasses and index.html to 2002-01-18
312
313* Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
314- update index.html (jsclasses)
315
316* Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
317- update jsclasses to 2001-11-29
318
319* Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
320- fixed spec file for Prosper and jsclasses
321- use RPM macro in %files
322- added BuildPrereq: jvf
323
324* Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
325- move revtex4 to texmacro-aps package
326
327* Sun Sep  9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
328- added prosper jsclasses
329
330* Mon Sep  6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
331- added revtex4 natbib
332
333* Mon Sep  3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
334- remove prereq tetex to avoid dependency-loop
335
336* Wed Aug  1 2001 Jun Nishii <jun@vinelinux.org>
337- tetex-macros-1.0-0vl1
338
339* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
340- 2.0-2
341- added kanjifonts-1.0 and removed jisfontsmetric
342
343* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
344- 2.0-1
345- install ldf in babel
346
347* Sat Jan  8 2000 Jun Nishii <jun@vinelinux.org>
348- added jisfontmetric.tex
349
350* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
351- change group.
352
353* Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
354- added babel
355
356* Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
357- added hoekwater
358
359* Mon Aug 3 1999 Jun Nishii <jun@flatout.org>
360- added psfrag
361
362* Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
363- added psnfss
364- Change directory tree according to the suggestion by Dr.Okumura.
365- remove many files from packages directory except documentations
366- disable mktexlsr and erase ls-R
367
368* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
369- added url.sty
370
371* Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
372- pLaTeX2e_Macros-1-2
373- added fancyhdr.sty, boxedminipage.sty
374- added graphics.cfg, color.cfg (use dvips as default)
375- symlink from epsbox to epsf
376
377* Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
378- pLaTeX2e_Macros-1-1
379  (rename as pLaTeX2e_Macros from pLaTeX-Classes)
380- added def files of graphics
381- added tools and hyperref
382- check the existence of mktexlsr
383
384* Tue Oct 5 1998 Jun Nishii <jun@flatout.org>
385- buildarch: noarch
386- added requires
387
388* Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
389- tiny bug fix and add %defattr
390
391* Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
392- first version fo platex-19980901
Note: See TracBrowser for help on using the repository browser.