source: projects/specs/trunk/t/texlive-common/texlive-common-vl.spec @ 1533

Revision 1533, 3.8 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%define tex_destdir     %{_datadir}
5%define texmf           %{tex_destdir}/texmf
6%define texlive_src     %{tex_destdir}/texlive-sources
7%define build_tex_destdir       %{buildroot}%{tex_destdir}
8%define build_texmf     %{buildroot}%{texmf}
9
10%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
11%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
12%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
13%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
14%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
15%define vartexfonts %{_var}/lib/texmf
16
17%define __find_provides %{nil}
18%define __find_requires %{nil}
19%define __perl_provides %{nil}
20%define __perl_requires %{nil}
21
22Autoreq: 0
23
24Summary: Common base for all TeX Live packages
25Summary(ja): TeX Live パッケージの共通ベース
26Name: texlive-common
27Version: 2009
28Release: 1%{?_dist_release}
29License: distributable
30Group: Applications/Publishing
31URL: http://www.tug.org/texlive/
32
33Requires: texlive-collection-basic = %{version}
34Requires: texlive-collection-latex = %{version}
35Requires: texlive-collection-latexrecommended = %{version}
36Requires: texlive-collection-fontsrecommended = %{version}
37
38#### $ pdftex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
39## dehypht-x-2009-06-19.tex
40Requires: texlive-collection-langgerman = %{version}
41## catkoi
42Requires: texlive-collection-langcyrillic = %{version}
43
44#### $ xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini
45## unicode-letters
46Requires: texlive-collection-xetex = %{version}
47
48BuildArch:      noarch
49Buildroot:    %{_tmppath}/%{name}-%{version}-root
50
51Vendor:       Project Vine
52Distribution: Vine Linux
53Packager:     munepi
54
55
56%description
57The TeX Live software distribution offers a complete TeX system for a
58variety of Unix, Macintosh, Windows and other platforms. It
59encompasses programs for editing, typesetting, previewing and printing
60of TeX documents in many different languages, and a large collection
61of TeX macros and font libraries.
62
63The distribution includes extensive general documentation about TeX,
64as well as the documentation for the included software packages.
65
66This package is a virtual package
67to provide a common base for all TeX Live packages.
68
69
70%description -l ja
71TeX Live ソフトウェアディストリビューションは、
72さまざまな Unix, Macintosh, Windows、および
73他のプラットホームに対して完全な TeX システムを提供します。
74多くの異なった言語を含む TeX ドキュメントの
75編集、組版、閲覧、印刷するためのプログラム、
76そして、TeX マクロやフォントライブラリの大きなコレクションを
77同梱しています。
78
79このディストリビューションは
80同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
81TeX に関するたくさんの一般的なドキュメントを含んでいます。
82
83このパッケージは TeX Live パッケージの共通ベースを
84提供ための仮想パッケージです。
85
86
87%files
88
89
90%post
91%{exec_texhash}
92echo -n "    "
93echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
94echo -n "    "
95echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
96
97exit 0
98
99
100%postun
101%{exec_texhash}
102echo -n "    "
103echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
104# echo -n "    "
105# echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
106
107exit 0
108
109
110%changelog
111* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
112- TeX Live 2009
Note: See TracBrowser for help on using the repository browser.