source: projects/specs/trunk/t/texlive-collection-omega/texlive-collection-omega-vl.spec @ 9576

Revision 9576, 8.9 KB checked in by munepi, 9 years ago (diff)

synced tlnet to 20150522

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2015-2:
3## tlpdb2rpmspec collection-omega
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: Omega packages
10Summary(ja): TeX Live: Omega packages
11Name: texlive-collection-omega
12Version: 2015
13Release: 2%{?_dist_release}
14License: GPL+, LPPL
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: aleph.doc.tar.xz
19Source1: aleph.tar.xz
20Source2: antomega.doc.tar.xz
21Source3: antomega.source.tar.xz
22Source4: antomega.tar.xz
23Source5: lambda.tar.xz
24Source6: mxedruli.doc.tar.xz
25Source7: mxedruli.tar.xz
26Source8: omega.doc.tar.xz
27Source9: omega.tar.xz
28Source10: omegaware.doc.tar.xz
29Source11: omegaware.tar.xz
30Source12: otibet.doc.tar.xz
31Source13: otibet.source.tar.xz
32Source14: otibet.tar.xz
33
34Requires: texlive = %{version}
35Requires: texlive-collection-basic = %{version}
36Requires: texlive-collection-latex = %{version}
37
38Requires(post):         texlive = %{version}
39Requires(postun):       texlive = %{version}
40
41BuildArch:      noarch
42Buildroot:      %{_tmppath}/%{name}-%{version}-root
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       munepi
47
48%description
49The TeX Live software distribution offers a complete TeX system for a
50variety of Unix, Macintosh, Windows and other platforms. It
51encompasses programs for editing, typesetting, previewing and printing
52of TeX documents in many different languages, and a large collection
53of TeX macros and font libraries.
54
55The distribution includes extensive general documentation about TeX,
56as well as the documentation for the included software packages.
57
58This package is a collection of Omega packages:
59Omega, a 16-bit extended TeX by John Plaice and Yannis
60Haralambous, now updated to Aleph.
61
62This package contains the following CTAN packages:
63aleph: Extended TeX.
64antomega: Alternative language support for Omega/Lambda.
65lambda:
66mxedruli: A pair of fonts for different Georgian alphabets.
67omega: A wide-character-set extension of TeX.
68omegaware:
69otibet:
70
71%description -l ja
72TeX Live ソフトウェアディストリビューションは、
73さまざまな Unix, Macintosh, Windows、および
74他のプラットホームに対して完全な TeX システムを提供します。
75多くの異なった言語を含む TeX ドキュメントの
76編集、組版、閲覧、印刷するためのプログラム、
77そして、TeX マクロやフォントライブラリの大きなコレクションを
78同梱しています。
79
80このディストリビューションは
81同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
82TeX に関するたくさんの一般的なドキュメントを含んでいます。
83
84このパッケージは以下のようなパッケージ集です。
85Omega packages:
86Omega, a 16-bit extended TeX by John Plaice and Yannis
87Haralambous, now updated to Aleph.
88
89このパッケージは以下の CTAN パッケージを含んでいます:
90aleph: Extended TeX.
91antomega: Alternative language support for Omega/Lambda.
92lambda:
93mxedruli: A pair of fonts for different Georgian alphabets.
94omega: A wide-character-set extension of TeX.
95omegaware:
96otibet:
97
98%package doc
99Summary: TeX Live: Documentation files of %{name}
100Group: Applications/Publishing
101Requires: %{name} = %{version}-%{release}
102
103%description doc
104This package contains documentation files of %{name}.
105
106%prep
107%setup -c -n %{name}-%{version}
108%__tar -xvf %{SOURCE1}
109%__tar -xvf %{SOURCE2}
110%__tar -xvf %{SOURCE3}
111%__tar -xvf %{SOURCE4}
112%__tar -xvf %{SOURCE5}
113%__tar -xvf %{SOURCE6}
114%__tar -xvf %{SOURCE7}
115%__tar -xvf %{SOURCE8}
116%__tar -xvf %{SOURCE9}
117%__tar -xvf %{SOURCE10}
118%__tar -xvf %{SOURCE11}
119%__tar -xvf %{SOURCE12}
120%__tar -xvf %{SOURCE13}
121%__tar -xvf %{SOURCE14}
122
123%build
124
125%install
126[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
127
128%__mkdir_p %{buildroot}%{_datadir}
129
130## move texmf-dist to /usr/share/texmf-dist
131[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
132
133## move texmf to /usr/share/texmf
134[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
135
136## move tlpkg to /usr/share/tlpkg
137[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
138
139## move all non-arch binaries to /usr/bin
140[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
141
142## move others into /usr/share/texmf-dist
143%__mkdir_p %{buildroot}%{_tl_texmfdist}
144%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
145%__rm -rf * ||:
146
147
148## remove duplicated files between texlive and texlive-collection-*
149## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
150## remove unpacked files
151x=(
152scripts/context/stubs/unix/mtxrun
153scripts/ptex2pdf/ptex2pdf.lua
154scripts/texlive/fmtutil.pl
155scripts/texlive/texconfig-dialog.sh
156scripts/texlive/texconfig-sys.sh
157scripts/texlive/texconfig.sh
158scripts/texlive/texlinks.sh
159scripts/texlive/tlmgr.pl
160scripts/texlive/updmap.pl
161texconfig/tcfmgr
162web2c/fmtutil.cnf
163web2c/mktex.opt
164web2c/mktexdir
165web2c/mktexdir.opt
166web2c/mktexnam
167web2c/mktexnam.opt
168web2c/mktexupd
169web2c/texmf.cnf
170web2c/updmap-hdr.cfg
171web2c/updmap.cfg
172install-tl
173)
174if [ -d %{buildroot}%{_tl_texmfdist} ]; then
175pushd %{buildroot}%{_tl_texmfdist}
176%__rm -f ${x[@]} ||:
177popd
178fi
179
180## Files list
181find %{buildroot} -type f -or -type l | \
182    %__sed -e "s|%{buildroot}||g" > filelist.full
183
184find %{buildroot}%{_tl_texmfdist} -type d | \
185    %__sed -e "s|^%{buildroot}|%dir |" \
186           -e "s|$|/|"             >> filelist.full
187
188## subpackages
189grep "/texmf-dist/doc/" filelist.full > filelist.doc
190cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
191%__mv -f filelist.tmp filelist.full
192
193%clean
194%__rm -rf %{buildroot}
195
196%post
197%_tl_touch_run texhash
198%_tl_touch_run mtxrun
199
200[ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
201
202    %_tl_enable_map Map mxedruli.map
203    %_tl_enable_map Map omega.map
204
205%_tl_touch_run fmtutil
206
207exit 0
208
209
210%postun
211if [ "$1" = 0 ]; then
212    %_tl_touch_run texhash
213
214    [ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
215
216    %_tl_disable_map mxedruli.map
217    %_tl_disable_map omega.map
218
219fi
220
221exit 0
222
223%posttrans
224%{_tl_exec_texhash}
225%{_tl_exec_mtxrun}
226%{_tl_exec_updmap}
227%{_tl_exec_fmtutil}
228exit 0
229
230
231%files -f filelist.full
232%defattr(-,root,root,-)
233
234%files -f filelist.doc doc
235%defattr(-,root,root,-)
236
237%changelog
238* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
239- TeX Live 2015/pretest
240- synced tlnet to 20150522 (TeX Live 2015/pretest)
241
242* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
243- TeX Live 2015/pretest
244- synced tlnet to 20150426 (TeX Live 2015/pretest)
245
246* Wed Apr 01 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2014-4
247- synced tlnet to 20150401
248
249* Tue Oct 28 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
250- synced tlnet to 20141028
251
252* Sun Jul 06 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
253- synced tlnet to 20140706
254
255* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
256- upgraded to TeX Live 2014
257
258* Sun Apr 06 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
259- synced tlnet to 20140406
260
261* Wed Dec 18 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
262- synced tlnet to 20131218
263
264* Fri Nov 01 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
265- synced tlnet to 20131101
266
267* Wed Oct 02 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
268- synced tlnet to 20131002
269
270* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
271- synced tlnet to 20130919
272
273* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
274- upgraded to TeX Live 2013
275  - used tlnet archives
276  - synced tlnet to 20130823
277- added macros.texlive
278
279* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
280- updated to TeX Live 2012
281
282* Sat Dec 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
283- updated tlpdb2rpmspec.sh.in and dot.vtlpkg.conf.in:
284  - set external dependencies (texlive-collection-binextra,
285    texlive-collection-fontutils)
286
287* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
288- updated to TeX Live 2011
289- merged texlive-vtlpkg-2009-osx.patch from OSXWS
290- added %doc README (%files)
291
292* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
293- applied texlive-vtlpkg-2009-vine.patch
294  - remove arch dependent binaries
295- updated tlpdb2rpmspec.sh.in:
296  - improved tlpdb4a()
297  - make symlinks of core script utils (texlive-collection-binextra,
298    texlive-collection-context, texlive-collection-fontutils,
299    texlive-collection-langgreek, texlive-collection-langindic,
300    texlive-collection-latex, texlive-collection-latexextra,
301    texlive-collection-latexrecommended, texlive-collection-pictures,
302    texlive-collection-pstricks, texlive-collection-science)
303
304* Wed Jan 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
305- updated tlpdb2rpmspec.sh.in:
306  - improved %post
307
308* Sun Sep 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
309- updated tlpdb2rpmspec.sh.in:
310  - removed arch dependent binaries (texlive-collection-latexextra)
311  - improved updmap process in %post and %postun
312  - fixed perl path
313
314* Fri Jul 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
315- initial build
Note: See TracBrowser for help on using the repository browser.