source: projects/specs/trunk/t/texlive-collection-omega/texlive-collection-omega-vl.spec @ 9034

Revision 9034, 6.1 KB checked in by munepi, 10 years ago (diff)

synced tlnet to 20141028

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2014-3:
3## tlpdb2rpmspec collection-omega
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: Omega packages
10Summary(ja): TeX Live: Omega packages
11Name: texlive-collection-omega
12Version: 2014
13Release: 3%{?_dist_release}
14License: GPL+, LPPL
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: aleph.doc.tar.xz
19Source1: aleph.tar.xz
20Source2: antomega.doc.tar.xz
21Source3: antomega.source.tar.xz
22Source4: antomega.tar.xz
23Source5: lambda.tar.xz
24Source6: mxedruli.doc.tar.xz
25Source7: mxedruli.tar.xz
26Source8: omega.doc.tar.xz
27Source9: omega.tar.xz
28Source10: omegaware.doc.tar.xz
29Source11: omegaware.tar.xz
30Source12: otibet.doc.tar.xz
31Source13: otibet.source.tar.xz
32Source14: otibet.tar.xz
33
34Requires: texlive = %{version}
35Requires: texlive-collection-basic = %{version}
36Requires: texlive-collection-latex = %{version}
37
38Requires(post):         texlive = %{version}
39Requires(postun):       texlive = %{version}
40
41BuildArch:      noarch
42Buildroot:      %{_tmppath}/%{name}-%{version}-root
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       munepi
47
48%description
49The TeX Live software distribution offers a complete TeX system for a
50variety of Unix, Macintosh, Windows and other platforms. It
51encompasses programs for editing, typesetting, previewing and printing
52of TeX documents in many different languages, and a large collection
53of TeX macros and font libraries.
54
55The distribution includes extensive general documentation about TeX,
56as well as the documentation for the included software packages.
57
58This package is a collection of Omega packages:
59Omega, a 16-bit extended TeX by John Plaice and Yannis
60Haralambous, now updated to Aleph.
61
62This package contains the following CTAN packages:
63aleph: Extended TeX.
64antomega: Alternative language support for Omega/Lambda.
65lambda:
66mxedruli: A pair of fonts for different Georgian alphabets.
67omega: A wide-character-set extension of TeX.
68omegaware:
69otibet:
70
71%description -l ja
72TeX Live ソフトウェアディストリビューションは、
73さまざまな Unix, Macintosh, Windows、および
74他のプラットホームに対して完全な TeX システムを提供します。
75多くの異なった言語を含む TeX ドキュメントの
76編集、組版、閲覧、印刷するためのプログラム、
77そして、TeX マクロやフォントライブラリの大きなコレクションを
78同梱しています。
79
80このディストリビューションは
81同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
82TeX に関するたくさんの一般的なドキュメントを含んでいます。
83
84このパッケージは以下のようなパッケージ集です。
85Omega packages:
86Omega, a 16-bit extended TeX by John Plaice and Yannis
87Haralambous, now updated to Aleph.
88
89このパッケージは以下の CTAN パッケージを含んでいます:
90aleph: Extended TeX.
91antomega: Alternative language support for Omega/Lambda.
92lambda:
93mxedruli: A pair of fonts for different Georgian alphabets.
94omega: A wide-character-set extension of TeX.
95omegaware:
96otibet:
97
98%package doc
99Summary: TeX Live: Documentation files of %{name}
100Group: Applications/Publishing
101Requires: %{name} = %{version}-%{release}
102
103%description doc
104This package contains documentation files of %{name}.
105
106%prep
107%setup -c -n %{name}-%{version}
108%__tar -xvf %{SOURCE1}
109%__tar -xvf %{SOURCE2}
110%__tar -xvf %{SOURCE3}
111%__tar -xvf %{SOURCE4}
112%__tar -xvf %{SOURCE5}
113%__tar -xvf %{SOURCE6}
114%__tar -xvf %{SOURCE7}
115%__tar -xvf %{SOURCE8}
116%__tar -xvf %{SOURCE9}
117%__tar -xvf %{SOURCE10}
118%__tar -xvf %{SOURCE11}
119%__tar -xvf %{SOURCE12}
120%__tar -xvf %{SOURCE13}
121%__tar -xvf %{SOURCE14}
122
123%build
124
125%install
126[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
127
128%__mkdir_p %{buildroot}%{_datadir}
129
130## move texmf-dist to /usr/share/texmf-dist
131[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
132
133## move texmf to /usr/share/texmf
134[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
135
136## move tlpkg to /usr/share/tlpkg
137[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
138
139## move all non-arch binaries to /usr/bin
140[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
141
142## move others into /usr/share/texmf-dist
143%__mkdir_p %{buildroot}%{_tl_texmfdist}
144%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
145%__rm -rf * ||:
146
147
148## remove duplicated files between texlive and texlive-collection-*
149## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
150## remove unpacked files
151x=(
152scripts/epstopdf/epstopdf.pl
153scripts/texlive/fmtutil.sh
154texconfig/tcfmgr
155web2c/texmf.cnf
156web2c/updmap-hdr.cfg
157web2c/updmap.cfg
158install-tl
159)
160if [ -d %{buildroot}%{_tl_texmfdist} ]; then
161pushd %{buildroot}%{_tl_texmfdist}
162%__rm -f ${x[@]} ||:
163popd
164fi
165
166## Files list
167find %{buildroot} -type f -or -type l | \
168    %__sed -e "s|%{buildroot}||g" > filelist.full
169
170find %{buildroot}%{_tl_texmfdist} -type d | \
171    %__sed -e "s|^%{buildroot}|%dir |" \
172           -e "s|$|/|"             >> filelist.full
173
174## subpackages
175grep "/texmf-dist/doc/" filelist.full > filelist.doc
176cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
177%__mv -f filelist.tmp filelist.full
178
179%clean
180%__rm -rf %{buildroot}
181
182%post
183%_tl_touch_run texhash
184%_tl_touch_run mtxrun
185
186[ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
187
188    %_tl_enable_map Map mxedruli.map
189    %_tl_enable_map Map omega.map
190
191%_tl_touch_run fmtutil
192
193exit 0
194
195
196%postun
197if [ "$1" = 0 ]; then
198    %_tl_touch_run texhash
199
200    [ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
201
202    %_tl_disable_map mxedruli.map
203    %_tl_disable_map omega.map
204
205fi
206
207exit 0
208
209%posttrans
210%{_tl_exec_texhash}
211%{_tl_exec_mtxrun}
212%{_tl_exec_updmap}
213%{_tl_exec_fmtutil}
214exit 0
215
216
217%files -f filelist.full
218%defattr(-,root,root,-)
219
220%files -f filelist.doc doc
221%defattr(-,root,root,-)
222
223%changelog
224* Tue Oct 28 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
225- synced tlnet to 20141028
226
227* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
228- synced tlnet to 20140706
229
230* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
231- synced tlnet to 20140524
Note: See TracBrowser for help on using the repository browser.