source: projects/specs/trunk/t/texlive-collection-luatex/texlive-collection-luatex-vl.spec @ 1974

Revision 1974, 9.6 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-luatex
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: LuaTeX packages
28Summary(ja): TeX Live: LuaTeX packages
29Name: texlive-collection-luatex
30Version: 2009
31Release: 2%{?_dist_release}
32License: Public Domain, Freely redistributable without restriction
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of LuaTeX packages:
61Packages for LuaTeX, a Unicode-aware extension of pdfTeX, using
62Lua  as an embedded scripting and extension language.
63http://luatex.org/
64
65This package contains the following CTAN packages:
66luainputenc: Replacing inputenc for use in LuaTeX.
67luamplib: Use LuaTeX's built-in MetaPost interpreter.
68luaotfload: ConTeXt OTF loading system for Plain and LaTeX.
69luatextra: Additional macros for Plain TeX and LaTeX in LuaTeX.
70
71%description -l ja
72TeX Live ソフトウェアディストリビューションは、
73さまざまな Unix, Macintosh, Windows、および
74他のプラットホームに対して完全な TeX システムを提供します。
75多くの異なった言語を含む TeX ドキュメントの
76編集、組版、閲覧、印刷するためのプログラム、
77そして、TeX マクロやフォントライブラリの大きなコレクションを
78同梱しています。
79
80このディストリビューションは
81同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
82TeX に関するたくさんの一般的なドキュメントを含んでいます。
83
84このパッケージは以下のようなパッケージ集です。
85LuaTeX packages:
86Packages for LuaTeX, a Unicode-aware extension of pdfTeX, using
87Lua  as an embedded scripting and extension language.
88http://luatex.org/
89
90このパッケージは以下の CTAN パッケージを含んでいます:
91luainputenc: Replacing inputenc for use in LuaTeX.
92luamplib: Use LuaTeX's built-in MetaPost interpreter.
93luaotfload: ConTeXt OTF loading system for Plain and LaTeX.
94luatextra: Additional macros for Plain TeX and LaTeX in LuaTeX.
95
96%package doc
97Summary: TeX Live: Documentation files of %{name}
98Group: Applications/Publishing
99Requires: %{name} = %{version}-%{release}
100
101%description doc
102This package contains documentation files of %{name}.
103
104%prep
105
106%build
107
108%install
109[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
110
111PREF=%{buildroot}%{tex_destdir}
112
113manifest=(
114texmf-dist/doc/lualatex/luainputenc/README
115texmf-dist/doc/lualatex/luainputenc/inputenc.sty.diff
116texmf-dist/doc/lualatex/luainputenc/luainputenc.pdf
117texmf-dist/source/lualatex/luainputenc/Makefile
118texmf-dist/source/lualatex/luainputenc/luainputenc.dtx
119texmf-dist/tex/lualatex/luainputenc/eu2enc.def
120texmf-dist/tex/lualatex/luainputenc/eu2lmr.fd
121texmf-dist/tex/lualatex/luainputenc/luainputenc.lua
122texmf-dist/tex/lualatex/luainputenc/luainputenc.sty
123texmf-dist/tex/lualatex/luainputenc/lutf8.def
124texmf-dist/tex/lualatex/luainputenc/lutf8x.def
125texmf-dist/doc/luatex/luamplib/README
126texmf-dist/doc/luatex/luamplib/luamplib.pdf
127texmf-dist/source/luatex/luamplib/Makefile
128texmf-dist/source/luatex/luamplib/luamplib.dtx
129texmf-dist/tex/luatex/luamplib/luamplib-createmem.lua
130texmf-dist/tex/luatex/luamplib/luamplib.lua
131texmf-dist/tex/luatex/luamplib/luamplib.sty
132texmf-dist/doc/luatex/luaotfload/README
133texmf-dist/doc/luatex/luaotfload/luaotfload.pdf
134texmf-dist/source/luatex/luaotfload/Makefile
135texmf-dist/source/luatex/luaotfload/luaotfload.dtx
136texmf-dist/tex/luatex/luaotfload/luaotfload.lua
137texmf-dist/tex/luatex/luaotfload/luaotfload.sty
138texmf-dist/tex/luatex/luaotfload/otfl-data-con.lua
139texmf-dist/tex/luatex/luaotfload/otfl-font-cid.lua
140texmf-dist/tex/luatex/luaotfload/otfl-font-def.lua
141texmf-dist/tex/luatex/luaotfload/otfl-font-dum.lua
142texmf-dist/tex/luatex/luaotfload/otfl-font-ini.lua
143texmf-dist/tex/luatex/luaotfload/otfl-font-map.lua
144texmf-dist/tex/luatex/luaotfload/otfl-font-ota.lua
145texmf-dist/tex/luatex/luaotfload/otfl-font-otb.lua
146texmf-dist/tex/luatex/luaotfload/otfl-font-otc.lua
147texmf-dist/tex/luatex/luaotfload/otfl-font-otd.lua
148texmf-dist/tex/luatex/luaotfload/otfl-font-otf.lua
149texmf-dist/tex/luatex/luaotfload/otfl-font-oti.lua
150texmf-dist/tex/luatex/luaotfload/otfl-font-otn.lua
151texmf-dist/tex/luatex/luaotfload/otfl-font-ott.lua
152texmf-dist/tex/luatex/luaotfload/otfl-font-tfm.lua
153texmf-dist/tex/luatex/luaotfload/otfl-font-xtx.lua
154texmf-dist/tex/luatex/luaotfload/otfl-luat-dum.lua
155texmf-dist/tex/luatex/luaotfload/otfl-node-dum.lua
156texmf-dist/tex/luatex/luaotfload/otfl-node-fnt.lua
157texmf-dist/tex/luatex/luaotfload/otfl-node-ini.lua
158texmf-dist/tex/luatex/luaotfload/otfl-node-inj.lua
159texmf-dist/tex/luatex/luaotfload/otfl-node-res.lua
160texmf-dist/doc/luatex/luatextra/README
161texmf-dist/doc/luatex/luatextra/luaextra.pdf
162texmf-dist/doc/luatex/luatextra/luamcallbacks-test.tex
163texmf-dist/doc/luatex/luatextra/luamcallbacks.pdf
164texmf-dist/doc/luatex/luatextra/luatextra-reference.pdf
165texmf-dist/doc/luatex/luatextra/luatextra.pdf
166texmf-dist/source/luatex/luatextra/Makefile
167texmf-dist/source/luatex/luatextra/luaextra.dtx
168texmf-dist/source/luatex/luatextra/luamcallbacks.dtx
169texmf-dist/source/luatex/luatextra/luatextra-reference.tex
170texmf-dist/source/luatex/luatextra/luatextra.dtx
171texmf-dist/tex/luatex/luatextra/luaextra.lua
172texmf-dist/tex/luatex/luatextra/luamcallbacks.lua
173texmf-dist/tex/luatex/luatextra/luatextra-latex.tex
174texmf-dist/tex/luatex/luatextra/luatextra.lua
175texmf-dist/tex/luatex/luatextra/luatextra.sty
176)
177
178%__mkdir_p ${PREF}/texmf-dist
179for i in "${manifest[@]}"; do
180    %__install -D %{texlive_src}/$i ${PREF}/$i
181done
182
183## info
184%__rm -f %{buildroot}%{_infodir}/dir
185%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
186
187## man
188## man t1* files are provided by t1utils
189for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
190    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
191done
192
193## man some files are provided by psutils
194for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
195    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
196done
197
198## fix perl path
199for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
200    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
201done
202
203## remove asymptote directries, which provides asymptote package
204find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
205# find %{buildroot} -name "Makefile" | xargs %__rm -f
206
207# ## remove xindy
208# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
209
210# ## remove tex4ht
211# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
212
213## remove arch dependent binaries
214%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
215
216## remove unpackaging files
217find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
218find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
219
220## Files list
221find %{buildroot} -type f -or -type l | \
222    %__sed -e "s|%{buildroot}||g" > filelist.full
223
224find %{buildroot}%{texmf}-dist -type d | \
225    %__sed -e "s|^%{buildroot}|%dir |" \
226           -e "s|$|/|"             >> filelist.full
227
228## subpackages
229grep "/texmf-dist/doc/" filelist.full > filelist.doc
230cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
231%__mv -f filelist.tmp filelist.full
232
233%clean
234%__rm -rf %{buildroot}
235
236%post
237%{exec_texhash}
238
239exit 0
240
241
242%postun
243if [ "$1" = 0 ]; then
244    %{exec_texhash}
245
246fi
247
248exit 0
249
250%files -f filelist.full
251%defattr(-,root,root)
252
253%files -f filelist.doc doc
254%defattr(-,root,root)
255
256%changelog
257* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
258- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-luatex
259- removed arch dependent binaries (texlive-collection-latexextra)
260- fixed perl path
261- improved updmap process in %%post and %%postun
262
263* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
264- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-luatex
Note: See TracBrowser for help on using the repository browser.