source: projects/specs/trunk/t/texlive-collection-latex3/texlive-collection-latex3-vl.spec @ 2505

Revision 2505, 11.2 KB checked in by munepi, 13 years ago (diff)

updated all texlive-collection-* packages: improved %%post

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
3## tlpdb2rpmspec collection-latex3
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: LaTeX3 packages
28Summary(ja): TeX Live: LaTeX3 packages
29Name: texlive-collection-latex3
30Version: 2009
31Release: 3%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-latex = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of LaTeX3 packages:
61
62
63This package contains the following CTAN packages:
64expl3: Packages showing a proposed LaTeX3 programming convention.
65keys3:
66mh: The MH bundle
67xpackages: High-level LaTeX3 concepts.
68
69%description -l ja
70TeX Live ソフトウェアディストリビューションは、
71さまざまな Unix, Macintosh, Windows、および
72他のプラットホームに対して完全な TeX システムを提供します。
73多くの異なった言語を含む TeX ドキュメントの
74編集、組版、閲覧、印刷するためのプログラム、
75そして、TeX マクロやフォントライブラリの大きなコレクションを
76同梱しています。
77
78このディストリビューションは
79同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
80TeX に関するたくさんの一般的なドキュメントを含んでいます。
81
82このパッケージは以下のようなパッケージ集です。
83LaTeX3 packages:
84
85
86このパッケージは以下の CTAN パッケージを含んでいます:
87expl3: Packages showing a proposed LaTeX3 programming convention.
88keys3:
89mh: The MH bundle
90xpackages: High-level LaTeX3 concepts.
91
92%package doc
93Summary: TeX Live: Documentation files of %{name}
94Group: Applications/Publishing
95Requires: %{name} = %{version}-%{release}
96
97%description doc
98This package contains documentation files of %{name}.
99
100%prep
101
102%build
103
104%install
105[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
106
107PREF=%{buildroot}%{tex_destdir}
108
109manifest=(
110texmf-dist/doc/latex/expl3/README
111texmf-dist/doc/latex/expl3/expl3.pdf
112texmf-dist/doc/latex/expl3/source3.pdf
113texmf-dist/source/latex/expl3/expl3.dtx
114texmf-dist/source/latex/expl3/l3.ins
115texmf-dist/source/latex/expl3/l3alloc.dtx
116texmf-dist/source/latex/expl3/l3basics.dtx
117texmf-dist/source/latex/expl3/l3box.dtx
118texmf-dist/source/latex/expl3/l3calc.dtx
119texmf-dist/source/latex/expl3/l3chk.dtx
120texmf-dist/source/latex/expl3/l3clist.dtx
121texmf-dist/source/latex/expl3/l3doc.dtx
122texmf-dist/source/latex/expl3/l3expan.dtx
123texmf-dist/source/latex/expl3/l3file.dtx
124texmf-dist/source/latex/expl3/l3final.dtx
125texmf-dist/source/latex/expl3/l3format.ins
126texmf-dist/source/latex/expl3/l3int.dtx
127texmf-dist/source/latex/expl3/l3intexpr.dtx
128texmf-dist/source/latex/expl3/l3io.dtx
129texmf-dist/source/latex/expl3/l3keys.dtx
130texmf-dist/source/latex/expl3/l3keyval.dtx
131texmf-dist/source/latex/expl3/l3msg.dtx
132texmf-dist/source/latex/expl3/l3names.dtx
133texmf-dist/source/latex/expl3/l3num.dtx
134texmf-dist/source/latex/expl3/l3precom.dtx
135texmf-dist/source/latex/expl3/l3prg.dtx
136texmf-dist/source/latex/expl3/l3prop.dtx
137texmf-dist/source/latex/expl3/l3quark.dtx
138texmf-dist/source/latex/expl3/l3seq.dtx
139texmf-dist/source/latex/expl3/l3skip.dtx
140texmf-dist/source/latex/expl3/l3tl.dtx
141texmf-dist/source/latex/expl3/l3token.dtx
142texmf-dist/source/latex/expl3/l3toks.dtx
143texmf-dist/source/latex/expl3/l3vers.dtx
144texmf-dist/source/latex/expl3/l3xref.dtx
145texmf-dist/source/latex/expl3/source3.tex
146texmf-dist/makeindex/expl3/l3doc.ist
147texmf-dist/tex/latex/expl3/expl3.sty
148texmf-dist/tex/latex/expl3/l3basics.sty
149texmf-dist/tex/latex/expl3/l3box.sty
150texmf-dist/tex/latex/expl3/l3calc.sty
151texmf-dist/tex/latex/expl3/l3chk.sty
152texmf-dist/tex/latex/expl3/l3clist.sty
153texmf-dist/tex/latex/expl3/l3doc.cls
154texmf-dist/tex/latex/expl3/l3expan.sty
155texmf-dist/tex/latex/expl3/l3file.sty
156texmf-dist/tex/latex/expl3/l3int.sty
157texmf-dist/tex/latex/expl3/l3intexpr.sty
158texmf-dist/tex/latex/expl3/l3io.sty
159texmf-dist/tex/latex/expl3/l3keys.sty
160texmf-dist/tex/latex/expl3/l3keyval.sty
161texmf-dist/tex/latex/expl3/l3msg.sty
162texmf-dist/tex/latex/expl3/l3names.sty
163texmf-dist/tex/latex/expl3/l3num.sty
164texmf-dist/tex/latex/expl3/l3precom.sty
165texmf-dist/tex/latex/expl3/l3prg.sty
166texmf-dist/tex/latex/expl3/l3prop.sty
167texmf-dist/tex/latex/expl3/l3quark.sty
168texmf-dist/tex/latex/expl3/l3seq.sty
169texmf-dist/tex/latex/expl3/l3skip.sty
170texmf-dist/tex/latex/expl3/l3tl.sty
171texmf-dist/tex/latex/expl3/l3token.sty
172texmf-dist/tex/latex/expl3/l3toks.sty
173texmf-dist/tex/latex/expl3/l3xref.sty
174texmf-dist/doc/latex/keys3/README
175texmf-dist/doc/latex/keys3/keys3-test.tex
176texmf-dist/doc/latex/keys3/keys3.pdf
177texmf-dist/doc/latex/keys3/keys3opts2.pdf
178texmf-dist/source/latex/keys3/keys3.dtx
179texmf-dist/source/latex/keys3/keys3.ins
180texmf-dist/source/latex/keys3/keys3opts2.dtx
181texmf-dist/source/latex/keys3/keys3opts2.ins
182texmf-dist/tex/latex/keys3/keys3.sty
183texmf-dist/tex/latex/keys3/keys3opts2.sty
184texmf-dist/doc/latex/mh/README
185texmf-dist/doc/latex/mh/breqn-technotes.pdf
186texmf-dist/doc/latex/mh/breqn.pdf
187texmf-dist/doc/latex/mh/empheq.pdf
188texmf-dist/doc/latex/mh/flexisym.pdf
189texmf-dist/doc/latex/mh/mathstyle.pdf
190texmf-dist/doc/latex/mh/mathtools.pdf
191texmf-dist/doc/latex/mh/mhsetup.pdf
192texmf-dist/doc/latex/mh/xfrac.pdf
193texmf-dist/source/latex/mh/breqn-technotes.tex
194texmf-dist/source/latex/mh/breqn.dtx
195texmf-dist/source/latex/mh/empheq.dtx
196texmf-dist/source/latex/mh/flexisym.dtx
197texmf-dist/source/latex/mh/mathstyle.dtx
198texmf-dist/source/latex/mh/mathtools.dtx
199texmf-dist/source/latex/mh/mhsetup.dtx
200texmf-dist/source/latex/mh/xfrac.dtx
201texmf-dist/tex/latex/mh/breqn.sty
202texmf-dist/tex/latex/mh/cmbase.sym
203texmf-dist/tex/latex/mh/empheq.sty
204texmf-dist/tex/latex/mh/flexisym.sty
205texmf-dist/tex/latex/mh/mathpazo.sym
206texmf-dist/tex/latex/mh/mathptmx.sym
207texmf-dist/tex/latex/mh/mathstyle.sty
208texmf-dist/tex/latex/mh/mathtools.sty
209texmf-dist/tex/latex/mh/mhsetup.sty
210texmf-dist/tex/latex/mh/msabm.sym
211texmf-dist/tex/latex/mh/xfrac.sty
212texmf-dist/doc/latex/xpackages/README
213texmf-dist/doc/latex/xpackages/xbase/ldcsetup.pdf
214texmf-dist/doc/latex/xpackages/xbase/template.pdf
215texmf-dist/doc/latex/xpackages/xbase/xparse.pdf
216texmf-dist/doc/latex/xpackages/xtras/l3keys2e.pdf
217texmf-dist/source/latex/xpackages/xbase/ldcsetup.dtx
218texmf-dist/source/latex/xpackages/xbase/template-test.tex
219texmf-dist/source/latex/xpackages/xbase/template-test2.tex
220texmf-dist/source/latex/xpackages/xbase/template.dtx
221texmf-dist/source/latex/xpackages/xbase/tprestrict-test.tex
222texmf-dist/source/latex/xpackages/xbase/xbase.ins
223texmf-dist/source/latex/xpackages/xbase/xparse-test.tex
224texmf-dist/source/latex/xpackages/xbase/xparse.dtx
225texmf-dist/source/latex/xpackages/xtras/l3keys2e-demo.tex
226texmf-dist/source/latex/xpackages/xtras/l3keys2e.dtx
227texmf-dist/source/latex/xpackages/xtras/l3keys2e.ins
228texmf-dist/tex/latex/xpackages/xbase/ldcsetup.sty
229texmf-dist/tex/latex/xpackages/xbase/template.sty
230texmf-dist/tex/latex/xpackages/xbase/xparse.sty
231texmf-dist/tex/latex/xpackages/xtras/l3keys2e.sty
232)
233
234%__mkdir_p ${PREF}/texmf-dist
235for i in "${manifest[@]}"; do
236    %__install -D %{texlive_src}/$i ${PREF}/$i
237done
238
239## info
240%__rm -f %{buildroot}%{_infodir}/dir
241%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
242
243## man
244## man t1* files are provided by t1utils
245for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
246    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
247done
248
249## man some files are provided by psutils
250for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
251    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
252done
253
254## fix perl path
255for i in source/metapost/expressg/expressg.dtx \
256         doc/metapost/expressg/n2mpsprl.prl \
257         doc/latex/songbook/contrib/crd2sb/crd2sb; do
258    [ -f %{build_texmf}-dist/${i} ] && \
259        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
260done
261
262## remove asymptote directries, which provides asymptote package
263find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
264# find %{buildroot} -name "Makefile" | xargs %__rm -f
265
266# ## remove xindy
267# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
268
269# ## remove tex4ht
270# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
271
272## remove arch dependent binaries
273%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
274
275## remove unpackaging files
276find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
277find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
278
279## Files list
280find %{buildroot} -type f -or -type l | \
281    %__sed -e "s|%{buildroot}||g" > filelist.full
282
283find %{buildroot}%{texmf}-dist -type d | \
284    %__sed -e "s|^%{buildroot}|%dir |" \
285           -e "s|$|/|"             >> filelist.full
286
287## subpackages
288grep "/texmf-dist/doc/" filelist.full > filelist.doc
289cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
290%__mv -f filelist.tmp filelist.full
291
292%clean
293%__rm -rf %{buildroot}
294
295%post
296%{exec_texhash}
297
298exit 0
299
300
301%postun
302if [ "$1" = 0 ]; then
303    %{exec_texhash}
304
305fi
306
307exit 0
308
309%files -f filelist.full
310%defattr(-,root,root)
311
312%files -f filelist.doc doc
313%defattr(-,root,root)
314
315%changelog
316* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
317- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-latex3
318- improved %%post
319
320* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
321- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-latex3
322- removed arch dependent binaries (texlive-collection-latexextra)
323- fixed perl path
324- improved updmap process in %%post and %%postun
325
326* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
327- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-latex3
Note: See TracBrowser for help on using the repository browser.