source: projects/specs/trunk/t/texlive-collection-langturkmen/texlive-collection-langturkmen-vl.spec @ 7148

Revision 7148, 16.5 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-langturkmen
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Turkmen
48Summary(ja): TeX Live: Turkmen
49Name: texlive-collection-langturkmen
50Version: 2012
51Release: 1%{?_dist_release}
52License: LPPL
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
61#BuildRequires:         texlive-sources = %{version}
62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Turkmen:
81Support for typesetting Turkmen.
82
83This package contains the following CTAN packages:
84turkmen: Babel support for Turkmen.
85hyphen-turkmen: Turkmen hyphenation patterns.
86
87%description -l ja
88TeX Live ソフトウェアディストリビューションは、
89さまざまな Unix, Macintosh, Windows、および
90他のプラットホームに対して完全な TeX システムを提供します。
91多くの異なった言語を含む TeX ドキュメントの
92編集、組版、閲覧、印刷するためのプログラム、
93そして、TeX マクロやフォントライブラリの大きなコレクションを
94同梱しています。
95
96このディストリビューションは
97同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
98TeX に関するたくさんの一般的なドキュメントを含んでいます。
99
100このパッケージは以下のようなパッケージ集です。
101Turkmen:
102Support for typesetting Turkmen.
103
104このパッケージは以下の CTAN パッケージを含んでいます:
105turkmen: Babel support for Turkmen.
106hyphen-turkmen: Turkmen hyphenation patterns.
107
108%package doc
109Summary: TeX Live: Documentation files of %{name}
110Group: Applications/Publishing
111Requires: %{name} = %{version}-%{release}
112
113%description doc
114This package contains documentation files of %{name}.
115
116%prep
117
118%build
119
120%install
121[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
122
123PREF=%{buildroot}%{tex_destdir}
124
125manifest=(
126texmf-dist/doc/latex/turkmen/README
127texmf-dist/doc/latex/turkmen/turkmen.pdf
128texmf-dist/source/latex/turkmen/turkmen.dtx
129texmf-dist/source/latex/turkmen/turkmen.ins
130texmf-dist/tex/latex/turkmen/turkmen.ldf
131)
132
133%__mkdir_p ${PREF}/texmf-dist
134for i in "${manifest[@]}"; do
135    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
136done
137## make symlinks of core script utils
138mk_symlinks=(
139texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
140texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
141texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
142texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
143texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
144texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
145texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
146texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
147texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
148texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
149texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
150texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
151texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
152texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
153texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
154texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
155texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
156texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
157texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
158texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
159texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
160texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
161texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
162texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
163texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
164texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
165texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
166texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
167texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
168texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
169texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
170texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
171texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
172texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
173texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
174texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
175texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
176texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
177texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
178texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
179texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
180texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
181texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
182texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
183texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
184texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
185texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
186texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
187texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
188texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
189texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
190texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
191texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
192texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
193texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
194texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
195texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
196texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
197texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
198texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
199texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
200texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
201texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
202texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
203texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
204texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
205texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
206texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
207texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
208texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
209texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
210texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
211texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
212texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
213texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
214texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
215texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
216texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
217texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
218texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
219texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
220texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
221texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
222texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
223texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
224texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
225texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
226texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
227texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
228texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
229texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
230texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
231texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
232)
233%__mkdir_p %{buildroot}%{_bindir}
234pushd %{buildroot}%{_bindir}
235    for i in "${mk_symlinks[@]}"; do
236        tlc=$(/bin/echo $i | cut -f 1 -d",")
237        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
238        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
239
240        [ "%{name}" = "$tlc" ] || continue
241        [ -f $rlnk ] || exit 1
242        %__ln_s $rlnk $lnk || exit 1
243    done
244popd
245## Files list
246find %{buildroot} -type f -or -type l | \
247    %__sed -e "s|%{buildroot}||g" > filelist.full
248
249find %{buildroot}%{texmf}-dist -type d | \
250    %__sed -e "s|^%{buildroot}|%dir |" \
251           -e "s|$|/|"             >> filelist.full
252
253## subpackages
254grep "/texmf-dist/doc/" filelist.full > filelist.doc
255cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
256%__mv -f filelist.tmp filelist.full
257
258%clean
259%__rm -rf %{buildroot}
260
261%post
262%touch_run texhash
263%touch_run mtxrun
264
265%touch_run fmtutil
266
267exit 0
268
269
270%postun
271if [ "$1" = 0 ]; then
272    %touch_run texhash
273
274fi
275
276exit 0
277
278%posttrans
279%{exec_texhash}
280%{exec_mtxrun}
281%{exec_updmap}
282%{exec_fmtutil}
283exit 0
284
285
286%files -f filelist.full
287%defattr(-,root,root,-)
288
289%files -f filelist.doc doc
290%defattr(-,root,root,-)
291
292%changelog
293* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
294- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-langturkmen
295
296* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
297- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-langturkmen
298- set external dependencies (texlive-collection-binextra,
299  texlive-collection-fontutils)
300
301* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
302- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langturkmen
303
304* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
305- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langturkmen
306- make symlinks of core script utils (texlive-collection-binextra,
307  texlive-collection-context, texlive-collection-fontutils,
308  texlive-collection-langgreek, texlive-collection-langindic,
309  texlive-collection-latex, texlive-collection-latexextra,
310  texlive-collection-latexrecommended, texlive-collection-pictures,
311  texlive-collection-pstricks, texlive-collection-science)
312
313* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
314- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langturkmen
315- improved %%post
316
317* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
318- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langturkmen
319- removed arch dependent binaries (texlive-collection-latexextra)
320- fixed perl path
321- improved updmap process in %%post and %%postun
322
323* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
324- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langturkmen
Note: See TracBrowser for help on using the repository browser.