source: projects/specs/trunk/t/texlive-collection-langtibetan/texlive-collection-langtibetan-vl.spec @ 7148

Revision 7148, 19.1 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2012

RevLine 
[1533]1## -*- coding: utf-8-unix -*-
[7148]2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
[1974]3## tlpdb2rpmspec collection-langtibetan
[1533]4
[5207]5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
[7148]9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
[1533]13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
[7148]20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
[1533]46
47Summary: TeX Live: Tibetan
48Summary(ja): TeX Live: Tibetan
49Name: texlive-collection-langtibetan
[7148]50Version: 2012
[5207]51Release: 1%{?_dist_release}
[1533]52License: GPL+
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
[7148]61#BuildRequires:         texlive-sources = %{version}
[1533]62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Tibetan:
81Support for typesetting Tibetan.
82
83This package contains the following CTAN packages:
84ctib: Tibetan for TeX and LATeX2e.
85otibet:
86
87%description -l ja
88TeX Live ソフトウェアディストリビューションは、
89さまざまな Unix, Macintosh, Windows、および
90他のプラットホームに対して完全な TeX システムを提供します。
91多くの異なった言語を含む TeX ドキュメントの
92編集、組版、閲覧、印刷するためのプログラム、
93そして、TeX マクロやフォントライブラリの大きなコレクションを
94同梱しています。
95
96このディストリビューションは
97同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
98TeX に関するたくさんの一般的なドキュメントを含んでいます。
99
100このパッケージは以下のようなパッケージ集です。
101Tibetan:
102Support for typesetting Tibetan.
103
104このパッケージは以下の CTAN パッケージを含んでいます:
105ctib: Tibetan for TeX and LATeX2e.
106otibet:
107
108%package doc
109Summary: TeX Live: Documentation files of %{name}
110Group: Applications/Publishing
111Requires: %{name} = %{version}-%{release}
112
113%description doc
114This package contains documentation files of %{name}.
115
116%prep
117
118%build
119
120%install
121[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
122
123PREF=%{buildroot}%{tex_destdir}
124
125manifest=(
126texmf-dist/doc/latex/ctib/README
127texmf-dist/doc/latex/ctib/ctib4tex.pdf
128texmf-dist/doc/latex/ctib/ctib4tex.tex
129texmf-dist/source/latex/ctib/COPYING
130texmf-dist/source/latex/ctib/EMTEX
131texmf-dist/source/latex/ctib/HISTORY
132texmf-dist/source/latex/ctib/INSTALL
133texmf-dist/source/latex/ctib/MIKTEX
134texmf-dist/fonts/source/public/ctib/bzrsetup.mf
135texmf-dist/fonts/source/public/ctib/ctib.mf
136texmf-dist/fonts/source/public/ctib/ctibcode.mf
137texmf-dist/fonts/source/public/ctib/ctiblett.mf
138texmf-dist/fonts/source/public/ctib/ctibligs.mf
139texmf-dist/fonts/source/public/ctib/ctibnum.mf
140texmf-dist/fonts/source/public/ctib/ctibpunc.mf
141texmf-dist/fonts/source/public/ctib/ctibsplt.mf
142texmf-dist/fonts/source/public/ctib/ctibvow.mf
143texmf-dist/fonts/tfm/public/ctib/ctib.tfm
144texmf-dist/tex/latex/ctib/ctib.sty
145texmf-dist/tex/latex/ctib/ctib.tex
146texmf-dist/tex/latex/ctib/lctctib.fd
147texmf-dist/tex/latex/ctib/lctenc.def
148texmf-dist/doc/latex/otibet/README
149texmf-dist/doc/latex/otibet/allbasic-mule.tex
150texmf-dist/doc/latex/otibet/allbasic.dvi
151texmf-dist/doc/latex/otibet/allbasic.tex
152texmf-dist/doc/latex/otibet/otibet-mule.tex
153texmf-dist/doc/latex/otibet/testtib.tex
154texmf-dist/doc/latex/otibet/tiblatex.dvi
155texmf-dist/doc/latex/otibet/tiblatex.tex
156texmf-dist/doc/latex/otibet/unidoc.dvi
157texmf-dist/doc/latex/otibet/unidoc.tex
158texmf-dist/doc/latex/otibet/yugpacan.dvi
159texmf-dist/doc/latex/otibet/yugpacan.tex
160texmf-dist/source/latex/otibet/Makefile
161texmf-dist/source/latex/otibet/allbasic.odvi
162texmf-dist/source/latex/otibet/convnum.scm
163texmf-dist/source/latex/otibet/generate-otp.el
164texmf-dist/source/latex/otibet/oct2otp.c
165texmf-dist/source/latex/otibet/pl2ovp.scm
166texmf-dist/source/latex/otibet/tibetan.pl
167texmf-dist/source/latex/otibet/tiblatex.odvi
168texmf-dist/source/latex/otibet/tibovp.scm
169texmf-dist/source/latex/otibet/unidoc.odvi
170texmf-dist/source/latex/otibet/yugpacan.odvi
171texmf-dist/fonts/ofm/public/otibet/otibetan.ofm
172texmf-dist/fonts/ovf/public/otibet/otibetan.ovf
173texmf-dist/fonts/ovp/public/otibet/otibetan.ovp
174texmf-dist/fonts/source/public/otibet/bzrsetup.mf
175texmf-dist/fonts/source/public/otibet/tibetan.mf
176texmf-dist/fonts/tfm/public/otibet/tibetan.tfm
177texmf-dist/omega/ocp/otibet/tibadjusttsheg.ocp
178texmf-dist/omega/ocp/otibet/tibinunicode.ocp
179texmf-dist/omega/ocp/otibet/tibinwylie.ocp
180texmf-dist/omega/ocp/otibet/tibout.ocp
181texmf-dist/omega/ocp/otibet/tibspecial.ocp
182texmf-dist/omega/ocp/otibet/tibuniuni.ocp
183texmf-dist/omega/ocp/otibet/tibvowel.ocp
184texmf-dist/omega/otp/otibet/tibadjusttsheg.otp
185texmf-dist/omega/otp/otibet/tibetan-mule2uni-old.otp
186texmf-dist/omega/otp/otibet/tibetan-mule2uni.otp
187texmf-dist/omega/otp/otibet/tibinunicode.otp
188texmf-dist/omega/otp/otibet/tibinwylie.otp
189texmf-dist/omega/otp/otibet/tibout.otp
190texmf-dist/omega/otp/otibet/tibshow.otp
191texmf-dist/omega/otp/otibet/tibspecial.otp
192texmf-dist/omega/otp/otibet/tibuniuni.otp
193texmf-dist/omega/otp/otibet/tibvowel.otp
194texmf-dist/tex/latex/otibet/ot1tib.fd
195texmf-dist/tex/latex/otibet/otibet.sty
196texmf-dist/tex/latex/otibet/otibet.tex
197texmf-dist/tex/latex/otibet/t1tib.fd
198)
199
200%__mkdir_p ${PREF}/texmf-dist
201for i in "${manifest[@]}"; do
[5207]202    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
[1533]203done
[5207]204## make symlinks of core script utils
205mk_symlinks=(
206texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
[7148]207texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
208texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
[5207]209texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
210texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
[7148]211texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
212texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
[5207]213texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
214texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
215texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
216texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
217texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
218texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
219texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
220texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
[7148]221texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
[5207]222texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
223texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
224texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
[7148]225texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
[5207]226texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
227texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
228texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
229texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
230texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
231texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
232texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
233texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
234texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
235texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
236texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
237texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
238texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
239texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
240texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
241texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
242texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
243texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
244texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
245texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
246texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
247texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
[7148]248texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
[5207]249texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
[7148]250texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
[5207]251texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
252texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
[7148]253texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
[5207]254texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
[7148]255texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
[5207]256texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
257texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
258texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
259texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
260texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
261texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
262texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
263texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
264texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
265texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
266texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
267texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
268texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
[7148]269texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
270texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
[5207]271texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
272texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
273texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
274texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
275texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
[7148]276texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
[5207]277texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
278texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
279texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
280texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
281texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
282texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
283texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
284texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
[7148]285texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
[5207]286texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
[7148]287texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
[5207]288texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
289texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
[7148]290texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
[5207]291texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
292texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
293texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
294texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
295texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
[7148]296texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
[5207]297texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
298texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
299)
300%__mkdir_p %{buildroot}%{_bindir}
301pushd %{buildroot}%{_bindir}
302    for i in "${mk_symlinks[@]}"; do
[7148]303        tlc=$(/bin/echo $i | cut -f 1 -d",")
304        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
305        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
[1533]306
[5207]307        [ "%{name}" = "$tlc" ] || continue
308        [ -f $rlnk ] || exit 1
309        %__ln_s $rlnk $lnk || exit 1
310    done
311popd
[1533]312## Files list
313find %{buildroot} -type f -or -type l | \
314    %__sed -e "s|%{buildroot}||g" > filelist.full
315
316find %{buildroot}%{texmf}-dist -type d | \
317    %__sed -e "s|^%{buildroot}|%dir |" \
318           -e "s|$|/|"             >> filelist.full
319
320## subpackages
321grep "/texmf-dist/doc/" filelist.full > filelist.doc
322cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
323%__mv -f filelist.tmp filelist.full
324
325%clean
326%__rm -rf %{buildroot}
327
328%post
[7148]329%touch_run texhash
330%touch_run mtxrun
[1533]331
332exit 0
333
334
335%postun
336if [ "$1" = 0 ]; then
[7148]337    %touch_run texhash
[1533]338
339fi
340
341exit 0
342
[7148]343%posttrans
344%{exec_texhash}
345%{exec_mtxrun}
346%{exec_updmap}
347%{exec_fmtutil}
348exit 0
349
350
[1533]351%files -f filelist.full
[5207]352%defattr(-,root,root,-)
[1533]353
354%files -f filelist.doc doc
[5207]355%defattr(-,root,root,-)
[1533]356
357%changelog
[7148]358* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
359- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-langtibetan
360
361* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
362- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-langtibetan
363- set external dependencies (texlive-collection-binextra,
364  texlive-collection-fontutils)
365
[5207]366* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
367- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langtibetan
368
369* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
370- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langtibetan
371- make symlinks of core script utils (texlive-collection-binextra,
372  texlive-collection-context, texlive-collection-fontutils,
373  texlive-collection-langgreek, texlive-collection-langindic,
374  texlive-collection-latex, texlive-collection-latexextra,
375  texlive-collection-latexrecommended, texlive-collection-pictures,
376  texlive-collection-pstricks, texlive-collection-science)
377
[2505]378* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
379- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langtibetan
380- improved %%post
381
[1974]382* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
383- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langtibetan
384- removed arch dependent binaries (texlive-collection-latexextra)
385- fixed perl path
386- improved updmap process in %%post and %%postun
387
[1533]388* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
389- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langtibetan
Note: See TracBrowser for help on using the repository browser.