source: projects/specs/trunk/t/texlive-collection-langswedish/texlive-collection-langswedish-vl.spec @ 5207

Revision 5207, 14.0 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

RevLine 
[1533]1## -*- coding: utf-8-unix -*-
[5207]2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
[1974]3## tlpdb2rpmspec collection-langswedish
[1533]4
[5207]5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
[1533]9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
[5207]19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
[1533]20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
[5207]22%define vartexfonts %{_var}/lib/texmf/fonts
[1533]23
24Summary: TeX Live: Swedish
25Summary(ja): TeX Live: Swedish
26Name: texlive-collection-langswedish
[5207]27Version: 2011
28Release: 1%{?_dist_release}
[1533]29License: LPPL
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34Requires: texlive-collection-basic = %{version}
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Swedish:
58Support for typesetting Swedish.
59
60This package contains the following CTAN packages:
61swebib: Swedish bibliography styles.
[5207]62hyphen-swedish: Swedish hyphenation patterns.
[1533]63
64%description -l ja
65TeX Live ソフトウェアディストリビューションは、
66さまざまな Unix, Macintosh, Windows、および
67他のプラットホームに対して完全な TeX システムを提供します。
68多くの異なった言語を含む TeX ドキュメントの
69編集、組版、閲覧、印刷するためのプログラム、
70そして、TeX マクロやフォントライブラリの大きなコレクションを
71同梱しています。
72
73このディストリビューションは
74同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
75TeX に関するたくさんの一般的なドキュメントを含んでいます。
76
77このパッケージは以下のようなパッケージ集です。
78Swedish:
79Support for typesetting Swedish.
80
81このパッケージは以下の CTAN パッケージを含んでいます:
82swebib: Swedish bibliography styles.
[5207]83hyphen-swedish: Swedish hyphenation patterns.
[1533]84
85%package doc
86Summary: TeX Live: Documentation files of %{name}
87Group: Applications/Publishing
88Requires: %{name} = %{version}-%{release}
89
90%description doc
91This package contains documentation files of %{name}.
92
93%prep
94
95%build
96
97%install
98[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
99
100PREF=%{buildroot}%{tex_destdir}
101
102manifest=(
103texmf-dist/doc/latex/swebib/README
104texmf-dist/bibtex/bst/swebib/sweabbrv.bst
105texmf-dist/bibtex/bst/swebib/swealpha.bst
106texmf-dist/bibtex/bst/swebib/sweplain.bst
107texmf-dist/bibtex/bst/swebib/sweplnat.bst
108texmf-dist/bibtex/bst/swebib/sweunsrt.bst
109)
110
111%__mkdir_p ${PREF}/texmf-dist
112for i in "${manifest[@]}"; do
[5207]113    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
[1533]114done
[5207]115## make symlinks of core script utils
116mk_symlinks=(
117texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
118texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
119texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
120texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
121texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
122texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
123texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
124texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
125texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
126texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
127texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
128texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
129texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
130texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
131texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
132texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
133texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
134texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
135texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
136texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
137texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
138texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
139texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
140texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
141texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
142texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
143texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
144texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
145texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
146texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
147texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
148texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
149texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
150texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
151texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
152texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
153texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
154texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
155texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
156texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
157texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
158texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
159texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
160texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
161texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
162texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
163texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
164texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
165texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
166texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
167texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
168texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
169texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
170texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
171texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
172texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
173texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
174texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
175texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
176texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
177texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
178texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
179texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
180texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
181texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
182texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
183texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
184texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
185texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
186texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
187texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
188texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
189texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
190texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
191texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
192texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
193texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
194texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
195texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
196texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
197texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
198texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
199)
200%__mkdir_p %{buildroot}%{_bindir}
201pushd %{buildroot}%{_bindir}
202    for i in "${mk_symlinks[@]}"; do
203        tlc=$(echo $i | cut -f 1 -d",")
204        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
205        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
[1533]206
[5207]207        [ "%{name}" = "$tlc" ] || continue
208        [ -f $rlnk ] || exit 1
209        %__ln_s $rlnk $lnk || exit 1
210    done
211popd
[1533]212## Files list
213find %{buildroot} -type f -or -type l | \
214    %__sed -e "s|%{buildroot}||g" > filelist.full
215
216find %{buildroot}%{texmf}-dist -type d | \
217    %__sed -e "s|^%{buildroot}|%dir |" \
218           -e "s|$|/|"             >> filelist.full
219
220## subpackages
221grep "/texmf-dist/doc/" filelist.full > filelist.doc
222cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
223%__mv -f filelist.tmp filelist.full
224
225%clean
226%__rm -rf %{buildroot}
227
228%post
229%{exec_texhash}
230
[2505]231rpm -q --quiet texlive-common || exit 0
232
[1533]233echo -n "    "
234echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
235
236exit 0
237
238
239%postun
240if [ "$1" = 0 ]; then
241    %{exec_texhash}
242
243fi
244
245exit 0
246
247%files -f filelist.full
[5207]248%defattr(-,root,root,-)
[1533]249
250%files -f filelist.doc doc
[5207]251%defattr(-,root,root,-)
[1533]252
253%changelog
[5207]254* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
255- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langswedish
256
257* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
258- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langswedish
259- make symlinks of core script utils (texlive-collection-binextra,
260  texlive-collection-context, texlive-collection-fontutils,
261  texlive-collection-langgreek, texlive-collection-langindic,
262  texlive-collection-latex, texlive-collection-latexextra,
263  texlive-collection-latexrecommended, texlive-collection-pictures,
264  texlive-collection-pstricks, texlive-collection-science)
265
[2505]266* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
267- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langswedish
268- improved %%post
269
[1974]270* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
271- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langswedish
272- removed arch dependent binaries (texlive-collection-latexextra)
273- fixed perl path
274- improved updmap process in %%post and %%postun
275
[1533]276* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
277- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langswedish
Note: See TracBrowser for help on using the repository browser.