source: projects/specs/trunk/t/texlive-collection-langspanish/texlive-collection-langspanish-vl.spec @ 7148

Revision 7148, 17.0 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-langspanish
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Spanish
48Summary(ja): TeX Live: Spanish
49Name: texlive-collection-langspanish
50Version: 2012
51Release: 1%{?_dist_release}
52License: LPPL
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
61#BuildRequires:         texlive-sources = %{version}
62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Spanish:
81Support for typesetting Spanish.
82
83This package contains the following CTAN packages:
84hyphen-spanish: Spanish hyphenation patterns.
85hyphen-catalan: Catalan hyphenation patterns.
86hyphen-galician: Galician hyphenation patterns.
87spanish: Spanish in Babel.
88spanish-mx: Typeset Spanish as in Mexico.
89
90%description -l ja
91TeX Live ソフトウェアディストリビューションは、
92さまざまな Unix, Macintosh, Windows、および
93他のプラットホームに対して完全な TeX システムを提供します。
94多くの異なった言語を含む TeX ドキュメントの
95編集、組版、閲覧、印刷するためのプログラム、
96そして、TeX マクロやフォントライブラリの大きなコレクションを
97同梱しています。
98
99このディストリビューションは
100同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
101TeX に関するたくさんの一般的なドキュメントを含んでいます。
102
103このパッケージは以下のようなパッケージ集です。
104Spanish:
105Support for typesetting Spanish.
106
107このパッケージは以下の CTAN パッケージを含んでいます:
108hyphen-spanish: Spanish hyphenation patterns.
109hyphen-catalan: Catalan hyphenation patterns.
110hyphen-galician: Galician hyphenation patterns.
111spanish: Spanish in Babel.
112spanish-mx: Typeset Spanish as in Mexico.
113
114%package doc
115Summary: TeX Live: Documentation files of %{name}
116Group: Applications/Publishing
117Requires: %{name} = %{version}-%{release}
118
119%description doc
120This package contains documentation files of %{name}.
121
122%prep
123
124%build
125
126%install
127[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
128
129PREF=%{buildroot}%{tex_destdir}
130
131manifest=(
132texmf-dist/doc/latex/spanish/README
133texmf-dist/doc/latex/spanish/romanidx.sty
134texmf-dist/doc/latex/spanish/spanish.ldf
135texmf-dist/doc/latex/spanish/spanish.pdf
136texmf-dist/doc/latex/spanish/spanish2.html
137texmf-dist/source/latex/spanish/spanish.dtx
138texmf-dist/source/latex/spanish/spanish.ins
139texmf-dist/doc/latex/spanish-mx/README
140texmf-dist/tex/latex/spanish-mx/esmx.cfg
141texmf-dist/tex/latex/spanish-mx/spanishmx.ldf
142texmf-dist/tex/latex/spanish-mx/spanishmx.sty
143)
144
145%__mkdir_p ${PREF}/texmf-dist
146for i in "${manifest[@]}"; do
147    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
148done
149## make symlinks of core script utils
150mk_symlinks=(
151texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
152texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
153texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
154texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
155texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
156texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
157texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
158texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
159texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
160texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
161texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
162texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
163texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
164texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
165texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
166texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
167texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
168texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
169texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
170texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
171texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
172texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
173texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
174texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
175texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
176texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
177texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
178texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
179texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
180texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
181texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
182texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
183texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
184texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
185texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
186texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
187texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
188texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
189texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
190texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
191texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
192texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
193texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
194texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
195texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
196texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
197texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
198texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
199texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
200texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
201texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
202texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
203texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
204texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
205texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
206texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
207texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
208texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
209texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
210texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
211texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
212texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
213texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
214texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
215texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
216texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
217texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
218texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
219texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
220texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
221texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
222texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
223texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
224texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
225texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
226texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
227texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
228texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
229texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
230texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
231texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
232texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
233texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
234texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
235texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
236texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
237texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
238texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
239texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
240texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
241texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
242texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
243texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
244)
245%__mkdir_p %{buildroot}%{_bindir}
246pushd %{buildroot}%{_bindir}
247    for i in "${mk_symlinks[@]}"; do
248        tlc=$(/bin/echo $i | cut -f 1 -d",")
249        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
250        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
251
252        [ "%{name}" = "$tlc" ] || continue
253        [ -f $rlnk ] || exit 1
254        %__ln_s $rlnk $lnk || exit 1
255    done
256popd
257## Files list
258find %{buildroot} -type f -or -type l | \
259    %__sed -e "s|%{buildroot}||g" > filelist.full
260
261find %{buildroot}%{texmf}-dist -type d | \
262    %__sed -e "s|^%{buildroot}|%dir |" \
263           -e "s|$|/|"             >> filelist.full
264
265## subpackages
266grep "/texmf-dist/doc/" filelist.full > filelist.doc
267cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
268%__mv -f filelist.tmp filelist.full
269
270%clean
271%__rm -rf %{buildroot}
272
273%post
274%touch_run texhash
275%touch_run mtxrun
276
277%touch_run fmtutil
278
279exit 0
280
281
282%postun
283if [ "$1" = 0 ]; then
284    %touch_run texhash
285
286fi
287
288exit 0
289
290%posttrans
291%{exec_texhash}
292%{exec_mtxrun}
293%{exec_updmap}
294%{exec_fmtutil}
295exit 0
296
297
298%files -f filelist.full
299%defattr(-,root,root,-)
300
301%files -f filelist.doc doc
302%defattr(-,root,root,-)
303
304%changelog
305* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
306- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-langspanish
307
308* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
309- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-langspanish
310- set external dependencies (texlive-collection-binextra,
311  texlive-collection-fontutils)
312
313* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
314- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langspanish
315
316* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
317- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langspanish
318- make symlinks of core script utils (texlive-collection-binextra,
319  texlive-collection-context, texlive-collection-fontutils,
320  texlive-collection-langgreek, texlive-collection-langindic,
321  texlive-collection-latex, texlive-collection-latexextra,
322  texlive-collection-latexrecommended, texlive-collection-pictures,
323  texlive-collection-pstricks, texlive-collection-science)
324
325* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
326- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langspanish
327- improved %%post
328
329* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
330- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langspanish
331- removed arch dependent binaries (texlive-collection-latexextra)
332- fixed perl path
333- improved updmap process in %%post and %%postun
334
335* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
336- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langspanish
Note: See TracBrowser for help on using the repository browser.