source: projects/specs/trunk/t/texlive-collection-langportuguese/texlive-collection-langportuguese-vl.spec @ 1974

Revision 1974, 6.4 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-langportuguese
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Portuguese
28Summary(ja): TeX Live: Portuguese
29Name: texlive-collection-langportuguese
30Version: 2009
31Release: 2%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Portuguese:
61
62
63This package contains the following CTAN packages:
64ordinalpt: Counters as ordinal numbers in Portuguese.
65hyphen-portuguese:
66
67%description -l ja
68TeX Live ソフトウェアディストリビューションは、
69さまざまな Unix, Macintosh, Windows、および
70他のプラットホームに対して完全な TeX システムを提供します。
71多くの異なった言語を含む TeX ドキュメントの
72編集、組版、閲覧、印刷するためのプログラム、
73そして、TeX マクロやフォントライブラリの大きなコレクションを
74同梱しています。
75
76このディストリビューションは
77同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
78TeX に関するたくさんの一般的なドキュメントを含んでいます。
79
80このパッケージは以下のようなパッケージ集です。
81Portuguese:
82
83
84このパッケージは以下の CTAN パッケージを含んでいます:
85ordinalpt: Counters as ordinal numbers in Portuguese.
86hyphen-portuguese:
87
88%package doc
89Summary: TeX Live: Documentation files of %{name}
90Group: Applications/Publishing
91Requires: %{name} = %{version}-%{release}
92
93%description doc
94This package contains documentation files of %{name}.
95
96%prep
97
98%build
99
100%install
101[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
102
103PREF=%{buildroot}%{tex_destdir}
104
105manifest=(
106texmf-dist/doc/latex/ordinalpt/README
107texmf-dist/doc/latex/ordinalpt/ordinalpt.pdf
108texmf-dist/source/latex/ordinalpt/ordinalpt.dtx
109texmf-dist/source/latex/ordinalpt/ordinalpt.ins
110texmf-dist/tex/latex/ordinalpt/ordinalpt.sty
111)
112
113%__mkdir_p ${PREF}/texmf-dist
114for i in "${manifest[@]}"; do
115    %__install -D %{texlive_src}/$i ${PREF}/$i
116done
117
118## info
119%__rm -f %{buildroot}%{_infodir}/dir
120%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
121
122## man
123## man t1* files are provided by t1utils
124for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
125    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
126done
127
128## man some files are provided by psutils
129for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
130    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
131done
132
133## fix perl path
134for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
135    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
136done
137
138## remove asymptote directries, which provides asymptote package
139find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
140# find %{buildroot} -name "Makefile" | xargs %__rm -f
141
142# ## remove xindy
143# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
144
145# ## remove tex4ht
146# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
147
148## remove arch dependent binaries
149%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
150
151## remove unpackaging files
152find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
153find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
154
155## Files list
156find %{buildroot} -type f -or -type l | \
157    %__sed -e "s|%{buildroot}||g" > filelist.full
158
159find %{buildroot}%{texmf}-dist -type d | \
160    %__sed -e "s|^%{buildroot}|%dir |" \
161           -e "s|$|/|"             >> filelist.full
162
163## subpackages
164grep "/texmf-dist/doc/" filelist.full > filelist.doc
165cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
166%__mv -f filelist.tmp filelist.full
167
168%clean
169%__rm -rf %{buildroot}
170
171%post
172%{exec_texhash}
173
174echo -n "    "
175echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
176
177exit 0
178
179
180%postun
181if [ "$1" = 0 ]; then
182    %{exec_texhash}
183
184fi
185
186exit 0
187
188%files -f filelist.full
189%defattr(-,root,root)
190
191%files -f filelist.doc doc
192%defattr(-,root,root)
193
194%changelog
195* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
196- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langportuguese
197- removed arch dependent binaries (texlive-collection-latexextra)
198- fixed perl path
199- improved updmap process in %%post and %%postun
200
201* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
202- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langportuguese
Note: See TracBrowser for help on using the repository browser.