source: projects/specs/trunk/t/texlive-collection-langother/texlive-collection-langother-vl.spec @ 5207

Revision 5207, 15.0 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
3## tlpdb2rpmspec collection-langother
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
22%define vartexfonts %{_var}/lib/texmf/fonts
23
24Summary: TeX Live: Other hyphenation patterns
25Summary(ja): TeX Live: Other hyphenation patterns
26Name: texlive-collection-langother
27Version: 2011
28Release: 1%{?_dist_release}
29License: LPPL, GPL+, Freely redistributable without restriction
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34Requires: texlive-collection-basic = %{version}
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Other hyphenation patterns:
58Hyphenation patterns for languages without (much) other
59support.
60
61This package contains the following CTAN packages:
62hyphen-afrikaans: Afrikaans hyphenation patterns.
63hyphen-armenian: Armenian hyphenation patterns.
64hyphen-coptic: Coptic hyphenation patterns.
65hyphen-esperanto: Esperanto hyphenation patterns.
66hyphen-estonian: Estonian hyphenation patterns.
67hyphen-icelandic: Icelandic hyphenation patterns.
68hyphen-indonesian: Indonesian hyphenation patterns.
69hyphen-interlingua: Interlingua hyphenation patterns.
70hyphen-irish: Irish hyphenation patterns.
71hyphen-kurmanji: Kurmanji hyphenation patterns.
72hyphen-lao: Lao hyphenation patterns.
73hyphen-romanian: Romanian hyphenation patterns.
74hyphen-serbian: Serbian hyphenation patterns.
75hyphen-slovenian: Slovenian hyphenation patterns.
76hyphen-turkish: Turkish hyphenation patterns.
77hyphen-uppersorbian: Upper Sorbian hyphenation patterns.
78hyphen-welsh: Welsh hyphenation patterns.
79
80%description -l ja
81TeX Live ソフトウェアディストリビューションは、
82さまざまな Unix, Macintosh, Windows、および
83他のプラットホームに対して完全な TeX システムを提供します。
84多くの異なった言語を含む TeX ドキュメントの
85編集、組版、閲覧、印刷するためのプログラム、
86そして、TeX マクロやフォントライブラリの大きなコレクションを
87同梱しています。
88
89このディストリビューションは
90同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
91TeX に関するたくさんの一般的なドキュメントを含んでいます。
92
93このパッケージは以下のようなパッケージ集です。
94Other hyphenation patterns:
95Hyphenation patterns for languages without (much) other
96support.
97
98このパッケージは以下の CTAN パッケージを含んでいます:
99hyphen-afrikaans: Afrikaans hyphenation patterns.
100hyphen-armenian: Armenian hyphenation patterns.
101hyphen-coptic: Coptic hyphenation patterns.
102hyphen-esperanto: Esperanto hyphenation patterns.
103hyphen-estonian: Estonian hyphenation patterns.
104hyphen-icelandic: Icelandic hyphenation patterns.
105hyphen-indonesian: Indonesian hyphenation patterns.
106hyphen-interlingua: Interlingua hyphenation patterns.
107hyphen-irish: Irish hyphenation patterns.
108hyphen-kurmanji: Kurmanji hyphenation patterns.
109hyphen-lao: Lao hyphenation patterns.
110hyphen-romanian: Romanian hyphenation patterns.
111hyphen-serbian: Serbian hyphenation patterns.
112hyphen-slovenian: Slovenian hyphenation patterns.
113hyphen-turkish: Turkish hyphenation patterns.
114hyphen-uppersorbian: Upper Sorbian hyphenation patterns.
115hyphen-welsh: Welsh hyphenation patterns.
116
117%prep
118
119%build
120
121%install
122[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
123
124PREF=%{buildroot}%{tex_destdir}
125
126manifest=(
127
128)
129
130%__mkdir_p ${PREF}/texmf-dist
131for i in "${manifest[@]}"; do
132    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
133done
134## make symlinks of core script utils
135mk_symlinks=(
136texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
137texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
138texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
139texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
140texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
141texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
142texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
143texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
144texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
145texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
146texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
147texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
148texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
149texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
150texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
151texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
152texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
153texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
154texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
155texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
156texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
157texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
158texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
159texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
160texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
161texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
162texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
163texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
164texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
165texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
166texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
167texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
168texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
169texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
170texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
171texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
172texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
173texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
174texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
175texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
176texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
177texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
178texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
179texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
180texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
181texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
182texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
183texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
184texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
185texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
186texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
187texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
188texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
189texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
190texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
191texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
192texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
193texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
194texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
195texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
196texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
197texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
198texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
199texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
200texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
201texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
202texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
203texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
204texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
205texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
206texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
207texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
208texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
209texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
210texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
211texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
212texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
213texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
214texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
215texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
216texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
217texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
218)
219%__mkdir_p %{buildroot}%{_bindir}
220pushd %{buildroot}%{_bindir}
221    for i in "${mk_symlinks[@]}"; do
222        tlc=$(echo $i | cut -f 1 -d",")
223        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
224        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
225
226        [ "%{name}" = "$tlc" ] || continue
227        [ -f $rlnk ] || exit 1
228        %__ln_s $rlnk $lnk || exit 1
229    done
230popd
231## Files list
232find %{buildroot} -type f -or -type l | \
233    %__sed -e "s|%{buildroot}||g" > filelist.full
234
235find %{buildroot}%{texmf}-dist -type d | \
236    %__sed -e "s|^%{buildroot}|%dir |" \
237           -e "s|$|/|"             >> filelist.full
238
239%clean
240%__rm -rf %{buildroot}
241
242%post
243%{exec_texhash}
244
245rpm -q --quiet texlive-common || exit 0
246
247echo -n "    "
248echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
249
250exit 0
251
252
253%postun
254if [ "$1" = 0 ]; then
255    %{exec_texhash}
256
257fi
258
259exit 0
260
261%files -f filelist.full
262%defattr(-,root,root,-)
263
264%changelog
265* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
266- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langother
267
268* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
269- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langother
270- make symlinks of core script utils (texlive-collection-binextra,
271  texlive-collection-context, texlive-collection-fontutils,
272  texlive-collection-langgreek, texlive-collection-langindic,
273  texlive-collection-latex, texlive-collection-latexextra,
274  texlive-collection-latexrecommended, texlive-collection-pictures,
275  texlive-collection-pstricks, texlive-collection-science)
276
277* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
278- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langother
279- improved %%post
280
281* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
282- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langother
283- removed arch dependent binaries (texlive-collection-latexextra)
284- fixed perl path
285- improved updmap process in %%post and %%postun
286
287* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
288- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langother
Note: See TracBrowser for help on using the repository browser.