source: projects/specs/trunk/t/texlive-collection-langhungarian/texlive-collection-langhungarian-vl.spec @ 1533

Revision 1533, 5.6 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Hungarian
28Summary(ja): TeX Live: Hungarian
29Name: texlive-collection-langhungarian
30Version: 2009
31Release: 1%{?_dist_release}
32License: LPPL, GPL+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Hungarian:
61Support for typesetting Hungarian.
62
63This package contains the following CTAN packages:
64magyar: Hungarian language definition for Babel.
65hyphen-hungarian: New Hungarian hyphenation patterns.
66
67%description -l ja
68TeX Live ソフトウェアディストリビューションは、
69さまざまな Unix, Macintosh, Windows、および
70他のプラットホームに対して完全な TeX システムを提供します。
71多くの異なった言語を含む TeX ドキュメントの
72編集、組版、閲覧、印刷するためのプログラム、
73そして、TeX マクロやフォントライブラリの大きなコレクションを
74同梱しています。
75
76このディストリビューションは
77同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
78TeX に関するたくさんの一般的なドキュメントを含んでいます。
79
80このパッケージは以下のようなパッケージ集です。
81Hungarian:
82Support for typesetting Hungarian.
83
84このパッケージは以下の CTAN パッケージを含んでいます:
85magyar: Hungarian language definition for Babel.
86hyphen-hungarian: New Hungarian hyphenation patterns.
87
88%package doc
89Summary: TeX Live: Documentation files of %{name}
90Group: Applications/Publishing
91Requires: %{name} = %{version}-%{release}
92
93%description doc
94This package contains documentation files of %{name}.
95
96%prep
97
98%build
99
100%install
101[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
102
103PREF=%{buildroot}%{tex_destdir}
104
105manifest=(
106texmf-dist/doc/latex/magyar/magyar.ldf
107)
108
109%__mkdir_p ${PREF}/texmf-dist
110for i in "${manifest[@]}"; do
111    %__install -D %{texlive_src}/$i ${PREF}/$i
112done
113
114## info
115%__rm -f %{buildroot}%{_infodir}/dir
116%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
117
118## man
119## man t1* files are provided by t1utils
120for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
121    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
122done
123
124## man some files are provided by psutils
125for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
126    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
127done
128
129## remove asymptote directries, which provides asymptote package
130find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
131# find %{buildroot} -name "Makefile" | xargs %__rm -f
132
133# ## remove xindy
134# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
135
136# ## remove tex4ht
137# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
138
139## remove unpackaging files
140find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
141find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
142
143## Files list
144find %{buildroot} -type f -or -type l | \
145    %__sed -e "s|%{buildroot}||g" > filelist.full
146
147find %{buildroot}%{texmf}-dist -type d | \
148    %__sed -e "s|^%{buildroot}|%dir |" \
149           -e "s|$|/|"             >> filelist.full
150
151## subpackages
152grep "/texmf-dist/doc/" filelist.full > filelist.doc
153cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
154%__mv -f filelist.tmp filelist.full
155
156%clean
157%__rm -rf %{buildroot}
158
159%post
160%{exec_texhash}
161
162echo -n "    "
163echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
164
165exit 0
166
167
168%postun
169if [ "$1" = 0 ]; then
170    %{exec_texhash}
171
172fi
173
174exit 0
175
176%files -f filelist.full
177%defattr(-,root,root)
178
179%files -f filelist.doc doc
180%defattr(-,root,root)
181
182%changelog
183* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
184- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhungarian
Note: See TracBrowser for help on using the repository browser.