source: projects/specs/trunk/t/texlive-collection-langhungarian/texlive-collection-langhungarian-vl.spec @ 7148

Revision 7148, 16.4 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2012

RevLine 
[1533]1## -*- coding: utf-8-unix -*-
[7148]2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
[1974]3## tlpdb2rpmspec collection-langhungarian
[1533]4
[5207]5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
[7148]9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
[1533]13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
[7148]20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
[1533]46
47Summary: TeX Live: Hungarian
48Summary(ja): TeX Live: Hungarian
49Name: texlive-collection-langhungarian
[7148]50Version: 2012
[5207]51Release: 1%{?_dist_release}
[1533]52License: LPPL, GPL+
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
[7148]61#BuildRequires:         texlive-sources = %{version}
[1533]62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Hungarian:
81Support for typesetting Hungarian.
82
83This package contains the following CTAN packages:
84magyar: Hungarian language definition for Babel.
[5207]85hyphen-hungarian: Hungarian hyphenation patterns.
[1533]86
87%description -l ja
88TeX Live ソフトウェアディストリビューションは、
89さまざまな Unix, Macintosh, Windows、および
90他のプラットホームに対して完全な TeX システムを提供します。
91多くの異なった言語を含む TeX ドキュメントの
92編集、組版、閲覧、印刷するためのプログラム、
93そして、TeX マクロやフォントライブラリの大きなコレクションを
94同梱しています。
95
96このディストリビューションは
97同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
98TeX に関するたくさんの一般的なドキュメントを含んでいます。
99
100このパッケージは以下のようなパッケージ集です。
101Hungarian:
102Support for typesetting Hungarian.
103
104このパッケージは以下の CTAN パッケージを含んでいます:
105magyar: Hungarian language definition for Babel.
[5207]106hyphen-hungarian: Hungarian hyphenation patterns.
[1533]107
108%package doc
109Summary: TeX Live: Documentation files of %{name}
110Group: Applications/Publishing
111Requires: %{name} = %{version}-%{release}
112
113%description doc
114This package contains documentation files of %{name}.
115
116%prep
117
118%build
119
120%install
121[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
122
123PREF=%{buildroot}%{tex_destdir}
124
125manifest=(
126texmf-dist/doc/latex/magyar/magyar.ldf
127)
128
129%__mkdir_p ${PREF}/texmf-dist
130for i in "${manifest[@]}"; do
[5207]131    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
[1533]132done
[5207]133## make symlinks of core script utils
134mk_symlinks=(
135texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
[7148]136texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
137texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
[5207]138texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
139texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
[7148]140texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
141texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
[5207]142texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
143texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
144texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
145texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
146texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
147texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
148texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
149texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
[7148]150texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
[5207]151texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
152texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
153texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
[7148]154texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
[5207]155texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
156texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
157texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
158texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
159texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
160texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
161texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
162texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
163texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
164texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
165texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
166texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
167texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
168texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
169texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
170texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
171texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
172texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
173texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
174texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
175texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
176texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
[7148]177texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
[5207]178texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
[7148]179texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
[5207]180texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
181texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
[7148]182texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
[5207]183texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
[7148]184texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
[5207]185texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
186texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
187texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
188texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
189texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
190texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
191texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
192texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
193texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
194texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
195texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
196texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
197texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
[7148]198texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
199texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
[5207]200texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
201texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
202texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
203texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
204texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
[7148]205texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
[5207]206texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
207texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
208texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
209texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
210texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
211texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
212texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
213texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
[7148]214texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
[5207]215texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
[7148]216texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
[5207]217texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
218texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
[7148]219texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
[5207]220texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
221texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
222texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
223texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
224texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
[7148]225texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
[5207]226texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
227texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
228)
229%__mkdir_p %{buildroot}%{_bindir}
230pushd %{buildroot}%{_bindir}
231    for i in "${mk_symlinks[@]}"; do
[7148]232        tlc=$(/bin/echo $i | cut -f 1 -d",")
233        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
234        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
[1533]235
[5207]236        [ "%{name}" = "$tlc" ] || continue
237        [ -f $rlnk ] || exit 1
238        %__ln_s $rlnk $lnk || exit 1
239    done
240popd
[1533]241## Files list
242find %{buildroot} -type f -or -type l | \
243    %__sed -e "s|%{buildroot}||g" > filelist.full
244
245find %{buildroot}%{texmf}-dist -type d | \
246    %__sed -e "s|^%{buildroot}|%dir |" \
247           -e "s|$|/|"             >> filelist.full
248
249## subpackages
250grep "/texmf-dist/doc/" filelist.full > filelist.doc
251cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
252%__mv -f filelist.tmp filelist.full
253
254%clean
255%__rm -rf %{buildroot}
256
257%post
[7148]258%touch_run texhash
259%touch_run mtxrun
[1533]260
[7148]261%touch_run fmtutil
[2505]262
[1533]263exit 0
264
265
266%postun
267if [ "$1" = 0 ]; then
[7148]268    %touch_run texhash
[1533]269
270fi
271
272exit 0
273
[7148]274%posttrans
275%{exec_texhash}
276%{exec_mtxrun}
277%{exec_updmap}
278%{exec_fmtutil}
279exit 0
280
281
[1533]282%files -f filelist.full
[5207]283%defattr(-,root,root,-)
[1533]284
285%files -f filelist.doc doc
[5207]286%defattr(-,root,root,-)
[1533]287
288%changelog
[7148]289* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
290- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-langhungarian
291
292* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
293- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-langhungarian
294- set external dependencies (texlive-collection-binextra,
295  texlive-collection-fontutils)
296
[5207]297* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
298- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langhungarian
299
300* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
301- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langhungarian
302- make symlinks of core script utils (texlive-collection-binextra,
303  texlive-collection-context, texlive-collection-fontutils,
304  texlive-collection-langgreek, texlive-collection-langindic,
305  texlive-collection-latex, texlive-collection-latexextra,
306  texlive-collection-latexrecommended, texlive-collection-pictures,
307  texlive-collection-pstricks, texlive-collection-science)
308
[2505]309* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
310- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langhungarian
311- improved %%post
312
[1974]313* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
314- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langhungarian
315- removed arch dependent binaries (texlive-collection-latexextra)
316- fixed perl path
317- improved updmap process in %%post and %%postun
318
[1533]319* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
320- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhungarian
Note: See TracBrowser for help on using the repository browser.