source: projects/specs/trunk/t/texlive-collection-langfinnish/texlive-collection-langfinnish-vl.spec @ 1533

Revision 1533, 5.2 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Finnish
28Summary(ja): TeX Live: Finnish
29Name: texlive-collection-langfinnish
30Version: 2009
31Release: 1%{?_dist_release}
32License: Freely redistributable without restriction, Public Domain
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Finnish:
61Support for typesetting Finnish.
62
63This package contains the following CTAN packages:
64finbib: A Finnish version of plain.bst.
65hyphen-finnish: Hyphenation patterns for Finnish language.
66
67%description -l ja
68TeX Live ソフトウェアディストリビューションは、
69さまざまな Unix, Macintosh, Windows、および
70他のプラットホームに対して完全な TeX システムを提供します。
71多くの異なった言語を含む TeX ドキュメントの
72編集、組版、閲覧、印刷するためのプログラム、
73そして、TeX マクロやフォントライブラリの大きなコレクションを
74同梱しています。
75
76このディストリビューションは
77同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
78TeX に関するたくさんの一般的なドキュメントを含んでいます。
79
80このパッケージは以下のようなパッケージ集です。
81Finnish:
82Support for typesetting Finnish.
83
84このパッケージは以下の CTAN パッケージを含んでいます:
85finbib: A Finnish version of plain.bst.
86hyphen-finnish: Hyphenation patterns for Finnish language.
87
88%prep
89
90%build
91
92%install
93[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
94
95PREF=%{buildroot}%{tex_destdir}
96
97manifest=(
98texmf-dist/bibtex/bst/finbib/finplain.bst
99)
100
101%__mkdir_p ${PREF}/texmf-dist
102for i in "${manifest[@]}"; do
103    %__install -D %{texlive_src}/$i ${PREF}/$i
104done
105
106## info
107%__rm -f %{buildroot}%{_infodir}/dir
108%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
109
110## man
111## man t1* files are provided by t1utils
112for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
113    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
114done
115
116## man some files are provided by psutils
117for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
118    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
119done
120
121## remove asymptote directries, which provides asymptote package
122find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
123# find %{buildroot} -name "Makefile" | xargs %__rm -f
124
125# ## remove xindy
126# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
127
128# ## remove tex4ht
129# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
130
131## remove unpackaging files
132find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
133find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
134
135## Files list
136find %{buildroot} -type f -or -type l | \
137    %__sed -e "s|%{buildroot}||g" > filelist.full
138
139find %{buildroot}%{texmf}-dist -type d | \
140    %__sed -e "s|^%{buildroot}|%dir |" \
141           -e "s|$|/|"             >> filelist.full
142
143%clean
144%__rm -rf %{buildroot}
145
146%post
147%{exec_texhash}
148
149echo -n "    "
150echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
151
152exit 0
153
154
155%postun
156if [ "$1" = 0 ]; then
157    %{exec_texhash}
158
159fi
160
161exit 0
162
163%files -f filelist.full
164%defattr(-,root,root)
165
166%changelog
167* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
168- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langfinnish
Note: See TracBrowser for help on using the repository browser.