source: projects/specs/trunk/t/texlive-collection-langcroatian/texlive-collection-langcroatian-vl.spec @ 5207

Revision 5207, 14.4 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
3## tlpdb2rpmspec collection-langcroatian
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
22%define vartexfonts %{_var}/lib/texmf/fonts
23
24Summary: TeX Live: Croatian
25Summary(ja): TeX Live: Croatian
26Name: texlive-collection-langcroatian
27Version: 2011
28Release: 1%{?_dist_release}
29License: LPPL
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34Requires: texlive-collection-basic = %{version}
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Croatian:
58Support for typesetting Croatian.
59
60This package contains the following CTAN packages:
61hrlatex: LaTeX support for Croatian documents.
62hyphen-croatian: Croatian hyphenation patterns.
63
64%description -l ja
65TeX Live ソフトウェアディストリビューションは、
66さまざまな Unix, Macintosh, Windows、および
67他のプラットホームに対して完全な TeX システムを提供します。
68多くの異なった言語を含む TeX ドキュメントの
69編集、組版、閲覧、印刷するためのプログラム、
70そして、TeX マクロやフォントライブラリの大きなコレクションを
71同梱しています。
72
73このディストリビューションは
74同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
75TeX に関するたくさんの一般的なドキュメントを含んでいます。
76
77このパッケージは以下のようなパッケージ集です。
78Croatian:
79Support for typesetting Croatian.
80
81このパッケージは以下の CTAN パッケージを含んでいます:
82hrlatex: LaTeX support for Croatian documents.
83hyphen-croatian: Croatian hyphenation patterns.
84
85%package doc
86Summary: TeX Live: Documentation files of %{name}
87Group: Applications/Publishing
88Requires: %{name} = %{version}-%{release}
89
90%description doc
91This package contains documentation files of %{name}.
92
93%prep
94
95%build
96
97%install
98[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
99
100PREF=%{buildroot}%{tex_destdir}
101
102manifest=(
103texmf-dist/doc/latex/hrlatex/README
104texmf-dist/doc/latex/hrlatex/hrlatex.pdf
105texmf-dist/doc/latex/hrlatex/sample.fsbispit.tex
106texmf-dist/doc/latex/hrlatex/sample.minimal.cp1250.tex
107texmf-dist/doc/latex/hrlatex/sample.minimal.latin2.tex
108texmf-dist/doc/latex/hrlatex/sample.minimal.utf8.tex
109texmf-dist/doc/latex/hrlatex/sample.prezentacija.tex
110texmf-dist/source/latex/hrlatex/hrlatex.dtx
111texmf-dist/source/latex/hrlatex/hrlatex.ins
112texmf-dist/tex/latex/hrlatex/fsbispit.cls
113texmf-dist/tex/latex/hrlatex/fsbmath.sty
114texmf-dist/tex/latex/hrlatex/hrlatex.sty
115)
116
117%__mkdir_p ${PREF}/texmf-dist
118for i in "${manifest[@]}"; do
119    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
120done
121## make symlinks of core script utils
122mk_symlinks=(
123texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
124texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
125texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
126texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
127texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
128texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
129texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
130texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
131texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
132texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
133texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
134texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
135texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
136texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
137texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
138texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
139texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
140texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
141texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
142texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
143texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
144texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
145texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
146texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
147texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
148texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
149texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
150texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
151texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
152texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
153texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
154texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
155texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
156texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
157texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
158texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
159texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
160texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
161texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
162texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
163texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
164texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
165texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
166texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
167texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
168texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
169texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
170texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
171texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
172texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
173texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
174texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
175texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
176texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
177texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
178texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
179texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
180texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
181texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
182texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
183texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
184texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
185texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
186texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
187texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
188texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
189texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
190texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
191texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
192texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
193texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
194texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
195texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
196texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
197texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
198texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
199texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
200texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
201texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
202texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
203texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
204texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
205)
206%__mkdir_p %{buildroot}%{_bindir}
207pushd %{buildroot}%{_bindir}
208    for i in "${mk_symlinks[@]}"; do
209        tlc=$(echo $i | cut -f 1 -d",")
210        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
211        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
212
213        [ "%{name}" = "$tlc" ] || continue
214        [ -f $rlnk ] || exit 1
215        %__ln_s $rlnk $lnk || exit 1
216    done
217popd
218## Files list
219find %{buildroot} -type f -or -type l | \
220    %__sed -e "s|%{buildroot}||g" > filelist.full
221
222find %{buildroot}%{texmf}-dist -type d | \
223    %__sed -e "s|^%{buildroot}|%dir |" \
224           -e "s|$|/|"             >> filelist.full
225
226## subpackages
227grep "/texmf-dist/doc/" filelist.full > filelist.doc
228cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
229%__mv -f filelist.tmp filelist.full
230
231%clean
232%__rm -rf %{buildroot}
233
234%post
235%{exec_texhash}
236
237rpm -q --quiet texlive-common || exit 0
238
239echo -n "    "
240echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
241
242exit 0
243
244
245%postun
246if [ "$1" = 0 ]; then
247    %{exec_texhash}
248
249fi
250
251exit 0
252
253%files -f filelist.full
254%defattr(-,root,root,-)
255
256%files -f filelist.doc doc
257%defattr(-,root,root,-)
258
259%changelog
260* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
261- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langcroatian
262
263* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
264- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langcroatian
265- make symlinks of core script utils (texlive-collection-binextra,
266  texlive-collection-context, texlive-collection-fontutils,
267  texlive-collection-langgreek, texlive-collection-langindic,
268  texlive-collection-latex, texlive-collection-latexextra,
269  texlive-collection-latexrecommended, texlive-collection-pictures,
270  texlive-collection-pstricks, texlive-collection-science)
271
272* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
273- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langcroatian
274- improved %%post
275
276* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
277- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langcroatian
278- removed arch dependent binaries (texlive-collection-latexextra)
279- fixed perl path
280- improved updmap process in %%post and %%postun
281
282* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
283- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langcroatian
Note: See TracBrowser for help on using the repository browser.