source: projects/specs/trunk/t/texlive-collection-langafrican/texlive-collection-langafrican-vl.spec @ 9950

Revision 9950, 8.4 KB checked in by munepi, 8 years ago (diff)

synced tlnet to 20160110 (TeX Live 2016/dev)

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2015-3:
3## tlpdb2rpmspec collection-langafrican
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: African scripts
10Summary(ja): TeX Live: African scripts
11Name: texlive-collection-langafrican
12Version: 2015
13Release: 3%{?_dist_release}
14License: GPL+, GPLv2+
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: ethiop.doc.tar.xz
19Source1: ethiop.source.tar.xz
20Source2: ethiop.tar.xz
21Source3: ethiop-t1.doc.tar.xz
22Source4: ethiop-t1.tar.xz
23Source5: fc.doc.tar.xz
24Source6: fc.tar.xz
25Source7: hyphen-ethiopic.tar.xz
26
27Requires: texlive = %{version}
28Requires: texlive-collection-basic = %{version}
29
30Requires(post):         texlive = %{version}
31Requires(postun):       texlive = %{version}
32
33BuildArch:      noarch
34Buildroot:      %{_tmppath}/%{name}-%{version}-root
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38Packager:       munepi
39
40%description
41The TeX Live software distribution offers a complete TeX system for a
42variety of Unix, Macintosh, Windows and other platforms. It
43encompasses programs for editing, typesetting, previewing and printing
44of TeX documents in many different languages, and a large collection
45of TeX macros and font libraries.
46
47The distribution includes extensive general documentation about TeX,
48as well as the documentation for the included software packages.
49
50This package is a collection of African scripts:
51Support for African scripts.
52
53This package contains the following CTAN packages:
54ethiop: LaTeX macros and fonts for typesetting Amharic.
55ethiop-t1: Type 1 versions of Amharic fonts.
56fc: Fonts for African languages.
57hyphen-ethiopic: Hyphenation patterns for Ethiopic scripts.
58
59%description -l ja
60TeX Live ソフトウェアディストリビューションは、
61さまざまな Unix, Macintosh, Windows、および
62他のプラットホームに対して完全な TeX システムを提供します。
63多くの異なった言語を含む TeX ドキュメントの
64編集、組版、閲覧、印刷するためのプログラム、
65そして、TeX マクロやフォントライブラリの大きなコレクションを
66同梱しています。
67
68このディストリビューションは
69同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
70TeX に関するたくさんの一般的なドキュメントを含んでいます。
71
72このパッケージは以下のようなパッケージ集です。
73African scripts:
74Support for African scripts.
75
76このパッケージは以下の CTAN パッケージを含んでいます:
77ethiop: LaTeX macros and fonts for typesetting Amharic.
78ethiop-t1: Type 1 versions of Amharic fonts.
79fc: Fonts for African languages.
80hyphen-ethiopic: Hyphenation patterns for Ethiopic scripts.
81
82%package doc
83Summary: TeX Live: Documentation files of %{name}
84Group: Applications/Publishing
85Requires: %{name} = %{version}-%{release}
86
87%description doc
88This package contains documentation files of %{name}.
89
90%prep
91%setup -c -n %{name}-%{version}
92%__tar -xvf %{SOURCE1}
93%__tar -xvf %{SOURCE2}
94%__tar -xvf %{SOURCE3}
95%__tar -xvf %{SOURCE4}
96%__tar -xvf %{SOURCE5}
97%__tar -xvf %{SOURCE6}
98%__tar -xvf %{SOURCE7}
99
100%build
101
102%install
103[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
104
105%__mkdir_p %{buildroot}%{_datadir}
106
107## move texmf-dist to /usr/share/texmf-dist
108[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
109
110## move texmf to /usr/share/texmf
111[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
112
113## move tlpkg to /usr/share/tlpkg
114[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
115
116## move all non-arch binaries to /usr/bin
117[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
118
119## move others into /usr/share/texmf-dist
120%__mkdir_p %{buildroot}%{_tl_texmfdist}
121%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
122%__rm -rf * ||:
123
124
125## remove duplicated files between texlive and texlive-collection-*
126## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
127## remove unpacked files
128x=(
129scripts/context/stubs/unix/mtxrun
130scripts/ptex2pdf/ptex2pdf.lua
131scripts/texlive/fmtutil.pl
132scripts/texlive/texconfig-dialog.sh
133scripts/texlive/texconfig-sys.sh
134scripts/texlive/texconfig.sh
135scripts/texlive/texlinks.sh
136scripts/texlive/tlmgr.pl
137scripts/texlive/updmap.pl
138texconfig/tcfmgr
139web2c/fmtutil.cnf
140web2c/mktex.opt
141web2c/mktexdir
142web2c/mktexdir.opt
143web2c/mktexnam
144web2c/mktexnam.opt
145web2c/mktexupd
146web2c/texmf.cnf
147web2c/updmap-hdr.cfg
148web2c/updmap.cfg
149install-tl
150)
151if [ -d %{buildroot}%{_tl_texmfdist} ]; then
152pushd %{buildroot}%{_tl_texmfdist}
153%__rm -f ${x[@]} ||:
154popd
155fi
156
157## Files list
158find %{buildroot} -type f -or -type l | \
159    %__sed -e "s|%{buildroot}||g" > filelist.full
160
161find %{buildroot}%{_tl_texmfdist} -type d | \
162    %__sed -e "s|^%{buildroot}|%dir |" \
163           -e "s|$|/|"             >> filelist.full
164
165## subpackages
166grep "/texmf-dist/doc/" filelist.full > filelist.doc
167cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
168%__mv -f filelist.tmp filelist.full
169
170%clean
171%__rm -rf %{buildroot}
172
173%post
174%_tl_touch_run texhash
175%_tl_touch_run mtxrun
176
177[ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
178
179    %_tl_enable_map MixedMap ethiop.map
180
181%_tl_touch_run fmtutil
182
183exit 0
184
185
186%postun
187if [ "$1" = 0 ]; then
188    %_tl_touch_run texhash
189
190    [ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
191
192    %_tl_disable_map ethiop.map
193
194fi
195
196exit 0
197
198%posttrans
199%{_tl_exec_texhash}
200%{_tl_exec_mtxrun}
201%{_tl_exec_updmap}
202%{_tl_exec_fmtutil}
203exit 0
204
205
206%files -f filelist.full
207%defattr(-,root,root,-)
208
209%files -f filelist.doc doc
210%defattr(-,root,root,-)
211
212%changelog
213* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
214- TeX Live 2016/dev
215- synced tlnet to 20160110 (TeX Live 2016/dev)
216
217* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
218- TeX Live 2015/pretest
219- synced tlnet to 20150522 (TeX Live 2015/pretest)
220
221* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
222- TeX Live 2015/pretest
223- synced tlnet to 20150426 (TeX Live 2015/pretest)
224
225* Wed Apr 01 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2014-4
226- synced tlnet to 20150401
227
228* Tue Oct 28 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
229- synced tlnet to 20141028
230
231* Sun Jul 06 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
232- synced tlnet to 20140706
233
234* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
235- upgraded to TeX Live 2014
236
237* Sun Apr 06 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
238- synced tlnet to 20140406
239
240* Wed Dec 18 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
241- synced tlnet to 20131218
242
243* Fri Nov 01 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
244- synced tlnet to 20131101
245
246* Wed Oct 02 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
247- synced tlnet to 20131002
248
249* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
250- synced tlnet to 20130919
251
252* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
253- upgraded to TeX Live 2013
254  - used tlnet archives
255  - synced tlnet to 20130823
256- added macros.texlive
257
258* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
259- updated to TeX Live 2012
260
261* Sat Dec 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
262- updated tlpdb2rpmspec.sh.in and dot.vtlpkg.conf.in:
263  - set external dependencies (texlive-collection-binextra,
264    texlive-collection-fontutils)
265
266* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
267- updated to TeX Live 2011
268- merged texlive-vtlpkg-2009-osx.patch from OSXWS
269- added %doc README (%files)
270
271* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
272- applied texlive-vtlpkg-2009-vine.patch
273  - remove arch dependent binaries
274- updated tlpdb2rpmspec.sh.in:
275  - improved tlpdb4a()
276  - make symlinks of core script utils (texlive-collection-binextra,
277    texlive-collection-context, texlive-collection-fontutils,
278    texlive-collection-langgreek, texlive-collection-langindic,
279    texlive-collection-latex, texlive-collection-latexextra,
280    texlive-collection-latexrecommended, texlive-collection-pictures,
281    texlive-collection-pstricks, texlive-collection-science)
282
283* Wed Jan 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
284- updated tlpdb2rpmspec.sh.in:
285  - improved %post
286
287* Sun Sep 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
288- updated tlpdb2rpmspec.sh.in:
289  - removed arch dependent binaries (texlive-collection-latexextra)
290  - improved updmap process in %post and %postun
291  - fixed perl path
292
293* Fri Jul 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
294- initial build
Note: See TracBrowser for help on using the repository browser.