source: projects/specs/trunk/t/texlive-collection-langafrican/texlive-collection-langafrican-vl.spec @ 8744

Revision 8744, 5.4 KB checked in by munepi, 10 years ago (diff)

synced tlnet to 20140706

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2014-2:
3## tlpdb2rpmspec collection-langafrican
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: African scripts
10Summary(ja): TeX Live: African scripts
11Name: texlive-collection-langafrican
12Version: 2014
13Release: 2%{?_dist_release}
14License: GPL+, GPLv2+
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: ethiop.doc.tar.xz
19Source1: ethiop.source.tar.xz
20Source2: ethiop.tar.xz
21Source3: ethiop-t1.doc.tar.xz
22Source4: ethiop-t1.tar.xz
23Source5: fc.doc.tar.xz
24Source6: fc.tar.xz
25Source7: hyphen-ethiopic.tar.xz
26
27Requires: texlive = %{version}
28Requires: texlive-collection-basic = %{version}
29
30Requires(post):         texlive = %{version}
31Requires(postun):       texlive = %{version}
32
33BuildArch:      noarch
34Buildroot:      %{_tmppath}/%{name}-%{version}-root
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38Packager:       munepi
39
40%description
41The TeX Live software distribution offers a complete TeX system for a
42variety of Unix, Macintosh, Windows and other platforms. It
43encompasses programs for editing, typesetting, previewing and printing
44of TeX documents in many different languages, and a large collection
45of TeX macros and font libraries.
46
47The distribution includes extensive general documentation about TeX,
48as well as the documentation for the included software packages.
49
50This package is a collection of African scripts:
51Support for African scripts.
52
53This package contains the following CTAN packages:
54ethiop: LaTeX macros and fonts for typesetting Amharic.
55ethiop-t1: Type 1 versions of Amharic fonts.
56fc: Fonts for African languages.
57hyphen-ethiopic: Hyphenation patterns for Ethiopic scripts.
58
59%description -l ja
60TeX Live ソフトウェアディストリビューションは、
61さまざまな Unix, Macintosh, Windows、および
62他のプラットホームに対して完全な TeX システムを提供します。
63多くの異なった言語を含む TeX ドキュメントの
64編集、組版、閲覧、印刷するためのプログラム、
65そして、TeX マクロやフォントライブラリの大きなコレクションを
66同梱しています。
67
68このディストリビューションは
69同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
70TeX に関するたくさんの一般的なドキュメントを含んでいます。
71
72このパッケージは以下のようなパッケージ集です。
73African scripts:
74Support for African scripts.
75
76このパッケージは以下の CTAN パッケージを含んでいます:
77ethiop: LaTeX macros and fonts for typesetting Amharic.
78ethiop-t1: Type 1 versions of Amharic fonts.
79fc: Fonts for African languages.
80hyphen-ethiopic: Hyphenation patterns for Ethiopic scripts.
81
82%package doc
83Summary: TeX Live: Documentation files of %{name}
84Group: Applications/Publishing
85Requires: %{name} = %{version}-%{release}
86
87%description doc
88This package contains documentation files of %{name}.
89
90%prep
91%setup -c -n %{name}-%{version}
92%__tar -xvf %{SOURCE1}
93%__tar -xvf %{SOURCE2}
94%__tar -xvf %{SOURCE3}
95%__tar -xvf %{SOURCE4}
96%__tar -xvf %{SOURCE5}
97%__tar -xvf %{SOURCE6}
98%__tar -xvf %{SOURCE7}
99
100%build
101
102%install
103[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
104
105%__mkdir_p %{buildroot}%{_datadir}
106
107## move texmf-dist to /usr/share/texmf-dist
108[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
109
110## move texmf to /usr/share/texmf
111[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
112
113## move tlpkg to /usr/share/tlpkg
114[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
115
116## move all non-arch binaries to /usr/bin
117[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
118
119## move others into /usr/share/texmf-dist
120%__mkdir_p %{buildroot}%{_tl_texmfdist}
121%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
122%__rm -rf * ||:
123
124
125## remove duplicated files between texlive and texlive-collection-*
126## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
127## remove unpacked files
128x=(
129scripts/texlive/fmtutil.sh
130texconfig/tcfmgr
131web2c/texmf.cnf
132web2c/updmap-hdr.cfg
133web2c/updmap.cfg
134install-tl
135)
136if [ -d %{buildroot}%{_tl_texmfdist} ]; then
137pushd %{buildroot}%{_tl_texmfdist}
138%__rm -f ${x[@]} ||:
139popd
140fi
141
142## Files list
143find %{buildroot} -type f -or -type l | \
144    %__sed -e "s|%{buildroot}||g" > filelist.full
145
146find %{buildroot}%{_tl_texmfdist} -type d | \
147    %__sed -e "s|^%{buildroot}|%dir |" \
148           -e "s|$|/|"             >> filelist.full
149
150## subpackages
151grep "/texmf-dist/doc/" filelist.full > filelist.doc
152cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
153%__mv -f filelist.tmp filelist.full
154
155%clean
156%__rm -rf %{buildroot}
157
158%post
159%_tl_touch_run texhash
160%_tl_touch_run mtxrun
161
162[ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
163
164    %_tl_enable_map MixedMap ethiop.map
165
166%_tl_touch_run fmtutil
167
168exit 0
169
170
171%postun
172if [ "$1" = 0 ]; then
173    %_tl_touch_run texhash
174
175    [ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
176
177    %_tl_disable_map ethiop.map
178
179fi
180
181exit 0
182
183%posttrans
184%{_tl_exec_texhash}
185%{_tl_exec_mtxrun}
186%{_tl_exec_updmap}
187%{_tl_exec_fmtutil}
188exit 0
189
190
191%files -f filelist.full
192%defattr(-,root,root,-)
193
194%files -f filelist.doc doc
195%defattr(-,root,root,-)
196
197%changelog
198* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
199- synced tlnet to 20140706
200
201* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
202- synced tlnet to 20140524
Note: See TracBrowser for help on using the repository browser.