source: projects/specs/trunk/t/texlive-collection-langafrican/texlive-collection-langafrican-vl.spec @ 7855

Revision 7855, 5.7 KB checked in by munepi, 11 years ago (diff)

update source snapshot, TLNET: 20131002

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2013-3:
3## tlpdb2rpmspec collection-langafrican
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: African scripts
10Summary(ja): TeX Live: African scripts
11Name: texlive-collection-langafrican
12Version: 2013
13Release: 3%{?_dist_release}
14License: GPL+, GPLv2+
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: ethiop.doc.tar.xz
19Source1: ethiop.source.tar.xz
20Source2: ethiop.tar.xz
21Source3: ethiop-t1.doc.tar.xz
22Source4: ethiop-t1.tar.xz
23Source5: fc.doc.tar.xz
24Source6: fc.tar.xz
25Source7: hyphen-ethiopic.tar.xz
26
27Requires: texlive = %{version}
28Requires: texlive-collection-basic = %{version}
29
30Requires(post):         texlive = %{version}
31Requires(postun):       texlive = %{version}
32
33BuildArch:      noarch
34Buildroot:      %{_tmppath}/%{name}-%{version}-root
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38Packager:       munepi
39
40%description
41The TeX Live software distribution offers a complete TeX system for a
42variety of Unix, Macintosh, Windows and other platforms. It
43encompasses programs for editing, typesetting, previewing and printing
44of TeX documents in many different languages, and a large collection
45of TeX macros and font libraries.
46
47The distribution includes extensive general documentation about TeX,
48as well as the documentation for the included software packages.
49
50This package is a collection of African scripts:
51Support for African scripts.
52
53This package contains the following CTAN packages:
54ethiop: LaTeX macros and fonts for typesetting Amharic.
55ethiop-t1: Type 1 versions of Amharic fonts.
56fc: Fonts for African languages.
57hyphen-ethiopic: Hyphenation patterns for Ethiopic scripts.
58
59%description -l ja
60TeX Live ソフトウェアディストリビューションは、
61さまざまな Unix, Macintosh, Windows、および
62他のプラットホームに対して完全な TeX システムを提供します。
63多くの異なった言語を含む TeX ドキュメントの
64編集、組版、閲覧、印刷するためのプログラム、
65そして、TeX マクロやフォントライブラリの大きなコレクションを
66同梱しています。
67
68このディストリビューションは
69同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
70TeX に関するたくさんの一般的なドキュメントを含んでいます。
71
72このパッケージは以下のようなパッケージ集です。
73African scripts:
74Support for African scripts.
75
76このパッケージは以下の CTAN パッケージを含んでいます:
77ethiop: LaTeX macros and fonts for typesetting Amharic.
78ethiop-t1: Type 1 versions of Amharic fonts.
79fc: Fonts for African languages.
80hyphen-ethiopic: Hyphenation patterns for Ethiopic scripts.
81
82%package doc
83Summary: TeX Live: Documentation files of %{name}
84Group: Applications/Publishing
85Requires: %{name} = %{version}-%{release}
86
87%description doc
88This package contains documentation files of %{name}.
89
90%prep
91%setup -c -n %{name}-%{version}
92%__tar -xvf %{SOURCE1}
93%__tar -xvf %{SOURCE2}
94%__tar -xvf %{SOURCE3}
95%__tar -xvf %{SOURCE4}
96%__tar -xvf %{SOURCE5}
97%__tar -xvf %{SOURCE6}
98%__tar -xvf %{SOURCE7}
99
100%build
101
102%install
103[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
104
105%__mkdir_p %{buildroot}%{_datadir}
106
107## move texmf-dist to /usr/share/texmf-dist
108[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
109
110## move texmf to /usr/share/texmf
111[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
112
113## move tlpkg to /usr/share/tlpkg
114[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
115
116## move all non-arch binaries to /usr/bin
117[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
118
119## move others into /usr/share/texmf-dist
120%__mkdir_p %{buildroot}%{_tl_texmfdist}
121%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
122%__rm -rf * ||:
123
124
125## remove duplicated files between texlive and texlive-collection-*
126## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
127## remove unpacked files
128x=(
129scripts/texlive/tlmgr.pl
130texconfig/tcfmgr
131texconfig/tcfmgr.map
132web2c/fmtutil.cnf
133web2c/mktex.opt
134web2c/mktexdir
135web2c/mktexdir.opt
136web2c/mktexnam
137web2c/mktexnam.opt
138web2c/mktexupd
139web2c/texmf.cnf
140web2c/updmap.cfg
141web2c/updmap-hdr.cfg
142doc/chktex/ChkTeX.pdf
143install-tl
144)
145if [ -d %{buildroot}%{_tl_texmfdist} ]; then
146pushd %{buildroot}%{_tl_texmfdist}
147%__rm -f ${x[@]} ||:
148popd
149fi
150
151## Files list
152find %{buildroot} -type f -or -type l | \
153    %__sed -e "s|%{buildroot}||g" > filelist.full
154
155find %{buildroot}%{_tl_texmfdist} -type d | \
156    %__sed -e "s|^%{buildroot}|%dir |" \
157           -e "s|$|/|"             >> filelist.full
158
159## subpackages
160grep "/texmf-dist/doc/" filelist.full > filelist.doc
161cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
162%__mv -f filelist.tmp filelist.full
163
164%clean
165%__rm -rf %{buildroot}
166
167%post
168%_tl_touch_run texhash
169%_tl_touch_run mtxrun
170
171[ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
172
173    %_tl_enable_map MixedMap ethiop.map
174
175%_tl_touch_run fmtutil
176
177exit 0
178
179
180%postun
181if [ "$1" = 0 ]; then
182    %_tl_touch_run texhash
183
184    [ -f %{_tl_texmfdist}/web2c/updmap.cfg ] || exit 0
185
186    %_tl_disable_map ethiop.map
187
188fi
189
190exit 0
191
192%posttrans
193%{_tl_exec_texhash}
194%{_tl_exec_mtxrun}
195%{_tl_exec_updmap}
196%{_tl_exec_fmtutil}
197exit 0
198
199
200%files -f filelist.full
201%defattr(-,root,root,-)
202
203%files -f filelist.doc doc
204%defattr(-,root,root,-)
205
206%changelog
207* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
208- TLNET 20131002
209
210* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
211- TLNET 20130919
212
213* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
214- generated by tlpdb2rpmspec 2013-1: tlpdb2rpmspec collection-langafrican
215- TLNET 20130823
Note: See TracBrowser for help on using the repository browser.