source: projects/specs/trunk/t/texlive-collection-htmlxml/texlive-collection-htmlxml-vl.spec @ 8476

Revision 8476, 6.2 KB checked in by munepi, 10 years ago (diff)

TeX Live 2014

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2014-1:
3## tlpdb2rpmspec collection-htmlxml
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: HTML/SGML/XML support
10Summary(ja): TeX Live: HTML/SGML/XML support
11Name: texlive-collection-htmlxml
12Version: 2014
13Release: 1%{?_dist_release}
14License: LPPL 1.3, Freely redistributable without restriction, LPPL
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: classpack.doc.tar.xz
19Source1: classpack.source.tar.xz
20Source2: classpack.tar.xz
21Source3: jadetex.doc.tar.xz
22Source4: jadetex.source.tar.xz
23Source5: jadetex.tar.xz
24Source6: passivetex.tar.xz
25Source7: tex4ht.doc.tar.xz
26Source8: tex4ht.tar.xz
27Source9: xmltex.doc.tar.xz
28Source10: xmltex.tar.xz
29
30Requires: texlive = %{version}
31Requires: texlive-collection-basic = %{version}
32Requires: texlive-collection-fontsrecommended = %{version}
33Requires: texlive-collection-latex = %{version}
34
35Requires(post):         texlive = %{version}
36Requires(postun):       texlive = %{version}
37
38BuildArch:      noarch
39Buildroot:      %{_tmppath}/%{name}-%{version}-root
40
41Vendor:         Project Vine
42Distribution:   Vine Linux
43Packager:       munepi
44
45%description
46The TeX Live software distribution offers a complete TeX system for a
47variety of Unix, Macintosh, Windows and other platforms. It
48encompasses programs for editing, typesetting, previewing and printing
49of TeX documents in many different languages, and a large collection
50of TeX macros and font libraries.
51
52The distribution includes extensive general documentation about TeX,
53as well as the documentation for the included software packages.
54
55This package is a collection of HTML/SGML/XML support:
56Packages to convert LaTeX to XML/HTML, and typset XML/SGML.
57
58This package contains the following CTAN packages:
59classpack: XML mastering for LaTeX classes and packages.
60jadetex: Macros supporting Jade DSSSL output.
61passivetex: Support package for XML/SGML typesetting
62tex4ht: Convert (La)TeX to HTML/XML.
63xmltex: Support for parsing XML documents.
64
65%description -l ja
66TeX Live ソフトウェアディストリビューションは、
67さまざまな Unix, Macintosh, Windows、および
68他のプラットホームに対して完全な TeX システムを提供します。
69多くの異なった言語を含む TeX ドキュメントの
70編集、組版、閲覧、印刷するためのプログラム、
71そして、TeX マクロやフォントライブラリの大きなコレクションを
72同梱しています。
73
74このディストリビューションは
75同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
76TeX に関するたくさんの一般的なドキュメントを含んでいます。
77
78このパッケージは以下のようなパッケージ集です。
79HTML/SGML/XML support:
80Packages to convert LaTeX to XML/HTML, and typset XML/SGML.
81
82このパッケージは以下の CTAN パッケージを含んでいます:
83classpack: XML mastering for LaTeX classes and packages.
84jadetex: Macros supporting Jade DSSSL output.
85passivetex: Support package for XML/SGML typesetting
86tex4ht: Convert (La)TeX to HTML/XML.
87xmltex: Support for parsing XML documents.
88
89%package doc
90Summary: TeX Live: Documentation files of %{name}
91Group: Applications/Publishing
92Requires: %{name} = %{version}-%{release}
93
94%description doc
95This package contains documentation files of %{name}.
96
97%prep
98%setup -c -n %{name}-%{version}
99%__tar -xvf %{SOURCE1}
100%__tar -xvf %{SOURCE2}
101%__tar -xvf %{SOURCE3}
102%__tar -xvf %{SOURCE4}
103%__tar -xvf %{SOURCE5}
104%__tar -xvf %{SOURCE6}
105%__tar -xvf %{SOURCE7}
106%__tar -xvf %{SOURCE8}
107%__tar -xvf %{SOURCE9}
108%__tar -xvf %{SOURCE10}
109
110%build
111
112%install
113[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
114
115%__mkdir_p %{buildroot}%{_datadir}
116
117## move texmf-dist to /usr/share/texmf-dist
118[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
119
120## move texmf to /usr/share/texmf
121[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
122
123## move tlpkg to /usr/share/tlpkg
124[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
125
126## move all non-arch binaries to /usr/bin
127[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
128
129## move others into /usr/share/texmf-dist
130%__mkdir_p %{buildroot}%{_tl_texmfdist}
131%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
132%__rm -rf * ||:
133
134
135## remove duplicated files between texlive and texlive-collection-*
136## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
137## remove unpacked files
138x=(
139# scripts/texlive/tlmgr.pl
140# scripts/texlive/updmap.pl
141# scripts/fontools/autoinst
142# scripts/glossaries/makeglossaries
143# scripts/m-tx/m-tx.lua
144# scripts/musixtex/musixtex.lua
145# scripts/pmx/pmx2pdf.lua
146# scripts/latexmk/latexmk.pl
147# scripts/jfontmaps/kanji-config-updmap.pl
148# scripts/jfontmaps/kanji-fontmap-creator.pl
149# scripts/latexpand/latexpand
150# scripts/epstopdf/epstopdf.pl
151# scripts/convbkmk/convbkmk.rb
152# scripts/jfontmaps/kanji-config-updmap-sys.sh
153# scripts/luaotfload/luaotfload-tool.lua
154# texconfig/tcfmgr
155# texconfig/tcfmgr.map
156# web2c/fmtutil.cnf
157# web2c/mktex.opt
158# web2c/mktexdir
159# web2c/mktexdir.opt
160# web2c/mktexnam
161# web2c/mktexnam.opt
162# web2c/mktexupd
163# web2c/texmf.cnf
164# web2c/updmap.cfg
165# web2c/updmap-hdr.cfg
166# doc/chktex/ChkTeX.pdf
167install-tl
168)
169if [ -d %{buildroot}%{_tl_texmfdist} ]; then
170pushd %{buildroot}%{_tl_texmfdist}
171%__rm -f ${x[@]} ||:
172popd
173fi
174
175## Files list
176find %{buildroot} -type f -or -type l | \
177    %__sed -e "s|%{buildroot}||g" > filelist.full
178
179find %{buildroot}%{_tl_texmfdist} -type d | \
180    %__sed -e "s|^%{buildroot}|%dir |" \
181           -e "s|$|/|"             >> filelist.full
182
183## subpackages
184grep "/texmf-dist/doc/" filelist.full > filelist.doc
185cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
186%__mv -f filelist.tmp filelist.full
187
188%clean
189%__rm -rf %{buildroot}
190
191%post
192%_tl_touch_run texhash
193%_tl_touch_run mtxrun
194
195%_tl_touch_run fmtutil
196
197exit 0
198
199
200%postun
201if [ "$1" = 0 ]; then
202    %_tl_touch_run texhash
203
204fi
205
206exit 0
207
208%posttrans
209%{_tl_exec_texhash}
210%{_tl_exec_mtxrun}
211%{_tl_exec_updmap}
212%{_tl_exec_fmtutil}
213exit 0
214
215
216%files -f filelist.full
217%defattr(-,root,root,-)
218
219%files -f filelist.doc doc
220%defattr(-,root,root,-)
221
222%changelog
223* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
224- TLNET 20140524
Note: See TracBrowser for help on using the repository browser.