source: projects/specs/trunk/t/texlive-collection-htmlxml/texlive-collection-htmlxml-vl.spec @ 8049

Revision 8049, 5.8 KB checked in by munepi, 10 years ago (diff)

TLNET 20131218

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2013-5:
3## tlpdb2rpmspec collection-htmlxml
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: HTML/SGML/XML support
10Summary(ja): TeX Live: HTML/SGML/XML support
11Name: texlive-collection-htmlxml
12Version: 2013
13Release: 5%{?_dist_release}
14License: Freely redistributable without restriction, LPPL
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: jadetex.doc.tar.xz
19Source1: jadetex.source.tar.xz
20Source2: jadetex.tar.xz
21Source3: passivetex.tar.xz
22Source4: tex4ht.doc.tar.xz
23Source5: tex4ht.tar.xz
24Source6: xmltex.doc.tar.xz
25Source7: xmltex.tar.xz
26
27Requires: texlive = %{version}
28Requires: texlive-collection-basic = %{version}
29Requires: texlive-collection-fontsrecommended = %{version}
30Requires: texlive-collection-latex = %{version}
31
32Requires(post):         texlive = %{version}
33Requires(postun):       texlive = %{version}
34
35BuildArch:      noarch
36Buildroot:      %{_tmppath}/%{name}-%{version}-root
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       munepi
41
42%description
43The TeX Live software distribution offers a complete TeX system for a
44variety of Unix, Macintosh, Windows and other platforms. It
45encompasses programs for editing, typesetting, previewing and printing
46of TeX documents in many different languages, and a large collection
47of TeX macros and font libraries.
48
49The distribution includes extensive general documentation about TeX,
50as well as the documentation for the included software packages.
51
52This package is a collection of HTML/SGML/XML support:
53Packages to convert LaTeX to XML/HTML, and typset XML/SGML
54
55This package contains the following CTAN packages:
56jadetex: Macros supporting Jade DSSSL output.
57passivetex: Support package for XML/SGML typesetting
58tex4ht: Convert (La)TeX to HTML/XML.
59xmltex: Support for parsing XML documents.
60
61%description -l ja
62TeX Live ソフトウェアディストリビューションは、
63さまざまな Unix, Macintosh, Windows、および
64他のプラットホームに対して完全な TeX システムを提供します。
65多くの異なった言語を含む TeX ドキュメントの
66編集、組版、閲覧、印刷するためのプログラム、
67そして、TeX マクロやフォントライブラリの大きなコレクションを
68同梱しています。
69
70このディストリビューションは
71同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
72TeX に関するたくさんの一般的なドキュメントを含んでいます。
73
74このパッケージは以下のようなパッケージ集です。
75HTML/SGML/XML support:
76Packages to convert LaTeX to XML/HTML, and typset XML/SGML
77
78このパッケージは以下の CTAN パッケージを含んでいます:
79jadetex: Macros supporting Jade DSSSL output.
80passivetex: Support package for XML/SGML typesetting
81tex4ht: Convert (La)TeX to HTML/XML.
82xmltex: Support for parsing XML documents.
83
84%package doc
85Summary: TeX Live: Documentation files of %{name}
86Group: Applications/Publishing
87Requires: %{name} = %{version}-%{release}
88
89%description doc
90This package contains documentation files of %{name}.
91
92%prep
93%setup -c -n %{name}-%{version}
94%__tar -xvf %{SOURCE1}
95%__tar -xvf %{SOURCE2}
96%__tar -xvf %{SOURCE3}
97%__tar -xvf %{SOURCE4}
98%__tar -xvf %{SOURCE5}
99%__tar -xvf %{SOURCE6}
100%__tar -xvf %{SOURCE7}
101
102%build
103
104%install
105[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
106
107%__mkdir_p %{buildroot}%{_datadir}
108
109## move texmf-dist to /usr/share/texmf-dist
110[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
111
112## move texmf to /usr/share/texmf
113[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
114
115## move tlpkg to /usr/share/tlpkg
116[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
117
118## move all non-arch binaries to /usr/bin
119[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
120
121## move others into /usr/share/texmf-dist
122%__mkdir_p %{buildroot}%{_tl_texmfdist}
123%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
124%__rm -rf * ||:
125
126
127## remove duplicated files between texlive and texlive-collection-*
128## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
129## remove unpacked files
130x=(
131scripts/fontools/autoinst
132scripts/texlive/tlmgr.pl
133scripts/texlive/updmap.pl
134texconfig/tcfmgr
135texconfig/tcfmgr.map
136web2c/fmtutil.cnf
137web2c/mktex.opt
138web2c/mktexdir
139web2c/mktexdir.opt
140web2c/mktexnam
141web2c/mktexnam.opt
142web2c/mktexupd
143web2c/texmf.cnf
144web2c/updmap.cfg
145web2c/updmap-hdr.cfg
146doc/chktex/ChkTeX.pdf
147install-tl
148)
149if [ -d %{buildroot}%{_tl_texmfdist} ]; then
150pushd %{buildroot}%{_tl_texmfdist}
151%__rm -f ${x[@]} ||:
152popd
153fi
154
155## Files list
156find %{buildroot} -type f -or -type l | \
157    %__sed -e "s|%{buildroot}||g" > filelist.full
158
159find %{buildroot}%{_tl_texmfdist} -type d | \
160    %__sed -e "s|^%{buildroot}|%dir |" \
161           -e "s|$|/|"             >> filelist.full
162
163## subpackages
164grep "/texmf-dist/doc/" filelist.full > filelist.doc
165cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
166%__mv -f filelist.tmp filelist.full
167
168%clean
169%__rm -rf %{buildroot}
170
171%post
172%_tl_touch_run texhash
173%_tl_touch_run mtxrun
174
175%_tl_touch_run fmtutil
176
177exit 0
178
179
180%postun
181if [ "$1" = 0 ]; then
182    %_tl_touch_run texhash
183
184fi
185
186exit 0
187
188%posttrans
189%{_tl_exec_texhash}
190%{_tl_exec_mtxrun}
191%{_tl_exec_updmap}
192%{_tl_exec_fmtutil}
193exit 0
194
195
196%files -f filelist.full
197%defattr(-,root,root,-)
198
199%files -f filelist.doc doc
200%defattr(-,root,root,-)
201
202%changelog
203* Wed Dec 18 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
204- TLNET 20131218
205
206* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
207- TLNET 20131101
208
209* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
210- TLNET 20131002
211
212* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
213- TLNET 20130919
214
215* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
216- TLNET 20130823
Note: See TracBrowser for help on using the repository browser.