source: projects/specs/trunk/t/texlive-collection-htmlxml/texlive-collection-htmlxml-vl.spec @ 7770

Revision 7770, 7.0 KB checked in by munepi, 11 years ago (diff)

dropped all obsolete texlive-collection packages of TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2013-1:
3## tlpdb2rpmspec collection-htmlxml
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: HTML/SGML/XML support
10Summary(ja): TeX Live: HTML/SGML/XML support
11Name: texlive-collection-htmlxml
12Version: 2013
13Release: 1%{?_dist_release}
14License: Freely redistributable without restriction, LPPL
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: jadetex.doc.tar.xz
19Source1: jadetex.source.tar.xz
20Source2: jadetex.tar.xz
21Source3: passivetex.tar.xz
22Source4: tex4ht.doc.tar.xz
23Source5: tex4ht.tar.xz
24Source6: xmltex.doc.tar.xz
25Source7: xmltex.tar.xz
26
27Requires: texlive = %{version}
28Requires: texlive-collection-basic = %{version}
29Requires: texlive-collection-fontsrecommended = %{version}
30Requires: texlive-collection-latex = %{version}
31
32Requires(post):         texlive = %{version}
33Requires(postun):       texlive = %{version}
34
35BuildArch:      noarch
36Buildroot:      %{_tmppath}/%{name}-%{version}-root
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       munepi
41
42%description
43The TeX Live software distribution offers a complete TeX system for a
44variety of Unix, Macintosh, Windows and other platforms. It
45encompasses programs for editing, typesetting, previewing and printing
46of TeX documents in many different languages, and a large collection
47of TeX macros and font libraries.
48
49The distribution includes extensive general documentation about TeX,
50as well as the documentation for the included software packages.
51
52This package is a collection of HTML/SGML/XML support:
53Packages to convert LaTeX to XML/HTML, and typset XML/SGML
54
55This package contains the following CTAN packages:
56jadetex: Macros supporting Jade DSSSL output.
57passivetex: Support package for XML/SGML typesetting
58tex4ht: Convert (La)TeX to HTML/XML.
59xmltex: Support for parsing XML documents.
60
61%description -l ja
62TeX Live ソフトウェアディストリビューションは、
63さまざまな Unix, Macintosh, Windows、および
64他のプラットホームに対して完全な TeX システムを提供します。
65多くの異なった言語を含む TeX ドキュメントの
66編集、組版、閲覧、印刷するためのプログラム、
67そして、TeX マクロやフォントライブラリの大きなコレクションを
68同梱しています。
69
70このディストリビューションは
71同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
72TeX に関するたくさんの一般的なドキュメントを含んでいます。
73
74このパッケージは以下のようなパッケージ集です。
75HTML/SGML/XML support:
76Packages to convert LaTeX to XML/HTML, and typset XML/SGML
77
78このパッケージは以下の CTAN パッケージを含んでいます:
79jadetex: Macros supporting Jade DSSSL output.
80passivetex: Support package for XML/SGML typesetting
81tex4ht: Convert (La)TeX to HTML/XML.
82xmltex: Support for parsing XML documents.
83
84%package doc
85Summary: TeX Live: Documentation files of %{name}
86Group: Applications/Publishing
87Requires: %{name} = %{version}-%{release}
88
89%description doc
90This package contains documentation files of %{name}.
91
92%prep
93%setup -c -n %{name}-%{version}
94%__tar -xvf %{SOURCE1}
95%__tar -xvf %{SOURCE2}
96%__tar -xvf %{SOURCE3}
97%__tar -xvf %{SOURCE4}
98%__tar -xvf %{SOURCE5}
99%__tar -xvf %{SOURCE6}
100%__tar -xvf %{SOURCE7}
101
102%build
103
104%install
105[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
106
107%__mkdir_p %{buildroot}%{_datadir}
108
109## move texmf-dist to /usr/share/texmf-dist
110[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
111
112## move texmf to /usr/share/texmf
113[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
114
115## move tlpkg to /usr/share/tlpkg
116[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
117
118## move all non-arch binaries to /usr/bin
119[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
120
121## move others into /usr/share/texmf-dist
122%__mkdir_p %{buildroot}%{_tl_texmfdist}
123%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
124%__rm -rf * ||:
125
126
127## remove duplicated files between texlive and texlive-collection-*
128## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
129## remove unpacked files
130x=(
131texconfig/tcfmgr
132texconfig/tcfmgr.map
133web2c/fmtutil.cnf
134web2c/mktex.opt
135web2c/mktexdir
136web2c/mktexdir.opt
137web2c/mktexnam
138web2c/mktexnam.opt
139web2c/mktexupd
140web2c/texmf.cnf
141web2c/updmap.cfg
142web2c/updmap-hdr.cfg
143doc/chktex/ChkTeX.pdf
144install-tl
145)
146if [ -d %{buildroot}%{_tl_texmfdist} ]; then
147pushd %{buildroot}%{_tl_texmfdist}
148%__rm -f ${x[@]} ||:
149popd
150fi
151
152## Files list
153find %{buildroot} -type f -or -type l | \
154    %__sed -e "s|%{buildroot}||g" > filelist.full
155
156find %{buildroot}%{_tl_texmfdist} -type d | \
157    %__sed -e "s|^%{buildroot}|%dir |" \
158           -e "s|$|/|"             >> filelist.full
159
160## subpackages
161grep "/texmf-dist/doc/" filelist.full > filelist.doc
162cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
163%__mv -f filelist.tmp filelist.full
164
165%clean
166%__rm -rf %{buildroot}
167
168%post
169%_tl_touch_run texhash
170%_tl_touch_run mtxrun
171
172%_tl_touch_run fmtutil
173
174exit 0
175
176
177%postun
178if [ "$1" = 0 ]; then
179    %_tl_touch_run texhash
180
181fi
182
183exit 0
184
185%posttrans
186%{_tl_exec_texhash}
187%{_tl_exec_mtxrun}
188%{_tl_exec_updmap}
189%{_tl_exec_fmtutil}
190exit 0
191
192
193%files -f filelist.full
194%defattr(-,root,root,-)
195
196%files -f filelist.doc doc
197%defattr(-,root,root,-)
198
199%changelog
200* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
201- generated by tlpdb2rpmspec 2013-1: tlpdb2rpmspec collection-htmlxml
202- TLNET 20130823
203
204* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
205- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-htmlxml
206
207* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
208- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-htmlxml
209- set external dependencies (texlive-collection-binextra,
210  texlive-collection-fontutils)
211
212* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
213- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-htmlxml
214
215* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
216- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-htmlxml
217- make symlinks of core script utils (texlive-collection-binextra,
218  texlive-collection-context, texlive-collection-fontutils,
219  texlive-collection-langgreek, texlive-collection-langindic,
220  texlive-collection-latex, texlive-collection-latexextra,
221  texlive-collection-latexrecommended, texlive-collection-pictures,
222  texlive-collection-pstricks, texlive-collection-science)
223
224* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
225- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-htmlxml
226- improved %%post
227
228* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
229- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-htmlxml
230- removed arch dependent binaries (texlive-collection-latexextra)
231- fixed perl path
232- improved updmap process in %%post and %%postun
233
234* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
235- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-htmlxml
Note: See TracBrowser for help on using the repository browser.